#openstack-meeting: releaseteam

Meeting started by dhellmann at 14:01:29 UTC (full logs).

Meeting summary

    1. https://etherpad.openstack.org/p/mitaka-relmgt-plan (dhellmann, 14:01:53)

  1. old business (from R-11) (dhellmann, 14:03:05)
    1. dhellmann talk to monasca team about releases (dhellmann, 14:03:12)
    2. governance tag updates: https://review.openstack.org/#/c/274884/ (dhellmann, 14:03:24)
    3. releases repo updates: https://review.openstack.org/#/c/274898/ (merged) (dhellmann, 14:03:24)
    4. dhellmann talk to mestery about networking-ovn, octavia, vmware-nsx (dhellmann, 14:04:04)
    5. https://review.openstack.org/#/c/272696/ (dhellmann, 14:04:11)
    6. dhellmann change searchlight and aodh to cycle-with-intermediary (dhellmann, 14:05:01)
    7. https://review.openstack.org/271366 change aodh to cycle-with-milestones (merged) (dhellmann, 14:05:01)
    8. https://review.openstack.org/271369 change searchlight to cycle-with-milestones (merged) (dhellmann, 14:05:01)
    9. dhellmann send email encouraging independent projects to record their releases in the releases repository (dhellmann, 14:05:12)
    10. http://lists.openstack.org/pipermail/openstack-dev/2016-January/084756.html (dhellmann, 14:05:19)
    11. ttx to file the magnum fix today (dhellmann, 14:09:15)
    12. https://review.openstack.org/271318 (merged) (dhellmann, 14:09:15)
    13. dhellmann file governance change to merge freezer deliverables for consistency (dhellmann, 14:09:28)
    14. https://review.openstack.org/271372 merge freezer deliverables (merged) (dhellmann, 14:09:28)
    15. dhellmann reorganize releases repository to clean up urls (dhellmann, 14:09:43)
    16. https://review.openstack.org/271550 rearrange content in preparation to move to new vhost (merged) (dhellmann, 14:09:43)

  2. should we make pre-release collapsing the default behavior in reno? (dhellmann, 14:10:41)
    1. AGREED: change reno default to collapse pre-releases into final releases (dhellmann, 14:17:26)

  3. how do we want to handle locking down releases for libraries during the freeze period? (dhellmann, 14:18:25)
    1. http://docs.openstack.org/releases/mitaka/schedule.html (dhellmann, 14:37:58)
    2. ACTION: dhellmann add requirements freeze dates to mitaka calendar (dhellmann, 14:39:47)
    3. ACTION: dhellmann announce library release freeze deadlines and thaw on ML (dhellmann, 14:40:14)

  4. starting to think about newton schedule (dhellmann, 14:45:29)
    1. https://review.openstack.org/#/c/275911/ (dhellmann, 14:45:30)

  5. patches to prioritize (dhellmann, 14:57:15)
    1. https://review.openstack.org/#/c/275829/ show more detail in list-changes job (dhellmann, 14:57:15)
    2. https://review.openstack.org/#/c/275853/ do not merge stdout & stderr when trying to check ancestry (I think this led to the keystoneclient 2.1.1 issue, but I'm not sure) (dhellmann, 14:57:15)
    3. https://review.openstack.org/275986 remove the announce flag from the release wrapper scripts (dhellmann, 14:57:15)

  6. open discussion (dhellmann, 14:57:54)


Meeting ended at 15:00:36 UTC (full logs).

Action items

  1. dhellmann add requirements freeze dates to mitaka calendar
  2. dhellmann announce library release freeze deadlines and thaw on ML


Action items, by person

  1. dhellmann
    1. dhellmann add requirements freeze dates to mitaka calendar
    2. dhellmann announce library release freeze deadlines and thaw on ML


People present (lines said)

  1. dhellmann (140)
  2. ttx (100)
  3. dims (11)
  4. fungi (5)
  5. openstack (3)


Generated by MeetBot 0.1.4.