14:02:10 <dhellmann> #startmeeting releaseteam
14:02:11 <openstack> Meeting started Fri Mar 18 14:02:10 2016 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:14 <openstack> The meeting name has been set to 'releaseteam'
14:02:44 <dhellmann> our agenda is under R-3 on https://etherpad.openstack.org/p/mitaka-release-tracking
14:03:03 <dhellmann> #topic Missing managed RC1s and clients
14:03:13 <dhellmann> these are highlighted with a red background on the spreadsheet
14:03:19 <dhellmann> #link https://docs.google.com/spreadsheets/d/1BLUDgediqgOzLZMMe8a3EAPOtyINAg2rpMtSyWjhC4o/edit#gid=0
14:03:26 <ttx> so we seem to have a status update on the managed ones, except manila
14:03:34 <dhellmann> yes
14:03:37 <dhellmann> bswartz : are you around?
14:04:13 <ttx> we can come back to that
14:04:32 <dhellmann> yeah
14:04:44 <ttx> it's relatively limited in number
14:04:46 <dhellmann> #topic Missing non-managed RC1s and intermediary refreshes
14:04:57 <dhellmann> these have the orange background in the spreadsheet
14:05:11 <dhellmann> we have a few more that haven't checked in yet
14:05:46 <ttx> I did not put any orange background on stuff which are new and never released in mitaka (think: cloudkitty)
14:06:01 <ttx> if those miss they will just be ignored and it doesn't really reflect badly on us
14:06:03 <dhellmann> #action dhellmann track down thinrichs daemontool sergmelikyan and TravT
14:06:16 <ttx> the others unformatunately are on the train already
14:06:27 <ttx> unfortunately
14:06:36 <ttx> and would make us look bad if they missed
14:06:39 <dhellmann> yes
14:07:04 <dhellmann> I wonder how many of the cycle-with-intermediary projects think they're done?
14:07:25 <ttx> maybe they are but they should tell us
14:07:34 <ttx> so that we cut early branches :)
14:07:50 <dhellmann> yes, I'll work on tracking them down today
14:07:58 <ttx> dhellmann: near the bottom of the file... a few I wanted to ask about
14:08:03 <dhellmann> I wasn't worrying too much about the unmanaged list
14:08:06 <ttx> python-aodhclient python-congressclient
14:08:24 <ttx> python-monascaclient python-searchlightclient
14:08:40 <ttx> python-solumclient
14:08:49 <ttx> those have some mitaka release
14:08:59 <ttx> should we just cut stable branches ? We are way past deadline
14:09:56 <ttx> os-win is also probably ready to cut
14:09:56 <dhellmann> have you tried to contact any of them? I heard from gordc about aodh a little while ago
14:10:14 <ttx> no, just highlighted them, we can spread the load of nagging
14:10:22 <dhellmann> it's hard to un-create the stable branch so I don't think we want to do it without an ack from the team
14:10:26 <ttx> just wanted to make sure the spreadsheet was current on those
14:10:38 <dhellmann> however, if they don't get a release out in time, we wouldn't create a branch from a late release
14:10:57 <ttx> So the current plan there is to create branch on release week
14:11:10 <ttx> we could totally just wait and do that
14:11:29 <dhellmann> yeah
14:11:39 <ttx> maybe just send a reminder that we'll just take what is tagged on release week, no more warnings
14:11:55 <ttx> and that they can contact us if they want to open newton earlier
14:11:57 <dhellmann> I haven't heard from some of these folks at all, so I'm not sure they're reading the emails, but yeah
14:12:12 <ttx> dhellmann: maybe personal
14:12:16 <dhellmann> we need to prepare the patch to remove tagging and branching rights
14:12:19 <dhellmann> ttx; yeah
14:12:41 <ttx> dhellmann: that way we limit nagging to the "managed" stuff
14:12:45 <dhellmann> if we don't want any of these folks creating releases and branches after the deadline, we need to make it so they can't
14:13:27 <dhellmann> I think we've heard from all of the managed teams, haven't we?
14:13:36 <ttx> yes
14:13:59 <ttx> So we can probably avoid nagging unmanaged/intermediary stuff
14:14:14 <ttx> Not sure we can avoid nagging on unmanaged/milestones stuff
14:14:20 <ttx> since they are at b3 and we need a RC1
14:14:29 <dhellmann> yeah, I'll poke those teams today
14:14:43 <ttx> which leads to the next topic
14:14:53 <dhellmann> #topic stable/mitaka branch for openstack/requirements: wait for managed RC1s ? All RC1s ?
14:14:56 <bswartz> dhellmann: here
14:15:03 <dhellmann> #undo
14:15:04 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0xa0765d0>
14:15:20 <dhellmann> bswartz : we need an rc1 for manila, do you have an eta?
14:15:41 <bswartz> dhellmann: there are 9 bugs open -- all have fixes and are being reviewed
14:15:50 <bswartz> dhellmann: we're hopeful to have something today
14:15:52 <dhellmann> bswartz : that's a lot
14:15:56 <dhellmann> bswartz : ok
14:15:58 <bswartz> I know
14:16:12 <ttx> we also need a final python-manilaclient -- can we take 1.8.0 and create stable/mitaka from that ?
14:16:31 <bswartz> there was 1 bug yesterday
14:16:33 <bswartz> let me check
14:16:54 <ttx> bswartz: you can re-release 1.8.1 if that's bugfix only
14:17:08 <bswartz> that fix is in the gate now
14:17:21 <dhellmann> ok, let's wait for that to merge, tag 1.8.1, and branch from there
14:17:25 <ttx> ok, so let's wait for that and tag 1.9.0 or 1.8.1 ?
14:17:28 <ttx> ack
14:17:33 <bswartz> 1.9.0 IMO
14:17:47 <dhellmann> the version will depend on the nature of the change
14:17:55 <bswartz> well wait I'd have to see what 1.8.0 hat
14:17:56 <bswartz> had
14:17:57 <dhellmann> it's only 1.9 if there is a feature or requirement
14:18:04 <bswartz> yeah I'll figure that out and push a tag
14:18:05 <dhellmann> *requirement change
14:18:07 <dhellmann> ok
14:18:16 <bswartz> err push a change to releases repo
14:18:18 <dhellmann> thanks, bswartz
14:18:27 <dhellmann> #topic stable/mitaka branch for openstack/requirements: wait for managed RC1s ? All RC1s ?
14:19:01 <ttx> so yeah, I was wondering when to pull the trigger
14:19:04 <dhellmann> ttx: the order for making the branches for requirements, devstack, etc. is in the TODO items in the etherpad
14:19:12 <dhellmann> it's a little messy because it's spread across 2 weeks
14:19:27 <dhellmann> it's on lin 217
14:19:32 <ttx> I did move the acl revert to release week
14:20:10 <dhellmann> I don't know if we need to wait for any more release candidates though? if we know we have a bug-fix release of manila client, for example...
14:20:16 <ttx> dhellmann: should we wait until all RC1s are done ? Just managed RC1s ?
14:20:42 <ttx> as long as we freeze requirements I think it's fine
14:20:49 <ttx> to just create the branch now
14:21:02 <dhellmann> we can't freeze the requirements if we need to update for bug fixes in libs
14:21:02 <ttx> and unfreeze once all RC1s are done ?
14:21:18 <dhellmann> so I think this is really tied to when the libraries are done, isn't it?
14:21:51 <ttx> well we can branch, but we have to push library version bumps on both sides if they happen, no ?
14:21:58 <dhellmann> yeah, true
14:22:16 * ttx is looking back at last cycle
14:23:46 <ttx> FF week: enable master/stable check
14:23:49 <dhellmann> I'd feel pretty good about it if we wait for the manila client release we know we're going to have shortly
14:24:02 <ttx> R-4: Bump constraints where needed (blocked by last libs)
14:24:08 <ttx> R-2: Branch g-r (when all stable branches are done)
14:24:16 <ttx> R-2: Disable cross-check (lifeless says it's a noop ?)
14:24:22 <ttx> R-2: Devstack branch
14:25:06 <ttx> hmm
14:25:27 <dhellmann> do we need to do anything explicit for the "master/stable check" this time?
14:26:14 <ttx> let me think
14:27:06 <ttx> not sure we changed anything there
14:27:31 <ttx> trying to find the change
14:28:43 <ttx> got it
14:29:02 <ttx> https://review.openstack.org/#/c/217300/
14:29:29 <ttx> then partially reverted by https://review.openstack.org/#/c/228805/
14:30:16 <ttx> Looks like we should have done that a couple weeks ago
14:30:19 <dhellmann> so those tests are to let us unfreeze master
14:30:21 <dhellmann> ?
14:30:27 <dhellmann> yeah
14:30:34 <dhellmann> we need a run book. we should work on that next cycle.
14:30:50 <ttx> allows stable tests to run against stable/master
14:31:37 <ttx> ensure we don't break mitaka with updates to global reqs
14:31:51 <ttx> until we create the requirements  branch
14:32:21 <dhellmann> so if we go ahead and create the requirements branch, does that do the same thing?
14:32:52 <ttx> it does, but we can't create the branch until all stable branches are cut
14:33:17 <dhellmann> what prevents that?
14:34:22 <ttx> iirc that can put you in a bad spot if you end up bumping requirements
14:34:51 <ttx> let's talk to Clark when he gets up
14:35:00 <dhellmann> ok, good idea
14:35:04 <ttx> and/or lifeless but it's saturday morning for him
14:35:13 <ttx> we'd probably not do anything on Friday evening anyway
14:35:19 <dhellmann> true
14:35:53 <dhellmann> moving on
14:35:57 <dhellmann> #topic Mitaka progress on constraints / branches / library backwards compat
14:36:16 <ttx> so the issue is that currently nothing prevent requirements to land that break stable. When you create the branch it can already be wedged
14:36:29 <ttx> anyway, let's wait
14:36:46 <ttx> I added that topic
14:37:06 <ttx> Was wondering if you got an update of te changes that were implemented in that area during mitaka, if any
14:37:20 <dhellmann> no, I need to check in with lifeless on that
14:37:27 <dhellmann> I haven't seen much action on it in a while, though
14:37:52 <ttx> right, I haven't seen anything, wanted to know if that was because I don't pay attention, or because nothing got changed
14:37:57 <dhellmann> yeah
14:38:08 <dhellmann> ok, I'll ping him and sachi
14:38:14 <ttx> ok, let's defer that to until you get a status update from lifeless
14:38:52 <dhellmann> #topic importing tags from unmanaged projects
14:38:53 <dhellmann> #link https://etherpad.openstack.org/p/V64PwVUePz
14:39:01 <dhellmann> #link https://review.openstack.org/294594
14:39:34 <dhellmann> you mention openstack-ansible in the agenda notes. I guess we should merge their deliverable files.
14:40:56 <ttx> yes
14:41:09 <dhellmann> noted, I'll propose that update today
14:41:12 <dhellmann> odyssey4me : ^^
14:41:33 <dhellmann> #topic stable/mitaka reviews for managed/milestones projects
14:41:35 <ttx> I'll handle the independent things one day, but no hurry there. I just want the mitaka release page to be accurate at this stage
14:41:50 <ttx> right, so for milestones-driven things
14:42:02 <dhellmann> right, I need to add a validation step to check the release model against the directory name
14:42:08 <ttx> we have ACL control over the changes proposed there, on managed projects
14:42:31 <ttx> in theory we should make sure that all changes merges on stable/mitaka is first merged on master, to avoid regressions
14:43:04 <dhellmann> #link https://review.openstack.org/#/q/branch:stable/mitaka+is:open
14:43:05 <ttx> https://review.openstack.org/#/q/branch:stable/mitaka
14:44:08 <dhellmann> I'll scan that list today
14:44:29 * dhellmann may end up working tomorrow, since he's out monday and tuesday
14:44:51 <ttx> so my question was, how much attention do we want to spend on that
14:44:59 <ttx> vs. trusting the ptl
14:45:09 <ttx> who also has +2 on that
14:45:38 <dhellmann> I'll scan it quickly, but I think it should be safe to trust the PTLs. Maybe an email remindere?
14:46:21 <dhellmann> we can re-check as they request rc2 tags
14:46:49 <ttx> oh, another thing, ideally we want translations merges in before we tag rc2
14:47:05 <dhellmann> true, we can just merge those ourselves, right?
14:47:09 <ttx> and/or translations truncation as submitted by AJaeger
14:47:18 <dhellmann> truncation?
14:47:28 <ttx> removal of incomplete translations files
14:47:40 <ttx> like you remove languages that are <80% translated
14:48:23 <dhellmann> ah
14:48:33 <ttx> we should make sure we have AJaeger in the loop. Told me the translations things should start flowing soon
14:48:43 * andymaier is back (gone 00:01:41)
14:48:45 <dhellmann> ok, so anything that comes from zanata or ajaeger can just be merged
14:49:15 * andymaier is away: I'm away, not watching this cannel right now.
14:49:45 * andymaier is back (gone 00:00:10)
14:50:03 <ttx> I'll look at the already-merged stuff
14:50:08 <dhellmann> sounds good
14:50:36 <ttx> alright that is all I could think of
14:50:43 <dhellmann> I'll go ahead and approve the .gitreview updates that are still open
14:50:57 <dhellmann> #topic open discussion
14:51:27 <dhellmann> I feel like we've been taking really extensive notes this cycle, so I hope we have enough details by the end to  prepare a run book to make some of the reasoning simpler next time around
14:51:50 <ttx> dhellmann: trick is my brain is usually too fried to write anything when I'm done
14:52:13 <dhellmann> yeah, that's why having the notes to look at in a few weeks when things settle down should be good
14:52:36 <dhellmann> oh, speaking of a few weeks, I mentioned that I made a poorly scheduled vacation plan for Apr 4-12, which falls right on top of the final release date
14:53:22 <dhellmann> I'll have my laptop, but I think we should be mostly done with tags at that point, and just need to unwind the test jobs and such
14:53:26 <ttx> it... is poor
14:53:30 <dhellmann> yeah :-/
14:53:58 <ttx> we'll try to get to a complete list of things
14:53:59 <dhellmann> I was focused on the week prior with final candidates
14:54:22 <dhellmann> I'll be in your tz, and can work some in the early mornings
14:54:35 <ttx> if you come to my place we can the release sprint
14:54:40 <ttx> do
14:54:57 <dhellmann> I might come home alone if I do that much work :-)
14:54:59 <ttx> not sure that counts as vacation though
14:55:04 <dhellmann> not really
14:56:18 <ttx> https://review.openstack.org/#/c/294416/ <-- a translations update
14:56:20 <dhellmann> I thought we'd be mostly retagging existing releases with their final versions, and didn't count on all of the branching stuff
14:56:23 <ttx> looks like they flow
14:57:09 <dhellmann> I don't have -2 on python-muranoclient
14:57:14 <dhellmann> https://review.openstack.org/#/c/291606/2
14:57:38 <ttx> you should limit your reviews to milestones-driven and managed
14:57:57 <dhellmann> the list isn't that long, but yeah
14:58:20 <ttx> the rest you can't +2/-2
14:58:33 <ttx> dhellmann: let's talk to clarkb later
14:58:37 <dhellmann> do you want to abandon https://review.openstack.org/#/c/293414/
14:58:44 <dhellmann> yeah, let's close the meeting out
14:58:49 <dhellmann> #endmeeting