14:01:34 <dhellmann> #startmeeting releaseteam
14:01:35 <openstack> Meeting started Fri Sep  2 14:01:34 2016 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:38 <openstack> The meeting name has been set to 'releaseteam'
14:01:45 <dhellmann> courtesy ping: ttx, dims, fungi
14:02:03 <ttx> o/
14:02:15 <fungi> hey-howdy!
14:02:25 * dims partially here - o/
14:02:40 <dhellmann> great, let's get started
14:02:50 <dhellmann> our agenda is under R-5 in https://etherpad.openstack.org/p/newton-relmgt-tracking
14:02:59 <dhellmann> #topic late milestone tag request reviews, if any
14:03:29 <dhellmann> we have one for tripleo-quickstart that requires some project-config changes to add a release job to the repo
14:05:32 <ttx> that will push it past deadline
14:05:44 <ttx> shall we do that later when we can as an exception ?
14:06:21 * dhellmann realizes he just pasted stuff into the wrong window
14:06:29 <fungi> heh
14:06:35 <dhellmann> #link p-c change for tripleo https://review.openstack.org/#/c/364874/
14:06:46 * anteaya waits for her answer in here
14:07:16 <dhellmann> ttx: yes, I think we can just wait and do that one as an exception, it only affects the tripleo team, iiuc
14:07:20 <ttx> trick is the job deployment takes 30-60min last time I checked so...
14:07:26 <ttx> yep
14:07:34 <dhellmann> yeah, so next week
14:07:42 <ttx> tripleO is odd enough
14:07:56 <ttx> (release-wise)
14:08:20 <ttx> that some exception sounds harmless
14:08:30 <dhellmann> yes, and nothing depends on that package either
14:08:50 <dhellmann> are there any other pending requests that haven't been enqueued yet?
14:09:16 <ttx> not that I know of
14:09:44 <dhellmann> ok
14:10:02 <ttx> how is branching going ?
14:10:04 <dhellmann> I've created branches for all of the libs now, aside from tripleo-common because that's a cycle-trailing deliverable
14:10:09 <ttx> ok
14:10:13 <dhellmann> I need to review the results to make sure they all worked right
14:10:29 <dhellmann> there was one glitch with python-brick-cinderclient-ext that I fixed by hand
14:10:30 <ttx> yes, and fill the tracking spreadsheet
14:10:31 <EmilienM> (about tripleo quickstart, its release is really not critical for us, if we want to skip it this time we can do it)
14:10:42 <dhellmann> it prompted me about proposing multiple patches, which was confusing so I thought something had broken
14:11:06 <dhellmann> EmilienM : if we don't get a release, you won't have anything to use to create a stable/newton branch
14:11:16 <dhellmann> maybe that doesn't matter?
14:11:22 <EmilienM> I'm not even sure
14:11:26 <dhellmann> ok
14:11:27 <EmilienM> weshay: ^
14:11:36 <EmilienM> do we want stable/newton on tripleo-quickstart?
14:11:55 <dhellmann> after I review the other branches I'll let infra know about the gerrit maintenance
14:11:58 <dhellmann> #action dhellmann let the infra team know whether it's OK to go ahead with gerrit maintenance today
14:12:13 <dhellmann> #topic oddities
14:12:30 <ttx> Those are the few that missed or could have refreshed
14:12:44 <weshay> EmilienM, I don't think it's critical afaik,  but we should confirm w/ trown
14:12:46 <dhellmann> we had a few stragglers that were resolved early today, and a few other projects that missed
14:13:09 <ttx> python-monascaclient has a ~2month-old release
14:13:11 <EmilienM> weshay: I suggest we skip it this time, I really to want to burn release managers time for nothing we don't actually need today
14:13:19 <weshay> EmilienM, +1
14:13:22 <EmilienM> I don't want*
14:13:29 <dhellmann> ttx: yes, that's the biggest issue
14:13:35 <ttx> dhellmann: we /could/ take over and release for them
14:13:37 <EmilienM> dhellmann: we'll skip it this time.
14:14:01 <dhellmann> ttx: I already created their stable branch from that existing release.
14:14:05 <ttx> I'm pretty sure they have some feature in there thy will want in newton
14:14:09 <ttx> oh, ok
14:14:19 <dhellmann> ttx: I do not want to set a precedent for not having to pay attention
14:14:32 <ttx> sounds good
14:14:59 <dhellmann> we'll let them cut an early ocata release and they can tell users who want those features to use that version, so they're not completely messed up
14:15:09 <ttx> right
14:15:38 <dhellmann> is there anything else to mention about stragglers or other oddities?
14:16:07 <dhellmann> ok, moving on
14:16:10 <dhellmann> #topic automation update
14:16:30 <dhellmann> the automation is working well. we had a few glitches, but we've resolved them all quickly.
14:16:44 <dhellmann> thanks again, fungi, for all the work you put into setting that up this cycle!
14:16:45 <fungi> i haven't gotten to my lingering documentation/content tasks for the releases site
14:16:57 <fungi> the past couple of weeks have sort of gotten away from me
14:17:20 <fungi> but afaik that's all that's left on my plate for this as of now
14:17:24 <dhellmann> np, things ought to calm down next week
14:17:33 <dhellmann> I believe that's right
14:17:44 <dhellmann> I have some ideas for changes, but those will wait for Ocata
14:18:06 <dhellmann> they're mostly refinements and shouldn't require a lot of extra help beyond the usual summit discussions and then some reviews
14:18:42 <dhellmann> the 2 big items are moving the u-c update step to a point after the pypi upload, and adding the ability to request stable branches
14:19:07 <fungi> yeah, after i get the final batch of contributor invites sent out on monday, i hope my week will settle down
14:19:29 <dhellmann> ++
14:19:38 <dhellmann> #topic model mismatches
14:20:01 <dhellmann> we identified several deliverables that had versions that didn't match their release model
14:20:44 <ttx> I wonder where the error is though
14:20:44 <dhellmann> I've avoided writing more strict validation rules for those things because when models change it can screw up the ability to do stable releases, but maybe that's another item to revisit for next cycle
14:21:07 <dhellmann> well, for a lot of them I'm sure I said "yes, that's a service, so a beta tag is fine" and didn't look at the actual release model
14:21:11 <ttx> did they want to do intermediary and failed at versioning ? Or did they fail to describe their wanted model ?
14:21:21 <dhellmann> good point
14:21:38 <dhellmann> either way, having stricter validation would have raised the question early, instead of this week
14:21:49 <ttx> In the case of Telemetry it feels like they actually /wanted/ to do intermediary, since they changed during this cycle
14:22:00 <dhellmann> true
14:22:29 <dhellmann> and I think the Tripleo case is confused by having some of the projects be trailing and others not
14:22:39 <ttx> if they still plan to do intermediary in Ocata, maybe switching back to -with-milestones has limited interest
14:22:49 <ttx> wondering how much of the automation relies on that being set correctly
14:23:11 <ttx> I think we rely on presence of bX/rcY rather than read the model
14:23:26 <dhellmann> I'll have to look at how the final release script works, but I think it just looks at what has an rc version in the deliverable files and doesn't care about release models
14:23:39 <ttx> iow, should we fix those back to what they are for Newton, or keep what they want to be in Ocata
14:23:54 <dhellmann> I know the CI jobs do look at the version in the git tag, but not the release models
14:24:09 <ttx> ok, so we could just move them around in the spreadsheet and let them be
14:24:38 <ttx> (although making sure they understand what that means and that it's what they want for Ocata could be useful)
14:24:39 <dhellmann> yeah, I think at this point we don't need to change any model tags for newton but we want to straighten it out for ocata
14:25:37 <dhellmann> I expect we'll have a face-to-face discussion with EmilienM and some of the other tripleo folks in Barcelona
14:25:48 <ttx> yes, and j
14:25:50 <dhellmann> and I'll track down jd__ to talk to him too
14:25:51 <ttx> jd__
14:26:17 <EmilienM> dhellmann: i'll be there
14:26:24 <ttx> maybe add note to postmortem to remember
14:26:33 <EmilienM> should I bring french wine before the discussion?
14:26:38 <dhellmann> only having 2 projects with this issue still seems like an improvement over last cycle, but I don't remember how many we had then
14:26:45 <ttx> in Barcelona ? You sir are doing int wrong
14:26:50 <ttx> it*
14:27:01 <EmilienM> ok I'll bring Sangria
14:27:06 * ttx sobs
14:27:52 <ttx> dhellmann: next topic ?
14:27:56 <dhellmann> postmortem note added
14:28:07 <dhellmann> #topic other release-related reviews
14:28:18 <ttx> yes, so I flagged a few reviews for attention
14:28:24 <ttx> https://review.openstack.org/#/c/360140/5
14:28:47 <ttx> This one has a negative remark from you so I didn't approve it
14:29:01 <ttx> although I did approve other trailing stuff
14:29:29 <ttx> Let me know if you're fine with it
14:29:33 <dhellmann> yeah, I think since it's trailing and new repos are one way they add features to the ansible stuff, it's probably ok
14:29:38 <dhellmann> we approved some other similar ones
14:29:57 <ttx> https://review.openstack.org/#/c/364307/3
14:29:59 <dhellmann> I added a +1
14:30:14 <ttx> that one is less urgent, but the only deliverable-related one you haven't approved yet
14:30:40 <dhellmann> hmm, this seems like it can wait for ocata
14:30:43 <ttx> Gerr..it..slow
14:31:20 <ttx> The 3 project-config ones are the things we have in the oven to improve the automation
14:31:49 <ttx> All merged except https://review.openstack.org/#/c/363979/
14:31:54 <ttx> which is W-1
14:32:07 <ttx> do you think we can enable it now ? Would you rather do that Tuesday ?
14:32:22 <dhellmann> let's go ahead
14:32:35 <dhellmann> fungi : can you put ^^ on your review list when you have some time?
14:32:46 <fungi> sure, pulling it up now
14:32:47 <dhellmann> there's no rush, but the thing we were waiting for is fixed
14:33:10 <ttx> OK, that is all from me
14:33:20 <fungi> lgtm +3
14:33:30 <dhellmann> I suppose we'll still publish "bad" info after another patch merges, but this at least gives us time to revert the release request
14:33:50 <dhellmann> #topic countdown email
14:34:01 <dhellmann> I have the RC1 and string freeze items to mention
14:34:07 <dhellmann> I'll also mention that library branches are created
14:34:15 <dhellmann> is there anything else to say in the reminder email today?
14:34:38 <fungi> nothing comes to mind
14:35:03 <dhellmann> ttx, anything from you?
14:35:26 <ttx> hmm, nothing. You talk about FFEs ?
14:35:34 <dhellmann> oh, I haven't mentioned those, no
14:35:50 <dhellmann> ok, good
14:36:10 <dhellmann> #topic open discussion
14:36:18 <ttx> Like.. not too many, stuff that can actually be completed, etc
14:36:38 <dhellmann> yeah, there's some advice like that in the process doc, I'll use that as a basis
14:36:52 <dhellmann> is there anything else we need to discuss this week?
14:37:28 <fungi> as noted earlier, tentative gerrit maintenance starting at 18:00 utc if we get the go-ahead from you
14:37:31 <fungi> #link http://lists.openstack.org/pipermail/openstack-dev/2016-August/102281.html
14:37:44 <dhellmann> fungi : yep, my next task is to review the branches and get back to you
14:37:48 <dhellmann> so far everything is looking green
14:37:52 <fungi> sounds great!
14:37:53 <anteaya> thank you
14:38:14 <ttx> all green
14:38:18 <ttx> karbor is a go
14:38:21 <dhellmann> fungi, anteaya : I'll ping you in #openstack-infra in a bit
14:38:26 <fungi> we'll be in a holding pattern preparing for the next ~3.5 hours
14:38:31 <fungi> so take your ime
14:38:33 <fungi> time
14:38:35 <dhellmann> k
14:38:53 <dhellmann> alright, I think we can wrap up a bit early again then
14:38:56 <dhellmann> thank you all!
14:38:56 <anteaya> dhellmann: thanks
14:39:11 <anteaya> thank you
14:39:18 <dhellmann> #endmeeting