15:01:37 <ttx> #startmeeting releaseteam
15:01:38 <openstack> Meeting started Fri Apr  7 15:01:37 2017 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:41 <openstack> The meeting name has been set to 'releaseteam'
15:01:58 <ttx> Ping list: dims, tonyb, stevemar
15:02:26 <ttx> #topic Pike-1 actions
15:02:52 <ttx> The only remaining Pike-1-targeted incomplete item would be https://review.openstack.org/448173
15:02:57 <ttx> waiting for dims to review it
15:03:14 <ttx> Anything else we should be completing before Pike-1 next week ?
15:03:46 <dhellmann> I think that's it in terms of our todo list
15:04:38 <ttx> #action dims to review https://review.openstack.org/448173 so we can close our P1 list
15:04:49 <ttx> #topic Bottleneck in stable reviews
15:04:53 <dhellmann> was there a countdown email this week? I'm behind
15:05:03 <fungi> there was, saw it this morning
15:05:11 <dhellmann> ok, cool, I just haven't read it yet then
15:05:13 <ttx> It feels like the bottleneck in getting stable-policy--compliant releases is not getting a lot better
15:05:39 <ttx> was wondering if we should not do the assessment by ourselves if after a given period of time the stable team didn't review it
15:05:43 <dhellmann> I agree :-/
15:05:53 <ttx> even if that means doing a cursory look
15:06:02 <ttx> long-term we need to grow replacements there
15:06:09 <dhellmann> yeah, I tend to look at the commit descriptions anyway
15:06:18 <ttx> even if that kind of contribution is not in fashion
15:06:46 <fungi> the end result is release management backfilling stable branch maintenance rather than the other way around like we'd hoped
15:06:50 <dhellmann> I've noticed some +1 votes from folks I don't recognize
15:06:58 <dhellmann> fungi : yeah
15:07:37 <ttx> I've been sitting on the idea of a "TC says it would be great if you contributed there" list
15:07:43 <dhellmann> although now I can't find an example
15:08:00 <ttx> which Anni @ Huawei said would do a lot to drive APAC contributors to valuable strategic contributions
15:08:02 <dhellmann> maybe we can replace all of stackalytics with a counter for number of stable reviews
15:08:11 <fungi> heh
15:08:27 <dhellmann> ttx: is that something we'd add to governance.o.o/tc?
15:08:33 <dhellmann> or somewhere else?
15:08:52 <fungi> the hit list/bounty hunt idea
15:09:08 <dhellmann> right
15:09:54 <fungi> "1. grow stable-maint-core reviewers by 3" or something like that
15:09:55 <ttx> dhellmann: TC-level to give it some "official" weight, which carries a lot of importance in those culture
15:09:57 <ttx> s
15:10:15 <dhellmann> yeah, having the tc maintain the list is a good idea. I'm wondering how to publish it.
15:10:24 <lbragstad> is this for stable maintenance across projects, or project specific stable maintenance?
15:10:39 <dhellmann> lbragstad : stable releases specifically
15:10:49 <fungi> lbragstad: sore spot right now is timely review of stable point release requests
15:10:59 <dhellmann> lbragstad : we need people to help ensure that new stable releases follow policy
15:11:03 <lbragstad> dhellmann fungi aha
15:11:17 <lbragstad> thanks
15:11:33 <fungi> interested? ;)
15:12:00 <lbragstad> i actually have a hard time getting folks to review stable patches in keystone ;)
15:12:08 * fungi works on his hard sell tactics
15:12:19 <ttx> anyway, how about we self-review them in they last more than a week  ?
15:12:21 <lbragstad> luckily dolphm and stevemar do a pretty good job of staying available
15:12:36 <dhellmann> ttx: ++
15:12:45 <ttx> while we wait for a more permanent fix
15:12:48 <dhellmann> ttx: 2 +2s for those?
15:12:54 <ttx> otherwise it's punishing whoever follows policy
15:12:58 <ttx> dhellmann: sure
15:13:10 <dims> o/ (sorry was writing up candidacy for something called the TC :)
15:13:12 <dhellmann> cool. I've already +2 several
15:13:20 <ttx> dims: who does those things on a Friday
15:13:39 <dhellmann> dims : you have until sunday for that!
15:13:53 <ttx> #agreed release management team will review stable releases directly if the stable team doesn't pick them up after a week. 2 +2s needed for approval
15:14:05 <dims> 2 soccer games, 1 ice cream social - full deck for weekend :)
15:14:19 <ttx> #info Whenever the TC comes up with a "Strategic contributions wanted" list, make sure to include stable team in it
15:14:57 <dims> ++ ttx
15:15:09 <ttx> my weekend: friends stopping by for lunch, table tennis game, wine fair and someone's birthday party
15:15:27 <dims> nice!
15:15:52 * dhellmann will be going to the farmer's market, then maybe shoe shopping. #excitement
15:16:04 <ttx> #topic Open discussion
15:16:09 <ttx> Ok, anything else ?
15:16:32 <lbragstad> would i be able to get added to the ping list for this meeting?
15:16:43 <lbragstad> or is that something i can go and do?
15:16:44 <dhellmann> I'm interested in input on this reno review: https://review.openstack.org/448066
15:16:55 <dhellmann> I'm not opposed, just not sure it's a good idea.
15:17:06 <dhellmann> lbragstad : ttx should probably add you to his notes
15:17:22 <lbragstad> dhellmann ttx cool - thank you
15:17:41 <ttx> lbragstad: want to be on the ping list ?
15:17:46 <ttx> ok done
15:17:49 <lbragstad> ttx yes please
15:18:11 <ttx> dhellmann: it's actually maintained directly on https://etherpad.openstack.org/p/pike-relmgt-tracking :)
15:18:35 <dhellmann> oh, right
15:18:38 <dims> dhellmann : does it cover how to deal with release notes for older releases?
15:19:03 <lbragstad> dims that's a good question
15:19:05 <dhellmann> dims : I think the idea is just that some projects wanting to adopt reno don't want the subdirectory
15:19:35 <dims> right dhellmann
15:19:41 <dhellmann> so I don't think we have a migration issue
15:20:49 <dims> dhellmann : i mean once you switch to this new style repos. there should be identical branches in that new repo
15:22:09 <dhellmann> I think in this case there is no "switching" -- the project that wants to use reno like this doesn't already have reno deployed?
15:22:27 <dhellmann> maybe I'm not understanding what you mean, though
15:23:33 <dims> say a project starts doing that then say down the pike we have a stable/teapot branch in the project repo and reno repo, will that scenario work with the code in that review
15:24:29 <dims> will ask on the review after i peek dhellmann
15:24:40 <ttx> ok, anything else ?
15:24:48 <dhellmann> yeah, this is just about moving the contents of releasenotes/notes into releasenotes/ so it doesn't affect branches
15:25:07 <dhellmann> that's it from me
15:25:27 <dims> gotcha thanks
15:28:30 <ttx> alright then
15:28:32 <ttx> #endmeeting