15:00:13 <ttx> #startmeeting releaseteam
15:00:14 <openstack> Meeting started Fri May 19 15:00:13 2017 UTC and is due to finish in 60 minutes. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:18 <openstack> The meeting name has been set to 'releaseteam'
15:00:19 <ttx> Ping list: dhellmann, dims, fungi, tonyb, stevemar, lbragstad
15:00:30 <dhellmann> o/
15:00:37 * dhellmann is on another call, will be here shortly
15:00:47 <fungi> hey there
15:01:09 <ttx> #link https://etherpad.openstack.org/p/pike-relmgt-tracking
15:01:12 <ttx> Agenda ^
15:01:27 <ttx> scroll down to R-15
15:01:46 <ttx> #topic Boston Forum outcomes
15:02:15 <ttx> First, was great seeing you all last week. Any lesson / thing we need to do from what we learnt at Summit ?
15:02:56 <dhellmann> we didn't have much related to the release team last week, which let me focus on some other themes
15:03:13 <ttx> I noted brainstorming binary releases options, but taht's well under way
15:03:26 <dhellmann> yeah, that thread got out of control pretty quickly
15:03:30 <dims> o/
15:03:43 <fungi> yeah, i felt like the new format was a great opportunity for efforts like release management to give feedback rather than receive it
15:04:10 <ttx> Still think we need to adapt to that binary-friendly world, but I would say we need to take the time
15:04:12 <fungi> sessions at the design summit tended to be the other way around
15:04:17 <ttx> (i.e. not now)
15:04:22 <dims> did we get any bites from folks on the onboarding front? (sorry i mssed that)
15:04:39 <ttx> dims: that session is when we connected with Caleb
15:05:00 <dims> ack on binary-friendly world ttx, golang deliverables will need them too
15:05:04 <ttx> so that was useful, at least for that. Otherwise nobody joined the team as a result of that session yet
15:05:04 <dims> ttx : ah cool
15:05:07 <fungi> the joint onboarding was nice, but yeah most interest seemed to be cross-community outreach
15:05:52 <ttx> ok, if nothing else, let's move on to next topic
15:05:52 <dhellmann> true
15:06:02 <ttx> #topic Follow-up with TC on lack of goals answers
15:06:26 <ttx> A large number of teams failed to fill their goals answers by the deadline
15:06:40 <ttx> Not sure what we should do at relmgt team level about that, beyond just raising the miss
15:06:56 <ttx> So the next step seems to live at TC level
15:07:01 <dhellmann> yeah, I see that as a TC project, so we should address it there
15:07:13 <dims> yep, not enough carrots or sticks...
15:07:42 <ttx> It seems to point to the process friction
15:08:00 <ttx> more than to any specific work being too hard to accomplish
15:08:10 <ttx> i.e. the same teams missed updating both goals
15:08:43 <dhellmann> could be
15:08:53 <ttx> anyway, that means we need to discuss it at TC level. Raise a ML thread ? Wait for office hours to be set up ?
15:09:32 <dhellmann> some of the teams are the ones that are regularly less engaged; some have drastically reduced staff now
15:10:01 <dhellmann> maybe a ML thread to get the TC discussion started?
15:10:31 <ttx> ok, I can do that -- although my absence at end of next week means you might need to step in that thread
15:10:41 <dhellmann> ok
15:10:55 <fungi> d'oh, yep i need to update the open goals for infra to say they don't apply i guess
15:11:36 <ttx> #action ttx to raise thread next week on goals answers
15:11:42 <fungi> i wonder if lack of updates are mostly from teams who forget they still need to do that when the goals aren't applicable to them
15:11:56 <ttx> #topic Need for a TC resolution stating something to the effect that projects that wish to be considered part of the openstack release should have their deliverables listed on releases.o.o
15:11:58 <dhellmann> it's likely true for some
15:12:00 <ttx> mouthful
15:12:23 <ttx> I was wondering if we still want to do that formalkly, or just assume that's the case
15:12:31 <dims> ttx : which teams are missing?
15:12:37 <ttx> after all we define what "the release" is
15:12:52 <dhellmann> I think fuel was missing at one point, but I don't know if that's even an issue any more
15:13:02 <dhellmann> most of the others were "independent" projects, I thought
15:13:21 <ttx> We have enough things in the fire at the moment so we might want to move that to backlog
15:13:24 <dhellmann> which aren't part of the release anyway, since they aren't on the cycle
15:13:28 <dhellmann> yeah
15:13:36 <dhellmann> I'm much more interested in resolving the goals process issues
15:13:46 <ttx> #info answer is no pressing need
15:14:00 <ttx> OK, I'll update the plan quickly
15:14:48 <ttx> #topic Heads-up on ttx's availability around milestones
15:15:17 <ttx> So... I committed to a number of travels and realized a bit after the fact that those were not great weeks for me to travel
15:15:44 <ttx> Like on pike-2 week I'll be traveling Tue-Fri
15:16:06 <ttx> Then on pike-3 week I'll be traveling Mon-Wed
15:16:17 <dhellmann> are you trying to one-up me? :-)
15:16:20 <ttx> and be away all the week before
15:16:40 <ttx> Those are weeks where I work, but I know that my productivity will be limited
15:16:56 <ttx> Especially those weeks around Pike-3 I'll be in China
15:16:57 <dims> i'll be around both weeks pike-2 milestone and pike-3 milestone as of this moment ttx dhellmann
15:17:11 <ttx> so I have no idea how well that will work
15:17:18 <dims> ah openstack china day
15:17:19 <ttx> (probably poorly)
15:17:22 <dhellmann> ttx: I think dims and I can handle reviews. Will you be able to handle the reminder emails, or should we do that?
15:17:33 <ttx> let me see
15:17:50 <ttx> I can do all reminder emails for pike-2, no problem
15:18:21 <ttx> The one on R-6 week, can probably get it done as well.
15:18:25 <dims> fyi, i am travelling last 3 weeks of june
15:18:37 <ttx> I mean, I can still get work done, but won't be as much on IRC
15:18:58 <dhellmann> ok
15:19:24 <ttx> dims: can you fill in your availability in "Team availability notes" in https://etherpad.openstack.org/p/pike-relmgt-tracking ?
15:19:35 <ttx> dhellmann: any planned absence between now and pike-3 ?
15:20:01 <dhellmann> I have no plans to travel for a while. I might end up doing a short vacation trip, but nothing big until after the release.
15:20:31 <dhellmann> at least nothing right now, but I'll let you know if that changes
15:20:52 <ttx> ok, looks like there will always be at least two of us on deck
15:21:42 <ttx> I'll try to be more careful in the future
15:22:20 <ttx> #topic Skip meeting next week ?
15:22:36 <ttx> I'll be off on Thursday-Friday next week (holiday)
15:22:55 <ttx> so I was thinking we should skip meeting, and discuss on channel ad-hoc
15:23:12 <dhellmann> yeah, we don't have a lot going on so that seems like a good idea
15:23:51 <dims> ++
15:23:58 <ttx> I'll try to get my pike-2 stuff done next week(s). It's likely that I'll have to defer the Storyboard stuff to Pike-3
15:24:19 <dhellmann> I have some of the remaining python 3 work queued up for review
15:24:25 <dhellmann> fungi, if you could put https://review.openstack.org/465739 on your list that would help
15:24:27 <ttx> lots of things on top of that pile
15:24:39 <ttx> #topic Open discussion
15:24:41 <dhellmann> once that's done, I'll look at the branching support for devstack
15:24:58 <fungi> dhellmann: starred, thanks for the heads up
15:25:56 <ttx> anything else ?
15:26:14 <dhellmann> nothing from me
15:26:26 <ttx> Alright then, have a great weekend
15:26:31 <ttx> #endmeeting