15:00:54 <ttx> #startmeeting releaseteam
15:00:54 <openstack> Meeting started Fri Jul 28 15:00:54 2017 UTC and is due to finish in 60 minutes. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:57 <openstack> The meeting name has been set to 'releaseteam'
15:00:59 <ttx> Ping list: dhellmann, dims, fungi, tonyb, stevemar, lbragstad
15:01:18 <lbragstad> o/
15:01:27 <ttx> Meeting agenda on https://etherpad.openstack.org/p/pike-relmgt-tracking ; scroll down to R-5
15:01:35 <ttx> dhellmann will be a couple minutes late
15:01:49 <ttx> fungi is mostly off today
15:01:53 <ttx> Let's get started
15:02:00 <ttx> (lots of ground to cover)
15:02:08 <ttx> #topic Missing client libs
15:02:21 <ttx> Good news, we have at least one Pike release for every client lib
15:02:29 <ttx> so no need to tag anything by ourselves
15:02:34 <dhellmann> o/
15:02:45 <ttx> #topic Missing Pike-3 milestone
15:02:57 <ttx> News here are slightly less good
15:03:23 <ttx> We have a number of cycle-with-milestones deliverables that were not tagged .0b3 yet
15:03:31 <ttx> around heat, neutron, sahara
15:03:45 <ttx> For sahara tellesnobrega is working on it
15:03:59 <ttx> I pinged kevinbenton for Neutron earlier
15:04:06 <dhellmann> heat hasn't done the doc migration either
15:04:18 <dhellmann> I haven't caught up with ricolin on that
15:04:31 <ttx> ricolin is probably sleeping by now given his TZ
15:04:40 <ttx> therve doesn't seem to be around
15:04:51 <ttx> so, probably a miss there
15:04:54 <dhellmann> yeah
15:05:08 <ttx> We could force-tag
15:05:18 <ttx> since we somehow need to mark FF
15:05:44 <ttx> thoughts ?
15:05:45 <dhellmann> I wonder how many PTLs will be at the PTG and if we could get them to come to a kick-off meeting or something if we scheduled an hour on wednesday
15:05:55 <ricolin> dhellmann,
15:05:56 <ttx> we could
15:05:58 <ricolin> ttx
15:06:04 <ricolin> o/
15:06:11 <ttx> ricolin: Hey! Aren't you sleeping ?
15:06:12 <dhellmann> hi, ricolin! we didn't expect you to be up at this hour :-)
15:06:28 <ricolin> heat already done with migrate I think
15:06:48 <ricolin> ttx, dhellmann 11pm for me:)
15:06:48 <ttx> ricolin: would be great if you could submit a releases request for the Pike-3 tag for openstack/heat
15:06:49 <smcginnis> dhellmann: I like the idea of having a PTL sync at the PTG.
15:06:49 <dhellmann> ricolin : oh, indeed, I hadn't checked the burndown today but it looks like you're good
15:07:02 * fungi is sort of around still, but mostly lurking
15:07:04 <dhellmann> oh, that's not so bad then.
15:07:42 <dhellmann> smcginnis: I'd be happy to help put together an agenda for it
15:07:53 <ricolin> ttx yes, we try to merge some last BP patch before send release out, which I should send the release patch it out in few hours
15:08:09 <smcginnis> dhellmann: Cool, I'll ask diablo_rojo_phon if we can get some space then.
15:08:14 <dhellmann> ++
15:08:37 <ricolin> dhellmann, yeah, sorry for the late schedule, it's my bad to miss that migrate ML
15:08:43 <ttx> dhellmann: you fine with waiting a few more hours for heat 0b3 ? I'll be gone by then
15:08:53 <dhellmann> ricolin : you're not the only one, so no worries -- I'm very glad you're done though
15:09:03 <dhellmann> ttx: sure, I'll watch for the patch and approve it this afternoon
15:10:07 <ttx> #info Pike-3 tags still needed for heat, neutron deliverables and sahara. Will be merged (or forced) by EOD
15:10:28 <ttx> #topic Cycle-with-intermediary without single Pike release yet
15:10:42 <dhellmann> ttx: so do you want me to go ahead and just tag master for anyone who doesn't submit a b3?
15:10:55 <dhellmann> sorry, that wasn't clear
15:11:17 <ttx> dhellmann: I think it's better to have a forced tag than to not have a tag at all for pike-3
15:11:21 <dhellmann> ok
15:11:27 <dhellmann> we should announce that, if you haven't already
15:11:29 <ttx> since I want those to be under FF as well
15:11:34 <dhellmann> but I'm fine doing it
15:11:37 <ttx> I'll icnlude it in the countdown email
15:11:41 <dhellmann> ++
15:11:43 <ttx> somewhere
15:11:49 <ttx> We still have a number of deliverables following the cycle-with-intermediary model which
15:11:57 <ttx> haven't done a Pike release yet
15:12:07 <dhellmann> I will wait until 20:00 UTC
15:12:08 <ttx> which makes their choice of release model pretty questionable
15:12:29 <dims> o/ am here now
15:13:02 <ttx> aodh bifrost ceilometer cloudkitty-dashboard cloudkitty magnum-ui magnum murano-agent networking-hyperv panko senlin-dashboard tacker
15:13:41 <ttx> I think what we said we'd do is to force a HEAD tag on August 10
15:13:47 <ttx> if we still have nothing by then
15:13:56 <dhellmann> that would be around rc1?
15:14:04 <ttx> yes, that's the RC1 target week
15:14:08 <ttx> (end of)
15:14:10 <dhellmann> yeah, I think that's what we said
15:14:16 <smcginnis> Makes sense to me.
15:14:34 <ttx> + put them on the docket for looking into whether they are still active enough to be kept in the official list
15:14:55 <ttx> i put some language about that on the countdown email
15:15:00 <ttx> which we'll review later
15:15:01 <dhellmann> sounds good
15:15:33 <ttx> #info If no Pike release is produced, one will be forced by August 10
15:15:41 <ttx> #topic Release dashboard (make-dashboard)
15:16:04 <ttx> dhellmann: That's a task from last week, did you produce it ? If yes, do you have a link ?
15:16:14 <ttx> didn't want to duplicate work
15:16:20 <dhellmann> I did not. It's easy to do though, so I can do that today too
15:16:26 <dhellmann> Do we still want one?
15:16:34 <dhellmann> or is the query from list-deliverables sufficient?
15:16:50 <dhellmann> the google doc has been helpful in the past
15:16:56 <ttx> hmm, I think I'd be more comfortable with one
15:16:59 <dhellmann> ok
15:17:14 <ttx> #action dhellmann to produce the release dashboard
15:17:21 <ttx> #topic Requirements freeze
15:17:45 <ttx> We are supposed to freeze requirements aroundish today
15:17:51 <ttx> pushing -2 to open patches
15:18:11 <ttx> Not sure if that should be done after/before pushing stable/pike branches though
15:18:11 <dims> ttx : python-barbicanclient is the one thing we may expect to show up. 4.5.0 was bad and was/is-being removed from u-c
15:18:29 <ttx> dims: can you cover -2ing open patches once that's done ?
15:18:37 <smcginnis> That drop back to 4.4.0 is going through gate now.
15:18:48 <dims> yep ttx
15:19:06 <ttx> dhellmann: I think it can happen independently from the stable/pike branch cutting
15:19:14 <ttx> (but around same time)
15:19:16 <dims> tonyb : fyi ^^ i'll -2 open requirements patches
15:19:41 <ttx> the process has it "just before"
15:19:59 <dhellmann> smcginnis , dims : should we branch barbicanclient at 4.4.0 instead of 4.5.0?
15:20:21 <dims> dhellmann : unless we hear back from barbican folks
15:20:26 <ttx> if not, we need to do a 4.6.0
15:20:27 <smcginnis> dhellmann: We may need to get input from the barbican team on that, but I think so.
15:20:32 <dims> dhellmann : i just asked kfarr to join us in -release
15:20:35 <dhellmann> #link dashboard https://docs.google.com/spreadsheets/d/1F2hFo6cf1OvIyoC-ifRpVgrkFiYMzbNFTr2MsAYLpqs/edit?usp=sharing
15:21:09 <ttx> #action dims to set -2 to open requirements patches
15:21:16 <ttx> #topic Stable branch creation
15:21:39 <ttx> dhellmann: I think it's time (for all libs). Thoughts ?
15:21:57 <dhellmann> ttx: sure, I can do that right after the meeting
15:22:06 <ttx> the only open question would be that barbican one
15:22:10 <dims> ttx : looks like tonyb already sent a plan and a date/time for requirements freeze - http://lists.openstack.org/pipermail/openstack-dev/2017-July/120205.html
15:22:36 <ttx> dims: oh, great
15:22:38 <ttx> missed that
15:23:04 <dims> ttx : will sync with tonyb and help with what he wants to do
15:23:10 <ttx> #action dhellmann to trigger stable/pike branch creation for all libs on their current pike version (except barbicanclient)
15:23:27 <ttx> #topic Review countdown email, and send
15:23:35 <ttx> #link https://etherpad.openstack.org/p/A3HuPm6Y4F
15:23:37 <ttx> draft ^
15:23:43 <ttx> let me add the thing I mentioned earlier
15:25:17 <smcginnis> LGTM
15:26:03 <dhellmann> I tweaked the language about the patches being proposed, but otherwise it looks good
15:26:59 <ttx> Added paragraph about forcing 0b3 tags
15:27:16 <ttx> OK, will send just after meeting then
15:27:18 <dhellmann> ++
15:27:23 <smcginnis> Wording looks good.
15:27:33 <dhellmann> I will apply the usual color rules to the dashboard, too
15:27:49 <ttx> #topic The ceilometer-powervm case
15:27:52 <dims> "As usual come find us on #openstack-release IRC channel if you have any questions" at the end?
15:28:10 <ttx> dims: please add
15:28:20 <ttx> A job fail made me notice the strange case of ceilometer-powervm
15:28:28 <ttx> It's a Telemetry team deliverable since end of 2015
15:28:41 <ttx> following the cycle-with-milestones model pretty well
15:28:41 <dhellmann> ttx: it sounds like we need to make another round of audits of tagging acls on official deliverables
15:28:59 <ttx> That said it was always tagged manually, thanks to a permissive ACL
15:29:10 * dims back in a bit. will read scrollback
15:29:14 <ttx> And never appeared on the lreeases website
15:29:20 <dhellmann> should we import the history?
15:29:23 <ttx> We have a number of potential actions
15:29:54 <ttx> We can fix it -- add history, fix ACL, educate the direct-tagger
15:30:25 <ttx> We can consider that it's a sign of being out of touch and remove the project from projects.yaml at the TC level
15:30:52 <smcginnis> ttx: Education is probably a good first step?
15:30:55 <ttx> We can ignore it, and not make it part of Pike (under the "not in releases website, not in openstack release" rule
15:31:54 <dhellmann> we haven't been following their releases, so that seems reasonable (combined with the education step for next cycle)
15:31:57 <ttx> I'm fine with educating, in this case it feels like they were not really cared for by the Telemetry team
15:32:56 <dhellmann> I notice that the telemetry team also has lots of unreleased deliverables, so this may be part of their laissez faire approach
15:33:25 <ttx> yeah, but the ceilometer-powervm team might be more a victim than anything else
15:33:45 <smcginnis> Maybe the whole team could use a little more education.
15:33:47 <ttx> Given that they have been tagging their milestones religiously, I'm pretty sure they think they operate ok
15:34:02 <ttx> (talking ceilometer-powervm, not ceilometer)
15:34:17 <dhellmann> ttx: true
15:34:44 <ttx> dhellmann: I'm almost for ignoring them in Pike
15:34:52 <ttx> and fix them in Queens if they want to be fixed
15:35:13 <dhellmann> ttx: right, that's what I meant
15:35:17 <ttx> Alternatively, import all history and make them appear in Mitaka/Newton/Ocata
15:35:54 <ttx> So.. Ignore for Pike, educate/solve for Queens ?
15:35:59 <dhellmann> well, let's ignore it for now, and talk to them about whether they want to be part of queens. if they do, then we can import the history. if not, we can suggest that they remove themselves from governance.
15:36:10 <ttx> dhellmann: works for me
15:37:03 <ttx> adding a note to the backlog for Queens
15:37:05 <dhellmann> smcginnis : what do you think?
15:38:29 <smcginnis> I'm fine ignoring for now and working to improve the situation in queens.
15:38:41 <ttx> yeah, it's definitely not a new problem
15:38:43 <smcginnis> They've gone this far.
15:38:46 <smcginnis> ttx: ++
15:38:48 <ttx> #topic Lay out tasks for remaining weeks
15:39:15 <ttx> Last topic, I'd like to add to the "tasks" sections for the coming week, based on the process doc
15:39:21 <ttx> weeks*
15:40:22 <ttx> Let me do that now and we can refine
15:42:24 <smcginnis> Sorry, I need to drop off to head out of town. Will check in later.
15:44:23 <dhellmann> smcginnis : ttyl
15:50:32 <dhellmann> ttx: the docs team doesn't need to branch any more
15:50:40 <dhellmann> I'll update that step with the new instructions
15:50:44 <ttx> ah cool
15:51:16 <ttx> OK, so according to that doc there isn't much to do next week
15:51:21 <dhellmann> around rc1 we'll land a patch to update some settings and rebuild the landing pages for docs.o.o
15:51:59 <ttx> dhellmann: Thanks for the help in cleaning up
15:52:04 <ttx> #topic Open discussion
15:52:07 <ttx> anything else ?
15:52:43 <dhellmann> #action dhellmann update PROCESS.rst with new doc team info
15:53:13 <dhellmann> I'm going to have to go back through the action list from the meeting to make sure I caught everything, but I'll scan the log when we're done
15:53:19 <dhellmann> other than that, I think we're good
15:53:58 <dhellmann> it might be a good idea to walk through the details of these things before we start with smcginnis if he's going to help us out
15:55:53 <dhellmann> maybe we can even get him to submit some of the patches we'll need :-)
15:56:24 <ttx> alright then
15:56:28 <ttx> #endmeeting