15:00:21 <smcginnis> #startmeeting releaseteam
15:00:22 <openstack> Meeting started Fri Aug 25 15:00:21 2017 UTC and is due to finish in 60 minutes. The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:25 <openstack> The meeting name has been set to 'releaseteam'
15:00:36 <smcginnis> Ping list: dims, fungi, tonyb, stevemar, lbragstad
15:00:54 <lbragstad> o/
15:01:06 <smcginnis> lbragstad: Hey Lance! :)
15:01:18 <smcginnis> #link https://etherpad.openstack.org/p/pike-relmgt-tracking
15:01:38 <smcginnis> Agenda for the meeting is the R-1 week section
15:02:08 <dhellmann> o/
15:02:25 <smcginnis> dhellmann: Just noticed I missed you in the ping list. Sorry about that.
15:03:40 <dhellmann> np
15:04:16 <dhellmann> how're things looking with rcs?
15:04:28 <dhellmann> I think I saw that we're expecting one more from neutron?
15:04:41 <smcginnis> dhellmann: Sorry just looking at that.
15:04:49 <smcginnis> Neutron is the only one I'm aware of so far.
15:05:20 <dhellmann> we probably want to wait until after that before setting up the patch to propose the final release tags
15:05:38 <dhellmann> just to make sure we don't make a mistake and tag the wrong release
15:05:59 <smcginnis> Is there an example patch for that from ocata I can take a look at?
15:06:13 <dhellmann> there's a tool to create the patch, check PROCESS.rst
15:06:16 * smcginnis needs to take a look at the docs again
15:06:29 <dhellmann> it's something like propose-final-release I think
15:06:31 <smcginnis> Hah, yep. Just thought of that after I asked. :)
15:06:39 <dhellmann> I can never remember the exact names for these things :-)
15:06:51 <smcginnis> Good thing everything is written down. ;)
15:06:52 <dhellmann> but yeah, the tool creates the patch for you, then we just need to get the PTLs and liaisons to +1
15:07:09 <dhellmann> then we all +2 and ttx can W+1
15:07:37 <smcginnis> So all PTLs for all projects?
15:08:04 <dhellmann> it's anyone who wants to sign on, but the patch will only contain changes for the milestone projects
15:08:21 <dhellmann> and we don't *need* them to, but it's a nice gesture, since the names all go into the tag metadata
15:08:53 <smcginnis> Very true.
15:09:22 <smcginnis> #topic Missing intemediary releases
15:09:31 <smcginnis> Did I see senlin go through?
15:09:53 <dhellmann> list-deliverables shows no unreleased projects
15:10:05 <dhellmann> there's an rc for senlin
15:10:26 <smcginnis> OK, thought I at least saw a patch there.
15:10:31 <dhellmann> and list-deliverables shows no projects missing rcs
15:10:52 <dhellmann> it's not smart enough to tell us if there are any projects with really old releases, though
15:10:59 <smcginnis> Does that also show whether a stable/pike branch was created?
15:11:09 <dhellmann> it can, let me run that
15:11:42 <dhellmann> http://paste.openstack.org/show/619437/
15:11:46 <dhellmann> 5 projects
15:11:49 <dhellmann> tempest doesn't branch
15:11:51 <smcginnis> #topic Missing stable branch
15:11:57 <dhellmann> I don't know about patrole
15:12:08 <dhellmann> the others are cycle-trailing, so I think it's ok for them to not have branched yet
15:12:21 <smcginnis> patrole is part of/related to tempest I think?
15:12:29 <dhellmann> it's a qa thing, but I don't know what it is
15:12:43 <dhellmann> "rbac integration tempest plugin"
15:12:46 <dhellmann> so that may not branch either
15:12:55 <smcginnis> Ah: Tempest plugin for testing and verifying..."
15:13:07 <smcginnis> And the others there are cycle-trailing.
15:13:26 <smcginnis> So we're in good shape for branches too it appears.
15:13:28 <dhellmann> I should add a stable-branch-type for "branchless" so we can skip those
15:13:32 <dhellmann> in the query, that is
15:13:36 <smcginnis> ++
15:14:00 <smcginnis> We should have channel bots that record anything that starts with "I should..."
15:14:32 <dhellmann> or someone else could write that patch to learn how to make those sorts of changes :-)
15:14:39 <dhellmann> haha, I like the bot idea
15:14:56 <smcginnis> Was that a <hint, hint, nudge> I detected?
15:14:56 <dhellmann> "someone should" could add to a wishlist
15:15:06 <dhellmann> yes, that's an elbow you feel in your side
15:15:08 <smcginnis> Ooh, I like where this is going.
15:15:22 <smcginnis> The ShouldBot.
15:15:27 <dhellmann> perfect name
15:15:48 <smcginnis> I'll put it on my list to check out.
15:15:57 <dhellmann> it could either add it to a list, or it could just reply "you're someone!"
15:16:17 <smcginnis> #action smcginnis to look into "branchless" stable-branch-type query support
15:16:25 <smcginnis> Hah, love it.
15:16:40 <smcginnis> #topic Assign R-0 week tasks
15:17:49 <smcginnis> Approve the final release patch created earlier - that patch will be created once everything is finally through, if I understand correctly.
15:18:13 <dhellmann> yeah, we should create that early Monday
15:18:40 <smcginnis> OK, I can take creating the patch to get the experience there.
15:19:19 <smcginnis> dhellmann: Oh, I see that was something with your name on it for this weeks actions.
15:19:53 <smcginnis> Did you want to create the patch?
15:20:02 <dhellmann> oh, sure, I can do that
15:20:06 <dhellmann> I forgot I signed up for that
15:20:23 <smcginnis> Either that or you were signed up while you were on vacation. :)
15:20:29 <dhellmann> that sounds likely
15:20:55 <smcginnis> Reset gerrit ACLs - what needs to be done there?
15:21:17 <dhellmann> I'm signed up for release testing, but I think since we've done releases pretty recently it's safe to skip that as a separate step
15:21:18 <smcginnis> Looks like another that is scripted - yay
15:21:25 <dhellmann> yeah, there are 2 pieces there
15:21:35 <smcginnis> dhellmann: Yep, I agree on release testing.
15:21:36 <dhellmann> change the group membership and change the gerrit acls files
15:22:19 <smcginnis> Did we have something with ACLs for telemetry?
15:22:55 <dhellmann> I'm not sure?
15:22:59 <smcginnis> I had taken an action at some point to talk to jd about an issue there, but it's still lower on my list.
15:23:32 <dhellmann> oh, I vaguely remember something there.
15:23:33 <dhellmann> maybe they weren't set up the same way as the other projects, so the scripted stuff wasn't working?
15:23:56 <smcginnis> I thought it was something like they did their own tagging.
15:24:06 <smcginnis> I need to go back and remember too.
15:24:08 <dhellmann> that might be it, yeah
15:24:25 <smcginnis> So would this script fix the glitch for us? :)
15:25:22 <dhellmann> no, I think because of the way it's set up the script skips it
15:25:29 <dhellmann> we'll have to see, though
15:25:39 <smcginnis> OK. I'll circle back to that later then.
15:25:57 <smcginnis> Looks like the two doc items on the action list are no longer needed after the changes there?
15:26:32 <dhellmann> we need to do 0.5 but not 0.6
15:27:04 <dhellmann> we can add the doc link today, in fact
15:27:43 <smcginnis> I can take that one unless someone else wants it.
15:28:12 <dhellmann> we should update the process doc to remove that step for the future, because as soon as we open the series on releases.o.o the docs page should exist on docs.o.o so we can just always have the link present
15:28:15 <dhellmann> go for it
15:28:28 <dhellmann> I'm working with the docs team on 0.6
15:28:35 <smcginnis> OK, great.
15:29:06 <dhellmann> the patches for 0.7 and 0.8 can be stacked up on top of the final release patch, so I'll do that
15:29:20 <smcginnis> Since you're so deeply involved in the docs work, do you want to update the process doc to reflect the changes?
15:29:27 <dhellmann> yeah, I'll take that
15:29:42 <smcginnis> Cool, thanks.
15:29:56 <smcginnis> And ttx should probably take the final release announcement?
15:30:07 <smcginnis> 0.9
15:30:27 <dhellmann> yeah
15:30:39 <dhellmann> and 0.10
15:30:43 <smcginnis> And 0.10 probably tonyb I would assume
15:30:46 <smcginnis> Oh, OK.
15:30:58 <dhellmann> yeah, that's the releases repo not the requirements repo
15:31:13 <smcginnis> Oh, right. I read that too fast.
15:31:27 * smcginnis will go with that instead of admitting his eyes are getting bad
15:31:43 <dhellmann> somewhere in here we should approve the open stable releases, and that's something for tonyb
15:32:12 <dhellmann> I don't see it on R+1 or R+2, it should go on one of those weeks
15:32:19 <dhellmann> don't steal the thunder of the final pike releases
15:32:27 <dhellmann> and don't confuse people about what versions are part of what series
15:32:29 <smcginnis> Hah, good point. :)
15:32:43 <dhellmann> R+1 probably
15:32:54 <dhellmann> that way the releases in R+2 are also on their own
15:33:02 <smcginnis> Just want it noted somewhere so it's on the radar.
15:33:11 <dhellmann> ++
15:33:29 <smcginnis> Great, that's it for tasks.
15:33:48 <smcginnis> Should one of us (or me) send out a countdown email yet?
15:34:11 <dhellmann> yeah, if we haven't done that this week it would be good to remind folks
15:34:19 <dhellmann> let's see what we should say
15:35:02 <smcginnis> Oh, there was one for R-1: http://lists.openstack.org/pipermail/openstack-dev/2017-August/121266.html
15:35:43 <dhellmann> ah, ok, then I think we're set
15:35:56 <dhellmann> those other things can be handled with a separate email early next week
15:36:06 <smcginnis> OK, that sounds like a plan to me.
15:36:14 <smcginnis> Anything else to cover?
15:36:19 <lbragstad> nothing from me
15:36:32 <dhellmann> nothing from me
15:36:50 <smcginnis> Alright. Thanks everyone. Enjoy your weekend.
15:36:54 <lbragstad> o/
15:36:55 <dhellmann> thanks, you too!
15:36:58 <smcginnis> #endmeeting