15:00:10 <smcginnis> #startmeeting releaseteam
15:00:11 <openstack> Meeting started Fri Oct 20 15:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:15 <openstack> The meeting name has been set to 'releaseteam'
15:00:21 <smcginnis> Ping list: dhellmann, dims, fungi, tonyb, lbragstad, ttx
15:00:28 <lbragstad> o/
15:00:43 <smcginnis> lbragstad: Morning lbragstad. Snow up there yet?
15:01:29 <lbragstad> not yet
15:01:39 <smcginnis> Soon enough I'm sure. :)
15:01:43 <lbragstad> oh yeah
15:02:00 <lbragstad> bow hunting on sunday morning and it's going to be in the 30s
15:02:38 <smcginnis> Too brisk for me to sit in the woods without a campfire.
15:03:02 <lbragstad> :)
15:03:11 <smcginnis> I think everyone is getting back from travelling, meetings, and power outages, so I'll wait a while.
15:03:32 <smcginnis> If no one else can make it, I guess I can just record an update and end early.
15:03:57 <lbragstad> sounds good - queens-1 is due today, yeah?
15:04:31 <smcginnis> Well, technically yesterday, but we can't really release anything right now so that buys some time.
15:04:46 <ttx> oops sorry
15:04:53 <ttx> travel day
15:04:57 <lbragstad> ah - we're still waiting no three patches in keystone, hoping to cut it today
15:05:17 <smcginnis> lbragstad: OK, as soon as you can get the release request in, that would be good.
15:05:25 <smcginnis> ttx: No worries, knew you were on the move.
15:05:41 <smcginnis> dhellmann was tied up with another meeting earlier.
15:06:04 <smcginnis> fungi had his power cut. I'm sure he's been paying his bills. :)
15:06:51 <smcginnis> Guess I'll just give an update then if it's just us.
15:06:58 <ttx> do we have anything on the agenda ?
15:06:59 <smcginnis> The usual etherpad: https://etherpad.openstack.org/p/queens-relmgt-tracking
15:07:02 <ttx> ok
15:07:07 <smcginnis> ttx: Not much, this shouldn't take long.
15:07:18 <smcginnis> #topic Zuul changes for release jobs
15:07:35 <smcginnis> We've been working through some changes that are preventing us from releasing anything.
15:08:08 <smcginnis> We've gotten pretty close. Just need a test release to be re-enqueued to see if the last changes addressed things.
15:08:42 <smcginnis> Hopefully once fungi is able to get back online he can help with that since no one else seems to be jumping on my request to help. :)
15:09:05 <smcginnis> Then we can start releasing again as normal on Monday.
15:09:05 <ttx> you have a tracker for those issues?
15:09:26 <ttx> I think I saw an etherpad link flying earlier
15:09:32 <smcginnis> Most were being tracked in the infra zuul etherpad, but I just started this one this morning:
15:09:35 <smcginnis> https://etherpad.openstack.org/p/release-job-failures
15:09:39 <ttx> ack
15:09:59 <smcginnis> Last one there just happened from another job, so not sure the impact of it yet.
15:10:12 <smcginnis> Might just be the next roadblock we run into after we get past the last one we hit.
15:10:55 <dhellmann> o/
15:10:58 <smcginnis> So there will likely be some activity in the -infra channel today towards that, but I will try to leave updates in -release just so it's easier to get the current status.
15:11:16 <smcginnis> dhellmann: Just giving an update on the release issues. Anything you want to add?
15:11:25 <dhellmann> reading the backlog
15:11:56 <dhellmann> I think that covers everything.
15:12:01 <smcginnis> OK, great.
15:12:11 <dhellmann> I'm in and out again today, so if we can find someone from infra to help debug that job failure that would be good
15:12:51 <smcginnis> I'm hoping we can get some help there. I'm not sure where to start with that last one.
15:13:11 <smcginnis> #topic Targeting release plan tasks
15:13:29 <smcginnis> This one is more of a question from me. We have our list of things:
15:13:29 <ttx> sorry that I could not help more this week with all the traveling and conferecing
15:13:38 <smcginnis> #link https://etherpad.openstack.org/p/queens-relmgt-plan
15:13:47 <ttx> it's just hard to keep tabs on others progress while on the road
15:13:59 <smcginnis> ttx: Yeah, been there. No problem.
15:14:09 <ttx> you just end up duplicating effort and not helping
15:14:45 <smcginnis> Just wondering with the tasks we signed up for if we should be targeting some of them to when we want to try to get them done. Or if there is some other way we've tried to track progress to keep those tasks moving.
15:15:07 <ttx> yes, targeting to milestones helped in the past
15:15:21 * ttx checks pike-1 tasks
15:15:28 <dhellmann> ++ for targets
15:15:37 <ttx> queens-1 I mean
15:16:16 <smcginnis> So should we go through and tag some of them to call them out for queens-2?
15:16:36 <ttx> yes, review your tasks and add words
15:16:48 <ttx> where you plan to work
15:17:17 <smcginnis> #action team to review Queens plan tasks and add milestone they plan to complete them by.
15:17:19 <dhellmann> I'll do that early next week
15:17:35 <smcginnis> OK, just wanted to bring that up.
15:17:40 <smcginnis> #topic Open Discussion
15:17:50 <smcginnis> Anything else we need to go over this week?
15:18:31 <ttx> nothing urgent
15:18:59 <smcginnis> OK, then I'll keep it short.
15:19:03 <smcginnis> Thanks everyone.
15:19:05 <dhellmann> smcginnis : do you feel like this week has given you any insight into the jobs?
15:19:09 <dhellmann> how they work, etc.?
15:19:28 <dhellmann> sort of throwing you into the deep end of the pool
15:20:00 <smcginnis> It's certainly helped to start to dig into some of it.
15:20:12 <smcginnis> I at least now know more of what I don't know, so I see that as progress.
15:20:18 <dhellmann> cool
15:20:34 <dhellmann> I'm wondering how we can document this stuff better
15:20:43 <smcginnis> We certainly have a lot of moving parts in a lot of different places.
15:21:10 <smcginnis> It would be good to somehow pull that into a consumable format to help see the big picture.
15:21:32 <dhellmann> do we have a place for the release team to write documentation that doesn't show up on releases.o.o? I'm not even sure where I would put a description of those jobs.
15:21:33 <smcginnis> I'll ponder that idea and see if there's anything I can start for that.
15:21:44 <dhellmann> maybe the infra manual?
15:21:49 <smcginnis> Yeah, we almost need our own "dev-ref" section.
15:22:12 <smcginnis> Yeah, maybe infra manual would work.
15:22:18 <dhellmann> if we start a new release-team repo with a sphinx build we could move our process document there, too
15:22:58 <smcginnis> Doesn't sound like a bad idea. But I do think having that (PROCESS.rst) in the repo can help others discover it.
15:23:05 <dhellmann> ok, let's think about where we want that and who the audience is
15:23:06 <dhellmann> if we're going to move the jobs into the releases repo, we will want them documented better anyway
15:23:13 <smcginnis> Though if we had a dedicated documentation location that would probably be better.
15:23:21 <smcginnis> And just mention it in the README.
15:23:29 <dhellmann> so maybe doing it right there in the tree but publishing it separately from releases.o.o is the right thing to do
15:23:35 <smcginnis> Good point about the jobs too.
15:23:58 <ttx> a general picture of the various jobs and commands used would be nice
15:24:01 <dhellmann> the releases.o.o publishing job is already custom, so we could move the source files for that to a new location and use the regular sphinx job
15:24:04 <dhellmann> for regular docs
15:24:08 <ttx> (and the various pipelines)
15:24:19 <smcginnis> Yeah, let's let that simmer.
15:24:25 <dhellmann> ++ for cogitation
15:24:35 <ttx> because every time I dive into the jobs I have to rebuild that mental picture
15:24:56 <ttx> Oh, it's a post job on releases, not a release-post job
15:24:57 <dhellmann> I would like to be able to swap out the pages that hold that stuff so I can learn something new :-)
15:25:01 <ttx> that sort of things
15:25:24 <smcginnis> ++
15:25:39 <smcginnis> OK, anything else?
15:25:47 <dhellmann> so let's get the jobs working, then we can move them and break everything again!
15:25:54 <dhellmann> that's it from me
15:25:56 <smcginnis> Haha, yep. :)
15:26:23 <smcginnis> OK, thanks everyone. Let's hope next week is a little more relaxed.
15:26:36 <smcginnis> #endmeeting