15:00:23 <smcginnis> #startmeeting releaseteam
15:00:24 <openstack> Meeting started Fri Dec  1 15:00:23 2017 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:27 <openstack> The meeting name has been set to 'releaseteam'
15:00:36 <smcginnis> Ping list: dhellmann, dims, fungi, tonyb, lbragstad, ttx
15:01:08 <lbragstad> o/
15:01:15 <ttx> o/
15:01:23 <smcginnis> #info Agenda - R-13 in https://etherpad.openstack.org/p/queens-relmgt-tracking
15:01:48 <ttx> reordering
15:02:26 <smcginnis> Makes sense. I'll just wait a minute or so to get going.
15:02:57 * ttx continues to read the silly press
15:03:40 <smcginnis> OK, let's get going.
15:03:48 <smcginnis> #topic Review Q2 TODOs
15:03:50 <smcginnis> #link https://etherpad.openstack.org/p/queens-relmgt-plan
15:04:29 <smcginnis> ttx: Were there specific items you wanted to discuss there?
15:04:36 <ttx> There were a number of q2-targeted things there
15:04:50 <ttx> Most we simply decided were not necessarily needed
15:04:54 * smcginnis is scanning for tags
15:05:19 <ttx> Like we don't really need to fix the ACL for Kolla since it doesn't really follow stable policy
15:05:28 <ttx> or things are now ok to upload to pypi
15:05:41 <smcginnis> I do need to take a look through my tasks there again. It's been a little while.
15:06:06 <smcginnis> Anyone else that has their name on something that either needs help or knows they will no longer be able to work on it?
15:06:08 <ttx> if there is anything else that was completed, now is a good time to update those
15:06:38 <ttx> Potential Zuul v3 compatibility work on line 74 is probably done now
15:06:54 <ttx> I'll mark it done
15:07:13 <smcginnis> Yeah, I'd say there was "potential work" there that has been done. :)
15:07:23 <ttx> smcginnis: your HIGH TODO on line 98 is done, no ?
15:07:58 <smcginnis> Yes. I need to remind folks going forward, but I think the actual todo is done.
15:07:59 <ttx> means we did all our HIGH TODO stuff
15:08:16 <ttx> leavnig quite a bunch of smaller TODOs for q3
15:09:14 <smcginnis> Overall, I think things look good.
15:09:15 <ttx> everyone should review the things with their names on them, and target to q3 the things they intend to work on
15:09:23 <ttx> otherwise just leave them as TODO
15:09:30 <smcginnis> ++
15:10:10 <fungi> looks like everything with my name next to it is crossed off, so time for some egg nog i guess
15:10:25 <smcginnis> #action Team needs to review work in the etherpad and update status, target to release, etc.
15:10:32 <smcginnis> fungi: You're done for the year! :)
15:10:49 <fungi> (though seriously, lmk if you need help working something out related to automation/infrastructure)
15:11:15 <smcginnis> For sure, thanks.
15:11:20 <smcginnis> #topic Potential narrowing of release models following the publication of the OpenStack map
15:11:24 <ttx> So... the publication of the OpenStack map, and the exercise of putting the various deliverables into separate buckets there, revealed some alignment between buckets and release models which we might want to turn into rules
15:11:51 <ttx> in particular, only deployment/lifecyclemanagement tools are using cycle-trailing
15:12:01 <ttx> that was kind of by design
15:12:11 <ttx> but we might want to express that more strongly
15:12:18 <smcginnis> So formalize that into a documented policy?
15:12:20 <ttx> in the same vein...
15:12:38 <ttx> All things in the main "OpenStack"ŭckets follow the cycle in some way
15:13:05 <ttx> which makes sense if we want to call the product we release at the end of the cycle 'OpenStack'
15:13:36 <fungi> that all makes a lot of sense
15:13:38 <ttx> basically, the question is, should cycle-trailing only be an option for deployment/packaging tools (I think yes)
15:14:19 <ttx> and should all the bits that fall into the main "openstack" bucket use a cycle-related model (cycle-with-intermediary or cycle-with-milestones) (I think yes)
15:14:27 <ttx> that's already the case now
15:14:31 <ttx> so we can document it
15:14:34 <smcginnis> The only non-deployment/packaging project I can think of that may need more time would probably be Horizon.
15:15:22 <ttx> yeah, although last time we talked about that we also said that horizon being the demo front-end kind of nmeds to be there on release day
15:15:29 <ttx> needs*
15:15:44 <smcginnis> #info Question raised if all "openstack" projects should be one of the cycle-* release models.
15:15:47 <smcginnis> True
15:15:56 <ttx> If that sounds like a good idea, I'll propose a bunch of changes
15:16:01 <smcginnis> #info Deployment/packaging would be the only cycle-trailing.
15:16:14 <smcginnis> ttx: That sounds like a good plan to me.
15:16:18 <fungi> i would find it odd if horizon weren't ready when the projects release (granted, we also supported documentation not being finalized until well after release and that's similarly strange from an end-user perspective)
15:16:28 <smcginnis> It could help eliminate some grey areas.
15:16:41 <ttx> Note that things in the openstack-operations bucket may opt for independent (like Rally)
15:16:59 <ttx> since it's a step more removed
15:17:11 <smcginnis> ttx: Is that bucket diagram published somewhere now?
15:17:22 <ttx> that is an excellent questionm
15:17:25 <ttx> mm
15:17:38 <ttx> mmm
15:17:53 <ttx> it's supposed to appear in the next version of the software catalog
15:17:54 <smcginnis> Just thinking it might be nice to link to it as a visual aid.
15:18:05 <ttx> but at this point it's not really anywhere except on slides
15:18:08 * dhellmann slinks in late
15:18:10 <ttx> oh definitely
15:18:21 <ttx> smcginnis: I'm working on it
15:18:35 <smcginnis> ttx: OK, great. I know it's a work in progress.
15:18:54 <ttx> OK, let me add that to the plan
15:18:57 <ttx> assigned to me
15:19:04 * smcginnis gives dhellmann a minute for scrollback before moving on.
15:19:39 <dhellmann> I agree with the release model discussion. I thought we'd already made the decision that trailing was for deployment tools and everything else had to use a cycle-based model but let's write it down.
15:19:52 <smcginnis> #action ttx to propose some changes formalizing release models in relation to buckets
15:20:03 <dhellmann> smcginnis : thanks, I'm caught up
15:20:04 <ttx> yes, it was just informal, the map gives us a framework for it
15:20:32 <smcginnis> It does help having that map to make it more clear/obvious what is being referred to.
15:20:47 <smcginnis> OK, I'll combine the next to items as I think they're related.
15:20:50 <smcginnis> #topic Release activities while team is at Kubecon
15:21:15 <smcginnis> I think we can skip the meeting since the majority of us will be in Austin.
15:21:24 <dhellmann> we could meet in person :-)
15:21:28 <ttx> Does that not violate some insurance policy?
15:21:34 <smcginnis> dhellmann: I'm hoping!
15:21:42 <dhellmann> ttx: that only applies if we're on the same flight, I think?
15:21:46 <smcginnis> ttx: Hah. Maybe we just can't all be on the same flight. :)
15:21:49 <ttx> Oh yes, that's that
15:21:51 <smcginnis> dhellmann: jinx
15:21:56 <dhellmann> :-P
15:22:08 <ttx> OK, so there is the release management discussion with K8s folks
15:22:13 <smcginnis> We'll have to take separate Uber's though.
15:22:18 <ttx> Thursday afternoon
15:22:29 <smcginnis> ttx: Oh? I wasn't aware of that. Do you have details?
15:22:41 <ttx> smcginnis: I do have details
15:23:11 * smcginnis signed up a while back thinking it would be a nice easy learning conference. Now schedule is full of obligations. :)
15:23:14 <ttx> your whole week schedule is about to change
15:23:29 <ttx> https://etherpad.openstack.org/p/k8s-openstack-community-story-trading
15:23:38 <ttx> I didn't know you were coming
15:24:02 <ttx> otherwise I would have put you in the loop earlier :)
15:24:07 <smcginnis> Oh, wow. Yeah, this is great.
15:24:25 * ttx has been a bit busy actually engaging with adjacent communities
15:24:42 <ttx> Add your name and join the party
15:25:16 <ttx> I kept my dinner options on Wed and Thu open so that we can continue the discussions there
15:25:17 <smcginnis> I was on the calls with Allison, but those were more around messaging and booth duty things.
15:25:40 <ttx> but worst case scenario that will be all 3 of us having a calm dinner
15:25:46 <dhellmann> I changed my flight to leave Sat since the OS SIG is late Friday afternoon so I'll be around Friday night, too
15:25:58 <ttx> ok, good to know
15:26:05 <smcginnis> I leave Saturday as well.
15:26:12 <dhellmann> ttx: I updated the framadate thing
15:26:39 <ttx> I don't really look into that framadate anymore, now that the schedule is solid
15:26:46 <ttx> there lies depression
15:26:52 <dhellmann> wasted effort!
15:27:18 <smcginnis> :)
15:27:41 <smcginnis> #info No release team meeting next week.
15:27:56 <ttx> dhellmann: for the Wednesday lunch spot I was thinking of invading the Four Seasons lobby bar and ordering bar food. That setting might work for our unknown number of participants
15:28:20 <smcginnis> IIRC, they have a big open area. That should work.
15:28:22 <dhellmann> that sounds reasonable. I was wondering if we needed reservations but that's hard to do with an unknown number
15:28:41 <ttx> yeah, they have a nice place and people tend to not go there from the Austin CC
15:28:49 <dhellmann> wfm then
15:28:56 <ttx> I really have no idea how many people will REALLY show up
15:29:37 <dhellmann> I updated the calendar entry
15:30:13 <smcginnis> When do folks get in to Austin? I arrive mid-day Tuesday.
15:30:21 <dhellmann> Tuesday evening some time
15:30:31 <ttx> late Tuesday
15:30:34 <dhellmann> looks like after 8 for me
15:30:51 <dhellmann> I'm staying in the conference hotel and I'm sure I'll be hungry by the time I get there
15:31:30 <smcginnis> I'm a couple blocks away at an AirBnB.
15:32:17 <smcginnis> Anything else we should discuss before next week?
15:32:49 <ttx> nope
15:33:04 <ttx> See you there!
15:33:07 <smcginnis> OK, I think we can wrap it up then. Thanks everyone.
15:33:15 <smcginnis> Looking forward to seeing everyone next week.
15:33:32 <smcginnis> #endmeeting