15:00:04 <smcginnis> #startmeeting releaseteam
15:00:05 <openstack> Meeting started Fri Feb  9 15:00:04 2018 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:08 <openstack> The meeting name has been set to 'releaseteam'
15:00:18 <smcginnis> Ping list: dhellmann, dims, fungi, tonyb, lbragstad, ttx, armstrong
15:00:24 <lbragstad> o/
15:00:34 <armstrong> Hello
15:00:54 <dhellmann> o/
15:01:10 <ttx> /
15:01:13 <smcginnis> #link https://etherpad.openstack.org/p/queens-relmgt-tracking Agenda
15:01:21 <smcginnis> Looks like we are around line 431
15:01:43 <smcginnis> armstrong: Will you be able to attend the PTG?
15:02:12 <armstrong> I didn’t get air ticket to come
15:02:21 <armstrong> I would have loved to
15:02:36 <smcginnis> armstrong: OK, that's too bad. Was thinking it would be a good time to show you some things.
15:02:56 <smcginnis> armstrong: And would be nice to meet. But by no means necessary. :)
15:02:58 <fungi> howdy
15:03:09 <smcginnis> OK, let's get started.
15:03:19 <smcginnis> #topic Pipeline
15:03:34 <ttx> I went through the list to check what was blocked and why
15:03:36 <smcginnis> I'll wait to talk about the photo. Just added that on there so I wouldn't forget.
15:03:56 <ttx> There are a couple in that list which we could unblock ourselves
15:04:06 <ttx> keystone
15:04:15 <ttx> devstack-plugin-container
15:04:18 <smcginnis> lbragstad: Do you think you will need an rc2?
15:04:25 <ttx> tacker-horizon
15:04:31 <dhellmann> lbragstad approved that patch, didn't he? so it's going to merge into keystone?
15:04:39 <lbragstad> yes
15:04:49 <lbragstad> https://review.openstack.org/#/c/541567/3
15:04:59 <dhellmann> lbragstad : should we wait for a new rc1 then?
15:05:05 <dhellmann> or go ahead and have an rc2 later?
15:05:21 <lbragstad> i'm working on a bug that would be nice to get included into queens
15:05:30 <lbragstad> but it's not a release stopper
15:05:32 <ttx> so there will be a rc2 anyway
15:05:33 <smcginnis> That sounds like an RC2 then.
15:05:37 <dhellmann> ok, if you're going to have an rc2 anyway we might as well go ahead with this one
15:05:42 <ttx> ok approving
15:05:45 <lbragstad> yeah
15:05:49 <dhellmann> thanks, lbragstad
15:06:04 <ttx> done
15:06:11 <lbragstad> no problem, thanks pinging the translations review
15:06:26 <ttx> devstack-plugin-container I can fast-track governance
15:06:35 <ttx> which would unblock it
15:06:42 <smcginnis> That one seems trivial enough.
15:06:47 <dhellmann> yeah, that seems ok
15:06:55 * lbragstad had a question about release notes, but he'll wait until open discussion
15:07:30 <smcginnis> lbragstad: Eh, just go ahead now I guess. :)
15:07:54 <ttx> smcginnis: dhellmann https://review.openstack.org/#/c/540906/
15:07:56 <lbragstad> i was curious about my comment here - https://review.openstack.org/#/c/542385/4/deliverables/queens/keystone.yaml
15:08:09 <ttx> if you +1 that review I'll fasttrack it
15:08:13 <smcginnis> Done
15:08:37 <smcginnis> lbragstad: Oh, sorry, I thought I responded to that.
15:08:48 <dhellmann> ttx: done
15:08:57 <smcginnis> lbragstad: It ends up with the validation it has to be added after branching, otherwise
15:09:13 <smcginnis> you can add a link to the unreleased.html page until then and update after.
15:09:22 <lbragstad> ok
15:09:40 <lbragstad> or i can just add the release-notes link directly to queens in the rc2 proposal?
15:09:42 <smcginnis> lbragstad: But not sure if we need the cycle-highlights linking to the release notes.
15:09:57 <smcginnis> lbragstad: Yeah, that would be a good time.
15:09:58 <ttx> OK governance opatch approved, release patch rebased
15:10:28 <lbragstad> i was trying to do what mriedem was doing here - https://review.openstack.org/#/c/542459/3/deliverables/queens/nova.yaml
15:10:52 <ttx> that leaves tacker-horizon... for which we could push teh project-config patch
15:11:06 <lbragstad> but yeah - that makes sense, nova's is tracking unreleased..
15:11:07 <smcginnis> lbragstad: OK, good. I'm sure Anne can give us feedback later when we see how this first time around goes.
15:11:11 <dhellmann> lbragstad : we will run a tool to add/update all of the release note links as part of our end-of-cycle process
15:11:23 <dhellmann> oh, maybe that's something different?
15:11:25 <ttx> I'll approve mistral since the proposer is the liaison
15:11:42 <d0ugal> Thanks :)
15:11:48 <ttx> err, it's workflow-1 now
15:12:01 <dhellmann> I think it's probably safe to approve ceilometer-powervm, too, since the interaction with that team is minimal
15:12:13 <ttx> yeah
15:12:17 <smcginnis> dhellmann: That's what I was thinking too.
15:12:24 <ttx> Let's pile up
15:12:39 <smcginnis> We could track down Gordon, but I know he was only doing it because we pressured him. ;)
15:12:45 <dhellmann> right
15:13:06 <smcginnis> Neutron did contact me yesterday asking for a little more time.
15:13:13 <ttx> dhellmann: smcginnis if we all +2 that shall pass
15:13:25 <smcginnis> I think they expected to have things squared away this morning (my morning).
15:13:48 <fungi> technically jd__ is back to being ptl for telemetry anyway
15:13:50 <dhellmann> I approved the ceilometer-powervm release
15:14:01 <dhellmann> fungi : that doesn't apply to releases for this cycle, though
15:14:03 <fungi> or at least will be after release
15:14:06 <dhellmann> right
15:14:06 <fungi> yeah, that
15:14:24 <ttx> dhellmann: shall we push the project-config patch for tacker-horizon?
15:14:38 <fungi> noting that he intended to be ptl last time and gordc stood in for him because he wasn't available to post his nomination
15:15:10 <fungi> was travelling or something like that
15:15:17 <smcginnis> yep
15:15:31 <dhellmann> ttx: maybe? I'm always more inclined to let teams feel a little pain when they don't pay attention to these things.
15:15:49 <ttx> dhellmann: they won't fix it before Monday now, due to tz
15:15:56 <dhellmann> otoh, with all of the turmoil with the zuulv3 transition and those jobs being changed...
15:16:01 <ttx> if we are fine waiting until then, then ok
15:16:28 <dhellmann> I'm fine going ahead if you all want to. I can propose the patch, but expect to be leaving here in about 90 minutes so I won't be able to watch it for failures
15:16:31 <smcginnis> My thinking is the same as dhellmann. With flexibility lately do to external factors.
15:16:47 <ttx> dhellmann: I'll pick it up if you can't follow up
15:17:11 <ttx> smcginnis: that is all we can affect at this point imho
15:17:19 <fungi> just a reminder, but if there are any release-blocker infra patches, please do give me a heads-up/reminder and i'll prioritize them
15:17:21 <ttx> (in Pipeline)
15:17:26 <dhellmann> https://review.openstack.org/542879
15:17:56 <smcginnis> Mistral is good now, right?
15:18:15 <ttx> d0ugal just workflowed-1 it
15:18:28 <smcginnis> ttx: That was somehow on the last patchset rev.
15:18:34 <d0ugal> ttx: that was PS1
15:18:40 <ttx> ah ok
15:18:42 <dhellmann> he proposed a new patch which has passed the checs
15:18:43 <dhellmann> checks
15:18:58 <d0ugal> yeah, sorry for the confusion, I noticed we were missing a bug fix that just landed.
15:19:01 <ttx> approved
15:19:13 <dhellmann> d0ugal : good call, saves potentially needing an rc2
15:19:26 <d0ugal> yeah, hopefully :)
15:20:01 <ttx> smcginnis: shall we move to missing bits?
15:20:12 <ttx> as we might need to decide on triggering those ourself
15:20:15 <smcginnis> Yeah, was just taking one last look through.
15:20:23 <smcginnis> #topic Missing RCs
15:20:32 <smcginnis> Anyone hear anything from these teams?
15:21:08 <dhellmann> EmilienM : what's up with tripleo-quickstart?
15:21:17 <smcginnis> Was just typing that. :)
15:21:19 <dhellmann> ricolin : is heat going to release as part of queens this cycle?
15:22:13 <dhellmann> I don't see dave-mccowan for barbican
15:22:51 <smcginnis> I can send out a ML post highlighting these and see if that gets those teams' attention.
15:23:05 <fungi> looks like the searchlight-ui second rc made it through to pypi with both a wheel and an sdist
15:23:19 <smcginnis> \o/
15:23:55 <smcginnis> Given the number we pushed through yesterday, I think our odd failure issue count is heading in the right direction.
15:24:15 <ttx> smcginnis: I'll let you approve https://review.openstack.org/#/c/540570 since I rebased it
15:24:37 <smcginnis> OK
15:24:49 <smcginnis> I see Neutron pushed an update.
15:25:02 <smcginnis> Hopefully they are ready, but neither one is in channel to ask.
15:26:09 <armstrong> @dhellmann: heat suppose to be an inter grail part of all OpenStack releases right?
15:26:27 <dhellmann> armstrong : I think that depends on who you ask.
15:26:40 <smcginnis> Anything else on the missing RCs? I will post to ML. If we don't hear from them...
15:26:41 <fungi> the heat team will definitely say so ;)
15:26:58 <smcginnis> True ;)
15:27:09 <dhellmann> but yeah, I expect them to participate in the release
15:28:06 <smcginnis> I'm a little surprised by Barbican and Heat. My impression was they are both fairly active projects right now.
15:28:09 <ttx> So those are milestone-driven RC1s, for which we have traditionally be a bit flexible around RC1 time
15:28:26 <ttx> So I would not force-tag them today
15:28:35 <dhellmann> smcginnis : heat has given us this sort of issue in the past. I think the small size of the barbican team is probably causing that issue.
15:28:41 <smcginnis> Force a final RC just prior to final release if they don't come around?
15:28:42 <ttx> ideally they should communicate that they are working on ut
15:28:45 <ttx> or it
15:29:03 <smcginnis> Hopefully if I post something that will get attention.
15:29:12 <ttx> smcginnis: it's worse than forcing it now tbh
15:29:20 <ttx> Maybe force it next week
15:29:23 <smcginnis> ttx: Oh, that's true.
15:29:28 <dhellmann> say, tuesday?
15:29:32 <smcginnis> Yeah, next week seems like a good balance.
15:29:33 <ttx> yeah...
15:29:53 <ttx> give them until Monday to propsoe one and/or ask formally for delay
15:29:54 <smcginnis> #agreed Force RCs next Tuesday for missing projects
15:30:08 <ttx> I'm fine waiting if we know they are aware they are pushing it
15:30:09 <smcginnis> That should be enough time.
15:30:38 <smcginnis> Yeah, if they contact us prior to then with a reason to delay, I'm fine with that too.
15:30:50 <smcginnis> As long as it's not too much of a delay.
15:30:56 <ttx> (and then stay on channel to keep us updated )
15:31:00 <smcginnis> ++
15:31:07 <dhellmann> ++
15:31:10 <dhellmann> what's up with patrole? that's the only other deliverable with no releases this cycle that we haven't talked about
15:31:30 <smcginnis> Oh right.
15:31:32 * ttx is lost with all those special-cased QA deliverables
15:31:52 <dhellmann> maybe that should be independent
15:32:07 <dhellmann> they have 2 releases that aren't recorded at all
15:32:07 <smcginnis> I would guess that's the case.
15:32:27 <dhellmann> ok, we can clean that up
15:32:32 <smcginnis> I don't see Andrea around, but we could ask in -qa.
15:32:40 <ttx> I think we raised that question in the past... not sure what the outcome was
15:33:00 <smcginnis> Maybe like forcing a release, we could force a switch to independent?
15:33:02 <ttx> for sahara-extra... I think we are not in a hurry, they have a 6.0.0 and a stable/queens branch
15:33:39 <dhellmann> smcginnis , ttx: I proposed a change to just delete the deliverable file for now
15:33:47 <smcginnis> ++
15:34:19 <ttx> that leaves tripleo-quickstart
15:34:30 <smcginnis> dhellmann: Do we also need to remove it from the repo list in governance/reference/projects.yaml?
15:34:39 <smcginnis> s/Do we/Should we/
15:34:48 <dhellmann> smcginnis : no, it's still an official repo, we're just not managing the releases
15:35:00 <smcginnis> I have a feeling -quickstart was just overlooked.
15:35:05 <smcginnis> dhellmann: OK, makes sense.
15:35:37 <dhellmann> tripleo-quickstart is cycle-trailing, so I wonder if they're waiting as long as possible to prepare a release
15:35:43 <dhellmann> did we give a separate deadline for them?
15:35:53 <smcginnis> Is it trailing?
15:35:56 * smcginnis looks again
15:36:06 <ttx> trailing but intermediary-released?
15:36:13 <dhellmann> yes
15:36:16 * ttx is still confised
15:36:18 <ttx> u
15:36:19 <dhellmann> this came up last cycle, too
15:36:27 <smcginnis> Oh, it is cycle-trailing. Then that's OK, right?
15:36:40 <dhellmann> they only did one release last cycle, too
15:36:47 <ttx> oh well
15:36:55 <ttx> let's say it's ok then
15:37:11 <dhellmann> they aren't creating branches in that repo
15:37:30 <smcginnis> I don't know anything about it, but a "quickstart" might be something that needs to be updated and released at the end after everything else is done.
15:37:42 <dhellmann> I wonder if it should just be independent
15:38:03 <dhellmann> it's some sort of bootstrap installer
15:38:08 <smcginnis> It's a little early for EmilienM, but we can ask.
15:38:09 <dhellmann> so yeah
15:38:19 <EmilienM> hello
15:38:29 <smcginnis> EmilienM: Good morning!
15:38:32 <ttx> never too early for EmilienM
15:38:33 <dhellmann> we need a section in these deliverable files for notes for us for "special handling instructions"
15:38:35 <EmilienM> good morning release-managers
15:38:56 <smcginnis> EmilienM: We were discussing tripleo-quickstart.
15:39:01 <ttx> dhellmann: "handle with care" ?
15:39:08 <ttx> dhellmann: "this side up" ?
15:39:09 * EmilienM invites weshay|ruck
15:39:11 <smcginnis> EmilienM: Should that be independent? Or is it tied to a cycle?
15:39:22 <weshay|ruck> hola
15:39:23 <EmilienM> smcginnis: probably independent for now
15:39:24 <smcginnis> And if the latter, should it be branching.
15:39:36 <EmilienM> smcginnis: we're in discussion to branch tripleo-quickstart-extras
15:39:38 <dhellmann> ttx: "deliveries around back"
15:39:46 <weshay|ruck> ya.. when discussed yesterday we said independent
15:39:46 <EmilienM> but not tripleo-quickstart
15:39:55 <EmilienM> works for me
15:40:13 <ttx> dhellmann: "keep dry"
15:40:17 <dhellmann> EmilienM : would you update the releases repo, please?
15:40:22 <dhellmann> ttx: "live animals"
15:40:26 <EmilienM> dhellmann: doing it now
15:40:29 <dhellmann> thanks!
15:40:40 <ttx> dhellmann: "do not stack"
15:40:46 <smcginnis> Thanks EmilienM, weshay|ruck.
15:40:52 <dhellmann> ttx: "team lift"
15:41:01 <smcginnis> :)
15:41:26 <smcginnis> OK, anything else on missing RCs?
15:41:27 <EmilienM> are you in a naming battle?
15:41:47 <smcginnis> EmilienM: I think it's end of release week delirium. ;)
15:41:51 <dhellmann> EmilienM : it's like a rap battle, but we're quoting boxes at each other
15:42:17 <EmilienM> ... on IRC. Very nerdy rappers ;-)
15:42:24 <smcginnis> Hah!
15:42:32 <ttx> "Stack correctly"
15:42:40 <smcginnis> #topic Issues
15:42:41 <ttx> https://www.shutterstock.com/da/image-vector/set-packaging-symbols-this-side-up-330528794
15:43:02 <fungi> ttx: if memory serves, the signs we saw on the pallets during the vancouver marketplace tour before the last summit there said "no stack!"
15:43:12 <ttx> "Stacking limitation"
15:43:13 <dhellmann> ttx: oh, you're cheating. I'm coming up with these from memory!
15:43:29 <dhellmann> fungi : are you sure that wasn't KubeConf?
15:43:31 <ttx> oooooh "Max Stack"
15:43:34 <fungi> ouch
15:43:40 * smcginnis tries to remember some of the signs from Walking Dead
15:43:53 <smcginnis> Haha, nice one.
15:44:07 <smcginnis> OK, heat-translator...
15:44:11 <fungi> dhellmann: i think they call it "kubageddon"  now
15:44:27 <smcginnis> This one apparently is a client lib?
15:44:36 <dhellmann> so for heat-translator we need to get the heat team to ask the requirements team for that FFE or we're going to be in a weird state where we've released something that isn't in CI
15:44:47 <ttx> dhellmann: no it was at OpenSTack Summit, although on a Oracle booth.
15:44:48 <dhellmann> I can't tell if it's a client lib or a regular lib
15:44:56 <dhellmann> we probably shouldn't have released it since it came after the deadline
15:45:01 <dhellmann> ttx: zing
15:45:39 <smcginnis> Yeah, we're kind of in a bad spot now with having a release that won't actually be picked up
15:46:09 <dhellmann> yeah, we should probably have a separate email thread about that
15:46:20 <smcginnis> +
15:46:25 <dhellmann> or maybe we ask for the ffe ourselves?
15:47:05 <smcginnis> Let's do that.
15:47:16 <smcginnis> Since we've released it.
15:47:22 <dhellmann> ok. I'm off to the airport shortly so can someone else do it?
15:47:29 <smcginnis> I can send that with the other post.
15:47:33 <dhellmann> ok, thanks, smcginnis
15:47:37 <ttx> thanks
15:47:37 <smcginnis> With, but separate.
15:47:41 <dhellmann> ++
15:48:06 <smcginnis> And for Rocky, we need to sort this out before lib freeze time. I will mention that in there as well.
15:48:26 <smcginnis> #topic PTG
15:48:39 <smcginnis> There are going to be team photos again.
15:48:51 <dhellmann> whatever happened to the pictures from denver? I haven't seen them.
15:49:02 <smcginnis> I never know when to schedule these, because no matter what they will be a disription.
15:49:08 <smcginnis> dhellmann: I was just wondering that.
15:49:12 <dhellmann> yeah, the time you picked seems fine
15:49:13 <smcginnis> I'm sure they are out there somewhere.
15:49:29 <dhellmann> or we could do it on wednesday since I assume that's when we're getting together to tag the release
15:49:32 <smcginnis> I figured right after the requirements team might at least be a little better.
15:49:56 <dhellmann> oh, wednesday doesn't seem to be an option
15:50:06 <smcginnis> Yeah.
15:50:11 <dhellmann> thursday is better than tuesday for sure
15:50:14 <smcginnis> Might be better to have that behind us too.
15:50:23 <dhellmann> yeah, good point
15:50:39 <smcginnis> Mon-Tue is usually pretty overbooked for this group anyway I think.
15:51:03 <dhellmann> right
15:51:47 <smcginnis> As far as tagging the release, I assume we'll just find a table somewhere relatively quiet and work through all that again.
15:51:50 <ttx> I'll make whatever time you pick
15:52:16 <dhellmann> smcginnis : yeah, good plan.
15:52:23 <ttx> https://www.flickr.com/photos/152419717@N06/sets/72157680602754246/
15:52:52 <smcginnis> Was there one from Denver? I think when I had looked before I only found this one for ATL.
15:53:00 <ttx> we don't seem to be on that list
15:53:31 <ttx> oh that was ATL
15:53:48 <smcginnis> Always chuckle at that Designate photo.
15:53:51 <ttx> https://www.flickr.com/photos/152419717@N06/37246381525/in/album-72157689092104285/
15:53:55 <dhellmann> I need to run, unfortunately.
15:53:55 <ttx> Here we are
15:54:03 <smcginnis> Thanks dhellmann!
15:54:11 <dhellmann> have a good weekend, folks!
15:54:22 <smcginnis> You too. And enjoy PTO.
15:54:26 <ttx> have a good week !
15:54:30 <fungi> thanks!
15:54:32 <armstrong> Bye @dhellmann
15:54:34 <dhellmann> thanks! I'll be back online thursday
15:54:48 <smcginnis> I think we're probably done here too. Anything else?
15:55:21 <ttx> nothing else from me
15:55:30 <smcginnis> OK, back to it then. Thanks everyone.
15:55:34 <smcginnis> #endmeeting