15:00:37 <smcginnis> #startmeeting releaseteam
15:00:38 <openstack> Meeting started Fri Apr  6 15:00:37 2018 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:42 <openstack> The meeting name has been set to 'releaseteam'
15:00:45 <dhellmann> o/
15:00:56 <annabelleB> o/
15:01:01 <ttx> o/
15:01:17 <smcginnis> Ping dhellmann, dims, fungi, tonyb, lbragstad, ttx, armstrong, annabelleB
15:01:19 <smcginnis> #link https://etherpad.openstack.org/p/rocky-relmgt-tracking Agenda
15:01:29 <armstrong> Hello
15:01:31 <smcginnis> ~line 77
15:01:59 <smcginnis> My internet connection has been a bit flakey this morning, so just in case...
15:02:03 <smcginnis> #chair dhellmann
15:02:04 <openstack> Current chairs: dhellmann smcginnis
15:02:07 <smcginnis> #chair ttx
15:02:08 <openstack> Current chairs: dhellmann smcginnis ttx
15:02:11 <knikolla> o/
15:02:16 <edmondsw> o/
15:02:42 <smcginnis> #topic Review days
15:02:47 <smcginnis> I just wanted to quick bring this up.
15:03:08 <smcginnis> We had picked days in Queens, but we ran out of time in Dublin before we got around to that for Rocku.
15:03:11 <smcginnis> y
15:03:59 <smcginnis> I've been basically sticking to what it was, but reviewing more here and there.
15:04:05 <smcginnis> #link https://etherpad.openstack.org/p/rocky-relmgt-plan
15:04:08 <dhellmann> I keep intending to review on Mondays, but someone keeps approving all of the requests before I get to them
15:04:14 * dhellmann looks pointedly at smcginnis
15:04:22 <smcginnis> Hah! :)
15:04:27 <ttx> smcginnis does indeed steal reviews
15:04:41 <smcginnis> If Monday's work better for you, I can pick a different day.
15:04:45 <ttx> probably a stackalytics thing
15:04:53 <smcginnis> At the bottom of the plan etherpad is the list.
15:05:04 <smcginnis> LOL, totally padding those stats. :D
15:05:13 <dhellmann> hey, worked for me ;-)
15:05:26 <dhellmann> I can take tuesday
15:05:44 <smcginnis> dhellmann: Feel free to swap our names if that is better for you.
15:05:44 <ttx> smcginnis: 10 more and you beat EmilienM
15:05:48 <dhellmann> and I can pitch in on other days if you like
15:05:58 <EmilienM> o/
15:05:59 <dhellmann> smcginnis : nah, it doesn't matter, I just didn't realize we'd changed up.
15:06:04 <ttx> and here I thought nobody could beat AJaeger
15:06:06 <EmilienM> what's up?
15:06:07 <dhellmann> any day works fine for me
15:06:15 <smcginnis> ttx: Ooh, now I'm really going to have to devote some review time.
15:06:34 <ttx> EmilienM: you're just at the other end of a joke we run on smcginnis , sorry for the spurious notification
15:06:37 <smcginnis> I think AJaeger is untouchable. ;)
15:06:59 <dhellmann> when we create the award for "most reviews" we'll have to call it the Jaeger Meister award
15:06:59 <ttx> EmilienM: if you don't want that, stop reviewing so much stuff
15:07:09 <EmilienM> ttx: I just fix typos with a bash script
15:07:11 <ttx> dhellmann: slow clap
15:07:12 <evrardjp> dhellmann: haha
15:07:12 <EmilienM> that's my job
15:07:19 <smcginnis> dhellmann: ++!
15:07:32 <ttx> the trick is we really don't want such an award
15:07:40 <dhellmann> very true
15:07:45 <smcginnis> Just like jaeger miester
15:07:46 <EmilienM> rename readme.rst to README.rst can be very tricky
15:07:47 <dhellmann> but I had to make the joke :-)
15:07:51 <dhellmann> smcginnis : ha!
15:07:53 * EmilienM disappears
15:08:34 <smcginnis> ttx: Are you able to have a designated review day, or should we fill in where we can?
15:08:57 <ttx> to be fair, EmilienM AJaeger mwhahaha and smcginnis have consistently been #1-4 in total reviews
15:09:05 <ttx> for like 4 cycles
15:09:49 <smcginnis> Oh really. Now I need to take a look.
15:09:52 <ttx> so it's probably not a random thing
15:10:09 <ttx> 3 cycles. In Ocata that damn stevemar made #4
15:10:32 <ttx> that was a tangent, sorry
15:10:41 <smcginnis> :)
15:10:44 <ttx> friday afternoon, beer, etc
15:11:08 <smcginnis> Hah!
15:11:11 <ttx> so yes I'm up for keeping Wednesdays
15:11:22 <dhellmann> noted in the etherpad
15:11:28 <smcginnis> Cool, thanks.
15:11:45 <smcginnis> Thursday can just be whoever can get to them until we get another core I guess. :)
15:11:56 <smcginnis> #topic Team availability around r-1 week
15:12:12 <smcginnis> ttx: Is there an issue here? Holiday month concerns?
15:12:46 <smcginnis> R-1 (Aug 20 - Aug 24) [ r-finalrc ]
15:12:53 <smcginnis> R-0 (Aug 27 - Aug 31) [ r-release, r-trailing-rc ]
15:12:55 <ttx> no, rocky-1
15:12:59 <ttx> we are both away
15:13:08 <dhellmann> 2 weeks from now the first milestone
15:13:09 <ttx> wanted to flag to dhellmann
15:13:15 <smcginnis> Oh, milestone 1.
15:13:16 <dhellmann> yeah, thanks for the heads-up
15:13:24 <dhellmann> I can try to make sure I'm around
15:13:29 <ttx> smcginnis: I'll be in Florence. What's YOUR excuse ?
15:13:39 <ttx> Also, I blame flaper87
15:13:59 <ttx> Always a safe bet
15:14:18 <smcginnis> Oh, chaperoning a group of high school students in Chicago. I may need a good excuse to sit quietly in a corner with my laptop, so probably not an issue.
15:14:42 <smcginnis> And I'm just out Thursday/Friday, so hopefully most of the fun is over by then.
15:14:44 <ttx> ok so we should have critical mass around
15:15:06 <smcginnis> Yep, I do plan on at least checking in as I can.
15:15:25 <smcginnis> First milestone is usually pretty tame anyway I think.
15:15:41 <smcginnis> Well, except when your entire infrastructure changes out and breaks things. :)
15:16:16 <dhellmann> yes, let's try not doing that this cycle
15:16:17 <evrardjp> :D
15:16:34 * smcginnis crosses fingers
15:16:38 <evrardjp> I heard zuul v4 is gonna be great
15:16:38 <smcginnis> #topic Progress converting RelMgt rocky plan into a StoryBoard board
15:16:44 <smcginnis> evrardjp: Hah!
15:16:48 <dhellmann> where did we come down on tagging for the milestone if projects don't?
15:17:16 <smcginnis> I don't think we pushed it until later last cycle.
15:17:21 <ttx> i think we said we'd force it
15:17:25 <ttx> ah hm
15:17:28 <smcginnis> Maybe we should catch those right away this time around and press the issue.
15:17:29 <ttx> well no then
15:17:59 <evrardjp> isn't there a risk if we do it automatically that nobody will care and nobody will request releases anymore ?
15:18:05 <smcginnis> #topic Tagging for missing projects
15:18:15 <smcginnis> evrardjp: Yeah, I do think that is a concern.
15:18:23 <smcginnis> We ideally want everything driven by the projects.
15:18:36 <dhellmann> right, that's why we haven't done it before
15:18:41 <smcginnis> With the release team just here to help.
15:18:42 <dhellmann> however, some teams keep missing the early ones
15:19:00 <evrardjp> dhellmann: do we know why?
15:19:11 <dhellmann> mostly they seem to forget
15:19:56 <dhellmann> it feels like it's correlated with a PTL's first term, but I haven't run numbers
15:19:58 <smcginnis> I will try to highlight the issue in the next release countdown email, but I think the ones that miss the milestones are not the ones reading those.
15:20:04 <dhellmann> right
15:20:19 <dhellmann> I feel like we agreed what to do, I just don't remember
15:20:24 <dhellmann> did we write it down in dublin?
15:20:39 <smcginnis> Probably early the following week we should take inventory of who missed and try to reach out to those PTLs directly.
15:20:54 <evrardjp> smcginnis: manual ping to remember to read this email?
15:20:56 * smcginnis scans rocky-relmgt-plan
15:21:01 <evrardjp> asking ack
15:21:03 <dhellmann> line 70 of https://etherpad.openstack.org/p/rocky-relmgt-plan
15:21:31 <smcginnis> evrardjp: I was thinking "hey, you missed the deadline. THis is important. Please let us know your situation." kind of thing.
15:22:07 <smcginnis> So a TODO for me.
15:22:17 <smcginnis> Wish we would have expanded on those notes a little more.
15:22:24 <dhellmann> did we announce that?
15:22:25 <smcginnis> But I will start with that info in the countdown.
15:22:26 <dhellmann> the change
15:22:35 <smcginnis> Not really. :/
15:22:50 <smcginnis> I probably should have started bringing it up in this last countdown.
15:23:13 <smcginnis> I'll see if I can draft a separate email specifically for this.
15:23:26 <smcginnis> #action smcginnis to post to ML about missing milestone plan
15:23:54 <smcginnis> Anything more we should discuss on that for now?
15:24:10 <dhellmann> I don't see anything in the feb or mar archives
15:24:16 <dhellmann> unless it was in a countdown email
15:24:25 <smcginnis> dhellmann: What kind of thing?
15:24:47 <dhellmann> an announcement of the change
15:24:56 <smcginnis> No, I did not send anything.
15:25:08 <smcginnis> But I will plan to now.
15:25:11 <dhellmann> sounds good
15:25:31 <smcginnis> #topic Progress converting RelMgt rocky plan into a StoryBoard board
15:25:40 <smcginnis> Speaking of things I should have done by now...
15:25:56 <smcginnis> I have not put anything into storyboard from our rocky planning.
15:25:57 <dhellmann> I thought we were each supposed to take our tasks? divide the work up?
15:26:00 <ttx> I updated a number of things on the etherpad this morning and was wondering...
15:26:14 <smcginnis> dhellmann: That would be ideal I think.
15:26:18 <ttx> I'd be fine with that
15:26:27 <smcginnis> Each take the tasks with our names by them and add it.
15:26:39 <dhellmann> I think I already did mine
15:26:40 <smcginnis> Anything not assigned, I can go back through and try to clean up.
15:26:47 <smcginnis> dhellmann: Cool, thanks.
15:26:57 <ttx> dhellmann: under openstack/releases ?
15:27:05 <flaper87> ttx: blaming me is always a safe bet! :D
15:27:07 <dhellmann> ttx: yes
15:27:11 <ttx> Also was wondering if we should build a common board
15:27:14 <dhellmann> #link https://storyboard.openstack.org/#!/project/932
15:27:18 <dhellmann> sure, we could do that
15:27:21 <dhellmann> I didn't go that far
15:27:36 <ttx> like a "Rocky plan" board
15:27:46 <dhellmann> I wasn't sure if we wanted to manage a worklist by hand or use tags to create a board that updates automatically
15:28:32 <smcginnis> dhellmann, ttx: You two probably have more experience with that functionality in sb than I do.
15:28:56 <dhellmann> I guess it depends on how many different items we have and how much we want to "track" the work
15:29:14 <dhellmann> our list is usually not very long
15:29:23 <ttx> I was thinking it was the only way to have a per-cycle plan there
15:29:44 <ttx> and have HIGH TODO . TODO / InProgress / Backlog columns
15:29:57 <dhellmann> ah, sure, if you want priority columns then a board is probably best
15:30:12 <dhellmann> were you thinking we'd update it by hand?
15:30:22 <ttx> move things around yes
15:30:28 <dhellmann> oh, and I didn't import backlog items
15:30:49 <dhellmann> at least I don't think I did; I guess I would have if it had my name on it
15:31:09 <dhellmann> so I could set up a board, unless smcginnis wants to use it as a learning opportunity :-)
15:31:39 <smcginnis> dhellmann: I probably do need to learn at some point, but if you can for now that would be appreciated.
15:31:44 <dhellmann> ok
15:31:51 * dhellmann creates a story to create a board
15:32:12 <smcginnis> :)
15:32:30 <dhellmann> #link https://storyboard.openstack.org/#!/story/2001793
15:32:50 <smcginnis> #topic
15:32:53 <dhellmann> feel free to edit/add comments there
15:32:59 <smcginnis> #topic Remove leftover stable/queens pre-release ACL
15:33:09 <smcginnis> #link https://review.openstack.org/#/c/557733/
15:33:17 <ttx> oh that one was just to flag a standing review to fungi
15:33:42 <smcginnis> OK, he mentioned he would be out during the meeting but back later.
15:33:51 <smcginnis> So hopefully he sees this and takes a look.
15:33:58 <smcginnis> Looks pretty straight forward.
15:35:15 <smcginnis> ttx: Did we finalize the thread about changing ACLs during RC?
15:35:44 <ttx> yes
15:35:54 <ttx> I just need to clean up ACLs now
15:35:55 <smcginnis> OK, good.
15:36:09 <ttx> which is dependent on that TC resolution
15:36:49 <smcginnis> #topic Open discussion
15:36:59 <smcginnis> Anything else we should discuss in the meeting?
15:37:50 <dhellmann> nothing from me
15:38:08 <evrardjp> none
15:38:26 <smcginnis> OK, we can get back to it then. Thanks everyone.
15:38:31 <evrardjp> thx
15:38:38 <annabelleB> bye!
15:38:46 <smcginnis> #endmeeting