15:03:09 <smcginnis> #startmeeting releaseteam
15:03:10 <openstack> Meeting started Fri Jun  8 15:03:09 2018 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:14 <openstack> The meeting name has been set to 'releaseteam'
15:03:22 <smcginnis> Too caught up looking at other things.
15:03:33 <dhellmann> o/
15:03:37 <annabelleB> o/
15:03:37 <smcginnis> Ping list: dhellmann, dims, fungi, tonyb, lbragstad, ttx, armstrong, annabelleB
15:03:46 <armstrong> Hello
15:03:53 <smcginnis> #link https://etherpad.openstack.org/p/rocky-relmgt-tracking Agenda
15:04:33 <smcginnis> Down around line ~244
15:05:04 <smcginnis> #topic Rocky-2 status
15:05:17 <smcginnis> Relatively painless yesterday.
15:05:35 <smcginnis> We still have Cinder and Sahara out there waiting to clear check.
15:05:58 <smcginnis> Unless anyone has any objections, I think we can continue to process those today.
15:06:07 <smcginnis> I saw we got a few of the lib releases through already.
15:06:44 <smcginnis> lbragstad: Not sure if you saw the comment on the keystonemiddleware request, but take a look and let me know if that makes sense.
15:06:56 <dhellmann> yeah, I went ahead and approved things in the order they arrived, regardless of the type
15:07:19 <smcginnis> ++
15:07:29 <jungleboyj> o/
15:07:36 <lbragstad> smcginnis: correct - we don't need a release for ksm, but i didn't want to miss a deadline if there was one for skm
15:07:38 <lbragstad> ksm*
15:07:45 <dhellmann> I pasted a list of the things that haven't merged an rc2 release tag yet
15:07:47 <fungi> the gate seems pretty slammed the past couple days, i expect due to last-minute approvals for r-2
15:08:14 <smcginnis> lbragstad: No, for cycle-with-intermediary you are fine. That can happen later once there are changes to get out there.
15:08:31 <dhellmann> it looks like we're missing quite a few
15:08:32 <ttx> I don't mind some amount of busy-ness
15:08:34 <lbragstad> ack - thanks
15:08:36 <smcginnis> dhellmann: Oh great, I was just about to run that report.
15:08:53 <lbragstad> i'll abandon that review for now to clear the queue
15:09:03 <smcginnis> dhellmann: Wait, I thought you did release-test yesterday. :D
15:09:10 <smcginnis> lbragstad: OK, thanks!
15:09:21 <dhellmann> haha
15:09:23 <smcginnis> Kind of the usual suspects in that list.
15:09:28 <dhellmann> removed
15:09:52 <dhellmann> trove said they weren't going to bother, right? I'm still not sure how I feel about that.
15:10:03 <smcginnis> Yeah...
15:10:30 <fungi> maybe they really mean they're not going to bother maintaining it
15:10:53 <ttx> cyborg might be worth checking
15:10:53 <smcginnis> Cyborg and freezer had done a milestone-1 release at least. Still checking through the list.
15:10:55 <dhellmann> or was that octavia?
15:11:04 <ttx> the others are definitely on the low-activity side
15:11:21 <fungi> last trove commit on master was nearly two months ago
15:11:31 <smcginnis> fungi: They said they had system package breakages right now or something so they are maintaining it but it is not in a good shape right now.
15:11:36 <ttx> yeah, checking on trove is on my list
15:11:53 <smcginnis> But with the history on trove, there's certainly plently of concern there.
15:12:02 <fungi> ahh, so they're blocked from merging anything until they work through whatever is wrong there, i guess
15:12:18 <fungi> still, that's a long time to go blocked merging to master
15:12:51 <smcginnis> I'm not sure if they have been blocked that whole time or if it was a recent discovery.
15:12:59 <smcginnis> They are not an active team from what I've seen.
15:13:11 <smcginnis> So it's possible there just wasn't anything until recently, then the issue was discoverd.
15:13:14 <smcginnis> ed
15:13:28 <dhellmann> I'll keep trove in mind as a priority for the team health-check review the tc just started
15:13:37 <smcginnis> Searchlight is the only one I've seen so far that has not had any milestone releases.
15:13:42 <smcginnis> dhellmann: ++
15:13:51 <smcginnis> But searchlight is maintenance-mode?
15:13:53 <fungi> searchlight has officially declared itself in maintenance mode, so that's less surprising
15:14:21 <smcginnis> So I wonder if we should remove their deliverable file from rocky and expect any future releases to be done as independent?
15:14:30 <johnsom> dhellmann What did we do?  We released R-MS2 and have done a client release.
15:14:55 <dhellmann> johnsom : sorry, I think I was confusing 2 projects
15:15:08 <johnsom> Ok
15:15:13 <smcginnis> johnsom: Falsely accused!
15:15:20 <johnsom> Grin, normal for us
15:15:49 <smcginnis> OK, I went through the list and searchlight is indeed the only one that has not done a milestone release at all.
15:16:00 <dhellmann> someone's project update video from the summit suggested that users tag their own releases, and I was mixing up who did that.
15:16:10 <smcginnis> So the others can still do m-3 and meet our two milestone criteria. Not ideal, but...
15:16:21 <smcginnis> dhellmann: That was dragonflow.
15:16:32 <dhellmann> aha, yes, another networking project. sorry, johnsom
15:16:35 <dhellmann> thanks, smcginnis
15:16:57 <smcginnis> Which reminds me, I should make sure their tagging ACLs are changed.
15:17:25 <smcginnis> Any thoughts on searchlight? Or should we leave that for another time?
15:17:48 <dhellmann> did searchlight have any updates?
15:18:04 <smcginnis> Or more generally, how to handle maintenance mode projects that are currently cycle-* based.
15:18:16 <ttx> I'd force release rather than switch to "independent" because all the "openstack" components are released on a cycle
15:18:38 <smcginnis> But even if the project is in maintenance mode or "code complete"?
15:18:43 <ttx> having "some" components independently-released would create confusion
15:18:49 * mlavalle wants to ask a question about tagging at the end of the meeting
15:18:50 <dhellmann> they only changes they have are translations and uncapping eventlet
15:18:57 <ttx> well, the component can be included at the same version
15:19:01 <dhellmann> and a couple of other ci-related changes
15:19:16 <dhellmann> so we should be able to safely add a milestone tag to searchlight
15:19:20 <smcginnis> https://github.com/openstack/searchlight/compare/4.0.0...master
15:19:20 <ttx> i.e. both Queens and Rocky get 6.0.0 or whathever
15:19:36 <dhellmann> http://paste.openstack.org/show/722988/
15:19:48 <dhellmann> shall I propose that?
15:20:05 <ttx> It's a parallel discussion to the "stable lib" one really
15:20:12 <smcginnis> Yeah
15:20:20 <ttx> The solution we opt for there is likely to be the solution we opt for here
15:20:44 <armstrong> ttx: is there any last chance to the trove team before a release is forced on them?
15:20:52 <smcginnis> dhellmann: Should we tag the milestone for that, or just plan on forcing a final release for the cycle?
15:20:54 <ttx> although we might want a release that is in sync with current requirements ?
15:21:23 <ttx> smcginnis: I think we said we'd force-tag rocky-3
15:21:39 <ttx> didn't we?
15:21:43 <smcginnis> OK, so don't force now, but do it for all of these next milestone.
15:21:47 <smcginnis> I think that's correct.
15:21:59 <ttx> It's the only "meaningful" milestone
15:22:03 <ttx> and a good test befor final
15:22:09 <dhellmann> "Projects using milestones are expected to tag at least 2 out of the 3 for each cycle, or risk being dropped as an official project. The release team will remind projects that miss the first milestone, and create tags on any later milestones for the project team by tagging HEAD at the time of the deadline. If the release team force-creates 2 tags for a project in the same given development cycle, the project will be
15:22:09 <dhellmann> treated as inactive and the release team will recommend dropping it from the official project list"
15:22:12 <smcginnis> Yeah, RC would be too late if there are issues.
15:22:16 <dhellmann> from https://releases.openstack.org/reference/release_models.html#cycle-with-milestones
15:22:28 <fungi> looks like trove has two commits since their rocky-1 tag, so not a lot but possibly still releasing (one of the two is not a testing-related change)
15:22:28 <dhellmann> "any later milestones"
15:22:31 <ttx> dhellmann wins
15:22:55 <smcginnis> dhellmann: So we force searchlight, but the others can wait until milestone 3.
15:22:59 <ttx> dhellmann: we'll likely need to adapt that policy for "stable" components, but yes
15:23:00 <fungi> er, possibly still worth releasing that is
15:23:56 <smcginnis> dhellmann: Were you volunteering earlier to get that release going?
15:23:58 <fungi> oh, nevermind, the trove change which didn't look test related may still be test related
15:24:32 <dhellmann> https://review.openstack.org/573749 is the searchlight tag
15:24:40 <smcginnis> dhellmann: Thanks
15:25:09 <smcginnis> OK, we should probably get going.
15:25:11 <smcginnis> #topic Stable library discussion continuation
15:25:22 <smcginnis> ttx: This is your topic?
15:25:38 <ttx> I was not the one to put it on the agenda for the week, but I can talk
15:26:03 <smcginnis> Oh right, I copied it forward from last week.
15:26:07 <ttx> I haven't given it more thought this week
15:26:37 <ttx> I think I'm still leaning toward 2bis
15:26:45 <ttx> or 2
15:26:48 <dhellmann> I added 1 new option to the list which i thought we discussed but maybe not
15:26:59 <dhellmann> which is to change them to the independent model
15:27:12 <smcginnis> We probably did discuss that but it didn't make it to the etherpad.
15:27:49 <fungi> i'm leaning toward 2 with the option of relaxing it to 2bis if we decide the precreation is busywork
15:27:56 <smcginnis> I kind of lean towards 2 now, but I'll admit I didn't get to spend any time pondering this over the last week.
15:27:57 <ttx> choice between 2 and 2bis depends how "costly" it is to do it proactively vs. reactively
15:28:24 <ttx> maybe punt to next week for decision, with homework to give it some thought next week?
15:28:32 <smcginnis> That might be best.
15:28:44 <ttx> Should we raise a thread on the ml?
15:28:59 <fungi> i also think dhellmann's new option 5 is really just 4 (or 4bis)
15:29:19 <smcginnis> I guess the difference would be documenting that expecation.
15:29:35 <dhellmann> fungi : well, it's a bit more explicit, but maybe that is the same in effect
15:29:37 <smcginnis> A thread on the ML seems appropriate. Who can get that started?
15:29:45 <dhellmann> we do actually support stable branches for independent projects
15:29:59 <ttx> I can take it (Monday) if dhellmann doesn't beat me to it
15:30:08 <fungi> dhellmann: yeah, basically option 4 but the specific release model is the existing independent model
15:30:09 <smcginnis> OK, thanks.
15:30:17 <dhellmann> ttx: I'll let you tackle it, thanks
15:30:31 <dhellmann> fungi : true
15:30:42 <fungi> dhellmann: oh, do we create stable branches consistently for independent release projects? or just when they need them?
15:30:42 <smcginnis> I have a feeling the next topic might have a lot of discussion time.
15:30:50 <dhellmann> fungi : as needed
15:31:00 <fungi> but yeah, happy to hash the rest of this out on the ml
15:31:06 <ttx> smcginnis: not sure :) It's not as if there was much choice
15:31:35 <dhellmann> ttx: do you have your usual visualizations for the schedule proposals?
15:31:38 <smcginnis> OK, let's go to the ML with this and move on to the next exciting topic.
15:31:49 <smcginnis> #topic A longer Stein cycle
15:31:59 <ttx> dhellmann: no, it's more an initial temp reading before I lay the options down
15:32:06 <dhellmann> ok
15:32:22 <jungleboyj> I find it appropriate that we are thinking of making Stein last longer.  :-)
15:32:38 <ttx> One side-effect of the potential co-location of PTG with Summit in 2019 is that it would push release into April instead of Feb/Mar
15:32:55 <ttx> which is not as bad as it cuold have been
15:33:06 <ttx> since (1) that Summit is actually early
15:33:17 <fungi> jungleboyj: this will be a full liter
15:33:26 <ttx> and (2) it's a winter cycle where a lot of time is traditionally wasted
15:33:26 <smcginnis> So what is the actual proposal here? Make it 6.5 months?
15:33:35 <ttx> smcginnis: no proposal
15:33:37 <fungi> i see two proposals in the agenda
15:33:40 <jungleboyj> fungi:  Yay!
15:33:45 <smcginnis> :)
15:33:53 <ttx> smcginnis: I think it will be hard to make it less than 7 months though
15:34:07 <ttx> since doing PTG at R+4 is a bit late already
15:34:18 <fungi> 7-month or 7.5-month look like the options outlined there
15:34:35 <ttx> We could also just swallow that pill and make it 7.5, and do our traditional "PTG at R+2"
15:35:05 <smcginnis> A couple extra weeks to get things aligned seems acceptable to me.
15:35:07 <ttx> I think those are the two most likely viable options (R+2 and R+4)
15:35:20 <smcginnis> Or just make it a year? :D
15:35:21 <ttx> R+3 would work too of course
15:35:31 <ttx> R+5 would waste a lot
15:35:46 <ttx> R+1 is uselessly late
15:35:57 <dhellmann> would having more time between release and the event help with planning talks, forum sessions, etc.?
15:36:08 <ttx> potentially.
15:36:08 <smcginnis> I think so.
15:36:10 <annabelleB> +1
15:36:10 <dhellmann> that's the main reason I could see to go with R+4
15:36:19 <jungleboyj> smcginnis:  I wondered when someone would say that.
15:36:40 <ttx> Only drawback is that you'd "burn" 4 weeks in a likey-5.5-month-long cycle
15:36:48 <fungi> r+3 would make for a nice middle ground if we feel r+4 is too much tmie
15:36:59 <fungi> er, too much time
15:37:03 <ttx> (if we go into a 5.5/6.5 rhythm)
15:37:12 <smcginnis> I think folks have enough to work on that those weeks would not be wasted waiting to get together to discuss things.
15:37:14 * ttx looks into history
15:37:25 <ttx> I think we did R+4 once
15:37:26 <armstrong> R+4 is one months later from the official release date?
15:37:39 <ttx> 4 weeks later yes
15:37:52 <dhellmann> if it means more spec writing and pre-discussion having the time might be good. if that isn't done, the time may be considered wasted.
15:37:58 <dhellmann> armstrong : right "R" is the release and "+4" is "four weeks later"
15:38:17 <armstrong> Ok thanks, that seems late to me
15:38:47 <dhellmann> the release would be happening 4 weeks before the event, which would give us a lot of time to plan what we're going to discuss at the event. perhaps too much.
15:38:54 <ttx> let me dive into historical records
15:38:55 <dhellmann> we can't move the event, we can only move the release date
15:39:19 <ttx> yeah we did R+4 once
15:39:26 <dhellmann> which cycle was that?
15:39:55 <ttx> release on Apr 17, 2014. Design Summit on May 15, 2014 week
15:40:09 <ttx> Icehouse
15:40:28 <ttx> Atlanta summit
15:40:33 <ttx> and we survived
15:40:45 <smcginnis> My first summit, so it all seemed good to me.
15:41:27 <ttx> otherwise we mostly did R+3 design summits
15:41:41 <smcginnis> ttx: So your plan for now is to run this by folks and get input, then make an official proposal sometime in the near future?
15:41:42 <ttx> R+2 was always considered pretty short
15:41:54 <dhellmann> do we think we're going to need the extra time to shift gears to the new summit/ptg format?
15:42:08 <smcginnis> I think +3 or +4 would work fine.
15:42:09 <ttx> yes... That discussion was useful already... I think R+2 is uselessly late
15:42:10 <dhellmann> or "back to the old" I should say
15:42:21 <smcginnis> Yeah, I would take +2 off the table.
15:42:26 <dhellmann> I agree
15:42:32 <ttx> I will try to layout R+4 and see where that goes
15:42:47 <ttx> R+5 and R+3 would probably also work, actually
15:42:58 <dhellmann> I would stick with 3 or 4
15:43:04 <ttx> but R+4 sounds like a good compromise
15:43:13 <ttx> given that we did R+0 / R+2 PTGs
15:43:25 <smcginnis> Yeah, might be good to layout both and see how things look.
15:43:34 <ttx> OK, I'll work on that
15:44:33 <smcginnis> Any other thoughts/input from other folks?
15:44:37 <ttx> There is no need to officialize anything (at least not until we get confirmation of teh event model, which should take a few months)
15:44:58 <ttx> When do you think we need to have a Stein schedule at the latest ?
15:45:03 <ttx> Rocky-3 ?
15:45:21 <smcginnis> Speaking of... is the event model something happening internally in the Foundation or is that a board discussion for the next meeting?
15:45:26 <ttx> Rocky-RC1 I'd say
15:46:04 <smcginnis> Yeah, really the sooner the better because I know some companies like to plan out the year as much as they can, but RC1 would probably be a good deadline.
15:46:09 <ttx> I know we-as-in-staff are currently checking if we can get an extra day to have non-overlapping PTG
15:46:23 <ttx> before going any further
15:46:30 <smcginnis> +1 for the extra day.
15:46:47 <fungi> though as a general process, i think the foundation staff go over the feedback from the survey(s), and then put together a proposal which gets floated at a board meeting to get their temperature on it
15:47:03 <ttx> That is all I needed, thanks
15:47:27 <smcginnis> OK, thanks. Let us know how things go. (which I'm sure you will)
15:47:40 <smcginnis> #topic Open discussion
15:47:48 <smcginnis> mlavalle: Did you have something you wanted to discuss?
15:48:01 <mlavalle> it's just a question
15:48:19 <smcginnis> Questions have a tendency to lead into longer discussion here. ;)
15:48:33 <mlavalle> I can ping you in the channel
15:48:54 <smcginnis> Here is fine unless you'd rather wait. Either way works.
15:49:05 <mlavalle> I'll ping you
15:49:11 <smcginnis> OK, sounds good.
15:49:19 <smcginnis> Any other items?
15:49:40 * smcginnis should have probably recorded some actions
15:49:49 <ttx> I did record them in the etherpad
15:49:53 <smcginnis> #action Team to review stable lib options and be ready to discuss next week
15:50:04 <smcginnis> #action ttx to start ML thread on stable libs
15:50:31 <smcginnis> ttx: Yeah, just thinking of making it easier for anyone taking a look at the meeting summary log.
15:50:51 <smcginnis> #action ttx to model R+4 schedule and see where that goes
15:51:19 <smcginnis> OK, if nothing else we can wrap it up for today.
15:51:19 <ttx> Looks like I failed at not signing up for $stuff today
15:51:32 <smcginnis> Haha, too late now.
15:51:53 <smcginnis> Alright, thanks everyone.
15:52:01 <jungleboyj> Thanks.
15:52:02 <armstrong> Thanks
15:52:04 <smcginnis> #endmeeting