15:00:33 <smcginnis> #startmeeting releaseteam
15:00:34 <openstack> Meeting started Fri Jul 20 15:00:33 2018 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:37 <openstack> The meeting name has been set to 'releaseteam'
15:00:40 <smcginnis> Ping list: dhellmann, dims, fungi, tonyb, lbragstad, ttx, armstrong, annabelleB
15:00:52 <armstrong> Hello
15:00:57 <ttx> o/
15:00:58 <armstrong> o/
15:01:02 <smcginnis> #link https://etherpad.openstack.org/p/rocky-relmgt-tracking
15:01:10 <smcginnis> Looks like we are down to around line 383
15:01:58 <annabelleB> o/
15:03:07 <smcginnis> Mr dhellmann, paging Mr dhellmann.
15:04:03 <dhellmann> o/
15:04:08 <smcginnis> \o/
15:04:09 * dhellmann had a cat box emergency
15:04:14 <smcginnis> #topic dealing with branching cycle-with-intermediary changes with unreleased content
15:04:21 <smcginnis> dhellmann: That sounds like fun. :)
15:04:43 * dhellmann thinks we have different ideas of fun
15:04:52 <smcginnis> #link http://lists.openstack.org/pipermail/openstack-dev/2018-July/132204.html
15:05:29 <dhellmann> we had a couple of projects that only had CI changes
15:05:53 <dhellmann> there wouldn't be any real reason to release for those, except that if we branch before the changes the stable branch may be immediately broken
15:06:05 <dhellmann> or could be, at any rate
15:06:26 <dhellmann> so I think we ought to go ahead and tag a release to use for the branch point
15:06:33 <dhellmann> smcginnis : how many of those still don't have releases today?
15:06:52 <smcginnis> That makes senese to me.
15:07:12 <smcginnis> I added some of that output in the etherpad. Just two libs and some flagged as "other".
15:07:19 <ttx> should requestsexceptions really be tied to cycle ?
15:07:35 <smcginnis> That kind of seems independent.
15:07:41 <dhellmann> mordred : ^^
15:08:59 <dhellmann> those items with type "other" have until the final release deadline to tag a release, right?
15:09:20 <mordred> yes - it should be independent
15:09:21 <smcginnis> I was going to ask about that. Some of them actually do seem like non-client libs, so not really sure.
15:09:23 <mordred> it almost never changes
15:09:28 <mordred> (requestsexceptions)
15:09:54 <mordred> I don't tihnk requestsexceptions has had a substantive change in a few years
15:09:57 <dhellmann> ok, I can move requestsexceptions to independent
15:10:06 <smcginnis> mordred: Thanks, that makes sense.
15:10:07 <ttx> maybe post a 1.4.1 release request while at it
15:10:24 <smcginnis> #link http://paste.openstack.org/show/726351/ Non-client lib unreleased commits
15:10:35 <smcginnis> Just ran that this morning ^^
15:10:44 <dhellmann> ttx: the only change is to tox
15:11:07 <smcginnis> * 76c6344 2018-06-12 01:14:20 +0800 fix tox python3 overrides
15:11:31 <armstrong> @smcginnis is this the current model used by project? cycle-with-intermediary
15:11:39 <smcginnis> Can probably just move it from rocky to _independent and wait until something more substantial gets merged.
15:11:52 <ttx> ok
15:11:54 <dhellmann> #link make requestsexceptions independent  https://review.openstack.org/584417
15:11:54 <patchbot> patch 584417 - releases - make requestsexceptions independent
15:11:59 <smcginnis> armstrong: By requestsexception?
15:12:37 <armstrong> yes
15:12:44 <ttx> looks like we haven't had oslo releases for a while ?
15:12:46 <smcginnis> armstrong: That one is set with "release-model: cycle-with-intermediary", but it doesn't really have a tie in to specific cycles.
15:12:57 <smcginnis> ttx: There were a few yesterday afternoon.
15:13:03 <armstrong> ok i see , thx
15:13:13 <smcginnis> ttx: Are you looking at dhellmann's post from last week or my paste from today?
15:13:25 <ttx> your paste
15:13:38 <dhellmann> futurist needs a new tag
15:13:44 <ttx> I guess those releases are not trigger for trivial/CI changes
15:13:50 <smcginnis> armstrong: Here's where that's set: http://git.openstack.org/cgit/openstack/releases/tree/deliverables/rocky/requestsexceptions.yaml#n3
15:14:34 <smcginnis> But to dhellmann's point, maybe we should still tag those before they are branched?
15:14:35 <armstrong> @smcginnis ok let me take a look at it
15:15:38 <ttx> osc-placement and neutron-lib need new releases too, but may qualify as late libs since they carry things that used to just be in their consuming projects
15:15:49 <smcginnis> I checked on those this morning.
15:16:00 <smcginnis> osc-placement is actually miscategorized.
15:16:26 <smcginnis> It is a plugin for osc, so that should really be a client lib. Melanie will change that along with doing the release next week.
15:17:09 <ttx> sahara-extra is really not a lib
15:17:17 <ttx> same for tosca-parser
15:17:18 <smcginnis> I've asked mlavalle to take a look at ovsdbapp, but probably should have also pointed out neutron-lib has a few things.
15:17:33 <ttx> ovsdbapp, not sure
15:17:33 <dhellmann> looks like oslo.reports could use a release, but there's a "remove deprecated" change in there and it feels late to be doing that
15:18:06 <mlavalle> smcginnis: we released neutron-lib this week
15:18:07 <ttx> dhellmann: it might be usage BY THE LIB of a deprecated option somewhere else
15:18:13 * ttx digs
15:18:21 <dhellmann> bnemec: ^^
15:18:42 <smcginnis> mlavalle: Looks like there were a couple commits sense then that look interesting.
15:18:46 <ttx> dhellmann: looks like it https://git.openstack.org/cgit/openstack/oslo.reports/commit/?id=884cee9f683ad3023ccffada4dbe1c1773cbbd40
15:18:50 <smcginnis> mlavalle: http://paste.openstack.org/show/726351/ line 145.
15:19:25 <smcginnis> mlavalle: If those are work already for stein then that's fine. Just want to make sure nothing is missed.
15:19:32 <dhellmann> ttx: so a doc change
15:19:55 <ttx> yeah
15:20:33 <ttx> dhellmann, smcginnis: what's your take on neutron-lib ?
15:20:45 <ttx> oh, dsicussion in parallel
15:20:48 <ttx> ignore me
15:20:51 <smcginnis> ttx: :)
15:21:39 <ttx> I'd argue ovsdbapp should be 'other'
15:22:00 <ttx> same for sahara-extra and tosca-parser
15:22:10 <smcginnis> I don't know enough about that deliverable. What makes those "other"?
15:22:11 * ttx checks requirements
15:22:19 <ttx> smcginnis: the fact that they are not a lib
15:22:33 <ttx> nor a service
15:22:38 <ttx> nor a horizon-plugin etc.
15:22:47 <smcginnis> What are they?
15:23:06 <smcginnis> Rico proposed the tosca-parser release just moments ago, btw.
15:23:19 <ttx> hmm tosca-parser is a lib. or at least it's usable as a lib
15:23:39 <ttx> same for ovsdbapp
15:24:15 <ttx> shara-extra contains a bunch of tools used by sahara
15:24:16 <smcginnis> Yeah, the repo description for ovsdbapp actually calls it a library.
15:25:07 <ttx> I'll propose a change to other-ify sahara-extra
15:27:33 <ttx> #link other-ify sahara-extra: https://review.openstack.org/584422
15:27:33 <dhellmann> do we want to go ahead and have releases for those other deliverables?
15:27:34 <patchbot> patch 584422 - releases - sahara-extra is not a library
15:27:41 <smcginnis> dhellmann: Do you think we need to update PROCESS to call out forcing releases before branching?
15:28:32 <dhellmann> I thought we did say we would do that, let me look at what we wrote
15:28:37 <ttx> So the only one left is ovsdbapp ?
15:28:56 <smcginnis> ttx: Yep, and mlavalle was going to check on that.
15:29:01 <ttx> ok
15:29:23 <ttx> smcginnis: oh and we need to fix osc-placement as well
15:29:42 <smcginnis> dhellmann: Yes, but to your meeting topic - I thought the question was whether to call out doing that earlier for these non-client libs.
15:29:52 <smcginnis> ttx: melwitt is going to do that with its release next week.
15:29:58 <ttx> ack
15:30:22 <ttx> #info osc-placement is miscategorized, that will be fixed by melwitt when she asks for release next week.
15:30:46 <ttx> #info ovsdbapp needs a release to catch latest change, mlavalle is going to look into it
15:30:49 <dhellmann> smcginnis : the only things I'm finding talk about projects with no changes
15:30:53 <dhellmann> for example, step 5 in https://releases.openstack.org/reference/process.html#between-milestone-3-and-rc1
15:31:16 <dhellmann> these are projects with CI changes, and since we only branch from tags, I think that means we need to force tags for them
15:31:29 <dhellmann> so yes, I think we need to update the process to say that at the appropriate points
15:31:37 <smcginnis> I agree.
15:31:56 <dhellmann> I can work on that patch today
15:32:43 <smcginnis> Anyone else have any opinions on this? Sounds like a good plan to me.
15:32:55 <ttx> wfm
15:33:07 <ttx> I doublechecked the list again and I think we covered everything
15:33:36 <smcginnis> OK, my topic kind of melded with this one. Anything else as far as the release status before we move on?
15:34:09 <ttx> we should still review the unreleased stuff
15:34:16 <ttx> line 392+
15:34:21 <smcginnis> #topic Release status
15:35:04 <smcginnis> So we have the two library ones, cmw and requestexception.
15:35:12 <smcginnis> The latter being moved to independent.
15:35:27 <ttx> cmw had no release at all
15:35:40 <smcginnis> Ceilometermiddleware being ceilometer, not sure what we want to do there other than just force the branching and move on. :/
15:36:13 <smcginnis> There are only two commits merged, neither functional changes.
15:36:37 <dhellmann> that tox change will have an impact on the pep8 job
15:36:47 <dhellmann> so we should probably tag and branch from there
15:37:02 <smcginnis> I can put up a patch for that.
15:37:12 <dhellmann> ok
15:37:24 <smcginnis> #action smcginnis to request tag and branch for openstack/ceilometermiddleware
15:37:43 <ttx> yes, there were some changes so we need to tag
15:37:47 <smcginnis> That's it for the library ones. I also included the other category.
15:37:59 <ttx> "6. For stable libraries that did not have any change merged over the
15:38:00 <ttx> cycle, create a stable branch from the last available release.
15:38:41 <ttx> "requirements" sounds like it should not be there
15:38:52 <dhellmann> requirements does have a library or tool or something that they release
15:39:01 <dhellmann> I'm not sure what actually uses it.
15:39:09 <dhellmann> #link https://review.openstack.org/584425 document another reason to force tags on intermediary projects
15:39:10 <patchbot> patch 584425 - releases - document another reason to force tags on intermedi...
15:39:27 <smcginnis> ttx: Should we update bullet 6 there to state that merged changes should be tagged before creating that stable branch?
15:39:58 <smcginnis> Oh, nevermind, dhellmann's patch does just that.
15:40:19 <ttx> looks like requirements end up being tagged
15:40:26 <ttx> but that will definitely happen later
15:40:44 <ttx> it's tagless actually
15:41:15 <smcginnis> IIRC, requirements and tempest are in our process for end of cycle activities.
15:41:25 <ttx> smcginnis: for those, I think we just need to remind the PTLs to remember to make a release
15:41:31 <dhellmann> ttx: tagless means we can branch from anywhere, but the tools in the requirements repo do get version tags
15:41:35 <ttx> those being lines 396+
15:42:04 <ttx> they still have some time
15:42:06 <dhellmann> https://pypi.org/project/openstack-requirements/
15:42:11 <smcginnis> I mostly included other just so we are aware of what is in that category and we've at least looked it over to see if there were issues. But I agree there's some time yet on those.
15:42:40 <ttx> all good
15:43:05 <smcginnis> Based on the lack of proper formatting for requirements on pypi, looks like that readme may need some fixing.
15:43:28 <dhellmann> yeah
15:43:44 <ttx> next topic ?
15:44:25 <smcginnis> Sure...
15:44:30 <smcginnis> #topic PTL election
15:44:39 <smcginnis> Self nomination starts next week.
15:45:27 <smcginnis> Since ttx and dhellmann are off being very busy with other things now, I'm assuming I'm going to have to break the yearly pattern and extend that unless someone else is ready to step in.
15:46:05 <dhellmann> I'm not sure I would have time to be PTL and drive the python3 work I have planned next cycle
15:46:18 <dhellmann> unless that all goes much more smoothly than I anticipate :-)
15:46:24 <smcginnis> dhellmann: Yeah, I think you have your plate full with other work.
15:46:28 <ttx> I'd rather not take it back right now unless you really can't do it :)
15:46:43 <ttx> Also the real test is next week
15:47:09 <smcginnis> I'm fine continuing. I wasn't originally planning on it, but I think things have settled with zuul migrations and automation to the point that it's really not a big deal anymore.
15:47:47 <ttx> #agreed
15:47:59 <dhellmann> I'll be on deck to deal with any disruption we cause in packaging for the python3 work
15:48:52 <smcginnis> OK, unless anyone is sitting in the back of the room secretly wanting to jump up, I'll propose myself next week and plan on going again for Stein.
15:49:01 <dhellmann> thanks, smcginnis
15:49:13 <ttx> thanks, fearless leader!
15:49:15 <dhellmann> maybe we can spend a bit of time focusing on recruiting next cycle, too
15:49:23 <smcginnis> Hah, no problem. :)
15:49:32 * dims waves from the back of the room
15:49:47 * dhellmann wonders who "dims" is. the name is vaguely familiar.
15:49:48 <smcginnis> Yeah, not sure what to do about that, but that will be a goal of mine for stein so we're not in the same situation for T.
15:50:00 <dims> LOL :)
15:50:02 <smcginnis> dims: o/ :)
15:50:16 <smcginnis> #topic Next week's activities
15:50:30 <smcginnis> ttx: Looks like you're putting the process info in the etherpad?
15:50:38 <ttx> yes
15:50:39 <dhellmann> smcginnis : maybe we can get some of the release liaisons to start helping with reviews. We might have to force that by saying that releases have to be reviewed by another liaison before they're approved.
15:51:14 <smcginnis> dhellmann: Not sure if that will fly, but we could certainly try it.
15:51:17 <ttx> smcginnis: (8) is not urgent, i can do it when back
15:51:25 <dhellmann> something to think about, anyway
15:51:45 <dhellmann> hmm, step 1 there looks a bit out of date after our "stable" discussions
15:52:34 <smcginnis> I think we can still try to do step 1, but knowing we will force it afterwards if no response?
15:52:36 <ttx> smcginnis: everything else should be clear enough ?
15:52:51 <smcginnis> I would still prefer that we aren't the ones initiating that tagging.
15:53:09 <smcginnis> ttx: Yeah, all steps are pretty straight forward. I don't anticipate any issues next week.
15:53:15 <ttx> You can coordinate (2) with prometheanfire
15:53:16 * smcginnis knocks on laminate
15:53:28 <ttx> the rest is more about PTL comms
15:53:39 <smcginnis> I think he plans on doing that step but will confirm and follow up.
15:53:46 <ttx> "oh, btw, remember you're technically frozen now"
15:53:55 <smcginnis> And I think I have most of the comms stuff queued up in the draft for the next countdown.
15:54:07 <smcginnis> I will double check that though before sending it out.
15:54:24 <smcginnis> Or maybe that warrants its own post just to make sure it's visible.
15:54:36 <smcginnis> Or both.
15:55:07 <ttx> I'll move that etherpad block to the Tasks section of the next week then
15:55:26 <smcginnis> Good, I was thinking about doing that.
15:55:36 <smcginnis> Anything else on this? 5 minutes left.
15:55:37 <ttx> I guess no meeting next week ?
15:55:56 <smcginnis> annabelleB, armstrong: Do you see any need for a meeting next week?
15:56:32 <annabelleB> not that I can think of? I’ll be out Aug 3 fwiw, but I can catch up when I’m back on the 6th/RC1 time
15:56:50 <smcginnis> annabelleB: OK, cool,.
15:57:02 <smcginnis> Yeah, I'll skip the meeting next week then.
15:57:08 <smcginnis> #topic Open discussion
15:57:14 <smcginnis> Anything else in the final minutes?
15:58:29 <dhellmann> nothing from me
15:58:41 <smcginnis> OK, thanks everyone. Safe travels dhellmann and ttx
15:58:48 <annabelleB> thanks smcginnis!
15:59:08 <smcginnis> #endmeeting