19:00:00 <tonyb> #startmeeting releaseteam
19:00:01 <openstack> Meeting started Thu May  9 19:00:00 2019 UTC and is due to finish in 60 minutes.  The chair is tonyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:04 <openstack> The meeting name has been set to 'releaseteam'
19:00:28 <diablo_rojo> o/
19:00:37 <tonyb> smcginnis, ttx, evrardjp, armstong: ping
19:00:53 <smcginnis> o/
19:00:53 <tonyb> oh and of course dhellmann .....
19:01:14 <dhellmann> o/
19:01:44 <tonyb> #link https://etherpad.openstack.org/p/train-relmgt-tracking
19:01:49 <ttx> o/
19:02:10 <tonyb> So I'll be up front, I'm not ready for this meeting I don't have the communicatiosn planned
19:02:37 <tonyb> but I think it's still worth looking at the queue and the tasks from the PTG
19:02:44 <ttx> I lined up a couple topics
19:02:52 <tonyb> ttx: I see that thanks :)
19:03:28 <ttx> also did a pass at organizing the stories on our PTg doc for easier consumption
19:03:28 <tonyb> So: Any remaining release issues
19:03:40 <ttx> I did approve a bunch today and it worked
19:03:55 <ttx> just wanted to make sure there was nothing left on everybody's minds
19:04:29 <tonyb> We need to decide what to do with the remaining pike-em changes
19:04:50 <tonyb> #link https://review.opendev.org/#/q/status:open+project:openstack/releases+branch:master+topic:pike-em
19:04:52 <ttx> ok adding to agenda
19:05:09 <tonyb> :)
19:05:48 <ttx> So on first topic: no standing issue ?
19:06:04 <tonyb> ttx: none that I'm aware of, others?
19:06:30 <ttx> Assuming that is a no
19:06:40 <smcginnis> Nothing that I've seen.
19:06:46 <ttx> and you can move to next topic :)
19:07:24 <tonyb> :)
19:07:31 <tonyb> #topic pike-em
19:07:51 <smcginnis> Last time I took a pass through, they all had issues to resolve or were waiting on updates from the teams.
19:08:28 <tonyb> smcginnis: Yup, at this point I wonder if we shoudln't just cut our losses and tage pike-em with what's there
19:08:57 <ttx> https://review.opendev.org/#/c/652842/ looks approvable
19:08:58 <tonyb> there are a few (like glance) that don't have a -1 so we could just merge them
19:09:14 <tonyb> ttx: snap ;P
19:09:53 <ttx> Are the others blocked on a class of issues, or are they all subtle
19:10:08 <diablo_rojo> I can try to go ping some of those PTLs/release liaisons by next meeting if we want to try that?
19:10:27 <smcginnis> Heat could probably go ahead since there was no response to my question after a couple weeks.
19:10:39 <tonyb> diablo_rojo: That'd be good if you have time
19:10:48 <ttx> some have issues that are not in the repo
19:10:52 <tonyb> so we can clear glance amd heat but that leaves a bunch
19:10:57 <ttx> Like https://review.opendev.org/#/c/652835/
19:11:04 <diablo_rojo> I imagine a lot of things got lost with the summit last week
19:11:25 <ttx> There aren't so many that pass tests and are waiting on PTL action
19:11:27 <diablo_rojo> Happy to go remind people about these and tell them what the plan is if we dont see action by next week
19:11:30 <tonyb> and to answer ttx's question I don't think things are subtle but they do need approvales from the teams
19:11:51 <ttx> I bet they don't jump on reviews that have Check-1
19:11:52 <tonyb> there are several that wont merge because of readme issues
19:12:14 <ttx> Agree that for those, some gentle reminder would help
19:12:15 <diablo_rojo> If there are people in particular I can ping them instead of going after all of them if you all have a list.
19:12:16 <tonyb> ttx: true
19:12:48 <ttx> just that you can't blindly gpo and ping everyone... rapier, not scattergun
19:12:59 <ttx> so it's a bit time-intensive
19:13:17 <ttx> tonyb: How about listing them all on an etherpad
19:13:23 <ttx> with what blocks them
19:13:26 <smcginnis> Honestly, we had a published date for the transition, so I'm leaning on just tagging last release and being done with it.
19:13:35 <ttx> Because otherwise we all have to interpret the signs
19:13:42 <ttx> which duplicates a lot of work
19:13:44 <smcginnis> If they weren't tracking the need to release things, then I think they were already in "extended maintenance" mode.
19:13:47 <smcginnis> Or unmaintained.
19:13:53 <ttx> Some are waiting on PTLs, other are waiting on patch refresh, others etc
19:14:10 <tonyb> ttx:Sure I'll add that as tasks for this week, with an aim to moving them forward/pinging befoer the next meeting
19:14:18 <ttx> smcginnis: isn't that what we are doing here ?
19:14:41 <smcginnis> No, we're doing a final release for them, then tagging.
19:14:50 <ttx> ah hm
19:14:54 <tonyb> ttx: We could skip the final realeas and just tag what's already there
19:15:05 <smcginnis> I'm saying, they missed the deadline for a final release and should now be in EM.
19:15:29 <ttx> smcginnis: half the requests are just pike-em requests and they still fail tests
19:15:45 <smcginnis> Most of those are because they are on top of the final release patches.
19:15:47 <ttx> but yes, I agree to skip the final release
19:15:53 <ttx> smcginnis: got it
19:16:22 <tonyb> okay
19:16:26 <ttx> So... maybe a ping on those patches, and then if no action we'll just do pike-em and be done
19:16:43 <diablo_rojo> Thats kind of what I was thinking
19:16:53 <tonyb> okay cool.
19:17:00 <diablo_rojo> One last chance since the summit took attention away from this.
19:17:01 <smcginnis> We could post to the ML that if we don't have the final releases worked through by the affected teams by next Thursday, we will just go ahead with the -em tag.
19:17:18 <diablo_rojo> That works too
19:17:47 <tonyb> diablo_rojo: wanna do that?
19:18:15 <tonyb> diablo_rojo: and tag the teams from
19:18:19 <tonyb> #link https://review.opendev.org/#/q/status:open+project:openstack/releases+branch:master+topic:pike-em+NOT+message:create
19:18:25 <tonyb> ?
19:18:28 <diablo_rojo> tonyb, sure put me down for that
19:18:54 <tonyb> \o/
19:19:31 <tonyb> #action diablo_rojo to email the list as ask for some attention on ^^ those changes or we'll just tag them next Thursday
19:19:55 <diablo_rojo> Oh jeeze now its all official as an action item
19:20:03 <tonyb> hehe
19:20:25 <tonyb> #topic Prioritize/Allocate tasks from https://etherpad.openstack.org/p/relmgmt-train-ptg
19:20:34 <ttx> OK so I organized that list a bit
19:20:46 <ttx> (the stories/tasks list at the bottom)
19:21:03 <ttx> Train process changes on one side, with milestone to do it before
19:21:14 <ttx> And tools improvements/wishlists on the other site
19:21:15 <ttx> side
19:21:44 <ttx> We have 3 big things
19:21:51 <ttx> (on the process changes side)
19:22:06 <ttx> Do stable autoreleases around milestones, Introduce cycle-automatic for "other" things that should get one release by the end of the cycle
19:22:12 <ttx> That's two actually
19:22:30 <ttx> The others are smaller (Track release liaisons in deliverable files, cycle-highlights process improvements)
19:22:51 <ttx> And arguably "Add email content to the Process document " is more of a continuous task, assigned to tonyb
19:23:18 <ttx> diablo_rojo: I'm assuming you are documenting the cycle-highlights collection changes ?
19:24:18 <ttx> I can take cycle-automatic, if someone takes stable autoreleases
19:24:19 <diablo_rojo> I think we did that during the process doc changes?
19:24:26 <diablo_rojo> at the PTG?
19:24:31 <diablo_rojo> But I can double check.
19:24:46 <ttx> diablo_rojo: maybe it's done already, please doublecheck that it is enough. Maybe an email to the list to communicate teh change
19:24:54 <diablo_rojo> Can do
19:25:03 * diablo_rojo adds second email to todo list
19:25:15 <tonyb> I admit I don't have a link to the etherpad where we corrected the process docs
19:25:23 <smcginnis> https://etherpad.openstack.org/p/relmgmt-train-ptg
19:25:28 <ttx> Anyone interested in documenting stable autoreleases around milestones?
19:25:36 <ttx> tonyb: Sean did submit the diff
19:25:44 <tonyb> Ahh there it is my bad
19:26:08 <smcginnis> Oh, that etherpad. Sorry, yeah, that's all squared away.
19:26:25 <tonyb> #link https://review.opendev.org/#/c/657426/
19:26:28 <smcginnis> I think I heard evrardjp volunteer for the autoreleases. :)
19:26:29 <tonyb> there it is
19:27:01 * tonyb will review that befoer I leave the office
19:27:10 <ttx> and anyone interested in documenting liaisons in deliverable files ?
19:27:20 <ttx> (that should be an easy one)
19:27:44 <diablo_rojo> I could probably do that too
19:27:49 <diablo_rojo> if noone else wants it
19:27:55 <ttx> We can also wait until the next meeting
19:28:01 <ttx> since we are missing people
19:28:03 <dhellmann> tonyb: https://etherpad.openstack.org/p/DEN-release-process is where we worked on the process doc
19:28:24 <tonyb> dhellmann: Thanks, it was linnked in the PTG etherpad I just missed it
19:28:36 <openstackgerrit> Merged openstack/releases master: [glance] final releases for pike  https://review.opendev.org/652842
19:28:53 <ttx> Looking at the improvements section -- is that all wishlist, or is there any tool in there that has priority
19:28:53 <tonyb> dhellmann: and smcginnis has already published the change which is good
19:28:58 <dhellmann> aha, yeah
19:30:38 <ttx> Feel free to move things between sections
19:30:43 <tonyb> ttx: are you on https://storyboard.openstack.org/#!/board/64 ?
19:30:52 <ttx> I'm on https://etherpad.openstack.org/p/relmgmt-train-ptg
19:31:27 <ttx> That board is a bit outdated
19:31:37 <tonyb> ttx: okay
19:31:45 <ttx> Bottom of https://etherpad.openstack.org/p/relmgmt-train-ptg
19:31:47 <dhellmann> yeah, we never fully adopted storyboard for tracking
19:31:58 <ttx> Once assigned people can create the SB stories and we can populate a new board
19:31:58 <tonyb> we shoudl fix that
19:32:00 <dhellmann> with just a few of us, the etherpad was more than sufficient
19:32:21 <smcginnis> I think we got *most* things moved from tracking etherpads to SB, but just need to keep up with it.
19:32:36 <ttx> Is there anything in the "Should do" section that you'd move to more or less priority
19:32:43 <dhellmann> it probably needs pruning, but sure
19:33:07 <tonyb> I kinda feel like the couple of tools items (L92-L95) could be in Must do as we modified the process assuming they were available
19:33:16 <dhellmann> ttx: those priorities look reasonable to me
19:33:42 <dhellmann> hmm, yeah, if we have process changes that rely on tool changes, those are musts
19:34:23 <tonyb> Yup apart from that I think we're good
19:35:05 <tonyb> Just needs people signed up to do them
19:35:33 <ttx> Maybe "Add a tool script for producing the list of intermediary deliverables that have not released (see step under "Between Milestone-1 and Milestone-2" for details)" is a must too if it's mentioned in process
19:36:14 <tonyb> ttx: Yeah probably
19:36:58 <ttx> I will take that one if the absent people don't want it
19:37:20 <tonyb> ttx: thanks
19:37:24 <ttx> I ant to give JP a chance to take $stuff :)
19:37:42 <ttx> I don't think we need to assign Should/can do items
19:37:49 <ttx> at least not right now
19:37:59 <tonyb> ttx: agreeed
19:39:25 <diablo_rojo> +2
19:39:33 <ttx> ok that is all I had on that topiuc
19:40:00 <tonyb> I added another thing .. that we shoudl have done at the PTG
19:40:03 <ttx> I propose we rediscuss assignments next week if we have other team members show up
19:40:09 <tonyb> #topic release days review
19:40:20 <ttx> ah yes
19:40:30 <ttx> I'm happy keeping the Thursdays
19:40:50 <tonyb> Please look at the days you're on and let us know if you need to change
19:40:55 <tonyb> ttx: great
19:41:05 <dhellmann> I'm not sure I'm going to be able to commit to a day, but it looks like we have someone to replace me on fridays
19:41:13 <dhellmann> (we have 2 signed up for monday)
19:41:25 <tonyb> true
19:41:37 <smcginnis> That was to have the stable and "normal" reviews, but I'm fine switching to Friday.
19:41:49 <tonyb> that was mostly because of stable but I can just take Monday if smcginnis is food with Friday?
19:41:50 <ttx> That would be ideal
19:41:56 <dhellmann> there haven't been a ton of friday reviews, so you could also leave that floating
19:41:59 <tonyb> cool
19:42:06 <dhellmann> but yeah
19:42:07 <ttx> That makes for early Monday and late Friday which is excellent for coverage
19:42:17 <smcginnis> ++
19:42:18 <tonyb> \o/
19:42:27 <tonyb> follow-the-sun
19:42:48 <dhellmann> like we planned it
19:42:56 <tonyb> :)
19:43:43 <smcginnis> The lack of sun is following me. Cold and gray here like most of the time in Denver. :)
19:43:46 <tonyb> I'll get an etherpad for this weeks communication done today and drop it here for review before I send it tomorrow
19:44:05 <tonyb> smcginnis: clear blue skies in MA at the moment ;P
19:44:20 <tonyb> just say'n'
19:44:21 * dhellmann enjoyed the cool weather in Denver, since it's already turning tropical here in Georgia
19:44:24 <smcginnis> :)
19:44:26 <diablo_rojo> smcginnis, its been sunny and 70 in seattle all week
19:44:39 <smcginnis> Yeah, yeah, yeah, I need to move.
19:44:45 <tonyb> :D
19:44:45 <diablo_rojo> smcginnis, yes, you do :)
19:45:08 <diablo_rojo> dhellmann, and tonyb and ttx are of course welcome to move to Seattle too :)
19:45:40 <smcginnis> Bridget wants to move to France, but looks like it's about the same there. At least in Paris. Will have to try further south.
19:46:26 <tonyb> smcginnis: I suspect ttx may know a thing or two about that
19:46:34 <tonyb> anyway I think we're done
19:46:43 <tonyb> #endmeeting