19:03:16 <ttx> #startmeeting releaseteam
19:03:16 <openstack> Meeting started Thu Jun 13 19:03:16 2019 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:19 <smcginnis> So long you've already forgotten? :D
19:03:20 <openstack> The meeting name has been set to 'releaseteam'
19:03:28 <diablo_rojo> o/
19:03:34 <ttx> tss... who wrote this silly bot I wonder
19:03:36 <dhellmann> o/
19:03:45 <diablo_rojo> Hahaha
19:03:50 <ttx> ping hberaud evrardjp armstrong tonyb
19:03:59 <dhellmann> I have lost the link to the tracking etherpad for this cycle, can someone paste it in?
19:04:06 <ttx> #link https://etherpad.openstack.org/p/train-relmgt-tracking
19:04:10 <armstrong> o/
19:04:16 <ttx> #topic Approval for unconfirmed milestone-1 pushes
19:04:24 <ttx> we have a couple of patches stuck
19:04:29 <ttx> Heat https://review.opendev.org/#/c/663635/
19:04:37 <ttx> Neutron https://review.opendev.org/#/c/663644/
19:04:39 <ttx> OSC https://review.opendev.org/#/c/663646/
19:04:44 <diablo_rojo> I got some attention on the neutron one
19:04:48 <diablo_rojo> pinged the other liaisons
19:05:03 <ttx> my question was -- should we just approve them, as planned?
19:05:15 <smcginnis> I think we can just approve them. That's what we did last cycle.
19:05:19 <ttx> neutron is a go, with mlavalle's +1
19:05:24 <smcginnis> We gave a few days for feedback, then just approved.
19:05:36 <smcginnis> We could wait until Monday since they haven't been out there too long.
19:05:46 <dtroyer> diablo_rojo: +1
19:05:58 <diablo_rojo> OSC's is good to go now too
19:06:03 <diablo_rojo> thanks dtroyer :)
19:06:04 <ttx> on it
19:06:14 <diablo_rojo> Just waiting on ricolin for heat
19:06:41 <ttx> hmm
19:07:20 <ttx> diablo_rojo: wait to ping him when China rises at the end of your day and +2a then?
19:08:03 <ttx> I'm fine with pushing now too, just a bit unfair given the ping was done in US time
19:08:31 <diablo_rojo> Yeah I didn't expect an answer from him for a while
19:08:49 <ttx> ok let's do that then. Approve at the very end of the Thursday
19:08:59 <ttx> give him a last chance
19:09:24 <ttx> #action diablo_rojo to +2a https://review.opendev.org/#/c/663635/ after giving a last chance to ricolin to approve
19:09:39 <ttx> #topic Two or one approver?
19:09:47 <diablo_rojo> Will be my first +W :)
19:10:21 <ttx> I've noticed recently that people were less inclined to directly single-approve +2a
19:10:43 <ttx> While we sait our apprentices should not, I was wondering if that should eb ageneral rule
19:10:55 <ttx> said*
19:11:02 <hberaud|gone> o/
19:12:19 <ttx> opinions?
19:12:21 <smcginnis> We can wait for two. I just don't want to slow things down too much if folks are waiting for a release and it's a pretty straightforward one.
19:13:14 <diablo_rojo> Say if it has like.. less than 5 patches in the listed changes?
19:14:18 <ttx> OK let's try to wait for two
19:14:47 <smcginnis> Works for me.
19:14:51 <ttx> giving discretion to experienced members to just push things
19:14:59 <ttx> but general rule shall be 2
19:15:03 <ttx> and 2 the rules shall be
19:15:55 <diablo_rojo> not 1.. not 3
19:15:59 <diablo_rojo> 2
19:16:12 <dhellmann> 4 is right out
19:16:28 <diablo_rojo> I love our team <3
19:16:49 <smcginnis> Releases only by unanimous approval!!
19:16:50 <smcginnis> :D
19:17:30 <smcginnis> Nothing else on the agenda.
19:17:38 <ttx> #info general rule for releases approval shall be to collect 2 +2s, with possibility when you know what you're doing to single-approve.
19:17:44 <ttx> #topic AOB
19:18:03 <ttx> Anything special for the coming weeks?
19:18:14 <diablo_rojo> Can has another +2 and a +w? https://review.opendev.org/#/c/660781/
19:18:32 <diablo_rojo> Once that merges I'll update the wiki to point to the file
19:18:37 <openstackgerrit> Merged openstack/releases master: [OpenStackClient] Create milestone-1 releases  https://review.opendev.org/663646
19:18:42 <diablo_rojo> and I have a couple follow up patches I am working on too
19:19:37 <dhellmann> I posted about the sphinxcontrib-datatemplates update. I have a new contributor there who is on fire adding features, and some are not backwards-compatible. https://review.opendev.org/#/c/665151/ should protect against breaks.
19:19:54 <dhellmann> it seems that the releases repo is the only one that uses that plugin
19:20:14 * diablo_rojo opens tab
19:20:22 <ttx> dhellmann: in list-changes there is a thing that lists liaisons... would that need to be updated for https://review.opendev.org/#/c/660781/?
19:21:06 <smcginnis> At before removing the wiki I think.
19:21:10 <dhellmann> ttx: if we want it to be accurate, yes.
19:21:21 <dhellmann> but yeah, as long as there is data in the wiki that shouldn't break
19:21:28 <diablo_rojo> Yeah I was going to go update all that in the follow up.
19:21:32 <diablo_rojo> Remove all the wiki stuff
19:21:36 <dhellmann> even then I think it will just report that it can't figure out the liaison
19:21:49 <diablo_rojo> And add a schema for testing the release_liaisons yaml
19:21:52 <smcginnis> I think you're right. We would get the PTL but no liaisons.
19:22:37 <ttx> ++
19:22:43 <ttx> OK anything else?
19:23:10 <diablo_rojo> Nothing from me
19:23:20 <dhellmann> nothing here
19:23:23 <ttx> https://review.opendev.org/#/c/618183/
19:23:31 <ttx> should it just be abandoned
19:24:08 <diablo_rojo> Kinda sounds like it?
19:24:16 <dhellmann> I wonder if the new telemetry team is going to want anything new to cope with
19:24:23 <openstackgerrit> Merged openstack/releases master: [neutron] Create milestone-1 releases  https://review.opendev.org/663644
19:24:37 <smcginnis> Nothing really since late last year. Maybe abandon it for now and he can restore it if things progress.
19:24:41 <ttx> ok, let me abandon it
19:25:46 <fungi> the signing key got updated to the one generated for train
19:25:53 <ttx> We could also abandon https://review.opendev.org/#/c/645045/
19:25:53 <smcginnis> \o/
19:25:59 <ttx> since I don;t think we want that
19:26:05 <smcginnis> I htink so.
19:26:07 <smcginnis> *think
19:26:13 <ttx> But since it's my opinion that killed it I'd rather have someone else abandon it
19:26:26 <smcginnis> I had the same opinion.
19:26:41 <ttx> Agreeing with me is a very safe opinion
19:27:14 <smcginnis> haha!
19:27:32 <diablo_rojo> lol
19:28:10 <ttx> dhellmann: care to abandon it?
19:28:27 <dhellmann> make diablo_rojo do it
19:28:47 <ttx> yes, that way the blame falls on her. Good call!
19:28:55 <ttx> Delegation!
19:29:10 * dhellmann hands diablo_rojo a hot potato
19:29:24 <ttx> and on those good words... if nothing else...
19:29:36 <ttx> #endmeeting