19:00:04 <smcginnis> #startmeeting releaseteam
19:00:05 <openstack> Meeting started Thu Aug  8 19:00:04 2019 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:08 <openstack> The meeting name has been set to 'releaseteam'
19:00:09 <ttx> ohai
19:00:16 <diablo_rojo_phon> o/
19:00:19 <smcginnis> ping: dhellmann diablo_rojo hberaud evrardjp armstrong tonyb
19:00:26 <dhellmann> o/
19:00:41 <armstrong> o/
19:00:57 <smcginnis> Tony sent out the handoff email - so, I guess y'all stuck with me again.
19:01:13 <fungi> welcome back
19:01:27 <smcginnis> He also said he was not going to be available for this meeting, but even so, I'd like to say thanks again for his time as PTL.
19:01:28 <fungi> and thanks for all your hard work tonyb! i hope you're sleeping in for a change
19:01:30 <ttx> I'll continue to frontload the agenda
19:01:36 <smcginnis> I know he was fighting a lot of conflicting priorities.
19:01:40 <smcginnis> ttx: Thanks!
19:02:02 <smcginnis> #link https://etherpad.openstack.org/p/train-relmgt-tracking Agenda
19:02:05 <ttx> nobody can expect my etherpad-driven bossing
19:02:11 <smcginnis> :)
19:02:12 <ttx> escape*
19:02:24 <ttx> nobody expects the Spanish Inquisition
19:02:35 <smcginnis> We're around line 304 on that etherpad.
19:02:53 <smcginnis> ttx: Thanks for getting that loaded and for taking care of proposing all of those patches today.
19:03:06 <dhellmann> nobody expects the French Imperative?
19:03:11 <smcginnis> #topic Turning cycle-with-intermediary summarized proposal into law
19:03:12 <smcginnis> Hah
19:03:19 <ttx> This was more painful than I expected (the autoreleases)
19:03:29 <ttx> we really need some more automation around that
19:03:41 <ttx> OK so... law
19:03:41 <smcginnis> Yeah, a little trickier to automate than at first glance.
19:03:54 <ttx> I posted the proposal, was about to propose a bunch of patches
19:04:07 <ttx> BUt i find useful to run through a practical example first
19:04:15 <smcginnis> ++
19:04:21 <ttx> So I compiled the list
19:04:39 <ttx> You can see that there are a bunch of horizon UI things
19:05:01 <ttx> And most of them did not release multiple times in Stein and or Rocky
19:05:27 <ttx> So I was wondering... should we limit our proposals to things that (1) did not release yet and (2) did release only once last cycle
19:05:36 <ttx> That would reduce churn
19:05:46 <ttx> and we'd have more legs to stand on
19:06:06 <dhellmann> can you remind me what we finally settled on for the policy?
19:06:16 <ttx> sure
19:06:27 <ttx> We said we'd propose the patch for things that have not released yet
19:06:46 <ttx> but it's OK to -1 the patch -- you just need to release before RC1
19:07:00 <ttx> and we'll autorelease if you forget (and complain)
19:07:10 <ttx> So basically the model change is a discussion opener
19:07:27 <ttx> But I feel like targeting more likely targets might be a good idea
19:07:49 <dhellmann> that makes sense
19:08:03 <smcginnis> I think there was some pushback on the ML thread, but then when the reasoning behind it was explained folks were a little more accepting of it.
19:08:10 <dhellmann> building that list is going to take a little bit of work
19:08:12 <ttx> You did only release once last cycle. And you haven't released yet. Are you sure you don;t want to do cycle-with-rc
19:08:21 <diablo_rojo_phon> Yeah it got better on the ml
19:09:04 <ttx> So if you agree, that means only proposing changes to things with * after the name
19:09:06 <smcginnis> I think your proposal is a good start ttx.
19:09:20 <smcginnis> * and **
19:09:22 <diablo_rojo_phon> Seems like a good place to start
19:09:27 <ttx> super-good targets are tricircle and cloudkitty-dashboard
19:09:34 <dhellmann> I count ~11 items
19:09:37 <dhellmann> not too bad
19:09:43 <ttx> monasca-thresh is a bit of an outlier
19:09:59 <ttx> IIRC it;s Java-based
19:10:33 <ttx> yes it is. Not sure how much it would like being RC-ed
19:10:44 <smcginnis> Like you pointed out, it's at least a good conversation starter.
19:10:53 * smcginnis didn't realize we still had java code
19:11:19 <ttx> well back in the age of abundance it was supposed to be gradually removed
19:11:32 <ttx> and now everyone just looks the other way
19:11:53 <smcginnis> Almost as bad as perl. :P
19:12:06 <ttx> Anyway, we still need people to send those model change proposals
19:12:23 <ttx> I'll propose the process changes
19:12:40 <ttx> (updating our process doc with what the new rule means)
19:13:12 <ttx> but would prefer if someone else took on the 11 model change proposals
19:13:18 <smcginnis> So of the ~11 deliverables, just a patch to switch over the release model to cycle-with-rc, add the PTLs, and have the commit message state why it's being proposed and inviting them to discuss, right?
19:13:35 <ttx> I count 15
19:13:41 <ttx> yes
19:13:43 <diablo_rojo_phon> If that's the case I can probably handle that.
19:14:06 <ttx> "You did only release once last cycle. And you haven't released yet. Are you sure you don;t want to do cycle-with-rc, which is much better for one-release-per-cycle"
19:14:56 <smcginnis> diablo_rojo_phon: If you can take that, that would be great.
19:15:02 <diablo_rojo_phon> Yeah I can put that as a comment in each review or as a part of the commit message
19:15:08 <ttx> "if you know you'll do just one, advise to +1. if you know you will do more than one, why not now ? -1 and propose a release. If you have no idea when you will release, -1, but propose a release before Rc1!"
19:15:29 <ttx> something like that
19:15:43 <smcginnis> diablo_rojo_phon: I see you are out next week. Is that something you can do yet this week?
19:15:48 <diablo_rojo_phon> Got it.
19:15:51 <ttx> basically make the "I have no effing idea" be the odd one
19:16:05 <diablo_rojo_phon> Yeah I can probably get that done before the end of the week.
19:16:11 <diablo_rojo_phon> The patches at least
19:16:22 <diablo_rojo_phon> Maybe not all of the chasing involved ;)
19:16:23 <smcginnis> Perfect, thanks diablo_rojo_phon.
19:16:34 <smcginnis> And thanks for getting that list together ttx.
19:16:40 <diablo_rojo_phon> No problem
19:16:50 <ttx> #action ttx to post process changes around unreleased things
19:17:00 <smcginnis> I can watch for review comments next week and approve the ones that get +1, abandon the ones that say hellz no.
19:17:17 <diablo_rojo_phon> Coolio
19:17:21 <ttx> #action diablo_rojo to push release-model-change patches for things that have not released yet AND did only release once last cycle
19:18:27 <smcginnis> #topic Review R-8 email content
19:18:38 <ttx> #link https://etherpad.openstack.org/p/relmgmt-weekly-emails
19:18:40 <smcginnis> #link https://etherpad.openstack.org/p/relmgmt-weekly-emails
19:18:52 <ttx> That is in preparation of next week, since most of us won't be around
19:18:56 <diablo_rojo_phon> Heh :)
19:19:21 <ttx> scroll down to line ~321
19:19:23 <smcginnis> So the etherpad actually only has an R-9 draft.
19:19:33 <ttx> It's a mind trick
19:19:36 <smcginnis> Is that meant to be sent in R-9 for R-8?
19:19:42 <smcginnis> Oh, yep.
19:19:43 <ttx> It's a R-* draft to be sent on R-9
19:19:48 <ttx> R-8
19:19:49 <smcginnis> Subject would appear so.
19:19:56 <ttx> I know it's confusing
19:20:05 <smcginnis> OK, I'm caught up now.
19:20:34 <ttx> Main focus on this email is to introduce the stages of freezes around train-3
19:20:52 <smcginnis> Should we add something to that about cycle-with-intermediary teams considering cycle-with-rc if they only need one release?
19:21:02 <ttx> Make it very clear that we do libs first, then client-libs, then feature-freeze the rest
19:21:05 <smcginnis> Or keep it focused on the things coming up.
19:21:18 <ttx> I would keep it focused on things coming up
19:21:35 <dhellmann> ++
19:21:41 <smcginnis> There always seems to be at least one team that gets caught by surprise by lib freezes, so that's probably a good call.
19:22:14 <smcginnis> In that case, the draft looks good to me. I can plan on sending that content out next week.
19:22:55 <smcginnis> #topic No meeting next week
19:22:58 <ttx> The R-6 email (sent on R-7 week) needs some work
19:23:06 <ttx> but there is still time
19:23:18 <ttx> I'll just add a few tasks so that we review it early enough
19:23:20 <smcginnis> I'll try to take a look at that.
19:23:47 <smcginnis> So looks like several of you are out next week.
19:24:07 <smcginnis> I will be here, but I'm fine skipping the meeting if there's not a need for it.
19:24:12 <smcginnis> *strong need
19:24:16 <ttx> Yeah, I think it's safe to skip
19:24:23 <ttx> We should be caught up with process
19:24:28 <diablo_rojo_phon> smcginnis: ttx and fungi and  I will be at the foundation staff off-site
19:24:42 <smcginnis> If anyone else has any concerns or needs to talk about anything in the mean time, we can just do that in channel.
19:24:53 <fungi> yeah
19:24:58 <smcginnis> diablo_rojo_phon: Nice. Should be quiet around here then.
19:25:10 <fungi> sure, you won't have me breaking anything
19:25:13 <smcginnis> :)
19:25:26 <smcginnis> #topic Open floor
19:25:28 <diablo_rojo_phon> Heh
19:26:19 <smcginnis> It would feel a little like slamming the door behind him, but I feel I should at least bring it up - should we reconsider the meeting time again?
19:26:37 <smcginnis> I know this isn't a great spot for ttx, evrardjp, or hberaud|gone.
19:27:25 <fungi> i'll do my best to attend whatever time you come up with
19:28:04 <smcginnis> From the TC office hour official keyholder ^ ;)
19:28:18 <diablo_rojo_phon> This time works for me, but we can also change it.
19:28:21 <ttx> smcginnis: It's hard to meet with the west coast before 1500utc summer / 1600utc winter, and my time slots between that and dinner are pretty full
19:28:27 <ttx> Let me check
19:28:51 <fungi> oh, in other news, there was a nova security advisory this week so be on the lookout for possibly expedited requests on stable point releases
19:28:54 <smcginnis> Not saying we need to change it, just wanted to put the idea out there since I know it's not the best.
19:29:05 <diablo_rojo_phon> I quite like not being faced with the threat of waking up at like.. 7/8 AM but can handle that if  it works for everyone else.
19:29:14 <smcginnis> I think the stein one is up right now and a rocky one waiting.
19:29:25 <ttx> Could move it to 1600utc Thursday
19:29:35 <smcginnis> https://review.opendev.org/#/c/675152/
19:29:47 <ttx> especially if that means we can get evrardjp more regularly
19:30:04 <smcginnis> That would be good. We used to be 1600, right?
19:30:17 <ttx> Used to be on Friday
19:30:32 <ttx> My Friday is wide open but not super-awesome to get things done
19:30:44 <fungi> yeah, ossa-2019-003 affected all supported nova branches (and em branches but those are obviously not getting point releases), so expect point release requests back to stable/queens
19:30:45 <smcginnis> I like to avoid Friday meetings when I can.
19:31:16 <fungi> i think the stable/queens patch is still in the gate at the moment
19:31:19 <ttx> Thursday 16 is after the TC office hour, and since we generally manage to keep meetings short, totally doable for me
19:32:16 <smcginnis> OK, let's think about Thursday 1600 for now and not make any changes. We can talk some more in a couple weeks when everyone is back and see what everyone thinks.
19:32:44 <ttx> yeah lets wait for evrardjp to chime in. If he can't make that one either, no point in changing
19:32:56 <smcginnis> ++
19:33:01 <dhellmann> what time is tc office hours on thurs in utc?
19:33:12 <ttx> 15
19:33:21 <dhellmann> ok
19:33:23 <ttx> monthly meeting at 14
19:34:12 <ttx> alright if nothing else I'll jump into my evening
19:34:28 <smcginnis> Yeah, I guess we're done here.
19:34:30 <smcginnis> Thanks everyone!
19:34:37 <fungi> thanks smcginnis!
19:34:38 <diablo_rojo_phon> Thanks!
19:34:44 <smcginnis> #endmeeting