16:00:22 <smcginnis> #startmeeting releaseteam
16:00:23 <openstack> Meeting started Thu Jan 23 16:00:22 2020 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:26 <openstack> The meeting name has been set to 'releaseteam'
16:00:28 <smcginnis> Ping list: ttx armstrong diablo_rojo, diablo_rojo_phon
16:00:30 <hberaud> o/
16:00:39 <smcginnis> #link https://etherpad.openstack.org/p/ussuri-relmgt-tracking Agenda
16:00:44 <armstrong> o/
16:01:09 <smcginnis> hberaud: You probably have a reminder, but if you want to be added to the ping list, feel free to add your nick to the etherpad ^
16:01:25 <elod> o/
16:01:26 <ttx> o/
16:01:43 <diablo_rojo> o/
16:01:47 <hberaud> smcginnis: sure thanks but irc notification is enough for me
16:01:54 <elod> hi, i'd like to join too, since i'd like to help with Rocky EM preparation :)
16:02:07 <smcginnis> +1
16:02:13 <smcginnis> elod: Welcome!
16:02:26 <elod> :)
16:02:46 <smcginnis> Looks like we around line 253 in the etherpad.
16:03:04 <smcginnis> #topic Review/assign tasks for future weeks leading up to milestone-2
16:03:24 <smcginnis> We have a list of tasks in R-14 and R-13 for milestone 2.
16:04:19 <smcginnis> ttx: I think you've always done membership freeze in the past, but I can take that one if you'd like.
16:04:59 <ttx> hmm, I prefer to do it as the tooling is in flux
16:05:09 <smcginnis> Ah, good call then. ;)
16:05:18 <ttx> (my new tool still being in review right now)
16:05:28 <ttx> But you can take the aclcheck the week after :)
16:05:29 <smcginnis> What was "Create task plan toward usurri-3"?
16:06:01 <ttx> It's about translating the task list from porcess into the tracking plan
16:06:16 <smcginnis> Thanks for taking that one.
16:06:27 <smcginnis> So R-14 is done, looking at R-13.
16:06:56 <smcginnis> I can take the autoreleases since the tooling there is a little in flux too.
16:07:38 <smcginnis> I think we're covered then.
16:08:03 <smcginnis> #topic What more should we do about independent signature links
16:08:10 <smcginnis> OK, I added this before the patch merged.
16:08:16 <smcginnis> #link https://review.opendev.org/699885
16:08:27 <smcginnis> This adds links to signatures on the releases.o.o page.
16:08:42 <smcginnis> The issue being that some of the older releases did not have signature files.
16:08:48 <smcginnis> So there are a few 404 links in there.
16:08:58 <smcginnis> I think less than there are good links though, at this point.
16:09:12 <smcginnis> So the outstanding question is if we want to do anything about those missing ones.
16:09:17 <smcginnis> I think some of our options are:
16:09:25 <smcginnis> 1) Retroactively generate the files
16:09:48 <smcginnis> 2) Add some mechanism to explictly skip adding the links for deliverables that do not have them.
16:10:07 * tonyb sneaks in the back
16:10:08 <ttx> I prefer 2
16:10:13 <smcginnis> 3) Do nothing and let there be older releases with 404 under the assumption that many will not bother with those old ones.
16:10:30 <smcginnis> ttx: Hey!
16:10:38 <smcginnis> I meant: tonyb: Hey! :)
16:10:44 <tonyb> smcginnis: o/
16:11:37 <smcginnis> So if we wanted to go with 2, we could add something to the deliverable yaml schema to have a new flag under each release, since it would need to be a per-release thing.
16:11:58 <smcginnis> Then update the sphinx directive used for those to recognize the flag and skip adding the link based on it.
16:12:04 <diablo_rojo> Seems reasonable to me.
16:12:04 <smcginnis> Sound about right?
16:12:14 <tonyb> smcginnis: Yup
16:12:23 <tonyb> and I like that option best of the 3
16:12:52 <smcginnis> That works for me. We'll have a bit of yaml file churn, and we'll need to go through and figure out which releases need that flag. Anyone signing up for doing all that?
16:13:00 * smcginnis looks in ttx's direction
16:13:43 <ttx> yes +1
16:13:55 <tonyb> smcginnis: I have a tool that can do most of: go through and figure out which releases need that flag. part
16:13:59 <smcginnis> Yes, you're signing up for the work, or yes, that sounds like a reasonable plan? :)
16:14:09 <smcginnis> tonyb: Oh, great.
16:14:21 <tonyb> I can so that part of ttx does the hard part
16:14:26 <smcginnis> We do have some pieces in place, so if someone wants to take the time to script it up, shouldn't really be too bad.
16:14:35 * diablo_rojo thinks it sounds like tonyb is signing up for the work
16:14:47 <tonyb> diablo_rojo: the *easy* part
16:14:57 <smcginnis> In that references patch, I did experiment with adding a link check, but obviously that made the docs build really, really slow.
16:15:22 <smcginnis> So tonyb comes up with the list. ttx updates the schema and sphinx extension?
16:15:24 <tonyb> Yeah I think it took more that 15mins to workout which ones are missing
16:15:35 <tonyb> smcginnis: I'm up for that
16:15:53 <smcginnis> #action tonyb to get list of broken links
16:15:54 <ttx> will just take me a bit
16:16:12 <smcginnis> #action ttx to update schema and sphinx directive to skip broken links
16:16:17 <smcginnis> It's at least a plan.
16:16:29 <ttx> I'll add it to the tracking so that I remember
16:16:38 <smcginnis> And on the plus side, I don't think it's too time critical since these are all older releases that are likely not viewed often.
16:17:02 <tonyb> ttx: If you let me know what the flag will look like  I can do that part tomorrow
16:18:12 <smcginnis> Probably something along these lines? http://paste.openstack.org/show/788723/
16:18:15 <ttx> tonyb: I have no idea yet
16:18:39 <ttx> but yeah probably ^
16:19:23 <tonyb> Okay I'll just assume that ;P
16:19:40 <smcginnis> Naming subject to changing, probably.
16:20:05 <smcginnis> OK, think we at least have a plan and direction there.
16:20:06 <tonyb> smcginnis: Sure but that's just sed at that point
16:20:09 <smcginnis> #topic Rocky transition to EM coming 2-24
16:20:11 <smcginnis> tonyb: ;)
16:20:39 <smcginnis> So just wanted to start making a little noise that we are getting close to the published EM transition date for Rocky.
16:20:52 <elod> I can prepare the mail and the list of the unreleased + open changes
16:21:02 <tonyb> elod: Thanks
16:21:10 <smcginnis> elod: Great! I was just thinking someone needs to get that sent out to the ML so folks start preparing.
16:21:28 <smcginnis> If it's like last time, there will be a crunch at the end with some teams trying to quickly get bug fixes backported.
16:21:28 <elod> the question is about your concern smcginnis the libraries?
16:21:47 <smcginnis> elod: Not sure what you're asking. :]
16:22:15 <elod> so should we focus some projects first? :)
16:22:26 <smcginnis> Oh, right!
16:22:39 <smcginnis> I'm still not sure.
16:23:24 <smcginnis> After the last discussion, it seemed like it was maybe a valid concern, but we also didn't run into any actual issues with doing them all at once in the wild, so maybe there's actually low risk given the "stableness" of the stable branches.
16:23:43 <elod> or what to do to avoid breakages?
16:23:45 <smcginnis> So, I guess I'm fine just sticking to what we've done and address issues if and when we run into them.
16:24:21 <elod> i'm ok with that, too
16:24:25 <smcginnis> We could just try to process library releases first, then give it a bit before we process the services.
16:24:43 <smcginnis> So not separate deadlines, but just kind of some caution built into our release processing.
16:25:12 <elod> separate mails/pad?
16:25:45 <smcginnis> Maybe in your post to the ML, just suggest teams focus on wrapping up their libraries first if there is any concern about changes?
16:26:09 <elod> sounds good to me
16:27:14 <smcginnis> Great, thanks for taking that part on elod. Hopefully things get more streamlined for doing these transitions.
16:27:36 <elod> no problem :)
16:27:36 <smcginnis> Anything else concerning EM transition from anyone?
16:28:20 <smcginnis> Good. We have some time for anything that comes up too.
16:28:23 <smcginnis> #topic tempest 23.0.0 release-failures
16:28:25 <armstrong> what is EM?
16:28:35 <smcginnis> armstrong: Extended maintenance.
16:28:36 <tonyb> armstrong: Extemed Maintenance
16:28:38 <elod> Extended Maintenance
16:28:42 <armstrong> ok thx
16:28:51 <smcginnis> So basically we used to end of life older branches, but now we let them stick around a little longer.
16:28:57 <smcginnis> We just don't do official releases anymore.
16:29:06 <smcginnis> Who added this topic?
16:29:27 <smcginnis> I guess I can just recap.
16:29:45 <smcginnis> We had a propose-update-constraints job failure yesterday due to an issue on one of the gitea servers.
16:30:19 <smcginnis> Not thinking, we reenqueued the job, but that didn't work since everything is triggered by the tagging job passing, which failed since that was already done successfully the first time around.
16:30:33 <smcginnis> So I ended up just manually running the script to propose the update.
16:30:53 <smcginnis> That was really the only thing that was missed, so everything should be good now.
16:31:45 <smcginnis> Was there anything more to discuss about that?
16:32:38 <tonyb> smcginnis: loooks like not?
16:33:02 <smcginnis> I guess not. :D
16:33:06 <smcginnis> #topic Open discussion
16:33:20 <smcginnis> Anything else to talk about today? Or should we get back to work?
16:33:35 <smcginnis> Or evening relaxation for tonyb. ;)
16:33:45 <diablo_rojo> Its so fun when we have more than just, smcginnis, ttx and I :)
16:34:04 <smcginnis> Or not even evening now. 3:30 in the morning for you, right tonyb?
16:34:13 <tonyb> 1734
16:34:13 <smcginnis> WTH are you doing here! :D
16:34:20 <smcginnis> Oh, travelling?
16:34:23 <tonyb> otherwise known as beer o'clock
16:34:34 <smcginnis> Then we should really let you get going.
16:34:44 <tonyb> smcginnis: I'm in the Czech republic
16:34:54 <smcginnis> Nice! I'd like to get there some day.
16:35:03 <smcginnis> OK, I think we can wrap up then.
16:35:05 <smcginnis> Thanks everyone!
16:35:07 <tonyb> smcginnis: We shoudl talk
16:35:09 <diablo_rojo> Thanks smcginnis!
16:35:15 <elod> tonyb: than you are quite close!
16:35:19 <armstrong> thanks
16:35:20 <tonyb> there's a conference that we need more OpenStack at ;P
16:35:21 <smcginnis> #endmeeting