14:01:14 <elodilles> #startmeeting releaseteam
14:01:14 <opendevmeet> Meeting started Fri Nov 19 14:01:14 2021 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:14 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:14 <opendevmeet> The meeting name has been set to 'releaseteam'
14:01:16 <ttx> o/
14:01:22 <hberaud> o/
14:01:23 <elodilles> hi o/
14:01:30 <elodilles> #link https://etherpad.opendev.org/p/yoga-relmgt-tracking
14:01:46 <elodilles> we are at line 73
14:02:20 <elodilles> let's start with the 1st topic
14:02:25 <elodilles> #topic Review task completion
14:02:43 <elodilles> #info Ensure that all trailing projects have been branched for the previous series
14:02:49 <elodilles> that was on me
14:03:05 <elodilles> I've proposed the patches, I hope i did it right
14:03:14 <elodilles> #link https://review.opendev.org/q/topic:trailing-xena
14:03:19 <elodilles> these are the patches ^^^
14:04:12 <ttx> IIRC our deadline is pretty fuzzy on those, at least the patches will start the discussion
14:04:43 <hberaud> +1
14:04:49 <elodilles> yes, the trailing delivery deadline is December 16th
14:05:11 <elodilles> so we are one month ahead of that
14:05:58 <elodilles> ok, if nothing else for this then i'll continue with the next task
14:06:37 <elodilles> #info Propose autoreleases for cycle-with-intermediary libraries which did not release since the previous release
14:07:15 <elodilles> i've generated the patches a bit late for this, instead of beginning of week, i created those yesterday afternoon
14:07:31 <elodilles> #link https://review.opendev.org/q/topic:yoga-milestone-1
14:08:00 <ttx> ok so we might give them a bit more time before force-approving those without -1
14:08:23 <ttx> (in theory we would have done that now)
14:08:32 <ttx> (and give those with -1 a few extra days)
14:08:38 <elodilles> note: there were quite many that were listed as not released yet, but either didn't have any change at all or just CI/tests/branch setup releated patches were merged
14:08:54 <ttx> yeah those can be ignored
14:09:12 <hberaud> the automaton patch can be abandonned
14:09:18 <hberaud> I left a comment
14:09:18 <elodilles> ttx: yes, thanks, let's give some time until the force-approve
14:09:40 <hberaud> https://review.opendev.org/c/openstack/releases/+/818403
14:09:55 <elodilles> hberaud: looking
14:11:10 <elodilles> hberaud: thanks, abandoned!
14:11:15 <hberaud> ty
14:12:58 <elodilles> do we want to agree on a force-approval deadline, like Tuesday, or something?
14:13:32 <ttx> I'd say approve all without -1s by Tuesday, then finalize those with -1s by end of week
14:13:35 <hberaud> Wednesday, seems more appropriate
14:13:50 <hberaud> or the end of week
14:13:52 <ttx> I don;t want to delay too much
14:14:07 <ttx> basically push by two business days
14:14:08 <hberaud> wfm
14:14:16 <elodilles> ok
14:15:07 <elodilles> #agreed yoga-milestone-1 patches: approve all without -1s by Tuesday, then finalize those with -1s by end of week
14:15:39 <elodilles> ok, next topic
14:15:48 <elodilles> #info To catch if there are acl issues in newly created repositories
14:15:58 <elodilles> ttx: this was yours
14:16:10 <ttx> yep, the script revealed one gap
14:16:20 <ttx> https://review.opendev.org/c/openstack/project-config/+/818356 (tap-as-a-service)
14:16:56 <ttx> (basically the idea is to make sure releases go through openstack/releases, so remove direct tagging rights
14:17:02 <ttx> )
14:17:21 <ttx> nothing more to say
14:17:32 <elodilles> #link https://review.opendev.org/c/openstack/project-config/+/818356
14:17:39 <elodilles> ttx: cool, thanks!
14:17:58 <elodilles> for the explanation, too
14:18:45 <elodilles> ok. the countdown email is not yet ready, as I'll send it after the meeting and when we are there :)
14:18:50 <elodilles> so next topic
14:18:55 <fungi> on a related note, was there ever a formal conclusion as to whether the release team can handle sigs' repos?
14:18:57 <elodilles> #topic Assign R-18 tasks
14:20:04 <elodilles> fungi: i don't know. hberaud , ttx , do you remember such?
14:20:14 <hberaud> nope
14:20:47 <ttx> We only do openstack release
14:20:56 <ttx> i.e. deliverables from project teams
14:21:09 <ttx> that's they key difference between project teams and sigs
14:21:32 <hberaud> Agreed with ttx
14:21:40 <ttx> so we tend to explictly stay away from SIG repos
14:21:56 <fungi> okay, i recall it came up on the ml last week, i thought it was ansible-collections-openstack but might have been somthing else
14:21:58 <ttx> that's why QA is still a project team
14:22:41 <ttx> (and with release management the onlt horizontal team left)
14:22:59 <ttx> it's because their repos are handled by us as part of "the release"
14:23:12 <fungi> oh, i see where i got confused
14:23:20 <ttx> (+ requirements)
14:23:38 <fungi> elodilles posted on openstack-discuss about a release job failure for ansible-collections-openstack but that was one they tagged themselves i guess
14:23:52 <ttx> (I tried to clean things up over the years and I think we finally got there)
14:24:20 <ttx> yes release jobs failure can be triggered by openstack/releases or direct tags :)
14:25:02 <elodilles> yes, and since it was not familiar to me i rather forwarded it to ML o:)
14:25:02 <fungi> yeah, he mis-attributed it to the ansible team in the e-mail, but that was it
14:25:32 <fungi> i thought maybe it was one which had been handled via openstack/releases but looks like it wasn't
14:25:51 <fungi> confusion cleared, thanks
14:26:05 <ttx> the only way to be sure bnothing falls into the cracks is really to have a finite, defined list of things we handle
14:26:25 <ttx> otherwise you're just never sure
14:26:26 <fungi> yes, i agree
14:26:42 <elodilles> yepp, that's for sure
14:26:48 <ttx> it's been tricky enough to compile that list (see release-management key in projects.yaml)
14:27:00 <ttx> there were exceptions all over the map :)
14:27:20 <ttx> but we are pretty good now... just need to periodically check all data is aligned
14:27:28 <ttx> like that ACL check we did this week
14:27:50 <fungi> makes sense, that's what reminded me
14:28:57 <elodilles> ok, so, next topic: assigning R-18 tasks
14:29:03 <elodilles> there is only 1 task
14:29:23 <elodilles> i guess this could be "all", right? o:)
14:29:32 <hberaud> yes
14:29:34 <elodilles> "Review any remaining milestone-1 exceptions"
14:30:20 <elodilles> added "all" to that then. thanks
14:30:41 <elodilles> next topic:
14:30:49 <elodilles> #topic Review countdown email contents
14:30:59 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:31:25 <elodilles> i've added and edited the mail ^^^
14:31:51 <elodilles> there is one thing: we don't have release cycle goal (page)
14:32:16 <ttx> It's hard to say we are past Yoga-1
14:32:17 <elodilles> so I'll remove that if you confirm that is OK
14:32:29 <ttx> I'd wait until next week to send this one
14:32:48 <ttx> Like wait until we process things on tuesday
14:32:49 <elodilles> ttx: hmm, yes, since the shifted deadline to Tuesday
14:33:17 <elodilles> ttx: that works for me
14:33:22 <hberaud> WFM
14:33:27 <ttx> otherwise looks good!
14:33:33 <elodilles> ok, thanks
14:33:39 <hberaud> +1
14:34:18 <elodilles> #action to elod: Send countdown mail on Tuesday, after Yoga-1 milestone patches have been merged
14:34:39 <elodilles> (hope i remember correctly for the keywords :))
14:34:47 <elodilles> anyway
14:34:51 <elodilles> next topic then
14:35:23 <elodilles> #topic     Branches without releases https://review.opendev.org/c/openstack/releases/+/818445
14:35:51 <ttx> yeah I was wondering about that one
14:36:14 <ttx> I think we only branch on release points, on purpose
14:37:02 <elodilles> openstack-ansible-roles have similar branching, i mean, without any release,
14:37:13 <elodilles> just the hashes, set as location
14:37:36 <ttx> the error looks more like a bug than a validation rule failure
14:37:45 <ttx> latest_release = deliv.releases[-1]
14:37:48 <ttx> IndexError: list index out of range
14:38:07 <hberaud> the openstack-ansible-role is tagless
14:38:17 <hberaud> https://opendev.org/openstack/releases/src/branch/master/deliverables/wallaby/openstack-ansible-roles.yaml#L3
14:38:27 <elodilles> hberaud: you are right
14:38:46 <hberaud> the tripleo-docs is a cwi deliverable
14:38:59 <hberaud> this is why it complain with it
14:39:34 <hberaud> I don't think this is possible to branch without releasing something
14:40:07 <hberaud> (in the tripleo-docs context)
14:40:26 <ttx> at the very minimum we should catch that case because currently the script just errors out
14:40:50 <hberaud> indeed
14:40:57 <ttx> but yes, the error matches
14:41:11 <ttx> "stable branches must be created from the latest tagged release..."
14:41:25 <ttx> here the script errors out trying to grab the latest release
14:41:34 <ttx> but there is none
14:42:04 <ttx> If it was tagless it would pass
14:42:14 <hberaud> yes
14:42:28 <ttx> or "upstream"
14:42:32 <elodilles> on the other hand do we want to allow this late branch cutting (for wallaby, in this case)?
14:42:46 <hberaud> it can't hurt
14:42:55 <elodilles> ok
14:43:07 <ttx> ok, who replies?
14:43:12 <hberaud> this is a trailing deliverable
14:43:20 <hberaud> this is why we missed to branch it
14:43:50 <elodilles> i see
14:44:06 <hberaud> it went under our radar
14:45:21 <elodilles> ok, so I can comment on the patch that this requires a release as well. <- is this OK?
14:45:36 <ttx> wfm
14:46:11 <hberaud> wfm
14:47:50 <elodilles> good. and another thing is the validation, it could be fixed with some clear error message then, i guess
14:49:11 <elodilles> i'll try to look into it. of course, if someone has an idea for how to fix, then please propose a patch for that :)
14:49:48 <elodilles> ok, next topic
14:49:54 <elodilles> #topic Proposing skipping meeting next week (just need to make sure we process all yoga-1)
14:50:40 <ttx> I won;t be around anyway, but there is also no task the week after
14:50:54 <hberaud> wfm
14:50:57 <ttx> trick is we still need to doublecheck that all yoga-1 is handled
14:51:23 <elodilles> yes, I mean, now we'll have the yoga-milestone-1 patches, but that can be handled without the meeting :)
14:52:12 <ttx> ++
14:52:33 <elodilles> ok
14:54:08 <elodilles> i've added a note to meeting agenda after (skip + make sure everything is good with yoga-milestone-1)
14:54:20 <elodilles> s/after//
14:54:35 <elodilles> last topic:
14:54:39 <elodilles> #topic Open Discussion
14:55:13 <elodilles> anything to mention? anyone?
14:55:37 <ttx> nope
14:56:03 <fungi> nothing here
14:57:13 <elodilles> okay, then thanks everyone, let's close the meeting
14:57:22 <elodilles> #endmeeting