14:01:01 <elodilles> #startmeeting releaseteam
14:01:01 <opendevmeet> Meeting started Fri Dec 10 14:01:01 2021 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:01 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:01 <opendevmeet> The meeting name has been set to 'releaseteam'
14:01:11 <elodilles> Ping list: hberaud ttx armstrong
14:01:13 <hberaud> o/
14:01:14 <armstrong> o/
14:01:28 <elodilles> \o/
14:01:59 <hberaud> the time flies...
14:02:22 <hberaud> it's already 3pm
14:02:29 <elodilles> ttx will be late a few mins as he mentioned an ~hour ago
14:02:36 <hberaud> no problem
14:02:49 <elodilles> hberaud: well, and december :) almost yoga-milestone-2 :)
14:02:55 <hberaud> I was just thinking it was 1 or 2pm
14:02:57 <hberaud> :)
14:03:00 <elodilles> :
14:03:01 <elodilles> :]
14:03:09 <elodilles> #link https://etherpad.opendev.org/p/yoga-relmgt-tracking
14:03:12 <hberaud> yeah
14:03:27 <elodilles> so we are at line 116
14:04:16 <elodilles> #topic Review task completion
14:04:28 <elodilles> so the only task was:
14:04:44 <elodilles> Prepare Xena cycle trailing, deadline is next week
14:04:59 <elodilles> I've sent the reminder mail ( http://lists.openstack.org/pipermail/openstack-discuss/2021-December/026194.html )
14:05:25 <elodilles> and actually we didn't need to propose another patches
14:05:53 <elodilles> as the former trailing-xena branch cut patches (with releases) were still open:
14:06:03 <hberaud> yep
14:06:05 <elodilles> https://review.opendev.org/q/topic:trailing-xena
14:07:06 <elodilles> and next week is the deadline for trailing-xena releases, if i'm not mistaken
14:07:37 <hberaud> yes
14:07:45 <hberaud> the 16
14:08:05 <elodilles> so these should be merged next week until 16th of December
14:08:14 <hberaud> yes
14:08:33 <elodilles> anything to add here?
14:08:37 <hberaud> nope
14:08:47 <elodilles> cool, thanks
14:09:00 <hberaud> yw
14:09:03 <elodilles> then next topic
14:09:11 <elodilles> #topic Skipping next 3 meetings?
14:09:18 <hberaud> +1
14:09:45 <hberaud> Anyway I won't be online between the 20 and the 3 of january
14:09:50 <elodilles> since that will be holiday period i think this is fair
14:10:02 <ttx> o/
14:10:06 <hberaud> o/
14:10:20 <ttx> yeah I think if we assign tasks in advance we should be fine
14:10:21 <elodilles> I'll be also on PTO, but will read mails and check patches time to time
14:10:24 <elodilles> ttx: o/
14:11:13 <elodilles> ok, I see no objections
14:12:06 <fungi> i'll still be around if there are problems, feel free to reach out
14:12:18 <elodilles> #agreed Skip meetings for week R-15, R-14 and R-13
14:13:04 <elodilles> fungi: good, thanks! be careful what you offer, we might need your help :)
14:13:14 <hberaud> :)
14:14:08 <elodilles> #info next meeting is R-12, 7th of January
14:14:25 <elodilles> #topic Assign R-15 and R-13/R-12 tasks
14:14:53 <elodilles> next week task is:
14:15:01 <elodilles> Review any remaining trailing project exceptions
14:15:21 <elodilles> i've added 'all' to it, hope it's not a problem o:)
14:15:32 <hberaud> :thumbsup:
14:16:09 <elodilles> then the next one is from tasks of week R-13
14:16:18 <elodilles> Ahead of MembershipFreeze, run governance_consistency.py
14:16:33 <elodilles> oh, i see ttx added himself there \o/
14:16:36 <elodilles> thanks
14:16:53 <ttx> all covered now
14:17:20 <elodilles> sweet, thanks to all \o/
14:17:24 <hberaud> hm
14:17:37 <hberaud> Where are the task for milestone 2?
14:17:46 <hberaud> s/tasks
14:18:07 <elodilles> hberaud: do we miss something?
14:18:11 <ttx> they have been trimmed a bit
14:18:14 <hberaud> let me check
14:18:15 <ttx> but they are there
14:18:49 <hberaud> No it's ok sorry
14:18:54 <hberaud> ttx is right
14:19:02 <elodilles> i see only those: https://releases.openstack.org/reference/process.html#milestone-2
14:19:19 <ttx> 1 2 3 match, the description in truncated
14:19:24 <ttx> is*
14:19:24 <hberaud> I was thinking that more tasks were there
14:19:32 <hberaud> yes
14:19:57 <opendevreview> Pierre Riteau proposed openstack/releases master: Release cloudkitty 13.0.1 for victoria  https://review.opendev.org/c/openstack/releases/+/821410
14:20:06 <hberaud> my bad
14:20:11 <ttx> we all should refer to the process doc instead
14:20:14 <elodilles> maybe "subtask" were added separately in the past?
14:20:28 <ttx> no, probably just a copypaste error
14:20:37 <hberaud> I was expecting more primary tasks
14:20:55 <opendevreview> Pierre Riteau proposed openstack/releases master: Release cloudkitty 14.0.1 for wallaby  https://review.opendev.org/c/openstack/releases/+/821411
14:21:40 <elodilles> should i add any task to the tracking pad?
14:21:46 <hberaud> no it's ok
14:22:04 <hberaud> until the root task is there it's ok
14:22:27 <hberaud> s/until/while/
14:23:12 <elodilles> hberaud: ok, cool. of course if it's more that you volunteered for, then I can take over things
14:23:22 <elodilles> just let me know
14:24:10 <elodilles> anything else regarding this topic?
14:24:17 <hberaud> I think it's ok and you are on PTO monday and tuesday so let us help you :)
14:24:43 <hberaud> nope
14:24:57 <elodilles> hberaud: ack :)
14:26:05 <elodilles> #topic Review week R-13's countdown email content (could be done at R-13 week meeting?)
14:26:21 <elodilles> well, let's review it now since we agreed to skip R-13 o:)
14:27:17 <elodilles> but R-12's mail can be reviewed in 1st week of January
14:27:27 <elodilles> on the meeting
14:27:55 <elodilles> for now, please review:
14:28:05 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:30:45 <ttx> that "Changes proposing those deliverables for inclusion in Yoga have been
14:30:47 <ttx> posted
14:30:55 <ttx> " part assumes there are governance inconsistencies
14:31:17 <ttx> but I guess people can ignore it
14:32:26 <ttx> I updated the wording so that it works in all cases
14:32:49 <ttx> LGTM now :)
14:32:50 <elodilles> I see, thanks!
14:32:59 <hberaud> LGTM
14:33:09 <ttx> Also added a happy new year
14:33:16 <elodilles> I'll send it 30th or 31st of December :)
14:33:19 <ttx> it's my non-robot side
14:33:26 <elodilles> ttx: :D
14:33:35 <elodilles> even better :]
14:33:38 <fungi> even robots can be cheerful
14:33:55 <elodilles> indeed :)
14:34:08 <ttx> there must be a gif for that
14:34:37 <elodilles> * for everything :]
14:34:41 <ttx> https://giphy.com/gifs/HannahtheSpanner-robot-dance-dancing-approximating-happiness-1pA2SJ1g6amgbDSFdZ
14:35:20 <elodilles> :)
14:36:00 <hberaud> hopefully it won't be to much happy
14:36:18 <fungi> more like ol' bob from the black hole
14:37:19 <hberaud> lol
14:37:36 <elodilles> :)
14:37:44 <elodilles> ok, i guess we can go to the last topic
14:37:51 <elodilles> #topic Open Discussion
14:39:19 <fungi> we seem to have recently acquired an inefficiency in updating zuul's persistent configuration state on project branch creation
14:40:23 <fungi> it's not particularly noticeable on one or a handful of new branch events, but when all of openstackansible got new branches added earlier this week, or when starlingx added a new branch to all of their repos yesterday, it left the ci system running basically no jobs for a few hours
14:40:58 <fungi> it shouldn't act that way of course, and it's on our radar, just wanted to give you a heads up
14:41:07 <hberaud> ack
14:41:41 <elodilles> yeah, i noticed that, and suspected that openstack-ansible's branch creation has to do something with it
14:41:54 <fungi> and if you're about to merge a change which adds lots of new branches, maybe give us a heads up
14:42:15 <fungi> hopefully we'll have it fixed soon
14:42:25 <elodilles> fungi: ack, thanks for the info, we'll try to remember that
14:43:06 <elodilles> though i guess we are not expecting now any other 'mass branch creation' patch
14:43:34 <fungi> probably not until rc time, but just in case
14:43:51 <elodilles> yepp, thanks, noted!
14:45:28 <elodilles> #action in case a change which adds lots of new branches is about to merge -> give heads up to infra team
14:45:36 <elodilles> and added here as well ^^^
14:46:11 <fungi> thanks
14:46:24 <elodilles> fungi: ++
14:46:38 <elodilles> anything else?
14:47:27 <hberaud> branch creation will start at R-6
14:47:41 <hberaud> s/branches
14:48:07 <hberaud> so 3-4 weeks before RC
14:48:44 <hberaud> else nope nothing on my end
14:49:09 <elodilles> hberaud: yes, around rc1 patches, right?
14:49:37 <hberaud> nope around final library rlease deadline
14:49:49 <fungi> oh, branching for libs
14:49:52 <elodilles> oh, i see, sorry
14:49:56 <hberaud> np
14:50:00 <fungi> yeah, i didn't think about that
14:50:10 <fungi> well, hopefully it'll be fixed by then anyway
14:50:33 <hberaud> it will happen in 10 weeks
14:50:51 <hberaud> so we are a bit large
14:50:56 <elodilles> ok, i'll search for that in the tracking page and maybe add a note there
14:51:56 <elodilles> okay, if there's nothing else, then let's close the meeting
14:52:15 <elodilles> thanks everyone for joining! o/
14:52:24 <elodilles> #endmeeting