14:00:25 <elodilles> #startmeeting releaseteam
14:00:25 <opendevmeet> Meeting started Fri Jan  7 14:00:25 2022 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:25 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:25 <opendevmeet> The meeting name has been set to 'releaseteam'
14:00:36 <hberaud> o/
14:00:36 <elodilles> Ping list: hberaud ttx armstrong
14:00:41 <elodilles> o/
14:01:02 <elodilles> #link https://etherpad.opendev.org/p/yoga-relmgt-tracking
14:01:14 <elodilles> we are at line 167
14:01:45 <ttx> o/
14:02:09 <elodilles> Happy New Year to everyone! \o/
14:02:50 <elodilles> let's start then with the 1st topic
14:03:02 <elodilles> #topic Review task completion (including week before)
14:03:19 <elodilles> the 1st task is from R-13:
14:03:34 <elodilles> *     Ahead of MembershipFreeze, run governance_consistency.py (ttx)
14:03:59 <ttx> yes so that yielded a bunch of deliverables that were never released
14:04:31 <ttx> we need to reach out to teams to know if they intend to make it part of Yoga
14:05:08 <ttx> re: barbican-ui that one have been pushed back for a while
14:05:24 <ttx> I won;t have much time to do the outreach though
14:05:36 <elodilles> ttx: i can do that
14:05:38 <ttx> so it would be good to assign that task next week
14:05:42 <ttx> elodilles: ++
14:06:08 <elodilles> i guess it is a mail to ML, right?
14:07:15 <ttx> I would go personal, but you decide :)
14:07:23 <ttx> or both
14:07:47 <elodilles> OK, sure, thanks for adding it to the tasks list :)
14:08:15 <elodilles> i've added my name to it
14:08:50 <ttx> the idea being we should finalize the list of deliverables for Yoga
14:09:13 <ttx> (normally that should have been done this week but that's not super important)
14:09:30 <elodilles> yes, that sounds reasonable
14:10:12 <elodilles> ok, i guess we can go to the next topic
14:10:25 <elodilles> i mean
14:10:28 <elodilles> task
14:10:30 <ttx> ++
14:10:50 <elodilles> Generate a list of all cycle-with-intermediary libraries which did not release since the 2021-11-17 date of milestone-1
14:11:19 <elodilles> hberaud: generated the patches:
14:11:26 <elodilles> https://review.opendev.org/q/topic:%22yoga-milestone-2%22
14:12:08 <elodilles> half of them have merged already
14:12:23 <ttx> Just approved one. still missing PTL approval for last 3
14:12:33 <elodilles> and we should merge the rest ASAP
14:12:37 <ttx> probably a no-brainer to push then though
14:12:38 <hberaud> I don't think we will get response from keystone|heat|tacker
14:12:59 <hberaud> those always missing usually
14:13:02 <elodilles> even force-merge then, right?
14:13:17 <ttx> yes.. no -1 by Friday, we should proceed
14:13:25 <hberaud> those are always missing usually
14:13:27 <ttx> I can approve them now if you're all ok
14:13:34 <elodilles> i've reviewed those, LGTM, +2'd them, but waited for a second review
14:13:41 <hberaud> +1
14:14:16 <elodilles> ttx: thanks in advance!
14:14:58 <ttx> so that leaves no exception (-1)
14:15:09 <ttx> one less task
14:15:11 <elodilles> yes
14:15:14 <elodilles> one less task
14:15:17 <elodilles> exactly :)
14:16:15 <elodilles> cool. next task then:
14:16:31 <elodilles> * To catch if there are acl issues in newly created repositories
14:16:51 <elodilles> ttx this was yours
14:17:10 <elodilles> "Skyline needs an update but that should be done after the repo is moved to openstack namespace"
14:17:21 <ttx> yeah
14:17:31 <ttx> We need to adjust the ACL there to block direct releases
14:17:43 <ttx> but that should wait until it's under openstack/ namespace
14:18:01 <ttx> which should happen during the next Gerrit rename window
14:18:13 <elodilles> is there some planned date for that?
14:18:16 <ttx> i don;t want to conflict with anythign going on there
14:18:24 <ttx> maybe fungi has a vague idea ^
14:18:28 <elodilles> are you aware of that?
14:19:07 <fungi> mmm
14:19:13 <ttx> It's not super urgent for us anyway since they won;t do an official release anytime soon
14:19:19 <ttx> like.. not for Yoga for sure
14:19:33 <ttx> they need to work on a lot of things to make it more openstacky first
14:19:38 <fungi> there was no opendev meeting this week due to winter holidays wrapping up
14:19:49 <ttx> I doubt it could be released by one of our release jobs right now
14:19:57 <fungi> was planning to discuss renames at this coming tuesday's meeting
14:20:15 <ttx> sometimes this month is a safe bet?
14:20:28 <fungi> probably, or very early february
14:20:36 <fungi> but this month is likely
14:20:40 <ttx> "in the coming month"
14:20:49 <elodilles> let's aim for february
14:21:11 <elodilles> i'll add a 'reminder task' somewhere for this
14:21:11 <ttx> maybe drop a note so that we remember to do it
14:21:13 <ttx> ++
14:21:16 <fungi> and yeah, there's no way just pushing a tag for skyline repos would result in any releaseable artifacts right now anyway. our release jobs wouldn't work with their packaging and layout
14:23:31 <elodilles> added a note for R-7's tasks list
14:24:36 <elodilles> #agreed Skyline needs an update but that should be done after the repo is moved to openstack namespace - get back to this in R-7
14:25:01 <ttx> ++
14:25:05 <elodilles> ok, this was the last task for now
14:25:09 <elodilles> next topic
14:25:19 <elodilles> #topic Assign R-11 tasks
14:25:42 <elodilles> no Yoga-2 exceptions as we mentioned already
14:26:19 <elodilles> and I've added my name to the two remaining tasks:
14:26:43 <elodilles> * never-released deliverables (discussed earlier)
14:26:56 <elodilles> * Plan the next release cycle schedule
14:27:10 <elodilles> for the latter I might need some help, but we will see
14:27:17 <opendevreview> Merged openstack/releases master: Yoga-2 Release for python-ironicclient  https://review.opendev.org/c/openstack/releases/+/823342
14:27:19 <opendevreview> Merged openstack/releases master: Yoga-2 Release for python-tackerclient  https://review.opendev.org/c/openstack/releases/+/823344
14:27:21 <opendevreview> Merged openstack/releases master: Yoga-2 Release for python-keystoneclient  https://review.opendev.org/c/openstack/releases/+/823343
14:27:23 <opendevreview> Merged openstack/releases master: Yoga-2 Release for python-heatclient  https://review.opendev.org/c/openstack/releases/+/823341
14:28:25 <elodilles> move on to the next topic then
14:28:35 <elodilles> #topic Review countdown email contents
14:28:47 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:29:27 <elodilles> i've prepared it, please double-check the dates and anything that i might missed ^^^
14:30:07 <ttx> hmm
14:30:22 <ttx> one of those dates seems off
14:30:27 <ttx> Non-client library freeze: February 10th, 2022 (R-6 week)
14:30:29 <ttx> Client library freeze: February 24th, 2022 (R-5 week)
14:30:39 <ttx> more than 7 days between R-5 and R-6
14:31:02 <elodilles> hmm
14:31:15 <ttx> Should be Feb 17 and Feb 24
14:31:48 <elodilles> i might have mistaken it with Oslo Feature Freeze date
14:31:52 <hberaud> indeed
14:33:21 <hberaud> concerning the final RC deadline I added "the week of"
14:33:31 <hberaud> instead of a specific day
14:33:51 <elodilles> hberaud: sounds good, thanks!
14:34:03 <hberaud> IIRC RC2 could be requested during all the week
14:34:38 <elodilles> that was not clear for me
14:34:53 <hberaud> else LGTM
14:35:00 <elodilles> hberaud: ++
14:35:19 <ttx> well the final RC deadline is the 21st, but they can ask for final all week before
14:35:41 <ttx> Final = March 25th even
14:35:57 <ttx> I mean, Final RC deadline is end of the week so March 25th
14:36:13 <elodilles> yes, 21st is Monday
14:37:05 <hberaud> ok
14:37:19 <ttx> if we say deadline, should be 25th
14:37:43 <elodilles> don't we usually put the deadlines to Thursdays? i mean, Final RC date is March 24th then, but maybe it's just bikeshedding now o:)
14:38:02 <ttx> well the schedule says:
14:38:12 <ttx> "The week of 21st-25th March, 2022 is the last week to issue release candidates or intermediary releases before release week. "
14:38:20 <ttx> so it accepts 25th RCs
14:38:32 <ttx> https://releases.openstack.org/yoga/schedule.html#y-finalrc
14:38:41 <elodilles> i can also accept that :)
14:38:56 <ttx> not very important
14:39:41 <ttx> LGTM!
14:40:10 <elodilles> thanks everyone! this had a lot of dates to check!
14:40:28 <elodilles> I'll send it after the meeting
14:40:35 <elodilles> move on to the last topic
14:40:43 <elodilles> #topic Open Discussion
14:41:20 <elodilles> anyone? anything to discuss?
14:41:25 <hberaud> not on my end
14:41:27 <ttx> not much
14:41:41 <ttx> stay safe!
14:41:50 <hberaud> you too!
14:42:13 <elodilles> indeed, stay safe
14:42:52 <elodilles> ok, if nothing else to discuss,
14:42:59 <elodilles> then let's end the meeting
14:43:10 <elodilles> thanks again everyone for joining!
14:43:12 <hberaud> elodilles: thank you
14:43:24 <elodilles> #endmeeting