14:00:52 <elodilles> #startmeeting releaseteam
14:00:52 <opendevmeet> Meeting started Fri Feb 11 14:00:52 2022 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:52 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:52 <opendevmeet> The meeting name has been set to 'releaseteam'
14:01:00 <hberaud> o/
14:01:05 <elodilles> Ping list: hberaud ttx armstrong
14:01:09 <armstrong> O/
14:01:20 <elodilles> #link https://etherpad.opendev.org/p/yoga-relmgt-tracking
14:01:32 <elodilles> hello everyone \o/
14:01:36 <elodilles> let's see where we are
14:01:38 <armstrong> Hello
14:01:56 <elodilles> we are @ line 249
14:02:04 <elodilles> waaaay down
14:03:20 <damani> hi
14:03:24 <elodilles> hi o/
14:03:27 <elodilles> cool, let's start
14:03:30 <diablo_rojo_phone> o/
14:03:38 <elodilles> #topic Review task completion
14:03:42 <damani> sorry i forgot to put my name i will do it now
14:03:49 <elodilles> damani: np :)
14:04:17 <elodilles> so the 1st task:
14:04:20 <elodilles> Review Skyline ACL settings (from R-12 week's task outcome) (ttx)
14:05:13 <elodilles> ttx: you mentioned last meeting that it is actually OK already, right?
14:05:13 <ttx> yes, that was done
14:05:23 <ttx> It was already ok, no change needed
14:05:28 <elodilles> awesome
14:05:41 <elodilles> Notify the Infrastructure team to generate an artifact signing key (but not replace the current one yet), and begin the attestation process. (diablo_rojo)
14:06:05 <fungi> she did
14:06:11 <diablo_rojo_phone> I did!
14:06:14 <elodilles> :]
14:06:19 <fungi> i hope to take care of it in the next week or so, but there's plenty of time
14:06:23 <elodilles> thanks for that!
14:06:24 <fungi> thanks diablo_rojo_phone!
14:06:33 <elodilles> both of you :)
14:07:11 <elodilles> the next 2 tasks seems to dependent on the release naming,
14:07:12 <diablo_rojo_phone> fungi: you'll be doing the hard part lol
14:07:24 <fungi> it's all cut-n-paste anyway ;)
14:07:31 <elodilles> which will happen hopefully next week
14:08:16 <elodilles> so i guess we can track these next week
14:08:42 <hberaud> it could be worth to repeat these tasks in our agenda
14:08:43 <elodilles> i'll add them to the tasks of next week
14:08:51 <hberaud> elodilles++
14:09:05 <fungi> yeah, the last one was as well, now that i think about it
14:09:16 <fungi> i can't properly label the new signing key without a cycle name
14:09:17 <elodilles> yepp
14:09:37 <elodilles> ohh, so that too
14:10:21 <fungi> reminder to the tc to pick names more than one release ahead in the future
14:10:29 <elodilles> :)
14:11:00 <fungi> in debian, the release team gets to pick release names. solves this particular deadlock ;)
14:11:22 <elodilles> fungi do you want me to add a reminder for the signing key task as well in our agenda?
14:11:44 <fungi> elodilles: no need, i'll just set myself a reminder to do it as soon as we have a name to put on it
14:11:51 <elodilles> fungi: ack :)
14:12:14 <elodilles> then let's go to the next topic
14:12:25 <elodilles> #topic Assign R-6  week tasks
14:13:34 <elodilles> hberaud damani : can i keep your names on the 1st task?
14:13:53 <damani> elodilles, yes sure
14:13:58 <hberaud> sur
14:14:00 <hberaud> sure
14:14:06 <elodilles> good, thanks!
14:14:29 <elodilles> i'll take care of the other moved task that was mine already
14:14:42 <damani> i will check with them when they have determined the name and update the document
14:14:55 <elodilles> damani: +1
14:14:57 <elodilles> so one is still open:
14:15:12 <elodilles> Propose autoreleases for cycle-with-intermediary libraries (excluding client libraries) which had commits that have not been included in a release.
14:15:13 <damani> elodilles, do you need help with something else ?
14:15:30 <damani> i can help you with other tasks if you need
14:16:03 <elodilles> damani: can you take maybe the autoreleases?
14:16:21 <damani> elodilles, ok
14:16:23 <ttx> I prefer not to take anything since I won;t be around to report on those or followup
14:16:37 <elodilles> ttx: sure, no problem
14:16:44 <damani> elodilles, just can give me a bit more information and i take it :)
14:16:52 <elodilles> damani: let me know if you need help
14:17:28 <damani> elodilles, ok
14:17:36 <elodilles> damani: the task has details in the rekease process page,
14:17:56 <damani> elodilles, yes i will check sorry
14:18:08 <elodilles> so i can help you with that :)
14:18:46 <elodilles> and as always, i'll take care about the countdown email
14:19:13 <elodilles> so we are done with the task assignments
14:19:22 <elodilles> next topic
14:19:31 <elodilles> #topic Review countdown email contents
14:19:41 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:20:06 <elodilles> please review if everything is correct ^^^
14:21:06 <damani> elodilles, seems good
14:21:09 <ttx> lgtm
14:21:24 <elodilles> \o/
14:21:55 <elodilles> next topic then
14:22:02 <elodilles> #topic PTL Nomination period (ends 15th February)
14:22:27 <elodilles> i was surprised that we are at this period already
14:22:44 <damani> :)
14:23:01 <hberaud> lol
14:23:08 <ttx> time flies!
14:23:21 <ttx> Means you are ready for another term.
14:23:52 <elodilles> anyway, i'm happy to continue, though i don't know yet how stressful the time will be around the release deadline
14:23:53 <damani> ttx, i think he have no choice actually :)
14:24:04 <hberaud> elodilles president!
14:24:10 <elodilles> :)
14:24:29 <hberaud> elodilles: we will be around to help you
14:24:56 <elodilles> thanks, hberaud that really helps a lot :)
14:25:38 <elodilles> anyway, just wanted to note this, who knows, maybe some of you want to be PTL as well ;)
14:25:49 <elodilles> let's move on then
14:26:06 <elodilles> #topic Release cadence adjustment proposed
14:26:21 <elodilles> yesterday TC had a video conf regarding this,
14:26:59 <elodilles> and we have a proposal for resolution: https://review.opendev.org/c/openstack/governance/+/828777
14:27:21 <elodilles> basically as I understand it doesn't impact us really
14:27:38 <elodilles> 6 months release cycle remains
14:27:46 <ttx> It does affect how fast or slow we drop branches
14:27:54 <ttx> but otherwise should be fine
14:28:44 <elodilles> as i understand the 18 months is there in general, but every second (tick) release will be longer maintained (24 months)
14:29:12 <elodilles> 18 months in 'maintained'
14:29:31 <fungi> yeah, from the examples we discussed, the oldest branch in a maintained state will always be between 12 and 24 months old
14:30:03 <elodilles> fungi: ++
14:30:08 <fungi> it can be as little as 12 right after a "tick" release, because we drop maintenance for the "tock" release following any "tick" which leaves maintenance
14:30:25 <fungi> so the oldest maintained branch will always be a "tick"
14:30:56 <fungi> and we'll plan to always have precisely two "tick" branches under maintenance
14:31:16 <fungi> (as well as the "tock" branches which follow them)
14:31:21 <elodilles> yepp
14:31:39 <ttx> rolling over to A should have more impact
14:31:50 <elodilles> ttx: that's right
14:31:55 <ttx> we still need to make progress on reviewing the code and see how much it will be affected
14:32:10 <fungi> i guess one way to look at it is that we'll switch to moving two branches out of maintenance at a time, once yearly, instead of just one at a time every 6 months
14:32:53 <diablo_rojo_phone> Thats an interesting shift
14:33:11 <elodilles> fungi: yepp
14:33:15 <fungi> the other bit of complexity is that it has implications for what upgrade test jobs we'll run for which branches
14:33:45 <elodilles> for what ttx mentioned:
14:34:06 <fungi> "tick" branches will test tick->tock and tick->tick upgrades, while tock branches will only test tock->tick upgrades
14:34:12 <elodilles> #action review alphabet rollover impact at https://etherpad.opendev.org/p/relmgt-alphabet-rollover-impact
14:34:43 <elodilles> (i need to remind myself as well to review the scripts in the list)
14:35:17 <elodilles> fungi: yes, that is another important point
14:36:35 <armstrong> Do we need to run any test on the tool?
14:36:35 <elodilles> so if anyone have time for reviewing the scripts for alphabet rollover impact, that would be awesome ^^^
14:38:50 <elodilles> armstrong: i don't think we have specific tests for that, but probably some can be tested locally beyond reviews
14:39:04 <armstrong> Ok
14:39:05 <elodilles> ttx hberaud : correct me if i'm wrong
14:39:52 <hberaud> I don't think (AFAIK)
14:40:10 <hberaud> I'll have check next week
14:40:45 <elodilles> hberaud: ++
14:41:23 <elodilles> anything else regarding either of the tick-tock release cadence or the alphabet rollover?
14:42:22 <hberaud> nope
14:42:39 <armstrong> Not from me
14:42:46 <elodilles> ok, then last topic
14:42:50 <elodilles> #topic Open Discussion
14:43:13 <elodilles> if there is something we missed in the agenda...
14:43:22 <hberaud> nothing on my end
14:43:42 <damani> nothing on my side
14:44:14 <elodilles> okay, then let's wrap up the meeting!
14:44:24 <elodilles> thanks everyone for joining!
14:44:25 <hberaud> thank you elodilles
14:44:30 <elodilles> #endmeeting