14:00:26 <elodilles> #startmeeting releaseteam
14:00:26 <opendevmeet> Meeting started Fri Feb 18 14:00:26 2022 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:26 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:26 <opendevmeet> The meeting name has been set to 'releaseteam'
14:00:34 <elodilles> Ping list: hberaud ttx armstrong damani
14:00:36 <armstrong> o/
14:00:50 <elodilles> #link https://etherpad.opendev.org/p/yoga-relmgt-tracking
14:01:06 <elodilles> o/
14:01:40 <elodilles> we are at line 270
14:05:04 <elodilles> hmm. we have a bit less number of participants so far, that i've expected
14:05:37 <fungi> i'm around, just very quiet
14:05:45 <elodilles> fungi: o/
14:05:56 <elodilles> ok, let's start
14:06:14 <elodilles> #topic Review task completion
14:06:31 <elodilles> 1st task: "Check with the Technical Committee to make sure Python runtimes have been determined for the next development cycle and that Zuul job templates have been created to include those runtimes."
14:06:45 <elodilles> it was on hberaud and damani
14:07:07 <elodilles> so I'll check with them later
14:07:15 <fungi> i haven't seen any changes proposed for zen python runtimes
14:07:42 <elodilles> you mean Zed :)
14:07:47 <elodilles> but yes :)
14:07:49 <fungi> zero
14:07:56 <elodilles> :]
14:07:58 <fungi> and yoga is definitely the last listed on the pti page
14:08:54 <elodilles> anyway, i'll add it to next week tasks again
14:09:01 <elodilles> just to not forget about this
14:09:27 <elodilles> next task:
14:09:35 <elodilles> "Follow-up task: Make sure the next development series name has been added to the data/series_status.yaml file (elod)"
14:10:07 <elodilles> i've added to the proposed schedule patch: https://review.opendev.org/c/openstack/releases/+/824489/5/
14:10:48 <elodilles> i wanted to ask whether we can merge this, but let's wait with this question till next week
14:11:32 <elodilles> #action Review and merge if possible: https://review.opendev.org/c/openstack/releases/+/824489/5/
14:11:42 <elodilles> next task then:
14:11:54 <elodilles> "Propose autoreleases for cycle-with-intermediary libraries (excluding client libraries) which had commits that have not been included in a release. (damani, elod)"
14:12:19 <elodilles> we did that with damani, patches are here: https://review.opendev.org/q/topic:yoga-final-non-client-libs
14:12:59 <elodilles> most of the patches have been merged,
14:13:17 <elodilles> there are some -1's,
14:13:42 <elodilles> and some open patches without responses
14:13:57 <elodilles> since deadline is today, i'll merge them after the meeting
14:14:22 <elodilles> except the ones with -1
14:14:59 <armstrong> what about those without PTL approve?
14:15:15 <elodilles> armstrong: we need to force merge them
14:15:27 <elodilles> as it is stated in the commit message
14:16:23 <armstrong> ok
14:16:35 <elodilles> we are done with this weeks tasks
14:16:54 <elodilles> #topic Assign R-5 week tasks
14:19:29 <elodilles> I'll add my name to the tasks, but feel free to add yours as well if you can do some of them
14:20:50 <armstrong> ok
14:21:02 <elodilles> thanks, let's move on
14:21:07 <armstrong> I will add my name beside yours
14:21:19 <elodilles> armstrong: ++
14:21:36 <elodilles> #topic Review countdown email contents
14:22:09 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:22:39 <elodilles> please review, and let me know if you've found any mistake ^^^
14:29:17 <armstrong> the email LGTM!
14:29:30 <elodilles> thanks armstrong o/
14:29:32 <elodilles> :)
14:29:41 <elodilles> let's go to the next topic then
14:29:48 <elodilles> #topic Removing TC tags framework
14:29:57 <elodilles> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-February/thread.html#27214
14:30:02 <armstrong> so we just have one week from the  RC deadline to final release?
14:30:42 <elodilles> armstrong: exactly. 1 week only.
14:30:52 <elodilles> i mean
14:31:09 <armstrong> ok thanks elodilles
14:31:21 <elodilles> RC1 deadline: March 10th, 2022
14:31:30 <elodilles> Final RC deadline: March 24th, 2022
14:31:42 <elodilles> then 1 week: Final Yoga release:  March 30th, 2022
14:31:54 <fungi> yeah, there's more than one "rc deadline" so don't get confused
14:32:10 <elodilles> yepp
14:32:33 <elodilles> so, about the topic:
14:32:45 <fungi> the rc1 deadline is the date by which projects need an rc1 tag, the final rc deadline is the last date projects are allowed to request subsequent rc tags after rc1
14:33:32 <elodilles> if they need another. yes. :)
14:34:49 <elodilles> so, about the tag removal: as the linked mail shows TC decided to get rid of the repo tags
14:35:04 <elodilles> like stable:follows-policy, and others
14:35:33 <elodilles> in our code we use ^^^ tag (to show some banner)
14:36:35 <elodilles> ttx said and I wrote too (to the mailing list) that we can drop this
14:37:25 <elodilles> I've propesed a small patch already (but got the comment that we need further cleanups as repo.tags are used other places as well)
14:38:42 <elodilles> I don't see any problem with that, but wanted to double check with the team, whether anyone sees any problem we could face by removing the tags
14:39:40 <elodilles> hberaud ttx : ping me if something comes to your mind that could be problem for us with this ^^^
14:40:53 <elodilles> i'll update the proposed patch, or rather create a follow up patch, and we will see
14:41:21 <elodilles> i think that it about this topic
14:41:23 <fungi> i'm doing similar removal work for the vulnerability:managed tag, and will be following up with the foundation webdev folks about any changes needed to the software lists on the www site
14:41:46 <fungi> right now some of those governance tags result in specific things being included in the project list
14:44:28 <elodilles> to tell you the truth i don't know all the tags and where they are used. I've seen that project pages there are things triggered by the tags, but that's all :)
14:45:21 <elodilles> #topic Open Discussion
14:45:52 <elodilles> anything to mention here?
14:46:44 <fungi> i've got the zed cycle artifact signing key generated, should have a change pushed shortly to record what it will be
14:47:03 <fungi> but obviously we won't put it into use by the jobs until after yoga is done
14:47:19 <elodilles> fungi: thanks for the info!
14:47:23 <fungi> this is just to get the attestation process for the new key bootstrapped
14:47:43 <elodilles> anything regarding that, that we could help with?
14:49:01 <fungi> reviewing the change once it's up, sure
14:49:10 <fungi> that'll be the next step anyway
14:49:50 <elodilles> just add me as reviewer and I'll review it! :) thanks!
14:49:56 <fungi> you bet
14:50:14 <elodilles> :]
14:50:49 <elodilles> any other topic?
14:51:11 <fungi> nothing from me
14:51:14 <armstrong> nothing from me
14:51:37 <elodilles> OK, thanks, then lets finish the meeting!
14:51:47 <fungi> thanks elodilles!
14:51:49 <elodilles> thanks fungi and armstrong for joining! o/
14:51:54 <armstrong> thanks
14:52:08 <elodilles> #endmeeting