14:00:52 <elodilles> #startmeeting releaseteam
14:00:52 <opendevmeet> Meeting started Fri Feb 25 14:00:52 2022 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:52 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:52 <opendevmeet> The meeting name has been set to 'releaseteam'
14:00:57 <hberaud> o/
14:01:05 <elodilles> Ping list: hberaud ttx armstrong damani
14:01:09 <armstrong> o/
14:01:18 <elodilles> #link https://etherpad.opendev.org/p/yoga-relmgt-tracking
14:01:32 <diablo_rojo_phone> o/
14:01:43 <elodilles> we are at line 288
14:01:51 <elodilles> hello everyone \o/
14:03:10 <hberaud> elodilles: sorry for last week I missed to mark me as in PTO in our agenda
14:03:38 <elodilles> hberaud: no problem :)
14:04:17 <elodilles> let's start as we have a long list for tasks :)
14:04:38 <elodilles> #topic Review task completion
14:04:44 <elodilles> 1st task:
14:04:54 <elodilles> "Check with the Technical Committee to make sure Python runtimes have been determined for the next development cycle and that Zuul job templates have been created to include those runtimes. (hberaud|damani)"
14:05:18 <fungi> looks like it's under discussion finally
14:05:43 <hberaud> so yes the patch have been proposed
14:05:55 <hberaud> https://review.opendev.org/c/openstack/governance/+/830454
14:06:20 <elodilles> nice, then we are on track i guess
14:06:23 <fungi> i have a feeling continued delays for rhel 9 and the new annual upgrades plan will impact the outcome there
14:06:40 <hberaud> ack
14:06:44 <elodilles> :S
14:07:39 <elodilles> do we want to add some follow up task for this, or is it enough that we have the patch?
14:08:07 <hberaud> can't hurt
14:08:19 <hberaud> I think the patch is enough
14:08:54 <hberaud> but we are near from the final so I'd suggest to simply keep an eye on this point
14:09:05 <elodilles> ok, thanks, i'll try to keep an eye on the patch then :)
14:09:06 <hberaud> to ensure that everything is aligned
14:09:14 <elodilles> agreed :)
14:09:23 <elodilles> next task:
14:09:32 <elodilles> "Process any remaining library freeze exception (elod/all)"
14:09:44 <elodilles> actually there were no exceptions
14:09:47 <elodilles> (so far?)
14:10:05 <hberaud> the openstacksdk patch is merged/closed?
14:10:15 <hberaud> the one with the comment
14:10:46 * elodilles searching for the patch
14:10:46 <hberaud> (that said that openstacksdk won't release much things within Y)
14:11:09 <elodilles> well, that is open. they have a release already,
14:11:29 <elodilles> but after that a significant amount of patches has landed
14:11:32 <hberaud> so then I think we can close it, isn't?
14:11:39 <hberaud> ok
14:12:04 <elodilles> you mean this one:
14:12:05 <elodilles> https://review.opendev.org/c/openstack/releases/+/829081
14:12:12 * hberaud looks
14:12:19 <elodilles> no answer from Artem
14:12:22 <hberaud> yes
14:12:38 <elodilles> to me it was a bit strange to have that amount of patches unreleased
14:12:59 <hberaud> yes
14:13:39 <elodilles> (especially because as far as i know openstacksdk does its development on feature branches, so why did they merge the feature branch then if they don't want to release it?)
14:13:54 <hberaud> no idea
14:14:20 <hberaud> what's their irc channel?
14:14:27 <hberaud> #openstack-?
14:14:46 <fungi> #openstack-sdks
14:14:51 <diablo_rojo_phone> SDKs
14:14:54 <diablo_rojo_phone> Yep
14:14:58 <hberaud> openstack-sdks
14:15:00 <hberaud> ues
14:15:42 <hberaud> Artem is not connected
14:15:44 <diablo_rojo_phone> They don't normally do feature braches. This was a particularly complicated and large and far teaching piece of work
14:15:51 <diablo_rojo_phone> gtema?
14:15:54 <hberaud> yes
14:16:29 <diablo_rojo_phone> Ah yep.
14:16:56 <diablo_rojo_phone> He's in Germany so he should still be online but perhaps he's on vacation or something
14:17:20 <hberaud> ok
14:17:27 <elodilles> diablo_rojo_phone: thanks for the info :-o
14:17:34 <hberaud> elodilles and I leave a comment on their channel
14:17:37 <elodilles> hberaud + me just pinged them on irc
14:17:38 <elodilles> :D
14:17:40 <elodilles> :)
14:17:48 <hberaud> let's wait for their feedback
14:17:56 <elodilles> yepp
14:18:20 <elodilles> thanks hberaud for reminding me to this patch!
14:18:22 <hberaud> without response next week I'd suggest to send an email
14:18:33 <hberaud> np
14:18:45 <elodilles> hberaud: ack, good idea!
14:18:59 <hberaud> elodilles: gtema just replied
14:19:09 <hberaud> (on their channel)
14:21:05 <fungi> #openstack-sdks
14:21:16 <fungi> er, wrong buffer recall, sorry!
14:21:39 <elodilles> (i also hate that when that happen: wrong buffer ;))
14:22:04 <elodilles> so Artem still holds the original comment ("no changes can be release at the moment. Yoga will will stay at current version")
14:22:30 <elodilles> i've just abandoned the patch
14:22:40 <hberaud> WFM
14:22:46 <elodilles> so the next task:
14:23:07 <elodilles> "Propose autoreleases (process_auto_releases) for cycle-with-intermediary client libraries which had commits that have not been included in a release."
14:23:25 <elodilles> the patches: https://review.opendev.org/q/topic:yoga-milestone-3
14:23:54 <elodilles> some remained without review from PTL/release liaison
14:24:10 <hberaud> I don't think we have to wait for those patches
14:24:18 <elodilles> i'll force-approve those after the meeting
14:24:28 <hberaud> ack
14:24:30 <hberaud> WFM
14:24:34 <elodilles> ++
14:25:13 <elodilles> so i think we are good with that task
14:25:29 <elodilles> "Evaluate any libraries that did not have any change merged over the cycle to see if it is time to transition them to the independent release model."
14:26:09 <elodilles> i've run the script that showed some of the not-yet-morged patches from the above yoga-milestone-3 group
14:26:20 <elodilles> and two other deliverables:
14:26:31 <elodilles> keystoneauth and kuryr
14:26:47 <elodilles> we missed these two last week :S
14:26:59 <elodilles> so I'll propose patches for them after the meeting
14:27:00 <hberaud> I don't think we want to move keyestone to the independent model
14:27:56 <elodilles> hmmm, sorry, i was wrong,
14:28:09 <elodilles> these have not been released actually,
14:28:12 <hberaud> Concerning kuryr, why not, however I think this is a collegial decision
14:28:15 <elodilles> but they have some patches
14:28:18 <hberaud> ok
14:28:57 <elodilles> just wanted to mention that we forgot to release them
14:29:45 <diablo_rojo_phone> Oh okay
14:29:57 <elodilles> i caught them during running the scripts for the task
14:30:21 <hberaud> concerning those from the M3 patches, those deliverables are strongly coupled with services so I'd suggest to keep them aligned under the same release model
14:31:18 <hberaud> its not too late to release them
14:31:30 <hberaud> (keystone and kuryr)
14:31:36 <elodilles> hberaud: ack
14:32:30 <elodilles> on the other hand i think i need further look at releases, because there were some without real/significant commits
14:32:51 <elodilles> so i'm planning to do some follow up here
14:33:02 <hberaud> ok
14:33:16 <elodilles> and maybe we can discuss them next week's meeting
14:33:47 <hberaud> ok
14:33:50 <elodilles> #action elod to evaluate released libraries without significant content
14:34:01 <elodilles> added a reminder to myself ^^^ :)
14:34:05 <elodilles> anyway
14:34:08 <elodilles> next task
14:34:46 <elodilles> "List cycle-with-intermediary deliverables that have not been released yet"
14:35:06 <elodilles> this was done by armstrong , see mail: http://lists.openstack.org/pipermail/openstack-discuss/2022-February/027379.html
14:35:12 <elodilles> thanks armstrong !
14:35:36 <armstrong> NP
14:35:46 <elodilles> and if I'm not mistaken all but one deliverables got release patches
14:36:07 <elodilles> patrole is still missing
14:36:44 <elodilles> i'll ping QA team and we will see
14:37:33 <elodilles> next task
14:37:41 <elodilles> "On Friday, remind the requirements team to freeze changes to openstack/requirements by applying -2 to all open patches."
14:37:50 <elodilles> prometheanfire: ^^^ o:)
14:38:16 <elodilles> hberaud: do we have any other TODO with this? o:)
14:38:43 <hberaud> to be vigilant :)
14:39:03 <fungi> i did suggest in #openstack-sdks that they consider switching to the independent release model since they don't seem to be releasing and freezing along with other libraries
14:39:05 <elodilles> as always ;)
14:39:31 <elodilles> fungi: oh, good idea :-o
14:39:37 <hberaud> usually during the two last series I was checking daily the requirements patches
14:39:40 <elodilles> fungi: thanks for proposing that
14:39:54 <hberaud> indeed good idea
14:40:17 <elodilles> hberaud: ack
14:40:26 <hberaud> so maybe I need to reconcider my POV concerning keystone
14:41:18 <elodilles> hberaud: do you see something there with keystone? :-o
14:41:47 <hberaud> yes... inactivity
14:41:53 <elodilles> :S
14:42:19 <hberaud> and so maybe a good candidate for the independent model
14:42:42 <elodilles> then I'll propose a release model changing patch there and we can discuss it there
14:42:47 <hberaud> however keystone is strongly coupled with series IIUC
14:42:58 <hberaud> ok
14:43:08 <hberaud> that's a good start
14:43:14 <elodilles> thanks for noting!
14:43:19 <elodilles> last task
14:43:31 <fungi> it's possible we'll see this more and more if service projects approach a "feature complete" state and don't really have something to add in a particular cycle
14:43:32 <elodilles> Sorry, that was our last task :)
14:43:43 <hberaud> yes
14:43:51 <elodilles> fungi: yepp, i agree
14:44:25 <fungi> hopefully we can get to a point where low levels of activity in a deliverable imply that it's stable, does what it's meant to, and has few remaining bugs
14:44:29 <elodilles> fungi: on the other hand we might need some discussion around that (maybe on PTG?) because not all teams are fond of 'independent' release model changes
14:44:37 <elodilles> as far as I remember...
14:45:08 <elodilles> fungi: ++
14:45:49 <elodilles> i'll add this topic to our 'things to change' maybe after the meeting
14:45:57 <fungi> we've gotten so used to constant churn in projects, that we can forget that's only one phase of a software's development
14:46:21 <elodilles> yeah, probably that's true
14:46:33 <diablo_rojo_phone> It's true. There comes a time where there's actual stability.
14:46:50 <diablo_rojo_phone> More or less feature complete and sans bugs
14:47:11 <elodilles> diablo_rojo_phone: ++
14:47:19 <elodilles> anyway, let's move on as we are running out of time :)
14:47:28 <elodilles> #topic Assign R-4 week tasks
14:48:00 <elodilles> please add your names to the tasks if you'll be around and can take them
14:48:32 <hberaud> I'm on PTO all the next week so I'll be totally disconnected and without laptop
14:48:39 <elodilles> hberaud: thanks, noted!
14:49:14 <hberaud> so... I won't volunteer
14:49:17 <elodilles> :)
14:49:33 <elodilles> understandably :)
14:50:13 <elodilles> all taken, next topic
14:50:16 <diablo_rojo_phone> Lol
14:50:20 <hberaud> however next week is a quiet week
14:50:46 <elodilles> yeah, after feature freeze it should be ;)
14:50:47 <elodilles> #topic Review countdown email contents
14:51:09 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:51:42 <elodilles> i've filled the template, please review ^^^
14:52:56 <hberaud> LGTM
14:53:10 <elodilles> ack, thanks!
14:53:18 <armstrong> LGTM too
14:53:23 <elodilles> armstrong: ++
14:53:28 <prometheanfire> elodilles: guess it's that time again?
14:53:43 <elodilles> prometheanfire: yes, it is, indeed :)
14:54:34 <elodilles> prometheanfire: let me know if I can help with something
14:56:01 <elodilles> i've added another topic to the agenda, it's more like some review heads-up:
14:56:19 <elodilles> #topic "Release identification and release naming" proposal: https://review.opendev.org/c/openstack/governance/+/829563
14:56:25 <prometheanfire> elodilles: https://review.opendev.org/829599 is gonna be the main thing to deal with
14:57:49 <elodilles> prometheanfire: ack, added myself to the patch so that i won't forget it :)
14:58:23 <fungi> it would probably be good to ask for clarification on 829563 as to what expectations they have for the release managers
14:59:08 <elodilles> regarding the identification / name proposal: I've seen that Thierry and Sean already reviewed it, thanks! so feel free to review it. I'm planneng to read it through thoroughly by myself as well
14:59:10 <fungi> because as it's written now, it just boils down to "we can also refer to the release by a year.number" (which doesn't imply any actual alterations to tooling or processes)
15:00:02 <fungi> i expect at a minimum the implication is that the releases site would additionally show the "release number"
15:00:11 <elodilles> fungi: name + number, if i'm not mistaken, but have to read it carefully
15:00:12 <fungi> but that's reading between the lines
15:00:23 <fungi> yes, name and number, hence my use of "also"
15:00:36 <elodilles> fungi: ack
15:00:50 <elodilles> so, please review if you have time :)
15:00:59 <fungi> it doesn't actually say that the release team/site needs to stop using the cycle name as the primary indicator though
15:01:05 <elodilles> last quick topic then
15:01:15 <elodilles> #topic Open Discussion
15:01:25 <elodilles> I see that rosmaita has added one
15:01:34 <elodilles> "any resolution to https://review.opendev.org/c/openstack/releases/+/829590/3/deliverables/wallaby/os-brick.yaml#30 ?"
15:02:11 <elodilles> actually I had a comment on it that the patch is a bit like exception from stable-policy perspective
15:02:26 <rosmaita> we are open to suggestions about better docs to accompany the backport
15:02:27 <elodilles> i hoped that smcginnis would comment on it o:)
15:02:39 <rosmaita> (assuming that you don't outright decide that we need to revert it)
15:02:40 <elodilles> though i know he is just very rarely around
15:03:36 <rosmaita> i don't know that there's a big rush, though things will only get busier over the next few weeks
15:03:40 <elodilles> rosmaita: i just wanted to call your attention that the patch is not fitting for stable policy (but maybe i am wrong)
15:04:04 <elodilles> rosmaita: sure, the sooner we get reviews, the better
15:04:26 <rosmaita> elodilles: yes, i understand your point, but it's kind of a bad bug for people who hit it
15:05:07 <fungi> what's the impact to people who aren't hitting that bug upgrading to the new point release without paying close attention to the release notes?
15:05:08 <elodilles> rosmaita: ack, I'm open to accept it, especially if the team agrees
15:06:10 <rosmaita> fungi: i am not 100% sure ... i thought it was not a big deal, but in discussion the other day, it may be problematic
15:06:19 <rosmaita> guess i need to get a definite answer
15:07:27 <rosmaita> i'd still like to get sean's opinion; in the meantime, i will follow up with the cinder team about operator impact
15:07:29 <fungi> yeah, it seems like a question of whether the impact of the bug is overall worse than the impact of operators assuming stable point releases don't require configuration changes
15:08:05 <elodilles> rosmaita: thanks, that sounds like a good way forward!
15:08:08 <rosmaita> i'll take an action item to get some details to leave on the patch
15:08:15 <rosmaita> thanks!
15:08:19 <elodilles> rosmaita: thanks too!
15:08:27 <elodilles> we are overtime
15:08:34 <elodilles> so if no objection
15:08:43 <elodilles> then let's close the meeting now
15:08:48 <hberaud> np
15:08:51 <elodilles> 3
15:08:51 <elodilles> 2
15:08:53 <elodilles> 1
15:08:53 <diablo_rojo_phone> Fine by me
15:08:57 <elodilles> #endmeeting