14:00:16 <elodilles> #startmeeting releaseteam
14:00:16 <opendevmeet> Meeting started Fri Mar 18 14:00:16 2022 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:16 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:16 <opendevmeet> The meeting name has been set to 'releaseteam'
14:00:23 <elodilles> Ping list: hberaud ttx armstrong damani
14:00:28 <armstrong> o/
14:00:31 <damani> hi
14:00:33 <elodilles> #link https://etherpad.opendev.org/p/yoga-relmgt-tracking
14:01:07 <elodilles> we are @ line 356
14:01:20 <elodilles> hi o/
14:05:08 <elodilles> okay, let's start with the 1st topic
14:05:25 <elodilles> #topic Process any standing RC1 deadline exceptions
14:05:35 <elodilles> we had one exception
14:05:46 <elodilles> cinder: https://review.opendev.org/c/openstack/releases/+/832367
14:06:14 <elodilles> and it was merged on Monday
14:06:20 <elodilles> so we are good with this \o/
14:07:43 <elodilles> (and i messed up the topic title...)
14:07:51 <elodilles> #topic Review task completion
14:07:57 <elodilles> this is the right topic
14:08:08 <elodilles> and the 1st task was 'Process any standing RC1 deadline exceptions'
14:08:25 <elodilles> and as I said, we are good with it \o/
14:08:38 <elodilles> next task was
14:08:53 <opendevreview> Hervé Beraud proposed openstack/releases master: Creating stable yoga for bifrost  https://review.opendev.org/c/openstack/releases/+/833602
14:08:54 <opendevreview> Hervé Beraud proposed openstack/releases master: release bifrost 13.1.0  https://review.opendev.org/c/openstack/releases/+/834316
14:08:57 <elodilles> "Gracefully release tempest plugins with latest changes available"
14:09:25 <elodilles> hberaud proposed the patches: https://review.opendev.org/q/topic:yoga-tp-latest
14:09:39 <hberaud> o/
14:09:48 <hberaud> oh sorry I missed the ping
14:10:31 <elodilles> no problem :) we are just at your 1st task :)
14:10:45 <elodilles> as i see half of them has merged
14:11:29 <elodilles> we have some -1s otherwise the rest is without review among the open patches,
14:11:57 <elodilles> so we should review and froce-merge the ones without review after the meeting
14:12:10 <elodilles> hberaud: anything else for this?
14:12:40 <opendevreview> Hervé Beraud proposed openstack/releases master: Creating stable yoga for ironic-inspector  https://review.opendev.org/c/openstack/releases/+/833607
14:12:41 <opendevreview> Hervé Beraud proposed openstack/releases master: release ironic-inspector 10.11.0  https://review.opendev.org/c/openstack/releases/+/834317
14:13:08 <hberaud> iurygregory: ^ (bifrost and ironic-inspector)
14:13:17 <hberaud> elodilles: so sorry
14:13:30 <iurygregory> hberaud, ack o/
14:13:37 <hberaud> iurygregory asked us to release those deliverbales again before cutting Y
14:14:06 <hberaud> ^ they are cwi deliverables without UC entries so let's go
14:14:18 <iurygregory> yeah =)
14:14:40 <hberaud> Else we can force the ones without responses
14:14:40 <elodilles> hberaud: ack, thanks!
14:14:53 <iurygregory> we should also be good with ipa-builder, ironic and ironic-python-agent we will probably release till Wed next week
14:15:49 <elodilles> iurygregory just as a reminder: March 24th is the deadline for final Yoga release candidates
14:16:15 <fungi> (thursday!)
14:16:21 <elodilles> yepp
14:16:24 <iurygregory> elodilles, yup that's why I'm saying next wed XD
14:16:58 <elodilles> and we should not cut requirements' stable/yoga until all the other stable/yoga branches have been cut
14:17:16 <iurygregory> hberaud, quick question any reason why the release + creation of stable/yoga can't be in the same patch?
14:17:40 <hberaud> good question
14:17:43 <hberaud> nope
14:17:53 <iurygregory> I thought it would be only one patch XD
14:17:59 <iurygregory> +1 on them
14:18:14 <hberaud> I prefered to split them without strong arguments :)
14:18:47 <elodilles> so iurygregory , it would be good to cut stable/yoga for the rest of the ironic projects as soon as possible
14:18:47 <iurygregory> no worries =)
14:19:19 <elodilles> speaking of that, next task:
14:19:29 <iurygregory> elodilles, ack ironic-python-agent-builder I added some comments to the patch https://review.opendev.org/c/openstack/releases/+/833609
14:19:40 <elodilles> "On the Monday, generate stable branches for all cycle deliverables that are still missing one. (hberaud)"
14:20:07 <iurygregory> ironic-python-agent I'm checking if CI is ok now (before cutting the release)
14:20:12 <elodilles> iurygregory: ack
14:20:19 <hberaud> elodilles: ah sorry I inverted the topics, the comments above are related to this task
14:21:00 <opendevreview> Tim Burke proposed openstack/releases master: Swift 2.29.1 release and cut branch for Yoga  https://review.opendev.org/c/openstack/releases/+/834319
14:21:22 <hberaud> So concerning the tempest task, I don't have much things to add
14:22:27 <elodilles> hberaud: so you mean that the still open patches without response, from these: https://review.opendev.org/q/topic:yoga-missing-stable-branches , can be also force merged, right?
14:23:06 <hberaud> yes
14:23:25 <elodilles> and as I see it's valid only for the swift patch for now :)
14:24:32 <hberaud> indeed
14:25:39 <elodilles> OK, then we will add ironic deliverables as 'remaining stable branching exception' for next week's task list then
14:25:49 <hberaud> +1
14:26:17 <elodilles> cool, next task
14:26:43 <elodilles> 'After all the projects enabled in devstack by default have been branched, we can engage with the QA, I18n and Requirements PTLs to finalize the stable branch setup'
14:26:46 <elodilles> this was on me
14:27:13 <elodilles> and prerequisite is to have all project branched
14:27:37 <hberaud> (my laptop lag)
14:28:07 <elodilles> yepp, mine too, no worries :D
14:28:38 <elodilles> so actually, with this, we have the same situation :)
14:28:57 <elodilles> I'll need to follow up this next week :)
14:29:21 <elodilles> requirements yoga branch cut should be merged last (and updated before)
14:29:36 <elodilles> (this one: https://review.opendev.org/c/openstack/releases/+/833610 )
14:29:53 <elodilles> next task
14:30:05 <elodilles> 'Ensure that all projects that are publishing release notes have the notes link included in their deliverable file.'
14:30:36 <elodilles> we have proposed so far 3 patches:
14:30:39 <elodilles> https://review.opendev.org/c/openstack/releases/+/834178
14:30:46 <elodilles> https://review.opendev.org/c/openstack/releases/+/834268
14:30:52 <elodilles> https://review.opendev.org/c/openstack/releases/+/834283
14:31:05 <elodilles> i think these can be merged ^^^
14:32:15 <fungi> priteau spotted a release notes race earlier with cloudkitty-dashboard... looks like if you approve two changes on different branches at the same moment and one of them is the patch which creates the release notes for the new branch, you have a ~50% chance of "unpublishing" that file until the next time a release notes build is promoted
14:33:13 <fungi> but more generally, merging things on different branches which alter release notes can race and end up publishing in the "wrong" order
14:33:35 <elodilles> oh, sounds interesting
14:34:13 <fungi> ideally we can work out a solution to that, but i have a feeling it's related to how the release notes jobs always operate on the master branch even though they can be triggered from changes on any branch
14:35:05 <elodilles> but that doesn't affect our 3 patches as they are all changing things on master branch, right?
14:35:28 <opendevreview> Merged openstack/releases master: Release manila-tempest-plugin for Yoga  https://review.opendev.org/c/openstack/releases/+/833582
14:36:37 <fungi> right, in this case the problem was that the yoga release notes addition change on master got approved at the same time as the constraints file bump patch for the stable/yoga branch (both autogenerated changes)
14:37:07 <elodilles> I see, thanks
14:37:13 <fungi> they both built release notes, but the stable/yoga constraints bump built release notes without the yoga file
14:37:36 <elodilles> fungi: ack, thanks for the info!
14:37:43 <fungi> and since it was promoted second, it removed the yoga release notes from the site until a new release notes change landed weeks later
14:37:56 <elodilles> :S
14:38:53 <elodilles> good to remember to this then
14:39:17 <elodilles> and let's hope we won't see this kind of issue
14:39:33 <elodilles> thanks again for the info
14:39:40 <fungi> well, at least if we see it again we know a likely place to look for the explanation
14:39:47 <elodilles> yepp
14:41:34 <elodilles> so back to the task, we still have missing release notes pages due to some generated patches are not yet merged: https://review.opendev.org/q/topic:reno-yoga+is:open
14:41:55 <elodilles> but most of the release note links are already there
14:42:14 <elodilles> i'll do follow up on this task, too
14:43:08 <elodilles> #action elod to check release notes links and push patch if necessary
14:43:43 <elodilles> next task was a general task:
14:43:47 <elodilles> 'Let cycle-with-rc projects iterate on RCs as needed'
14:44:05 <elodilles> I think there is nothing to add here now
14:44:40 <elodilles> we should continue to do this, until next week's final rc deadline at least :)
14:45:03 <hberaud> yes
14:45:12 <elodilles> I had one more task, which is related to Extended Maintenance:
14:45:18 <elodilles> 'Send an email to inform teams that Victoria will be switched to EM in one month (2022-04-27)'
14:45:41 <hberaud> the ironic patches falls in this case
14:46:17 <elodilles> hberaud: yepp, for example ironic :)
14:46:18 <hberaud> too
14:47:23 <elodilles> about the EM task: this is not done yet, i'll prepare the usual mail and generated etherpads with unreleased content hopefully today some time
14:47:35 <hberaud> ack
14:47:44 <elodilles> and we are done with the task review for this week
14:47:52 <elodilles> anything else to add here?
14:47:55 <hberaud> nope
14:48:16 <elodilles> then next topic
14:48:21 <elodilles> #topic Assign R-1 week tasks
14:48:38 <elodilles> actually I've added my name to all of the tasks,
14:49:11 <elodilles> but feel free to join if you want to help with any of the tasks
14:49:24 <hberaud> I can help you if you want
14:49:26 <elodilles> or simply just help with reviewing the release patches :)
14:49:30 <damani> elodilles, i can help with something
14:49:33 <damani> if you need
14:49:55 <elodilles> damani hberaud : feel free to pick a task :)
14:50:00 <hberaud> done
14:50:07 <elodilles> and thanks in advance!
14:50:59 <elodilles> or you can even ping me during the week and we can share tasks maybe
14:51:42 <elodilles> cool, let's continue with the next topic:
14:51:46 <damani> elodilles, yes i will ping you
14:51:52 <elodilles> #topic Review countdown email contents
14:51:56 <elodilles> damani: ++
14:52:10 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:52:41 <elodilles> please review ^^^
14:53:27 <armstrong> the email LGTM!
14:53:38 <hberaud> LGTM
14:54:07 <elodilles> cool, thx, will send after the meeting!
14:54:30 <elodilles> last topic then
14:54:35 <elodilles> #topic Open Discussion
14:55:29 <elodilles> maybe one thing here to mention
14:55:58 <elodilles> we have the PTG page already ( https://ptg.opendev.org )
14:56:17 <hberaud> ack
14:56:23 <elodilles> and our PTG etherpad is linked: https://etherpad.opendev.org/p/april2022-ptg-rel-mgt
14:56:36 <elodilles> but it is empty so far :)
14:56:52 <elodilles> i'll update with the pad draft
14:57:00 <elodilles> feel free to add there topics
14:58:59 <elodilles> (i've created the 'topic' section right now, but will update the whole page soon :))
14:59:17 <elodilles> so it's there, please add topics if you have any
14:59:28 <elodilles> anything else before we reach the end of the meeting?
15:00:02 <hberaud> nope
15:00:20 <elodilles> #info Etherpad is open for RelMgmt PTG session: https://etherpad.opendev.org/p/april2022-ptg-rel-mgt
15:00:34 <elodilles> good, then thanks everyone for participating!
15:00:45 <elodilles> see you next week!
15:00:49 <elodilles> #endmeeting