14:01:06 <elodilles> #startmeeting releaseteam
14:01:06 <opendevmeet> Meeting started Fri Jul 22 14:01:06 2022 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:06 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:06 <opendevmeet> The meeting name has been set to 'releaseteam'
14:01:10 <elodilles> Ping list: armstrong ttx hberaud diablo_rojo_phone
14:01:22 <elodilles> #link https://etherpad.opendev.org/p/zed-relmgt-tracking
14:01:51 <elodilles> we are a bit further down than the middle @ line 228
14:04:51 <elodilles> hmm, folks are on summer vacation as it seems :)
14:05:08 <fungi> sounds like a good idea ;)
14:05:28 <elodilles> let's run through the agenda to have some logs about the tasks
14:05:55 <elodilles> fungi: yepp, indeed, i was planning it myself, too, but was lazy to do that, so here i am :D
14:06:24 <elodilles> maybe i'll take some days off next week :]
14:06:32 <elodilles> anyway, let's start
14:06:32 <fungi> i know what you mean. i've been forgetting to take time off ever since this pandemic started (and even before, i'm sure)
14:06:45 <elodilles> :S
14:06:53 <elodilles> exactly like that...
14:07:09 <elodilles> #topic Review task completion
14:07:27 <elodilles> 1st task: '    Review any remaining milestone-2 exceptions (all)'
14:07:34 <elodilles> all the remaining patches were merged ( https://review.opendev.org/q/topic:zed-milestone-2 )
14:07:37 <elodilles> \o/
14:08:09 <elodilles> 2nd task: '    Reach out to project teams that have never-released deliverables and ask if they are ready to be included in Zed (or prefer to wait, or should be dropped). (elod)'
14:08:55 <fungi> seems like skyline got their pypi projects fixed up so they can release?
14:08:57 <elodilles> this was technically the continuation of R-13 week's task about deliverables vs governance project list consistency check task
14:09:49 <elodilles> fungi: yepp, they fixed it and ready to release
14:10:07 <elodilles> with the help of ttx (thanks!) skyline team managed to merge their patch
14:10:38 <elodilles> from venus team i got no answer (July 22nd) but patch was proposed: https://review.opendev.org/c/openstack/releases/+/850129
14:11:32 <elodilles> this needs some work still, but hopefully will be updated & merged, not like last cycle
14:11:44 <elodilles> i'll keep an eye on it
14:12:19 <elodilles> for the panko patch ( https://review.opendev.org/c/openstack/governance/+/850005 )
14:12:44 <elodilles> i've proposed a fix in python-pankoclient repo: https://review.opendev.org/c/openstack/python-pankoclient/+/850750
14:12:51 <elodilles> after that the validator should pass
14:13:19 <elodilles> but this one has no deadline anyway
14:13:57 <elodilles> so only venus team's deliverables is the one which needs attention
14:14:18 <elodilles> otherwise we are good with this task too
14:14:48 <elodilles> last task was: '    Plan the next release cycle schedule (elod, armstrong)'
14:15:17 <elodilles> 1st of all: we have the name for the next cycle: Antelope \o/
14:15:30 <fungi> thanks aprice and everyone else involved!
14:16:47 <elodilles> indeed, thanks for managing the process! \o/
14:17:10 <elodilles> (i was searching for the mail meanwhile)
14:17:46 <elodilles> #info Antelope is the next cycle's name -- https://lists.openstack.org/pipermail/openstack-discuss/2022-July/029672.html
14:18:09 <elodilles> and back to the task
14:18:57 <elodilles> unfortunately armstrong had some emergency issue with hospital visiting involved :S hope everything is OK there!
14:19:11 <fungi> yeah, hope all is well
14:19:27 <elodilles> so i've started the planning myself:
14:19:35 <elodilles> WIP patch proposed (26 weeks long) for Antelope cycle: https://review.opendev.org/c/openstack/releases/+/850753
14:20:08 <fungi> see inline comments, i think the doc build failure is because parameters have to come immediately after directives, you can't have an empty line between them
14:20:53 <elodilles> the planned release date is 05 April, 2023
14:21:13 <elodilles> fungi: thanks
14:21:52 <fungi> so it's thinking the parameter is supposed to be content, and that directive doesn't allow content, hence the rather strange error message
14:21:54 <elodilles> the date is just before Easter
14:23:06 <elodilles> fungi: ack, i'll update the patch soon :)
14:23:22 <elodilles> thanks for the pointers
14:23:26 <fungi> np
14:23:46 <elodilles> nevertheless, the question is about the release date and milestones
14:24:09 <elodilles> maybe the release date should be one week earlier
14:24:27 <elodilles> considering Easter...
14:25:00 <fungi> yeah, easter is 4 days later
14:25:23 <elodilles> on the other hand i thought this fits just before it, and '26 weeks' is also a good length
14:25:48 <fungi> passover also starts on the 5th
14:26:38 <elodilles> hmmm, then it is also not that good
14:27:22 <elodilles> i've tried to see different cultures different holidays but wasn't sure which are bank holidays
14:28:24 <elodilles> i don't think we should have longer than 26 weeks long cycle,
14:28:49 <fungi> if we're hoping to make the release more "visible" then after easter/passover could work better. releasing right before, much less on, a holiday people are likely to file the info away and then forget about it while they're enjoying time off
14:28:51 <elodilles> but then i'll propose a 25 week long schedule as well and folk can vote
14:30:04 <fungi> i can also check with foundation marketing folks and see if they think there might be a good "sweet spot" week in the calendar for improving our audience reach with the announcement
14:30:30 <elodilles> hmmm, so you vote for longer schedule, which should be then around 28 weeks long, since there is Easter + holidays
14:31:00 <elodilles> fungi: ack, that would be awesome! thanks for doing that!
14:31:13 <fungi> yw
14:31:39 <elodilles> let me know when there is an answer and i'll update the plan accordingly
14:32:25 <elodilles> #agreed fungi will check with foundation marketing folks if they have a preference about the release date
14:32:56 <elodilles> fungi: ^^^ marked it, otherwise i might forget it o:)
14:33:30 <fungi> thanks. i've already asked them, but there may be some delay in getting feedback
14:33:47 <elodilles> of course, they have to think it through as well
14:34:03 <fungi> either they'll add comments to the review or i'll quote them there myself
14:34:19 <elodilles> fungi: ++, sounds perfect
14:35:06 <elodilles> okay, this is on track so let's move on with the topic
14:35:14 <elodilles> #topic Assign R-9 tasks
14:35:49 <elodilles> i've added my name to the tasks :)
14:36:20 <elodilles> #topic Open Discussion
14:36:40 <elodilles> for starter, i had a quick topic: 'Skip next week's (R-10) meeting?'
14:37:12 <elodilles> as there is summer as we can see + there is no listed tasks for R-10 anyway for release team
14:38:16 <elodilles> given the low number of attendants of this meeting i think this is a sign that we can skip :)
14:39:34 <fungi> i'm doing my best not to let you get lonely!
14:39:48 <elodilles> thanks fungi o:)
14:40:30 <elodilles> anything to mention here under 'Open Discussion' topic?
14:40:50 <fungi> i have nothing, no
14:41:18 <elodilles> thanks, then let's end this meeting! :)
14:41:29 <elodilles> thanks for participating fungi ! :)
14:41:37 <elodilles> #endmeeting