14:00:51 <elodilles> #startmeeting releaseteam
14:00:51 <opendevmeet> Meeting started Fri Aug  5 14:00:51 2022 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:51 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:51 <opendevmeet> The meeting name has been set to 'releaseteam'
14:01:03 <elodilles> Ping list: armstrong ttx hberaud diablo_rojo_phone
14:01:05 <hberaud> o/
14:01:08 <armstrong> o/
14:01:17 <elodilles> #link https://etherpad.opendev.org/p/zed-relmgt-tracking
14:01:20 <ttx> o/
14:01:26 <diablo_rojo_phone> Hello!
14:01:42 <elodilles> o/
14:01:55 <elodilles> we are at line 253!
14:02:30 <elodilles> let's start quickly with the topics as we have quite many topics in our agenda!
14:02:41 <elodilles> #topic Review task completion
14:02:59 <elodilles> 1st task was: 'Generate a list of intermediary-released service deliverables that have not done a release in this cycle yet and propose release model change for them.'
14:03:13 <elodilles> since the generated list is mostly the same as usual (and we usually abandon the release model change patches for them) i've sent a mail instead:
14:03:24 <elodilles> https://lists.openstack.org/pipermail/openstack-discuss/2022-August/029798.html
14:03:50 <elodilles> as a result, vitrage deliverables were released
14:04:19 <armstrong> ok
14:04:19 <elodilles> ironic , OpenStackSDK and swift are still pending
14:05:05 <elodilles> anything to add here?
14:05:50 <ttx> nope
14:05:50 <armstrong> will you force the release on these three projects?
14:06:26 <elodilles> good question. maybe not force, but i could ping them as a gentle reminder on IRC :)
14:06:38 <armstrong> ok
14:07:12 <elodilles> #action elod to ping ironic OpenStackSDK and swift to prepare releases for the missing deliverables
14:07:28 <elodilles> thanks armstrong for the question :)
14:07:48 <elodilles> okay, next topic then
14:07:55 <armstrong> np
14:08:08 <elodilles> i mean, next task...
14:08:17 <elodilles> 'Propose convenience releases for Wallaby to ease the transition of Wallaby to Extended Maintenance and avoid rush and broken releases when the transition deadline is coming.'
14:08:38 <elodilles> actually, i've proposed ~1 month ago: https://review.opendev.org/q/topic:wallaby-stable
14:09:10 <elodilles> and ~half of them have merged already
14:10:28 <elodilles> those patches which won't get +1's from PTL/release liaisons will be abandoned soon
14:11:10 <elodilles> and that was the last task
14:11:26 <elodilles> #topic Assign R-8 tasks
14:11:52 <elodilles> actually, only two small tasks are there, so i added my name to them
14:12:11 <elodilles> if there's no objection :)
14:12:58 <elodilles> (in case there is, just add your name to the task ;))
14:13:10 <elodilles> let's move on to the next topic!
14:13:24 <elodilles> #topic PTG October 2022 Team Signup (Columbus, Ohio)
14:13:54 * elodilles still doesn't have the final approval for the travel from his company
14:14:03 <armstrong> I will add my name :)
14:14:20 <elodilles> hopefully i will get soon
14:14:30 <elodilles> but it's holiday season
14:14:31 <diablo_rojo> I shall be there :)
14:14:39 <elodilles> :)
14:15:20 <elodilles> i think I can still signup the team for the PTG
14:15:45 <diablo_rojo> You can :) \
14:15:50 <diablo_rojo> You have till the 12th
14:15:52 <armstrong> @diablo_rojo  are the ticket free?
14:15:55 <hberaud> same thing for me, I don't yet know about my company approval
14:16:04 <diablo_rojo> armstrong: since its an in person event, they are not.
14:16:15 <armstrong> :(
14:17:26 <ttx> i think signing up the team is pretty harmless at this point !
14:17:50 <ttx> I don;t think we'll do that many hours but always good to be on the agenda
14:18:07 <elodilles> ttx: i agree
14:18:40 <elodilles> #agreed elod will signup the release team for PTG
14:18:58 <elodilles> and let's hope everyone will be able to travel there
14:19:40 <elodilles> anything else to discuss about the Team Signup?
14:19:48 <ttx> if not it should not be too difficult to plug a single remote attendee in
14:19:51 <diablo_rojo> Nothing from me.
14:20:02 <ttx> it's when large groups are involved that it can quickly turn into a mess
14:20:47 <elodilles> ttx: yes, we probably could manage it easily
14:21:05 <elodilles> okay, next topic then
14:21:12 <elodilles> #topic Antelope release date pick
14:21:22 <elodilles> https://review.opendev.org/c/openstack/releases/+/850753
14:21:30 <elodilles> this is the proposed schedule ^^^
14:22:14 <elodilles> (or this one for better readability: https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_699/850753/5/check/openstack-tox-docs/699fc2d/docs/antelope/schedule.html )
14:22:39 <elodilles> it's according to Foundation's response for the 1st proposal
14:22:48 <ttx> Yeah my main issue with it is that it forces the next PTG to be the release week
14:23:13 <ttx> which is why I suggested to move it up a week.... but we could also just say it's ok
14:24:20 <ttx> Maybe we could build two options and ask around about the preference... possibly let the TC decide
14:24:53 <elodilles> according your other suggestion to release at March 22, then the PTG would be just next week, before Easter i guess
14:25:28 <elodilles> isn't that also a risky timing?
14:25:57 <elodilles> anyway, i can propose that schedule as well as you suggest
14:26:04 <ttx> easter and Passover week is the week after
14:26:30 <ttx> Mar 20-26: none
14:26:32 <ttx> Mar 27-Apr 2: none
14:26:34 <ttx> Apr 3-9: passover starts April 5, easter starts April 7
14:27:20 <elodilles> hmmm, ok, maybe that could work
14:27:50 <ttx> I think it works, it's just less ideal in terms of duration and where milestones fall
14:28:04 <ttx> question being, what do we care about the most
14:28:21 <elodilles> #action elod to propose another schedule plan (w/ March 22 release date) and let folks / Foundation / TC decide
14:28:29 <ttx> Release week can get busy as we do promotion that involve PTLs etc
14:28:31 <elodilles> ttx: ack
14:28:43 <elodilles> ttx: is this acceptable? ^^^
14:28:46 <ttx> so making that two difefrent weeks avoids too much collision
14:29:13 <ttx> elodilles: yes. I'd let the TC decide really, once people voice their preference on the reviews
14:29:38 <elodilles> ttx: ack, thanks for the ideas
14:29:59 <elodilles> then let's move on to next topic
14:30:22 <elodilles> #topic Hacking release so late in the cycle? https://review.opendev.org/c/openstack/releases/+/851273
14:31:32 <elodilles> afaik there were some issues in the past when hacking was released and CI jobs started to break
14:31:48 <ttx> yep, hacking releases we usually push during meilstone-1
14:31:52 <elodilles> that's why it is best to release early in the cycle
14:32:14 <ttx> so that if they trigger some work it does not conflict with any planned release work
14:32:18 <elodilles> we are just between zed-2 and zed-3
14:32:24 <armstrong> so the entire code base is moving to 3.10?
14:32:37 <elodilles> armstrong: i don't think so
14:33:16 <elodilles> the patch just drops py36 & py37 support
14:33:47 <elodilles> what every project should have done already
14:34:02 <armstrong> ok thx
14:35:06 <elodilles> and it does other things like 'support flake8 4.x' etc
14:36:07 <elodilles> anyway, the question is, whether we are really late (between zed-2 and zed-3)
14:36:34 <ttx> My vote would be on postponing
14:36:46 <ttx> but it's not a strong opinion
14:36:47 <hberaud> I agree with you to postpone it
14:36:57 <fungi> yes, that seems like it could be generally disruptive so late in the cycle
14:37:06 <elodilles> i agree too,
14:37:40 <ttx> it's more a question of habit. If there is no strong reason to push it late, we should defer it
14:37:59 <fungi> this may provide incentive for the qa team to plan changes for static analysis tools and similar linters so they can merge soon after the coordinated release
14:38:10 <elodilles> just really hope that there won't be such case when someone comes with the idea to urge us to release anyway, around release time :)
14:38:39 <elodilles> but i guess that possibility is weak (fingers crossed)
14:39:59 <elodilles> anyway, we are on consensus as i see
14:40:36 <elodilles> to postpone it to release it early in Antelope cycle
14:42:16 <elodilles> #agreed to postpone Hacking 5.0.0 release to eearly time in Antelope cycle
14:42:35 <elodilles> is this OK ^^^?
14:43:09 <ttx> ++
14:43:19 <elodilles> ack, then i'll comment on the release patch in behalf of the team
14:43:29 <elodilles> next topic then
14:43:43 <elodilles> #topic Review countdown email contents
14:43:54 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:43:58 <elodilles> please review ^^^
14:44:19 <elodilles> note that i did a bit bigger change in the mail than the usual,
14:44:35 <elodilles> due to the changes in the 1st task
14:44:59 <elodilles> (the crossed out sections won't be part of the mail)
14:45:33 <elodilles> (just showing the original content to see what will be left out)
14:46:50 <armstrong> ^^^ LGTM!
14:47:00 <elodilles> armstrong: ++
14:48:52 <armstrong> the  the "*swift "is this the project level? or  a *swift- team within Swift?
14:49:22 <elodilles> the 'swift' deliverable from Swift team :)
14:49:54 <armstrong> ok thx for the clarification
14:50:15 <ttx> lgtm
14:50:17 <hberaud> LGTM
14:50:34 <elodilles> thanks!
14:50:53 <elodilles> #topic Open Discussion
14:51:10 <elodilles> anyone, anything to discuss?
14:51:17 <hberaud> Just a friendly reminder about my PTO
14:51:25 <hberaud> I'll be afk during the next 3 weeks
14:51:40 <elodilles> hberaud: acknowledged, have a nice time off! :)
14:51:41 <hberaud> that's all for me
14:51:47 <hberaud> thanks
14:52:30 <ttx> have a good time off!
14:52:33 <hberaud> thanks
14:54:48 <elodilles> okay, we had the long silence :)
14:54:55 <elodilles> so let's close the meeting!
14:55:09 <elodilles> thanks everyone for participating! o/
14:55:19 <elodilles> #endmeeting