14:00:05 <elodilles> #startmeeting releaseteam
14:00:05 <opendevmeet> Meeting started Fri Sep 16 14:00:05 2022 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <opendevmeet> The meeting name has been set to 'releaseteam'
14:00:13 <elodilles> Ping list: armstrong ttx hberaud diablo_rojo_phone
14:00:17 <hberaud> o/
14:00:23 <elodilles> #link https://etherpad.opendev.org/p/zed-relmgt-tracking
14:00:25 <armstrong> o/
14:00:49 <elodilles> we are waay down at L386
14:00:55 <elodilles> o/
14:01:03 <elodilles> let's start!
14:01:21 <elodilles> #topic Review task completion
14:01:52 <elodilles> #info 1st task: 'Process any remaining library branching exception. (all)'
14:02:59 <elodilles> #info the following were relesed (with RFE): python-adjutantclient, python-magnumclient, python-saharaclient, python-venusclient
14:03:49 <elodilles> #info still missing: python-mistralclient, python-watcherclient, python-zaqarclient
14:04:10 <elodilles> out of which we have a release patch for python-watcherclient
14:05:02 <elodilles> and for zaqar we have a fix, but no reviewer unfortunately :/
14:05:15 <elodilles> not even after a direct mail to PTL
14:05:53 <hberaud> :(
14:07:00 <elodilles> anyway, i'll try to look after these, we will see next week, i guess that is the ultimate-final-after deadline to deal with them :/
14:07:27 <fungi> the tc can request our gerrit admins grant them access for approval rights over changes to any openstack repo
14:07:53 <elodilles> fungi: hmmm, maybe that's we need
14:08:15 <elodilles> at least for python-zaqarclient
14:08:34 <fungi> the tc has ultimate control over all openstack projects, should they choose to exercise it
14:09:18 <elodilles> fungi: ack, I'll send a request towards TC then on Monday if no reaction till that time
14:10:07 <elodilles> #action elod to request admin approval for python-zaqarclient fix to land by Monday if needed
14:10:51 <elodilles> i think that is all for now for this task
14:11:16 <elodilles> #info 2nd task: 'On Monday, generate release requests for all deliverables that do not have a suitable candidate yet. (elod) (armstrong)'
14:11:36 <elodilles> Branch devstack-plugin-* delivrables: https://review.opendev.org/c/openstack/releases/+/857264
14:12:14 <hberaud> only 2 plugings?
14:12:16 <elodilles> now that i see i did not add any deadline for this
14:12:33 <elodilles> hberaud: yes, i remember we had that many in last cycle as well
14:12:44 <elodilles> hberaud: did i miss any?
14:12:57 <hberaud> I was thinking that we had many of them during previous series...
14:13:44 <hberaud> Any idea... I don't know if you missed some of them but we could double checl
14:13:47 <hberaud> check
14:13:56 <hberaud> s/any/no/
14:14:28 <elodilles> hberaud: can you do that next week maybe?
14:14:44 <hberaud> I'll review this patch by running through the process and see if I can find more than 2
14:14:49 <elodilles> i found only these two, but i'll also look them up again
14:14:58 <hberaud> ack
14:14:59 <elodilles> hberaud: ack, thanks!
14:15:15 <hberaud> let's discuss this over the review
14:15:36 <elodilles> #action double-check if we missed any devstack-plugin-* deliverable
14:15:39 <elodilles> hberaud: ack
14:16:01 <elodilles> next subtask was:
14:16:21 <elodilles> cycle-with-intermediary deliverables that were not released yet: https://review.opendev.org/q/topic:zed-cwi-not-released
14:16:32 <elodilles> note: tempest plugins release patches will be proposed in R-2 week (see tasks there)
14:16:58 <elodilles> so those are skipped from this task
14:18:24 <elodilles> iurygregory: if you are around, can you please review quickly the two open patch: https://review.opendev.org/q/topic:zed-cwi-not-released
14:18:53 <elodilles> otherwise we should release them
14:19:23 <elodilles> next subtask was:
14:19:32 <elodilles> 'cycle-with-rc that are not trailing deliverables and that have not done a RC1 yet'
14:19:43 <elodilles> https://review.opendev.org/q/topic:zed-rc1-deadline
14:19:51 <elodilles> the patches ^^^
14:20:24 <elodilles> majority have been approved by PTLs/release liaisons and got merged
14:21:11 <hberaud> I double checked those that you've validated even without PTL agreement, however, I didn't +W them
14:21:41 <elodilles> hberaud: thanks a lot! i'll +W them right after the meeting!
14:21:55 <hberaud> ack
14:22:20 <elodilles> hberaud: and a special thanks for the tons of reviews you did during the week for these RC1 patches \o/
14:22:42 <hberaud> a couple of them remains, adjutant and ansible role, but if I remember correctly those are trailing projects
14:22:55 <hberaud> np, you are welcome
14:23:00 <elodilles> ansible roles definitely
14:23:32 <elodilles> some -1s are there too, so we will have some left over for next week as well
14:23:39 <elodilles> to review
14:23:40 <hberaud> adjutant can go
14:23:53 <elodilles> ack
14:24:19 <hberaud> and monasca-events-api too
14:24:32 <hberaud> adjutant*
14:24:43 <elodilles> i only +1'd some that had suspected gate issues
14:25:10 <hberaud> I see
14:25:13 <hberaud> seen
14:25:35 <hberaud> I think we could close the ansile-role patches
14:25:40 <elodilles> i'll double check them and send mail to PTLs if needed
14:25:54 <elodilles> hberaud: you mean abandon?
14:26:07 <hberaud> yes
14:26:09 <hberaud> but wait
14:26:36 <hberaud> they are cycle-with-rc too without being trailing deliverables
14:27:04 <hberaud> so I think we should also merge those
14:28:39 <elodilles> yes, i've checked what happened them during yoga and they were released too
14:28:51 <elodilles> so yes, those needs to be merged, too
14:29:02 <hberaud> Ok, WFM
14:29:26 <hberaud> I "recheck"'ed the both with broken CI
14:29:41 <elodilles> anyway, we have the task for next week to deal with exceptions...
14:29:50 <elodilles> hberaud: ack, thanks!
14:30:44 <elodilles> and actually these were the tasks, so we can continue with the next topic
14:30:59 <elodilles> #topic Assign R-2 tasks
14:31:11 <elodilles> i've added already my name to some of the tasks,
14:31:51 <elodilles> i left some tasks for others, but i can take them if there are no volunteers o:)
14:32:16 <hberaud> I took two of them
14:32:25 <elodilles> thanks! \o/
14:32:55 <elodilles> OK, then I've taken the remaining one :)
14:33:10 <elodilles> all sold!
14:33:24 <elodilles> #topic Review countdown email contents
14:33:43 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:33:57 <elodilles> please review ^^^
14:34:47 <iurygregory> elodilles, going to check today
14:35:02 <elodilles> iurygregory: thanks in advance \o/
14:35:31 <hberaud> LGTM
14:35:49 <armstrong> +1
14:36:08 <elodilles> thanks! i'll send it after the meeting
14:36:15 <hberaud> thanks
14:36:22 <opendevreview> Merged openstack/releases master: Release ovn-octavia-provider RC1 for Zed  https://review.opendev.org/c/openstack/releases/+/857152
14:36:34 <elodilles> #topic Open Discussion
14:36:44 <elodilles> maybe one thing to mention
14:37:42 <elodilles> that oslo.db 12.1.0 is now out and constraint is bumped
14:37:51 <elodilles> and we got some mail
14:37:54 <elodilles> https://lists.openstack.org/pipermail/openstack-discuss/2022-September/030317.html
14:37:58 <elodilles> in this thread ^^^
14:38:17 <hberaud> yes and cloudkitty raised that they got some issues
14:38:20 <elodilles> that some deliverables discovered to be impacted
14:38:22 <fungi> seems like just about everything is fixed now?
14:38:32 <elodilles> fungi: we cannot be sure
14:38:55 <hberaud> apparently no, cloudkitty seems to experience related issues
14:39:05 <elodilles> and watcher
14:39:33 <elodilles> and ec2-api
14:39:36 <fungi> i thought i saw someone mention additional patches to fix those, but i'm probably remembering incorrectly
14:40:21 <elodilles> and maybe those are not all
14:40:41 <fungi> in happier news, i'm analyzing contributor stats now that we're at the end of the rc week... from 2022-03-11T00:00:00 to 2022-09-16T00:00:00 we has 14270 merge to official deliverables from 715 contributors (these stats ignore changes proposed by our bot accounts)
14:40:54 <elodilles> fungi: there were a lot of fixes already
14:41:26 <fungi> er, we had 14270 changes merge to official deliverables, i mean
14:41:39 <elodilles> fungi: sounds nice \o/
14:41:59 <hberaud> fungi: what is the trend? increasing, dicreasing?
14:42:14 <hberaud> I guess increasing
14:42:14 <elodilles> so there is a bit of an increase of contributors if i remember the numbers correctly
14:42:16 <fungi> hberaud: i haven't compared, but i'll check
14:42:33 <fungi> also, elodilles, it looks like hberaud was waiting for you to review https://review.opendev.org/856325 before approving it
14:43:05 <elodilles> yoga: "13,500 changes authored by over 680 contributors"
14:43:14 <hberaud> \o/
14:43:25 <fungi> awesome
14:43:48 <fungi> great work, everyone!
14:43:49 <elodilles> fungi: thanks! +W'd
14:46:31 <elodilles> so back to oslo.db thing: we can expect further issues and thus maybe RC2s?
14:47:08 <hberaud> I think that yes
14:47:34 <elodilles> i guess now that most of the things are fixed we don't need to restrict oslo.db 12.1.0 from Zed
14:48:04 <elodilles> but we need to monitor the issue in the last weeks
14:48:04 <hberaud> I agree
14:48:29 <elodilles> ack
14:48:40 <elodilles> i think that's it from me
14:48:49 <elodilles> anything else to mention? anyone?
14:48:53 <hberaud> the remaining issues could be fixed and backported after Z (if not fixed by RC2)
14:49:04 <hberaud> nope
14:49:14 <elodilles> hberaud: yepp, maybe that is possible
14:49:47 <elodilles> ok, if nothing else, then let's close the meeting
14:50:06 <elodilles> thanks everyone for joining o/
14:50:14 <hberaud> thanks elodilles
14:50:23 <elodilles> #endmeeting