14:00:03 <elodilles> #startmeeting releaseteam
14:00:03 <opendevmeet> Meeting started Fri Sep 30 14:00:03 2022 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:03 <opendevmeet> The meeting name has been set to 'releaseteam'
14:00:05 <ttx> slurp slurp
14:00:05 <elodilles> Ping list: armstrong ttx hberaud diablo_rojo_phone
14:00:12 <hberaud> o/
14:00:18 <elodilles> #link https://etherpad.opendev.org/p/zed-relmgt-tracking
14:00:30 <elodilles> and we are almost at the bottom of the page
14:00:46 <elodilles> at line 429
14:00:48 <elodilles> o/
14:01:32 <elodilles> let's start with the topics!
14:01:38 <elodilles> #topic Review task completion
14:01:57 <elodilles> 1st task was:
14:02:08 <elodilles> #info Process any remaining stable branching exception. (all)
14:02:32 <elodilles> everything has branched
14:02:44 <elodilles> even requirements repository as well
14:02:52 <elodilles> so this is done
14:03:06 <elodilles> 2nd task was:
14:03:15 <elodilles> #info follow up on oslo.db 12.1.0 related issues (elod)
14:03:40 <elodilles> this was on me, but mostly done by ttx , so thanks for that ttx o/
14:03:50 <ttx> ~o~
14:04:25 <elodilles> #info watcher ec2-api magnum and zun released RCs that fixed their oslo.db 12.1.0 compatibility issues \o/
14:04:33 <ttx> I think we ahve all the known ones covered
14:04:57 <elodilles> i think yes
14:05:05 <ttx> well for the others it's too late
14:05:53 <elodilles> yes. if any was not discovered then they need to fix it after the final release
14:06:23 <elodilles> 3rd task:
14:06:33 <elodilles> #info remained from R-2: After all the projects enabled in devstack by default have been branched, we can engage with the QA, I18n and Requirements PTLs to finalize the stable branch setup. (elod)
14:06:44 <elodilles> QA team was pinged, they pushed the necessary patches: https://review.opendev.org/q/topic:qa-zed-release
14:07:07 <elodilles> there is no I18n team, as far as i know
14:07:29 <elodilles> so maybe we should remove this task from the process in the future
14:07:38 <elodilles> * subtask
14:07:38 <ttx> theer is an I18n sig
14:07:53 <elodilles> ttx: oh, is there?
14:08:01 <ttx> https://governance.openstack.org/sigs/
14:08:21 <ttx> ianychoi is the chair there
14:09:03 <elodilles> hmm, i did not find it in governance repository
14:09:14 <elodilles> only the I18n team in the legacy.yaml
14:09:46 <elodilles> okay, then I'll try to ping them after the meeting
14:10:49 <elodilles> anyway, to continue the subtasks:
14:10:54 <elodilles> requirements stable/zed branch cutting patch proposed: https://review.opendev.org/c/openstack/releases/+/858294
14:11:03 <elodilles> and also merged
14:11:22 <elodilles> now we need: "remind the requirements team to announce that the requirements freeze is lifted from master"
14:11:29 <elodilles> prometheanfire tonyb ^^^
14:11:42 <elodilles> maybe this is the easiest way :)
14:12:03 <ttx> elodilles: yeah it is no longer a project team, so it is listed in the governance-sigs repo instead
14:12:21 <elodilles> ttx: oh, ack, thanks
14:12:52 <ttx> https://opendev.org/openstack/governance-sigs/src/commit/175c615f2df82d52c87e73c87a86a7f84f643394/sigs.yaml#L150
14:13:48 <elodilles> i see. somehow i missed this repo :S
14:14:42 <elodilles> anyway, that's it for this task
14:15:17 <elodilles> 4th task:
14:15:25 <elodilles> #info Notify the documentation (Technical Writing SIG - https://wiki.openstack.org/wiki/Documentation) team that it should be safe to apply their process to create the new release series landing pages for docs.openstack.org (elod)
14:15:45 <elodilles> for this one there is really no such SIG anymore o:)
14:16:00 <elodilles> nevertheless, i've proposed the necessary changes
14:16:08 <elodilles> just like in previous cycle
14:16:18 <elodilles> https://review.opendev.org/q/topic:www-zed-final
14:16:33 <elodilles> the last one needs to be merged at release day
14:17:10 <fungi> the duties of the tech writing sig got split up between oslo and the tc
14:17:11 <elodilles> please review them after the meeting ^^^
14:17:32 <ttx> ack
14:17:36 <elodilles> fungi: yes, i remember that TC was informed
14:18:27 <elodilles> fungi: stephenfin was doing it (from oslo team) in xena, but he could not continue as far as i remember
14:18:50 <fungi> right, but oslo adopted openstackdocstheme
14:19:02 <fungi> so they're the approvers on any changes to that repo at least
14:19:29 <elodilles> fungi: hmmm, ok, then this needs another release process guideline update. i'll propose it
14:19:39 <elodilles> fungi: ack
14:19:51 <fungi> the other former docs team repos are for the tc to deal with at this point though
14:20:51 <elodilles> ack
14:21:24 <elodilles> fortunately it seems that only those 3 patches are the ones that we should take care of
14:21:47 <elodilles> so not that big issue
14:22:31 <fungi> specifically oslo has openstackdocstheme, openstack-doc-tools, os-api-ref
14:22:38 <elodilles> (of course, if i don't hide typos in them :S)
14:25:13 <elodilles> i think we can continue to the next task
14:25:37 <elodilles> #info follow up: Ensure that all projects that are publishing release notes have the notes link included in their deliverable file. (elod)
14:25:57 <elodilles> i've proposed another round of reno-links: https://review.opendev.org/c/openstack/releases/+/859690
14:27:13 <elodilles> we can merge this i think as new reno-links will appear in the coming weeks (as they usually does after the release in every cycle)
14:28:07 <elodilles> on the other hand, surprisingly good amount of reno-zed patches merged: https://review.opendev.org/q/topic:reno-zed
14:28:44 <elodilles> so at least we have less missing reno-links than usual (i think)
14:28:58 <ttx> \o/
14:29:16 <elodilles> okay, 5th task:
14:29:26 <elodilles> #info On the day before the deadline for final release candidates, propose last-minute RCs where needed (ttx)
14:29:44 <elodilles> ttx: thanks for doing this task!
14:30:07 <elodilles> See https://review.opendev.org/q/topic:last-minute-rcs for RC2s filed to pick up recent changes in stable/zed
14:30:20 <elodilles> (all merged \o/
14:30:39 <elodilles> tacker has https://review.opendev.org/c/openstack/releases/+/859832
14:30:49 <elodilles> this one was merged, too ^^^
14:30:57 <elodilles> ttx: anything to add?
14:31:17 <ttx> nope, all set!
14:31:25 <elodilles> thanks again \o/
14:31:32 <ttx> quite happy of how it went
14:31:40 <elodilles> me too :)
14:31:55 <elodilles> so say we all! :)
14:32:51 <elodilles> OK, so, the last 2 tasks (countdown mail + propose-final-releases) tasks are 'after-meeting' tasks
14:32:58 <elodilles> so that was all for now \o/
14:33:16 <elodilles> let's continue with the next topic
14:33:26 <elodilles> #topic Assign R+0 tasks
14:33:56 <elodilles> first of all we have "Special Review Guidelines!!!"
14:34:21 <elodilles> please follow that during the week
14:34:53 <ttx> I feel like all of those are (all)
14:35:09 <elodilles> ttx: yepp, just wanted to say that :)
14:35:15 <ttx> I plan to be around
14:35:29 <hberaud> same thing here
14:35:47 <elodilles> and definitely the same thing for me
14:36:15 <fungi> as will i
14:36:35 <elodilles> thanks all of you in advance! o/
14:36:59 <elodilles> okay, so all tasks are taken
14:37:00 <fungi> though i have a dentist appointment at 15:00 utc, i expect release activities will have mostly wrapped up by then
14:37:33 <elodilles> fungi: oh, good luck with that :S
14:38:04 <elodilles> yepp, at that time hopefully just the mails need to be sent
14:38:28 <elodilles> #topic Review countdown email contents
14:38:43 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:38:52 <elodilles> please review ^^^
14:39:59 <ttx> lgtm
14:41:38 <elodilles> thx, will send it after the meeting (+ will create the final release patch)
14:42:00 <elodilles> #topic Open Discussion
14:42:49 <elodilles> well, i forgot to add here in advance the PTG topic
14:43:21 <elodilles> the PTG page is generated already but I have'nt filled it with content yet: https://etherpad.opendev.org/p/oct2022-ptg-rel-mgt
14:43:37 <elodilles> what I'll do shortly
14:43:50 <elodilles> until that, feel free to add there topics
14:44:22 <elodilles> and of course we don't have yet any scheduled time slot
14:44:27 <elodilles> any preference for that?
14:45:13 <ttx> hmm
14:45:42 <ttx> I'd pick I'd pick a 13UTC slot
14:45:55 <fungi> if it doesn't conflict with openstack-tc, openstack-security or diversity-wg i should be able to make it
14:46:50 <ttx> If we pick 13utc or 14utc i can any day
14:47:23 <elodilles> what about having it on thursday or friday?
14:47:34 <ttx> Or we could just take our usual meetign slot time... but then I can't overflow as I have a hard stop at 16utc
14:47:34 <elodilles> 13 UTC is fine for me
14:47:52 <ttx> Thursday is perfect
14:48:25 <elodilles> on Thursday (or Friday) there's TC sessions @ 15 UTC
14:48:30 <ttx> maybe 14utc so that more people can join
14:48:48 <elodilles> fungi: is 14 UTC OK for you?
14:48:53 <elodilles> isn't that too early?
14:49:07 <fungi> nah, that's plenty late
14:49:15 <elodilles> cool :)
14:49:33 <fungi> i'm able to make 13:00 as well if it's preferable
14:49:56 <fungi> but i don't have anything at either of those times on thursday or friday
14:50:53 <elodilles> there is an operator-hour placeholder at 14 UTC Thursday, is it something you want to participate?
14:51:24 <elodilles> though no teams added yet
14:51:35 <ttx> I'm good
14:51:40 <elodilles> anyway, for me Thursday 13 or 14 UTC is OK
14:51:41 <fungi> no, i probably won't be in many (if any) of the operator hours
14:52:14 <elodilles> ok, then Thursday 14 UTC is what we chose
14:52:24 <fungi> sounds great, thanks
14:52:37 <ttx> got to run
14:52:38 <elodilles> hberaud: is that OK for you as well? do you planning to be there?
14:52:45 <hberaud> yes
14:53:01 <elodilles> ttx: ack, thanks, see you o/
14:53:07 <elodilles> hberaud: cool \o/
14:53:18 <fungi> if you book it into cactus-ThuB2 then you can use the same room the tc will be using (unless the plan is to use meetpad, in which case it won't matter)
14:53:46 <elodilles> #agreed relmgmt PTG session will be held @ Thursday 14 UTC
14:54:11 <elodilles> anything else to discuss?
14:54:35 <elodilles> (i'll add our time slot to the schedule page after the meeting)
14:56:29 <hberaud> nope
14:56:32 <elodilles> good. the silence signals me, that we don't have any other topic to discuss :)
14:56:49 <elodilles> thanks everyone for participating o/
14:56:52 <hberaud> elodilles: thank you!
14:56:58 <elodilles> #endmeeting