14:00:56 <elodilles> #startmeeting releaseteam
14:00:56 <opendevmeet> Meeting started Fri Sep 15 14:00:56 2023 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:56 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:56 <opendevmeet> The meeting name has been set to 'releaseteam'
14:01:00 <hberaud> o/
14:01:16 <elodilles> #link https://etherpad.opendev.org/p/bobcat-relmgt-tracking
14:01:20 <elodilles> o/
14:01:20 <opendevreview> Merged openstack/releases master: Release zaqar RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894728
14:01:22 <opendevreview> Merged openstack/releases master: Release zaqar-ui RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894727
14:01:25 <opendevreview> Merged openstack/releases master: Release manila RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894668
14:01:27 <opendevreview> Merged openstack/releases master: Release barbican RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894644
14:01:29 <opendevreview> Merged openstack/releases master: Release kuryr-kubernetes RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894663
14:01:37 <opendevreview> Merged openstack/releases master: Release designate RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894654
14:01:39 <opendevreview> Merged openstack/releases master: Release kuryr-libnetwork RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894664
14:01:41 <opendevreview> Merged openstack/releases master: Release octavia RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894695
14:01:44 <opendevreview> Merged openstack/releases master: Release octavia-dashboard RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894694
14:01:46 <opendevreview> Merged openstack/releases master: Release senlin RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894710
14:01:48 <opendevreview> Merged openstack/releases master: Release ceilometer RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894648
14:01:50 <opendevreview> Merged openstack/releases master: Release aodh RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894643
14:01:53 <opendevreview> Merged openstack/releases master: Release blazar-nova RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894646
14:01:55 <opendevreview> Merged openstack/releases master: Release adjutant RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894639
14:01:58 <elodilles> we are at R-3, line 411, very close to the bottom of the etherpad :-o
14:02:03 <opendevreview> Merged openstack/releases master: Release monasca-agent RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894674
14:02:05 <opendevreview> Merged openstack/releases master: Release monasca-notification RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894677
14:02:07 <opendevreview> Merged openstack/releases master: Release monasca-api RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894675
14:02:56 <elodilles> and let's start!
14:03:07 <elodilles> #topic Review task completion
14:03:13 <opendevreview> Merged openstack/releases master: Release monasca-thresh RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894679
14:03:20 <elodilles> "Process any remaining library branching exception (all)"
14:03:34 <elodilles> https://review.opendev.org/q/topic:bobcat-stable-branches+is:open
14:03:37 <opendevreview> Merged openstack/releases master: Release monasca-ui RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894680
14:03:39 <opendevreview> Merged openstack/releases master: Release monasca-persister RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894678
14:03:41 <opendevreview> Merged openstack/releases master: Release monasca-events-api RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894676
14:04:13 <elodilles> hmmm, we have still some branching patches open
14:06:05 <elodilles> I think we should merge them, except the python-barbicanclient one, but we have to ping the team there as it has to be merged ASAP
14:06:35 <hberaud> wfm
14:07:52 <elodilles> OK, I've added my +2s there
14:08:02 <elodilles> hberaud: can you quickly check them?
14:08:07 <opendevreview> Yasufumi Ogawa proposed openstack/releases master: Release tacker RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894717
14:08:07 <hberaud> yeah
14:09:34 <hberaud> done
14:09:39 <elodilles> thanks
14:09:50 <hberaud> np
14:09:55 <elodilles> next task then!
14:10:05 <elodilles> "on monday force the milestone 3 patches that are still opened (all)"
14:10:11 <elodilles> https://review.opendev.org/q/topic:bobcat-milestone-3+is:open
14:10:35 <elodilles> none is open, so we are done with this task
14:11:01 <elodilles> "On the Monday, generate release requests for all deliverables that have do not have a suitable candidate yet (elod)"
14:11:23 <elodilles> this had multiple sub tasks ^^^
14:11:28 <elodilles> "Branch devstack-plugin-* delivrables"
14:11:34 <elodilles> https://review.opendev.org/c/openstack/releases/+/894743
14:11:51 <elodilles> this is merged, so we are good
14:12:02 <elodilles> "cycle-with-intermediary deliverables"
14:12:07 <elodilles> https://review.opendev.org/c/openstack/releases/+/893418
14:12:25 <elodilles> this is the only one still open ^^^
14:12:33 <elodilles> python-openstackclient
14:13:10 <hberaud> I think we are late so I'd suggest to force it
14:13:18 <elodilles> i had a comment on the patch as it is there are some merged patches that are not part of the release
14:13:37 <elodilles> s/it is//
14:14:01 <opendevreview> Merged openstack/releases master: Release sahara RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894708
14:14:03 <opendevreview> Merged openstack/releases master: Release sahara-plugin-spark RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894705
14:14:06 <opendevreview> Merged openstack/releases master: Release sahara-plugin-cdh RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894703
14:14:08 <opendevreview> Merged openstack/releases master: Release sahara-plugin-storm RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894706
14:14:17 <frickler> I can ping gtema about the osc release
14:14:19 <elodilles> i was thinking whether we should update the hash before we proceed with the release
14:14:35 <hberaud> frickler: thx
14:14:39 <elodilles> frickler: that would be awesome
14:14:42 <gtema> elodilles, sorry, missed to response
14:14:59 <opendevreview> Merged openstack/releases master: Release sahara-plugin-ambari RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894702
14:15:02 <opendevreview> Merged openstack/releases master: Release sahara-plugin-vanilla RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894707
14:15:04 <opendevreview> Merged openstack/releases master: Release sahara-plugin-mapr RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894704
14:15:06 <opendevreview> Merged openstack/releases master: Release sahara-image-elements RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894701
14:15:09 <opendevreview> Merged openstack/releases master: Release sahara-extra RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894700
14:15:10 <gtema> more or less every day release change is not merged there is a big chance for new changes to come
14:15:37 <gtema> there was nothing urgent merged after change was created
14:15:37 <elodilles> gtema: now repos should have feature freeze on them o:)
14:16:14 <gtema> but we have branched already
14:16:30 <elodilles> gtema: not yet
14:16:36 <elodilles> gtema: good point
14:16:48 <elodilles> gtema: this is the patch: https://review.opendev.org/c/openstack/releases/+/893418
14:16:55 <elodilles> python-openstackclient
14:17:46 <gtema> ehm, I was sure I have seen a change for branching
14:18:24 <opendevreview> Sylvain Bauza proposed openstack/releases master: Release placement RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894698
14:18:31 <gtema> you are producing so many changes in last days that I completely lost overview
14:19:03 <elodilles> gtema: a general comment: it is good to avoid merging patches (especially bigger changes) between FF/branching and the final release, to avoid backporting conflicts
14:19:20 <gtema> https://review.opendev.org/c/openstack/releases/+/893619 - I was sure it was also for osc itself
14:20:40 <elodilles> gtema: 1st we release non-client libraries then client-libraries and other cycle-with-intermediary projects. but i know, many patches o:)
14:20:40 <opendevreview> Artem Goncharov proposed openstack/releases master: Release python-openstackclient for Bobcat  https://review.opendev.org/c/openstack/releases/+/893418
14:20:56 <gtema> ok, updated the hash
14:21:02 <elodilles> thanks!
14:21:09 <gtema> there was anyway nothing big landed in the meanwhile
14:21:22 <gtema> wlcm and one more time sorry for missing to response
14:21:25 <gtema> respond
14:21:34 <elodilles> no worries
14:21:42 <elodilles> i'll add the branching to it, too
14:22:26 <opendevreview> Merged openstack/releases master: Release sahara-dashboard RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894699
14:23:29 <opendevreview> Elod Illes proposed openstack/releases master: Release python-openstackclient for Bobcat  https://review.opendev.org/c/openstack/releases/+/893418
14:23:33 <elodilles> gtema: ^^^
14:23:59 <gtema> approved
14:24:08 <elodilles> and that's all, i try to not bother you anymore o:)
14:24:16 <elodilles> thanks! \o/
14:24:55 <elodilles> let's wait until the gate finishes with a Verified+1 and we can merge then
14:25:00 <elodilles> hberaud: ^^^
14:25:05 <hberaud> ack
14:25:24 <elodilles> cool. let's move on then
14:25:35 <elodilles> "cycle-with-rc that are not trailing deliverables and that have not done a RC1 yet"
14:25:43 <elodilles> #link https://review.opendev.org/q/topic:bobcat-rc1-deadline
14:26:09 <elodilles> most of them have been merged \o/
14:26:40 <elodilles> some -1s, that hopefully will be sorted out in a couple of days
14:26:58 <frickler> https://review.opendev.org/c/openstack/releases/+/894717 is weird, it has PTL -1 but still PTL-approved +1
14:27:30 <elodilles> yeah, sometimes there are anomalies around PTL-Approved :S
14:27:45 <elodilles> usually with another comment it is fixing itself
14:28:23 <frickler> ok, nevermind, then
14:28:39 <elodilles> hmmm. now that i'm looking at the patch, i guess it's because PTL has pushed the patch
14:29:06 <fungi> can probably look at the build log for that job to figure out why it decided that was an approval, or improve the job's logging if not
14:29:10 <elodilles> so it's a small bug in our job :P
14:29:34 <fungi> aha, yes i bet that overrides the vote checking
14:30:00 <elodilles> some finetune will be needed there in the job script then :S
14:30:14 <elodilles> anyways
14:30:31 <elodilles> note: we had to merge some release patch where there are gate issues, sadly :/
14:31:05 <elodilles> but that's the way we handled them in last cycles :/
14:31:28 <elodilles> mostly monasca and sahara deliverables related
14:32:23 <elodilles> otherwise as I said, most of the rc1 releases are out! \o/
14:32:31 <hberaud> \o/
14:32:49 <elodilles> next task:
14:32:57 <elodilles> "missed client library releases (repos that did not have any merged changes during Bobcat cycle)"
14:33:21 <elodilles> i added this during the week, as i found some missing releases ^^^
14:33:28 <hberaud> everything is now merged
14:33:41 <elodilles> https://review.opendev.org/q/topic:bobcat-client-lib-no-changes
14:34:30 <elodilles> this was originally a sub task of R-5: 'Evaluate any non-client libraries that did not have any change merged over the cycle....'
14:35:29 <opendevreview> Merged openstack/releases master: [mistral] Create 2023.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/894771
14:35:31 <opendevreview> Merged openstack/releases master: [murano] Create 2023.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/894780
14:35:34 <elodilles> there is a sentence on the process page, something like if we are not changing release model, then release them
14:35:47 <hberaud> I see
14:36:13 <elodilles> so we have to remind ourselves in next release to not forget this step o:)
14:36:42 <hberaud> :)
14:37:12 <elodilles> anyway, as you said, patches merged, so this is done!
14:37:29 <elodilles> let's move on:
14:37:32 <elodilles> "track the oslo.db and castellan isues to get it sorted out as soon as possible (hberaud)"
14:37:56 <elodilles> hberaud: can you tell us about the status here?
14:38:18 <hberaud> so, I think we won't see these releases moves on before the final release....
14:38:56 <elodilles> neither of them?
14:39:10 <hberaud> a mailing thread is currently happening and are related more or less to these 2 deliverables issues
14:39:12 <hberaud> yeah
14:39:21 <elodilles> :/
14:39:35 <hberaud> both are related to services who are not compat with the new versions
14:39:44 <hberaud> so services needs changes
14:40:00 <elodilles> and i guess we are late for that :/
14:40:02 <hberaud> (mostly manila and masakari)
14:40:03 <frickler> I've learned since last week that oslo.db >= 13 requires sqla >= 2.0, but does not specify that in its requirements
14:40:17 <hberaud> yeah
14:40:22 <elodilles> :S
14:40:46 <hberaud> this mail summarize well the situation https://lists.openstack.org/pipermail/openstack-discuss/2023-September/035100.html
14:40:52 <frickler> so I've also alerted the TC of this
14:40:59 <hberaud> thanks
14:41:28 <frickler> heat is also very far from adopting their db code it seems
14:41:49 <elodilles> thanks
14:41:55 <elodilles> so I guess we need to handle these similarly like we did in Antelope and Zed: we reverted the merged patches and did another releases, to avoid confusions
14:42:17 <hberaud> yeah, heat, aodh, masakari, manila
14:42:23 <elodilles> in this case oslo.db and castellan need the reverts
14:42:56 <hberaud> hm... for oslo.db I think that would require several reverts...
14:43:04 <hberaud> not sure this is a good approach
14:43:05 <frickler> castellan is just a case of bad timing, they released early in the cycle, but then it got forgotten
14:43:23 <frickler> for oslo.db I think they should be doing things in a feature branch really
14:44:05 <elodilles> frickler: that's a good thing to think about in the future
14:44:07 <hberaud> and requirements could be pined on the service side
14:45:01 <elodilles> yes, we have quite many oslo releases: 13.0.0, 13.0.1, 13.1.0, 14.0.0... and all of them not used during the cycle but listed among Bobcat's releases :S ouch :S
14:45:46 <hberaud> yeah
14:45:49 <elodilles> so what should we do then? :/
14:45:52 <opendevreview> Merged openstack/releases master: [sahara] Create 2023.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/894777
14:45:54 <opendevreview> Merged openstack/releases master: [monasca] Create 2023.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/894781
14:45:57 <opendevreview> Merged openstack/releases master: [glance] Create 2023.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/894779
14:45:59 <frickler> hberaud: pinning on the service side doesn't work for a distro that can only have one release of a lib, ask zigo ;)
14:46:12 <hberaud> frickler: I see
14:46:40 <hberaud> elodilles: I'd suggest to update the Bobcat list
14:46:50 <hberaud> (manually?)
14:47:03 <elodilles> i'm not fan of that :/
14:47:10 <hberaud> to reflect the reality
14:47:11 <elodilles> we don't want to change history
14:47:14 <hberaud> me too
14:47:20 <frickler> and then have no oslo.db in bobcat? or the latest from 2023.1?
14:47:31 <hberaud> yeah
14:47:39 <zigo> I agree with frickler: everything (and I really mean *EVERYITHING*) must be co-installable.
14:47:40 <hberaud> (the last of antelope)
14:48:24 <elodilles> is there any other option? :/
14:48:52 <frickler> well a large revert spam and redo all those things on a feature branch?
14:48:57 <zigo> Yeah, reverse changes in these libs, and re-release.
14:48:59 <hberaud> elodilles: merge stephenfin's patches on the service side
14:49:10 <zigo> That's another option (a bad one, I admit).
14:49:16 <frickler> hberaud: there are none for heat
14:49:45 <hberaud> ah
14:49:53 <zigo> And yeah, also that: fix problematic services.
14:50:42 <hberaud> stephenfin: what do you think about reverting the oslo.db changes to rewind before the version 13.0.0?
14:50:43 <frickler> we can do that next cycle, merge oslo.db bump early and then mark failing projects as release questionable instead
14:52:25 <elodilles> to revert that amount of patches is painful, but maybe this is the best approach + what frickler suggests ^^^
14:53:24 <hberaud> you suggest to revert during C?
14:53:34 <elodilles> nope
14:53:40 <elodilles> revert ASAP,
14:53:43 <hberaud> ok
14:53:51 <elodilles> create an oslo.db 15.0.0 release,
14:54:20 <elodilles> which is basically the same as oslo.db 12.3.2
14:54:56 <frickler> what's the deadline for all this, assuming we want to wait for feedback from stephenfin and TC possibly?
14:55:15 <elodilles> and as frickler said: prepare a release for Caracal *very* *early* and fix services ASAP then
14:55:57 <elodilles> frickler: i'd rather see this sorted out till next week's release meeting
14:56:15 <frickler> oh, also maybe cut a feature branch from oslo.db before doing reverts so that state is preserved
14:56:35 <frickler> and then the whole branch can get merged back later
14:56:44 <hberaud> +1 to create a feature branch
14:57:23 <elodilles> speaking of branches: we don't have stable/2023.2 on oslo.db either :-o
14:57:37 <elodilles> nor in castellan
14:57:46 <frickler> if we don't, then maybe we do not need the reverts
14:58:03 <frickler> we could branch off an older state instead
14:58:04 <elodilles> sorry, forget what i said
14:58:22 <elodilles> we *have* stable/2023.2 there
14:58:45 <elodilles> (i was on the wrong patch :P)
14:58:55 <hberaud> np
14:59:23 <frickler> but then the reverts would happen on stable/2023.2 only, right? and master could stay untouched
14:59:25 <hberaud> that' a ton of reverts => https://github.com/openstack/oslo.db/compare/12.3.2..14.0.0?diff=unified
14:59:38 <elodilles> frickler: that sounds good to me
14:59:58 <hberaud> frickler: yeah
15:00:39 <hberaud> but backports would become almost impossible
15:00:57 <hberaud> if a fix is landed on master
15:01:13 <frickler> well not worse than backports to 2023.1 I guess
15:01:22 <hberaud> yeah
15:01:34 <hberaud> exact
15:02:02 <elodilles> 26 patches have landed since 12.3.1 on oslo.db, so yes, that is quite many :/
15:02:28 <hberaud> what's the amount of works to fix heat?
15:02:34 <frickler> but that still sounds manageable, better than 100s
15:02:43 <elodilles> though there are revert + trivial doc changes among them
15:02:59 <frickler> hberaud: IIUC nobody knows exactly yet. but I saw a comment somewhere that sounded bad, let me check
15:03:11 <hberaud> can't the TC force the other patches against services?
15:03:44 <frickler> https://review.opendev.org/c/openstack/heat/+/886549/comments/37e3a9b7_a4caeb11
15:04:26 <frickler> the TC could at least put more pressure on those projects where patches are pending
15:04:27 <hberaud> Stephin started his work 2 years ago and raised warning 2 years ago, are we sure that the same situation won't repeat again in 6 months?
15:04:41 <hberaud> s/Stephin/Stephen/
15:04:43 <frickler> and maybe do closer tracking of progress
15:05:07 <hberaud> that's my main concern
15:05:09 <elodilles> so maybe ~15 out of 26 patches need to be reverted (or less if we are "lucky"), and hopefully without any conflicts...
15:06:10 <hberaud> because maintained projects are stucks by projects with low maintenance...
15:06:28 <frickler> gerrit cannot stack reverts automatically I guess, so it will need some manual work. but I think I would volunteer to do that
15:07:06 <hberaud> frickler: thx
15:07:13 <elodilles> oh, can't it? :-o
15:07:26 <elodilles> i thought it handles that well
15:08:15 <frickler> well I can give it a try
15:08:21 <elodilles> anyway, thanks in advance frickler
15:08:53 <frickler> so we decide to go ahead with that now and collect feedback on the reviews?
15:09:27 <elodilles> frickler: i'm in favor of this approach
15:09:36 <hberaud> let's go
15:10:12 <frickler> ok, maybe I won't complete this today, but before Monday evening
15:10:38 <hberaud> np that will lets time to people to react there
15:11:01 <elodilles> agreed: revert oslo.db and castellan patches that causes problems on service side + contact with TC regarding the way forward
15:11:09 <elodilles> is this OK then ^^^ ?
15:11:18 <hberaud> lgtm
15:11:25 <frickler> hmm, thinking about it a bit, the patches were all on master, so I think gerrit would place the revert onto master, too
15:11:37 <frickler> so need to do it locally, but that should be fine
15:11:46 <dmendiza[m]> Would be good to check with the Octavia folks to make sure they're not using the new Castellan APIs
15:12:07 <frickler> dmendiza[m]: new castallan isn't in u-c, so I doubt they would
15:12:19 <dmendiza[m]> ack
15:12:23 <hberaud> frickler: and what's about services already migrated
15:12:48 <frickler> all testing is using oslo.db 12.x currently due to u-c
15:12:55 <hberaud> where Stephen's patches are already merged on the service side
15:12:56 <frickler> and castellan 4.1.0
15:13:02 <elodilles> unless they use directly from master branch, what they shouldn't by default (though it's good to test against master branch in advance)
15:13:11 <frickler> so they all should work with that, too
15:13:42 <elodilles> as frickler says. they use 12.3.1
15:13:52 <elodilles> so that's good.
15:13:56 <zigo> After B is released, I'd appreciate *a lot* if we can track all missing patches for SQLA 2.x...
15:14:06 <elodilles> zigo: ++
15:14:09 <zigo> (so I can backport them in packages...)
15:14:13 <elodilles> OK, so:
15:14:21 <elodilles> #agreed: revert oslo.db and castellan patches that causes problems on service side + contact with TC regarding the way forward
15:14:26 <elodilles> #agreed revert oslo.db and castellan patches that causes problems on service side + contact with TC regarding the way forward
15:14:48 <zigo> The current sqla-20 tag isn't good enough, cause it includes what's currently already merged.
15:15:09 <elodilles> i'll add a task to next week to track this on etherpad as well
15:15:21 <hberaud> thx
15:16:03 <zigo> Cheers.
15:16:30 <frickler> zigo: we can only have one topic in gerrit, and I don't think changing the current one halfway through is a good idea
15:16:43 <frickler> so we'd need to do some extra tracking
15:16:53 <zigo> Agreed, an etherpad is probably better...
15:17:01 <frickler> or you need to filter what's not in 2023.2
15:17:48 <fungi> sorry, had to step away for a moment. is there any risk that some services have merged changes depending on things that have merged in newer oslo.db from this cycle? or has constraints saved us from that?
15:18:04 <frickler> fungi: the latter should hold true
15:18:26 <elodilles> yepp (fingers crossed)
15:18:27 <fungi> mainly make sure we watch out for oslo.db 15.0.0 breaking services that now need something which got reverted
15:18:42 <fungi> hopefully won't come up
15:18:50 <frickler> well the reqs bump should catch that
15:18:55 <fungi> agreed
15:19:22 <fungi> at least for anything that's tested on the reqs change anyway
15:19:49 <elodilles> yepp :S
15:20:22 <frickler> yes, but the number of cross jobs is pretty high. also only unit tests mostly, but we can't check everything
15:20:39 <elodilles> hberaud: as an oslo core member, could you track this task? i can take over other tasks from next week if that helps you
15:20:53 <hberaud> yeah
15:21:23 <frickler> any special topic to use for the reverts?
15:21:59 <hberaud> "revert-oslo.db-sqla2"?
15:22:05 <elodilles> hberaud: thanks!
15:22:15 <hberaud> "revert-oslo.db-sqla2-bobcat"
15:22:42 <frickler> and "revert-castellan-bobcat", then?
15:22:47 <elodilles> ++
15:22:48 <hberaud> yeah
15:23:03 <zigo> "unf...-everything" ? :)
15:23:10 <fungi> i wonder what the release notes for those are going to end up looking like
15:23:47 <fungi> since i don't think reverting release notes actually removes them
15:23:53 <frickler> well the release notes for oslo.db 15.0.0 would be empty, but we should likely add some explaining
15:24:02 <fungi> so probably there needs to also be a change merged... yeah that
15:24:09 <elodilles> fungi: we can check it as we did this already in the past :/
15:24:30 <elodilles> frickler: +1, some explanation would be helpful
15:25:07 <elodilles> anyway, we are quite overtime on the meeting, so let's move on
15:25:14 <fungi> i think this must be the longest release team meeting in many years
15:25:15 <hberaud> sorry, I need to go grabbing my kids at school
15:25:28 <elodilles> the discussion can be continued after the meeting
15:25:36 <elodilles> hberaud: ack
15:25:42 * hberaud afk
15:26:01 <elodilles> fungi: i think so, too :/ sorry for that
15:26:19 <fungi> no need to apologize! just an observation
15:26:28 <elodilles> #topic "Assign next week tasks"
15:26:34 <elodilles> all tasks taken
15:26:55 <elodilles> #topic Review countdown email
15:27:06 <opendevreview> Yasufumi Ogawa proposed openstack/releases master: Release tacker RC1 for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/894717
15:27:06 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
15:27:21 <elodilles> please review the mail ^^^
15:28:30 <frickler> should that mail mention oslo.db and castellan maybe?
15:28:45 <elodilles> frickler: good point
15:29:11 <elodilles> let me add something about them
15:30:45 * elodilles is searching for the mail thread link
15:34:19 <elodilles> added a dramatic 'Warning' to the mail
15:35:38 <elodilles> OK, let's move on, I'll send the mail some time later today
15:35:53 <elodilles> #topic Open Discussion
15:36:07 <elodilles> any other hot topic? :)
15:37:16 <frickler> https://review.opendev.org/c/openstack/releases/+/894630 would be nice, but nothing urgent
15:37:51 <elodilles> frickler: ACK, I'll review it :)
15:38:26 <elodilles> OK if nothing else, then
15:38:32 <elodilles> thanks for your patience and for your participation in the meeting!
15:38:37 <elodilles> #endmeeting