13:00:03 <elodilles> #startmeeting releaseteam
13:00:03 <opendevmeet> Meeting started Fri May 17 13:00:03 2024 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:03 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:03 <opendevmeet> The meeting name has been set to 'releaseteam'
13:00:07 <hberaud> o/
13:00:13 <elodilles> Ping list: release-team elod
13:00:15 <frickler> \o
13:00:21 <elodilles> #link https://etherpad.opendev.org/p/dalmatian-relmgt-tracking
13:00:42 <elodilles> we are @ L97
13:00:50 <elodilles> o/
13:00:58 <elodilles> Dalmatian-1 ~o~
13:01:44 <hberaud> life is too short...
13:02:03 <ttx> o/
13:02:05 <elodilles> and development cycles fly by
13:02:09 <elodilles> let's start!
13:02:18 <elodilles> #topic Review task completion
13:02:37 <elodilles> 1st task: 'Ensure that all trailing projects have been branched for the previous series. (elod)'
13:02:46 <elodilles> kayobe (kolla) and openstack-ansible were not branched
13:02:54 <elodilles> https://review.opendev.org/q/topic:caracal-trailing-branch-cut
13:03:06 <elodilles> patches proposed but teams responded with -1 ^^^
13:03:40 <elodilles> so we have to keep an eye on these and follow up later
13:03:57 <elodilles> 2nd task: 'Propose autoreleases for cycle-with-intermediary libraries which did not release since the previous release. (elod)'
13:04:10 <elodilles> https://review.opendev.org/q/topic:dalmatian-milestone-1
13:04:21 <elodilles> patches were generated ^^^
13:04:51 <elodilles> many deliverables had only non-functional changes, so around half needed a release patch
13:05:38 <elodilles> and as you can see there are many without response from team
13:06:20 <elodilles> i've +2+PTL-Approved+1'd them, so I think it's OK to proceed with them
13:06:32 <elodilles> if you'll have time to review
13:06:45 <ttx> Time to fill out the team reponse scorecard at the bottom of the etherpad!
13:07:13 <elodilles> hmmm, right, let me add details quickly
13:11:32 <elodilles> done
13:12:23 <elodilles> move on then:
13:12:55 <elodilles> 3rd task: 'Catch if there are acl issues in newly created repositories (ttx)'
13:13:06 <elodilles> * puppet-ceph triggered an issue, but was exempted recently
13:13:15 <elodilles> * updated aclissues to reflect that: https://review.opendev.org/c/openstack/releases/+/919928
13:13:23 <elodilles> anything to add ttx ?
13:13:56 <ttx> oh sorry
13:14:13 <ttx> Not much to add...
13:14:20 <elodilles> ACK
13:14:37 <elodilles> 4th task: 'Process Unmaintained transitioning patches for stable/zed (all)'
13:14:38 <ttx> We could change the code so that it's more granular (per repo instead of per-team) but that will do for now
13:14:57 <elodilles> ttx: +1
13:14:58 <ttx> Linking back to the change with the decision is a great improvement already
13:17:15 <elodilles> ACK
13:17:37 <elodilles> so, about the zed to unmaintained/zed:
13:17:41 <elodilles> https://review.opendev.org/q/topic:zed-unmaintained+is:open
13:18:21 <elodilles> we still have 2 patches to sort out,
13:19:02 <elodilles> but these are special cases
13:19:42 <elodilles> winstackers -> needs EOL rather
13:20:55 <elodilles> and openstack-ansible patch needs an update
13:21:32 <elodilles> #action elod to move winstckers to EOL and update OSA zed-unmtained patch
13:21:39 <elodilles> i'll take care of these ^^^
13:22:03 <ttx> sounds good
13:22:08 <elodilles> these were all of the tasks!
13:22:21 <elodilles> #topic Assign R-19 and R-18 week tasks
13:22:43 <ttx> I'm mostly traveling next week
13:23:20 <elodilles> ACK
13:23:29 <hberaud> will be a short one week for me too
13:23:47 <ttx> we need a meeting chair for the meeting in two weeks
13:23:53 <elodilles> a bit shorter to me, too, though it still will be 4 days to me :)
13:24:11 <elodilles> thx hberaud :)
13:24:15 <hberaud> taken
13:24:27 <elodilles> just like the tasks! thanks everyone!
13:24:30 <elodilles> move on then
13:24:48 <elodilles> #topic Review countdown email for week R-19
13:24:59 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
13:25:03 <elodilles> please review ^^^
13:25:09 <elodilles> one thing to mention:
13:25:19 <elodilles> i'm not sure about the 'goals'
13:25:31 <elodilles> are they still active goals?
13:25:50 <elodilles> it looks like stale tasks
13:25:53 <ttx> yeah, I was about to ask
13:26:02 <elodilles> e.g. migrate to jammy :S
13:26:12 <ttx> IIRC last cycle we skipped that mention.. Let me doublecheck
13:26:17 <elodilles> should be more like noble :)
13:26:21 <frickler> srbac is still active afaict
13:26:39 <elodilles> yes, that one is a long standing task, that's true
13:27:03 <ttx> Lat cycle we just said "Teams should now be focused on feature development."
13:27:03 <elodilles> so this somewhat feels half-relevant
13:27:17 <ttx> the TC has not set goals for a while now
13:27:25 <elodilles> yes
13:27:26 <frickler> I'll take updating/checking that list to the TC
13:27:28 <ttx> so I support just saying "feature development"
13:27:31 <elodilles> at least not 'cycle goals'
13:27:43 <elodilles> ttx: +1
13:27:44 <hberaud> lgtm
13:27:47 <elodilles> frickler: thanks!
13:28:13 <elodilles> mail updated
13:28:14 <ttx> We might want to edit the template if goals are not going to come back
13:29:11 <frickler> well we have some in the pipeline like eventlet deprecation
13:29:12 <ttx> lgtm
13:29:29 <frickler> but no consensus on the path forward yet
13:29:37 <frickler> +1 to the mail
13:29:39 <elodilles> yeah, that one, too :S
13:30:03 <elodilles> anyway, frickler can you update us with info from TC next time?
13:30:22 <frickler> not sure it will happen that fast, but I'll try to
13:30:29 <elodilles> we could wait with the template update until that is disclosed
13:30:31 <elodilles> ACK
13:31:05 <elodilles> anyway, thanks for the reviews, i'll send the mail after the meeting some time
13:31:23 <elodilles> #topic Open Discussion
13:31:26 <elodilles> we have one topic:
13:31:46 <elodilles> #info (frickler) Automated EOL for feature branches
13:31:54 <elodilles> #link https://review.opendev.org/c/openstack/releases/+/917788/1
13:32:05 <elodilles> #link https://review.opendev.org/c/openstack/releases/+/900810
13:32:17 <frickler> I found these while looking at open reviews, not sure how to best proceed
13:32:39 <elodilles> so these are about feature + bugfix branches
13:32:58 <frickler> on one hand I'd like to see those feature branches go away, otoh not sure how much we actually want to get involved
13:33:43 <elodilles> and note, that these are only the branches/deliverables that are listed on releases repo
13:34:53 <frickler> well https://review.opendev.org/c/openstack/releases/+/917781 would want to add tags for branches that aren't listed currently
13:36:05 <frickler> if we want to proceed, some agreement on the actual tag name structure would be needed first I guess
13:36:09 <elodilles> right. so, so far only *deliverables* that are listed in releases repo
13:36:11 <ttx> No strong opinion, I would be fine not getting involved
13:36:28 <ttx> we handle master and stable branches already, it feels like that's enough :)
13:36:47 <hberaud> +1 with ttx
13:37:48 <frickler> well we kind of added the handling of unmaintained branches already
13:38:16 <hberaud> at first glance I think it complexify things more than something else
13:38:18 <frickler> which aren't directly release related, so maybe we already crossed a line there
13:39:41 <ttx> I'm fine with the tooling handling it
13:39:53 <elodilles> frickler: true, series-eol and series-eom were not directly release related, but still, they are somewhat closer i'd say
13:40:02 <ttx> But I would not necessarily track those
13:40:31 <hberaud> feature branches, are just feature branches, not sure to see the point with eoling them...
13:40:56 <frickler> so you'd just delete them without a trace?
13:41:04 <hberaud> yeah
13:42:07 <frickler> and you'd let teams do that manually? or how would there be tooling for that if we have no record?
13:42:14 <ttx> That's an option. They were meant as glorified sets of changes
13:42:26 <hberaud> manually
13:42:57 <frickler> and does the same hold for bugfix branches or are those different?
13:43:33 <hberaud> good question, I think bugfix branches are slightly different use cases
13:43:53 <hberaud> IMO
13:45:07 <elodilles> ironic team handled bugfix branches manually, but by some accident, our tooling re-created some of the branches, so i think that's where the automation idea came from, mainly. (that bug i think (and hope) is fixed in our tooling)
13:45:22 <hberaud> a feature branch, if implementation on it is done, is supposed to be reintegrated somewhere in the official branches
13:45:50 <ttx> yeah I could see making a case for eoling bugfix branches
13:46:23 <hberaud> a feat branch is IMO a temp branch dedicated to develop a feature and basta
13:46:56 <elodilles> yepp that makes sense ^^^
13:47:11 <hberaud> but naming and semnatic can diverge between teams... maybe they are seeing feature branches like bugfix branches... don't know
13:47:25 <hberaud> but that's my definition of a feature branch
13:47:41 <frickler> ok so let's maybe check with timburke whether they can agree to that
13:47:44 <hberaud> something temporary
13:47:53 <hberaud> ok
13:48:10 <frickler> and then I'll try with rpittau to proceed with the bugfix patch
13:48:45 <elodilles> frickler: ACK, thanks in advance!
13:49:31 <elodilles> anything else to discuss?
13:49:59 <hberaud> nope
13:50:24 <frickler> well we had gmann's proposal for eoling stable branches of retired projects
13:50:33 <frickler> (half my idea I admit)
13:50:59 <frickler> #link https://review.opendev.org/c/openstack/project-team-guide/+/919608
13:52:29 <ttx> makes sense I think?
13:52:29 <elodilles> oh, i haven't reviewed that yet
13:52:39 <elodilles> to me it's a bit too harsh to directly EOL those stable branches, but I don't object if that is the decision
13:53:06 <elodilles> i mean, we close the option to people show up as maintainers for those repos
13:53:18 <elodilles> but i know that it is quite unlikely
13:53:48 <frickler> there should be at least 6 months of inactivity before retirement happens
13:54:17 <elodilles> and even inactivity haven't come out of the blue :)
13:54:21 <elodilles> so that's true
13:54:32 <frickler> and a repo could always be un-retired again
13:54:49 <elodilles> i mean some of these repos were just inactive through multiple cycles :/
13:54:50 <hberaud> It won't hurt IMO
13:55:00 <frickler> the opposing concern that on not doing this, people could continue using the stable branch without noticing the retirement
13:55:10 <elodilles> so as I said, i don't object o:)
13:55:34 <elodilles> frickler: that's also true
13:56:16 <elodilles> anyway, feel free to ping me for reviews to those EOL patches and I can +2 them
13:56:37 <frickler> those still need to be created iiuc, but will do
13:56:44 <elodilles> ++
13:56:46 <frickler> gmann: ^^
13:57:17 <elodilles> any other topic to the remaining 3 minutes? :)
13:57:45 <ttx> would not mind having them back before jumpiung on my next meeting :)
13:57:55 <elodilles> :)
13:58:04 <elodilles> thanks everyone then! o/
13:58:06 <elodilles> #endmeeting