13:00:19 <elodilles> #startmeeting releaseteam
13:00:19 <opendevmeet> Meeting started Fri Sep  6 13:00:19 2024 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:19 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:19 <opendevmeet> The meeting name has been set to 'releaseteam'
13:00:26 <elodilles> Ping list: release-team elod armstrong
13:00:36 <elodilles> #link https://etherpad.opendev.org/p/dalmatian-relmgt-tracking
13:00:57 <ttx> o/
13:01:00 <elodilles> we are way down at L353
13:01:04 <elodilles> o/
13:01:08 <ttx> (very jetlagged but here)
13:01:22 <elodilles> :S
13:01:43 <frickler> \o
13:02:12 <elodilles> ~o~
13:02:15 <elodilles> let's start!
13:02:25 <elodilles> #topic     Review task completion
13:02:36 <elodilles> Process any remaining client library freeze exception. (all)
13:02:50 <elodilles> #link https://review.opendev.org/q/topic:dalmatian-milestone-3+is:open
13:03:08 <elodilles> 1 patch left ^^^
13:03:21 <elodilles> I've updated it a couple of hours ago
13:03:44 <elodilles> i'd appreciate some review on that, and i think we can override PTL-Approved+1
13:03:57 <elodilles> as Hao was OK with the release
13:04:02 <frickler> ack
13:04:22 <elodilles> #link https://review.opendev.org/q/topic:dalmatian-no-merges+is:open
13:04:30 <frickler> do we want to amend and add the stable branch creation right away?
13:04:30 <elodilles> this is empty \o/
13:04:51 <elodilles> frickler: that's an option :)
13:05:00 <elodilles> let me add that
13:05:36 <opendevreview> Merged openstack/releases master: [nova] Create 2024.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/927929
13:05:38 <opendevreview> Merged openstack/releases master: [ironic] Create 2024.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/927935
13:07:38 <opendevreview> Elod Illes proposed openstack/releases master: Release final python-zaqarclient for 2024.2 Dalmatian  https://review.opendev.org/c/openstack/releases/+/927139
13:07:44 <elodilles> there it is ^^^
13:08:42 <frickler> thx
13:09:20 <opendevreview> Merged openstack/releases master: [vitrage] Create 2024.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/927951
13:09:22 <opendevreview> Merged openstack/releases master: [keystone] Create 2024.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/927943
13:09:25 <opendevreview> Merged openstack/releases master: [Telemetry] Create 2024.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/927940
13:09:27 <opendevreview> Merged openstack/releases master: [mistral] Create 2024.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/927933
13:09:29 <opendevreview> Merged openstack/releases master: [glance] Create 2024.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/927948
13:09:51 <elodilles> just a note, that we had some client libs that had release this week, officially we should have RFE requests for them, but as far as i see their versions are bumped in upperc-constraints.txt o:)
13:10:41 <elodilles> i might drop an email with RFE's just for the record :X
13:11:11 <frickler> I think this is a bit of unclear distribution of responsibilities, the reqs team will likely approve anything bot-generated based on release team approvals
13:12:43 <elodilles> frickler: hence we send the notification of '-2 all open patches [..]' o:)
13:13:09 <elodilles> but yes, these are some formal stuff and we had more 'late releases' recently
13:13:40 <elodilles> so we should have RFE mails for those anyways and we should have merged the version bumping patches anyways :X
13:13:56 <opendevreview> Carlos Eduardo proposed openstack/releases master: [manila] Add 2024.2/Dalmatian cycle highlights  https://review.opendev.org/c/openstack/releases/+/928281
13:14:05 <frickler> elodilles: that notification explicitly ends with "... but do approve changes for new OpenStack deliverable releases."
13:14:25 <elodilles> note2: i saw that openstacksdk and oslo.policy's 'new-release' patches succeeded on zuul and they were merged last weekend \o/
13:14:50 <elodilles> frickler: ah, you are right
13:14:58 <opendevreview> Merged openstack/releases master: [barbican] Create 2024.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/927947
13:15:48 <elodilles> nevertheless, the important thing is that we have the releases and they are bumped (except zaqarclient) already in upper-constraints \o/
13:15:52 <frickler> sdk is fine, osc isn't afaict
13:16:10 <elodilles> frickler: oh, so we still have one that is pending?
13:16:12 <ttx> approved last one in topic:dalmatian-milestone-3
13:16:22 <elodilles> ttx: thanks o/
13:16:53 <frickler> elodilles: as mentioned last week, the u-c bump was abandoned. it needs fixes merged in osc and a new release made
13:17:34 <elodilles> frickler: ah, i see
13:17:47 <elodilles> i mismatched it with openstacksdk
13:18:07 <elodilles> so we still have one thing to keep an eye on :/
13:19:14 <elodilles> frickler: by osc you mean python-openstackclient, right?
13:19:14 <frickler> https://review.opendev.org/c/openstack/python-openstackclient/+/925861 is the remaining fix iiuc (cc gtema)
13:19:18 <frickler> yes
13:19:34 <elodilles> ACK
13:19:37 <elodilles> thx
13:20:18 <elodilles> #action release-team: keep an eye on python-openstackclient as it still needs a release and it's upper constraint bump as soon as possible
13:20:25 <elodilles> this ^^^
13:20:30 <frickler> +1
13:20:50 <elodilles> move on then
13:20:56 <opendevreview> Merged openstack/releases master: [tacker] Create 2024.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/927950
13:21:09 <elodilles> next task was:
13:21:12 <elodilles> Early in the week, email openstack-discuss list to remind PTLs that cycle-highlights are due this week so that they can be included in release marketing preparations. (elod)
13:21:22 <elodilles> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/ZWB7UIZEGSYVU7Y5TEHXQ6INBFQPWZY4/
13:21:25 <elodilles> mail sent ^^^
13:21:49 <elodilles> and we got some cycle highlights patches \o/
13:21:57 <elodilles> and some promises as well :)
13:22:44 <elodilles> hope we will have more as i guess marketing folks are eagerly waiting for them
13:23:31 <elodilles> Freeze all cycle-based library releases except for release-critical bugs. Independently-released libraries may still be released, but constraint or requirement changes will be held until after the freeze period. (all)
13:23:49 <elodilles> well, this was just a reminder && guideline for us ^^^
13:23:57 <elodilles> Propose stable/2024.2 branch creation for all client and non-client libraries that had not requested it at freeze time. (frickler)
13:24:09 <elodilles> #link https://review.opendev.org/q/topic:dalmatian-stable-branches
13:24:14 <frickler> ah, that answers the question I had on the docstheme release, though
13:24:48 <frickler> some branch patches still missing because late releases were made
13:24:57 <frickler> I'll send those after the meeting
13:25:21 <elodilles> frickler: ACK, thanks, i'll be around to review and +W them
13:25:39 <elodilles> and thanks too for generating all the branching patches o/
13:26:00 <elodilles> List cycle-with-intermediary deliverables that have not been refreshed in the last 2 months and send email to them (see process for template). (elod)
13:26:13 <elodilles> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/QBNRSPUROJYTF2E3TYZLRPL6WDZTAFXJ/
13:26:22 <elodilles> i've sent it before the meeting
13:27:10 <ttx> looks good
13:27:18 <elodilles> it's not a big list, hopefully we'll get releases soon
13:27:46 <frickler> tempest is already proposed
13:29:01 <elodilles> (note that our script listed some ironic deliverables that were released quite recently, but i've checked those repos and removed from the list)
13:29:18 <elodilles> (but it maybe only because of my env, i'll check)
13:29:34 <elodilles> frickler: yepp, and that won't even be their last release :)
13:30:17 <elodilles> these were all the tasks for this week, i think we are pretty covered
13:30:52 <elodilles> say if you have anything to raise regarding the tasks
13:31:09 <ttx> nope
13:31:19 <elodilles> then next topic:
13:31:24 <elodilles> #topic     Assign R-3 week tasks
13:32:00 <elodilles> thanks ttx for chairing the next meeting o/
13:32:52 <elodilles> i've added my name to the only task that is not for everyone, or taken
13:33:10 <elodilles> #topic     Review countdown email for week R-3
13:33:29 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
13:33:35 <elodilles> please review ^^^
13:35:01 <armstrong> +1
13:35:09 <elodilles> thanks armstrong
13:35:13 <ttx> looks good
13:35:35 <elodilles> then i'll send it later on today, as usual
13:35:56 <elodilles> #topic     Open Discussion
13:36:13 <elodilles> anything to discuss?
13:37:18 <fungi> opendev is bringing a new cloud provider on line, so just keep an eye out for unusual job failures
13:37:43 <opendevreview> Merged openstack/releases master: Release final python-zaqarclient for 2024.2 Dalmatian  https://review.opendev.org/c/openstack/releases/+/927139
13:37:46 <elodilles> oh, good news \o/ thanks for the heads up fungi
13:38:10 <fungi> we're watching it closely as well, but can dial it back/off if something goes wrong
13:39:08 <elodilles> when is that expected to happen?
13:39:16 <fungi> it's in progress already
13:39:25 <elodilles> oh, good
13:39:38 <fungi> we started with one node at a time late utc yesterday and ramped it up to 20 nodes an hour ago
13:39:52 <elodilles> nice
13:40:08 <fungi> chances are we'll increase it more next week if it's looking okay
13:40:26 <elodilles> we'll ping you then if we see any issue
13:40:31 <fungi> please do!
13:40:38 <frickler> although it is not a completely new provider, just a new variant of rackspace, so I don't really expect anything to go wrong
13:40:49 <elodilles> cool \o/
13:41:05 <fungi> it's a ground-up redesign of their public cloud on entirely different versions, hypervisor, etc
13:41:13 <fungi> and in a new region
13:41:20 <elodilles> :-o
13:41:23 <fungi> on all new hardware
13:41:43 <fungi> so it might as well be a completely different provider, aside from the people involved in building and running it
13:42:19 <fungi> also it uses skyline for the webui, first time i've gotten to really poke at a production deployment of that
13:42:37 <elodilles> wow
13:44:46 <elodilles> thanks again, for the heads up, we'll keep an eye on our jobs then :)
13:45:00 <elodilles> anything else to discuss before we close the meeting?
13:47:00 <ttx> mothing from me
13:47:10 <elodilles> if nothing else, then thanks everyone for joining the meeting and let's end now o/
13:47:13 <elodilles> #endmeeting