13:00:31 <elodilles> #startmeeting releaseteam
13:00:31 <opendevmeet> Meeting started Fri Sep 20 13:00:31 2024 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:31 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:31 <opendevmeet> The meeting name has been set to 'releaseteam'
13:00:39 <elodilles> Ping list: release-team elod armstrong
13:00:47 <elodilles> #link https://etherpad.opendev.org/p/dalmatian-relmgt-tracking
13:01:07 <elodilles> we are @ L397
13:01:10 <ttx> o/
13:01:17 <elodilles> ~o~
13:02:29 <elodilles> let's start!
13:02:38 <elodilles> #topic     Review task completion
13:02:51 <elodilles> 1st task was:
13:02:56 <elodilles> '    On Monday, test the release announcement fix (ttx)'
13:03:07 <elodilles> thanks ttx , as we saw, worked well o/
13:03:13 <ttx> yes that was done
13:03:37 <elodilles> 2nd task:
13:03:41 <elodilles> '    On Monday, finally Approve RC1 releases that did not get a -1 (ttx)'
13:03:58 <elodilles> we got a lot of patches merged
13:04:34 <elodilles> unfortunately there are still some that have broken gates and lacks fixes :(
13:04:40 <elodilles> those are:
13:05:09 <elodilles> kuryr-kubernetes, kuryr-libnetwork, zun, ansible-role-thales-hsm
13:05:25 <ttx> OK let me copy those forward to next week tasks
13:05:39 <elodilles> thanks ttx ,
13:05:58 <elodilles> note that we should think about what to do if we won't get updates there
13:06:12 <elodilles> afaik kuryr is about to move to 'inactive'
13:06:22 <ttx> do any of those have someone actively working on them?
13:06:26 <elodilles> (kuryr was taken over by zun team)
13:06:38 <elodilles> ttx: no, that's the problem
13:07:02 <elodilles> i've seen a comment somewhere that we might need to drop them from the release
13:07:08 <elodilles> though we are late in the cycle :(
13:07:22 <fungi> where was the comment?
13:07:25 <ttx> if we don;t have a release we can't release it
13:07:56 <fungi> that certainly seem... tautological yes
13:08:03 <elodilles> fungi: i have to look for it
13:08:24 <elodilles> ttx: the question is whether we release them anyway, with broken gates,
13:08:39 <elodilles> we had to do this in the past once or twice :(
13:08:44 <ttx> ansible-role-thales-hsm is a barbican thing?
13:08:51 <elodilles> yep, barbican
13:09:12 <ttx> I guess we still have some time to get a fix there, can land late
13:09:30 <ttx> Zun/Kuryr is more of a problem
13:09:42 <elodilles> fungi: here is the comment from gmann https://review.opendev.org/c/openstack/releases/+/928531/1#message-347ee36d4b8404e941ddceb2026a998423163f6f
13:09:44 <ttx> Was there a PTL elected there?
13:09:50 <fungi> thanks elodilles
13:10:49 <elodilles> ttx: for zun, yes
13:11:16 <ttx> Still Hongbin?
13:12:02 <elodilles> i think so, but to be honest, i say it because our script added they
13:12:24 <elodilles> as reviewer
13:12:52 <ttx> There was a big holiday in China a few days ago
13:13:05 <elodilles> ah, i see
13:13:23 <elodilles> i can try to drop a mail to hongbin to ask for some help
13:13:24 <ttx> maybe we can get in touch with him via other channels. I'll see what I can do
13:13:52 <elodilles> ttx: ACK, thanks!
13:15:13 <elodilles> anything else to this task?
13:15:34 <ttx> elodilles: you can send Hongbin an email
13:15:42 <elodilles> ttx: ACK, will do then!
13:15:45 <ttx> detailing all the issues and the risk to be dropped from release
13:16:04 <elodilles> #action elod to send a mail to Zun PTL detailing all the issues and the risk to be dropped from release
13:16:16 <ttx> I'll ask Horace our China community manager to ping him on wechat and other solutions to pay attention to his email
13:16:28 <opendevreview> Merged openstack/releases master: Release ironic-inspector 12.3.0 for dalmatian  https://review.opendev.org/c/openstack/releases/+/929764
13:16:33 <elodilles> ttx: sounds like a plan! thanks!
13:17:21 <elodilles> i think that's what we can do about this
13:17:28 <elodilles> so let's move on
13:17:35 <elodilles> 3rd task was:
13:17:40 <elodilles> '    Gracefully release tempest plugins with latest changes available. (elod)
13:17:53 <elodilles> #link https://review.opendev.org/q/topic:dalmatian-tp-latest
13:18:48 <elodilles> i'll double check all the patches after the meeting and i think we should +2+W them as deadline has passed ^^^
13:19:21 <ttx> wait, what about the ansible HSM thing? Did we ping more directly the Barbican PTL?
13:19:23 <elodilles> either today, or if we don't want Friday-releases, then early Monday
13:19:43 <elodilles> ttx: not yet, at least not me
13:20:16 <elodilles> ttx: but i can do that as well
13:20:29 <ttx> yeah... two separate emails
13:20:35 <ttx> direct, not list
13:20:36 <elodilles> ttx: ACK
13:21:00 <ttx> (in retrospect we should probably have done that a week ago :) )
13:21:14 <elodilles> ttx: yeah :(
13:21:18 <fungi> he's xek in #openstack-barbican
13:21:37 <elodilles> ACK
13:21:45 <fungi> "idle: 3 days, 22 hours"
13:21:54 <fungi> so maybe not around this week
13:22:01 <ttx> OK once the email is sent we can add a ping there
13:22:06 <ttx> fire on all channels
13:22:14 <elodilles> +1
13:26:05 <elodilles> can we move on?
13:26:10 <ttx> yes!
13:26:16 <elodilles> ok, sorry :)
13:27:17 <elodilles> so the still open tempest-plugin release patches needs procedural PTL-Approved+1s + reviews + approvals if the patches are still correct
13:27:30 <ttx> fwiw the ansible thing looks easy enough to fix
13:27:30 <elodilles> either today or early Monday
13:27:54 <elodilles> ttx: that's promising then
13:28:19 <ttx> I might do it on Monday
13:28:24 <elodilles> ACK
13:28:31 <elodilles> 4th task was:
13:28:34 <elodilles> '    On the Monday, generate stable branches for all cycle deliverables that are still missing one (ttx)'
13:28:39 <ttx> but would be better if someone who knows what they are doing fixed it
13:28:54 <ttx> yes, so that one resulted in :
13:29:06 <ttx> #link https://review.opendev.org/c/openstack/releases/+/929409
13:29:14 <ttx> which should be ready to merge about now
13:29:51 <ttx> you can +2a it it will be processed after the inspector release
13:30:26 <elodilles> inspector released already merged :)
13:30:38 <elodilles> s/released/patch/
13:30:38 <ttx> alright +2a
13:30:53 <elodilles> ~o~
13:30:54 <elodilles> cool
13:31:08 <elodilles> '    After all the projects enabled in devstack by default have been branched, we can engage with the (elod)'
13:31:12 <elodilles> so
13:31:21 <elodilles> about this task ^^^
13:31:35 <elodilles> i haven't started it as we were not there yet
13:31:59 <ttx> maybe push it to Monday?
13:32:16 <elodilles> ACK, adding it to next week
13:32:30 <dansmith> elodilles: well, it was the latest when I updated that patch a few minutes after it landed :/
13:33:22 <elodilles> dansmith: yeah, i saw :) but i was sleeping at that time o:) (sorry, we are on meeting now)
13:33:32 <dansmith> (oh sorry)
13:34:01 <elodilles> 6th task:
13:34:04 <elodilles> '    Ensure that all projects that are publishing release notes have the notes link included in their deliverable file. (elod)'
13:34:16 <elodilles> #link https://review.opendev.org/q/topic:dalmatian-releasenotes
13:34:52 <elodilles> still not all, but quite many reno link added already
13:35:45 <elodilles> and we have a task for release day to do another round
13:36:20 <elodilles> so should be OK (and I'll run another round before that, to land them earlier)
13:36:42 <elodilles> and a semi-task was:
13:36:46 <elodilles> '    Let cycle-with-rc projects iterate on RCs as needed. The final release candidate for each project needs to be prepared at least one week before the final release date. (all / guideline)'
13:36:58 <elodilles> "storlets needs a RC2 to deal with  https://bugs.launchpad.net/python-openstackclient/+bug/2080600"
13:37:11 <elodilles> "probably means we need an python-openstackclient release too"
13:37:51 <ttx> maybe that was solved by the pin
13:37:54 <elodilles> has anyone see what happened with storlets?
13:38:18 <elodilles> i don't remember seeing RC2 from storlets
13:38:25 <ttx> tkajinam might know if anything more is needed there
13:39:09 <elodilles> oh, you mean the python-openstackclient<7.0.0 capping "solved" storlets problem as well?
13:39:42 <opendevreview> Merged openstack/releases master: stable/2024.2 branches for Ironic deliverables  https://review.opendev.org/c/openstack/releases/+/929409
13:40:47 <elodilles> i see that one patch merged to storlets stable/2024.2
13:41:29 <ttx> well if the issue was a 7.x regression I bet it did solve it
13:41:54 <elodilles> but anyway, next week is final rc week, so it is still possible to do an RC2 if needed
13:42:12 <ttx> yes, I'd let it flow
13:42:17 <elodilles> +1
13:43:01 <elodilles> about python-openstackclient: it is capped to <7.0.0 && 7.1.2 released, just in case... but cap is not removed
13:43:16 <elodilles> i wonder if we might be able to remove the cap next week?
13:43:25 <elodilles> or is that a far-fetched dream of mine? :)
13:45:23 <fungi> it should be possible to push a revert of the cap and then depends-on it with dnm changes in nova and storlets
13:45:34 <ttx> hmm
13:45:45 <ttx> Shouldn't the cap stay on stable/2024.2?
13:46:06 <fungi> not if we want it to reflect the versions on the releases site
13:46:29 <ttx> wouldn't that break Nova again? I mean, we did cap it for a reason
13:46:31 <fungi> since we're saying python-openstackclient 7.1.2 is the 2024.4/dalmatian version
13:46:51 <fungi> i thought 7.1.2 had the (latest) presumed fix for nova's issue
13:47:33 <elodilles> ttx: it might, i haven't looked closely whether nova folks merged a fix at the end. but as fungi says, we have to check it with a DNM patch maybe.
13:47:38 <ttx> i thought we did not have enough trust in current OSC to ship it as a dependency
13:47:54 <elodilles> and of course, if there are objection from any team, then we stay with capping <7.0.0
13:48:08 <ttx> oh sure
13:48:25 <elodilles> fungi: yes, you are right, 7.1.2 meant to fix the nova issue
13:48:30 <fungi> where i thought we ended up was that the <7 cap was a hopefully temporary measure to unblock nova's tests so they could get rc1 tagged asap
13:49:05 <fungi> and that we could possibly lift the cap again either during the rc period or even after release day
13:49:13 <elodilles> yes, that was my understanding as well
13:49:51 <elodilles> anyway, we can test that next week
13:49:53 <fungi> so that the stable/2024.2 branch is still viable. otherwise how do we, say, backport a security fix there if we don't consider it usable
13:49:58 <elodilles> let's move on as time is flying
13:50:13 <elodilles> fungi: +1
13:50:43 <elodilles> #topic     Assign R-1 week tasks
13:50:50 <elodilles> as i see all tasks taken
13:50:53 <elodilles> thx ttx o/
13:51:04 <elodilles> #topic     Review countdown email for week R-1
13:51:12 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
13:51:16 <elodilles> please review ^^^
13:51:55 <ttx> fwiw Horace is spaeking with Hongbin on wechat right now. I pointed them to the dnm patches, but would be good to sent the more complete email soon after meeting
13:52:21 <elodilles> ttx: will do
13:53:02 <ttx> email looks good after a couple fixes
13:54:01 <elodilles> cool, thanks
13:54:15 <elodilles> #topic     Open Discussion
13:54:21 <elodilles> anything to discuss?
13:54:47 <ttx> I started filling the "things to change" section of the doc
13:54:55 <ttx> Re: PTG I booked a run at our usual meeting time
13:55:06 <ttx> booked a room
13:55:12 <elodilles> +1+1+1
13:55:15 <ttx> that is all from me
13:55:17 <elodilles> and thanks :)
13:55:38 <fungi> an early heads up that i'll probably miss the release team session at the ptg, i've got some more family travel that's come up on short notice which will impact my ptg friday, but i'll catch up from the notes
13:55:58 <ttx> let me know when the Hongbin email is sent so that I let them know to expect it
13:56:25 <elodilles> fungi: ack, thanks for letting us know
13:56:39 <elodilles> ttx: ACK
13:57:22 <ttx> looks like uncap was proposed at https://review.opendev.org/c/openstack/requirements/+/929938
13:58:46 <elodilles> well, it's a bit confusing as we haven't branched yet with requirements repo, but the uncap needs to be tested there (though stable/2024.2 is still master for requirements)
13:59:42 <elodilles> but sure, we can use that for testing :)
13:59:54 <elodilles> anything else before we run out of time? :)
14:00:15 <fungi> the comments say it's already tested from a nova depends-on
14:00:28 <fungi> i commented suggesting doing the same for storlets
14:00:41 <elodilles> good, even better then \o/
14:01:04 <elodilles> let's close the meeting, but we can continue the discussion after the meeting
14:01:11 <elodilles> thanks everyone for participating o/
14:01:15 <elodilles> #endmeeting