14:00:06 <elodilles> #startmeeting releaseteam
14:00:06 <opendevmeet> Meeting started Fri Jan 24 14:00:06 2025 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:06 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:06 <opendevmeet> The meeting name has been set to 'releaseteam'
14:00:15 <elodilles> Ping list: release-team armstrong
14:00:34 <elodilles> #link https://etherpad.opendev.org/p/epoxy-relmgt-tracking
14:00:57 <elodilles> we are at line 215
14:01:06 <elodilles> o/
14:01:15 <ttx> o/
14:01:28 <armstrong> o/
14:02:18 <frickler> \o
14:02:23 <elodilles> let's start!
14:02:35 <elodilles> #topic Review task completion
14:02:44 <elodilles> '    Generate a list of intermediary-released service deliverables that have not done a release in this cycle yet (ttx)'
14:02:59 <elodilles> i see a list of deliverables here:
14:03:01 <elodilles> horizon
14:03:06 <elodilles> bifrost ironic-inspector ironic-prometheus-exporter ironic-python-agent-builder ironic-ui networking-baremetal networking-generic-switch
14:03:13 <elodilles> release-test, requirements
14:03:17 <elodilles> swift
14:03:30 <elodilles> ---
14:03:46 <frickler> requirements doesn't do any releases at all? that one got me confused
14:04:09 <elodilles> well, release-test and requirements repos are just 'noise'
14:04:36 <ttx> yeah, definitely not  thing we'd change the release model of
14:04:39 <elodilles> we don't require any release from those repos
14:05:42 <elodilles> what about the others?
14:06:23 <ttx> i think those are pretty classic, no need to suggest a switch
14:06:35 <ttx> horizon is the only one we could ask about
14:06:47 <ttx> since they used to be cycle-with-rc and switched
14:07:17 <elodilles> yeah i remember some of these appear on this list time to time
14:07:17 <ttx> so we could ask them if they still want the ability to release multiple times in a cycle
14:07:31 <ttx> ironic and Swift we had that discussion multiple times already
14:07:38 <elodilles> yepp
14:07:42 <ttx> no need to reignite it
14:07:48 <elodilles> +1
14:08:20 <ttx> but yes, we could ask for Horizon
14:08:28 <elodilles> let's do that then
14:08:42 <ttx> I'll add an action towards that in the tracker
14:08:50 <elodilles> thanks o/
14:09:00 <elodilles> cool
14:09:22 <elodilles> next task then:
14:09:28 <elodilles> '    Once https://review.opendev.org/c/openstack/governance/+/938938 is done:'
14:09:35 <elodilles> Merge https://review.opendev.org/c/openstack/releases/+/938780  (all)
14:09:42 <elodilles> Add Freezer back to OpenStack map (ttx)
14:09:58 <elodilles> as far as I can see the governance patch is not yet merged :/
14:10:09 <ttx> yeah, so we should push it back
14:10:20 <ttx> I'll copy it over to next weeks
14:10:37 <elodilles> ACK, thanks again
14:10:55 <elodilles> that's all then about this topic
14:11:10 <elodilles> #topic Assign R-8 week tasks
14:11:41 <ttx> al set!
14:11:44 <ttx> all*
14:11:49 <elodilles> \o/
14:12:06 <elodilles> #topic Review weekly countdown email
14:12:18 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:13:06 <elodilles> so the question is whether we want to send it at all
14:13:33 <elodilles> 1st part is about the release model change (above discussed task)
14:13:48 <ttx> yeah... we could skip it
14:14:13 <elodilles> or just advertise 2025.2 Flamingo release schedule proposal patch
14:14:29 <elodilles> ttx: did you have the time to think about the schedule patch?
14:14:44 <elodilles> should we advertise that to PTLs?
14:14:56 <elodilles> and ML?
14:15:01 <ttx> yeah I think it works, so we should ask people on the list to review it
14:15:11 <ttx> but probably a specific thread rather than release countdown
14:15:48 <elodilles> ok, i was thinking about here in the release countdown, but you are right
14:16:17 <elodilles> #action elod to send mail about 2025.2 Flamingo release schedule proposal patch
14:16:30 <elodilles> i'll send it after the meeting
14:16:40 <elodilles> and skip the release countdown mail then
14:17:01 <frickler> +1
14:17:04 <elodilles> #topic Open Discussion
14:17:13 <elodilles> anything to discuss?
14:17:27 <fungi> i didn't have anything
14:17:38 <frickler> couple of things I mentioned earlier
14:17:53 <frickler> seems the validation is failing only for eom branches here: https://review.opendev.org/c/openstack/releases/+/939950 so do we keep them with the old team or does someone want to fix the validation?
14:18:13 <elodilles> awww
14:18:21 <frickler> checking https://review.opendev.org/c/openstack/releases/+/938510/1 so we are prepared for the pbr beta release
14:18:26 <elodilles> let's keep them the old team for EOM branches
14:18:41 <elodilles> i don't want to rewrite history anyway... :S
14:19:26 <frickler> also the ensure-twine fix for noble needs more work https://review.opendev.org/c/zuul/zuul-jobs/+/940074
14:19:26 <ttx> approved 938510
14:19:41 <ttx> maybe wait until monday to approve the PBR release though
14:19:47 <frickler> ok, so I'll amend 939950 again, then
14:20:10 <frickler> the pbr patch is still waiting for PTL feedback anyway? at least it was earlier today
14:20:36 <elodilles> yep, let's keep it open until monday
14:21:27 <elodilles> #action approve PBR beta release patch on early Monday
14:21:31 <frickler> I would have hoped to be able to revert 2023.1 to eom today, but we're not there yet. or do we want to re-revert another cycle next week?
14:21:32 <elodilles> is this OK ^^^ ?
14:22:17 <frickler> I think that's fine, yes
14:22:20 <ttx> ack
14:22:39 <ttx> works for me
14:22:46 <elodilles> frickler: meh, let's just wait and try to finalize things for 2023.1 asap next week :/
14:23:43 <elodilles> i imagined this as a quick, one shot merge of stack of patches within some hours, but obviously i was too optimistic
14:24:20 <frickler> yes, too many skeletons in the closet ;)
14:24:48 <frickler> anyway, that's it from me I guess
14:24:56 <elodilles> ACK
14:25:06 <elodilles> thanks for bringing these up frickler !
14:25:15 <elodilles> anything else?
14:26:22 <elodilles> silence indicates me that we don't have other things to discuss :)
14:26:34 <elodilles> so thanks everyone for participating
14:26:44 <elodilles> #endmeeting