11:59:59 <tonyb> #startmeeting requirements
12:00:00 <openstack> Meeting started Wed Jun  1 11:59:59 2016 UTC and is due to finish in 60 minutes.  The chair is tonyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:03 <openstack> The meeting name has been set to 'requirements'
12:00:22 <tonyb> Roll call Who's here for the requirements meeting?
12:00:53 <coolsvap> Hello
12:00:57 <coreycb> o/
12:00:57 * coolsvap is
12:01:37 <tonyb> I think dims is sleeping, prometheanfire is on vacation
12:01:55 <dirk> Hey
12:02:01 <tonyb> dirk: hey.
12:02:29 * dirk is on vacation as well
12:02:45 <tonyb> dirk: Wel thanks for being here then :)
12:03:06 <tonyb> Anything in the review queue that stands out?
12:03:24 <tonyb> coolsvap: has a bunch of cruft cleaning reviews up
12:03:55 <coolsvap> yes
12:03:56 <dirk> There was a ping recently
12:04:27 <dirk> https://review.openstack.org/315348
12:05:00 <dirk> I am not sure what this one is waiting for..
12:05:13 <tonyb> dirk: Yeah .... doug/dims to review it
12:05:29 <dirk> I'm still trying to find time to go through coolsvap 's reviews
12:05:40 <dirk> But family is first this week..
12:05:53 <tonyb> dirk: good plan
12:06:10 <coolsvap> dirk, sure take your time :)
12:06:14 <tonyb> I'm also looking at coolsvap's reviews when I get free cycles
12:06:35 <coolsvap> i just got some free and uploaded the reviews
12:06:49 * tonyb wonders if 315348 is blocking anything?
12:07:18 <tonyb> coolsvap: Thanks.  That kind of curation takes time and energy
12:08:33 <dirk> tonyb I guess it does - there is no reason given though
12:08:54 <coolsvap> tonyb, can you add action-item to dims/dhellman to review patch 315348
12:09:12 <dirk> For me it makes sense to cherry pick it although it probably is outside stable policy
12:09:31 <tonyb> #action dims, dhellmann to review https://review.openstack.org/#/c/315348/
12:10:06 <tonyb> Yeah but requirements doesn't have the stable:follow-policy tag so we can be flexible
12:10:26 <tonyb> also for requirements we *really* want a single code base regardless of the branch
12:10:33 <tonyb> it's the data that matters
12:11:08 <dirk> +1
12:11:49 <coolsvap> yeah
12:11:59 * tonyb was thinking abotu how to spilt the code from the data earlier today
12:12:20 <tonyb> can't say I got very far but it's there as a thing to do ...
12:13:02 <tonyb> Anything else for general reviews?
12:13:12 <dirk> Not from me
12:13:21 <coolsvap> no
12:13:33 <tonyb> okay ....
12:13:43 <tonyb> #link https://etherpad.openstack.org/p/requirements-tasks
12:14:00 <tonyb> any of the 16 or so todo items to talk about?
12:14:48 <tonyb> coolsvap: You're the only one game enough to put your name next to an item
12:14:56 <tonyb> coolsvap: how's that going?
12:15:27 <coolsvap> tonyb, remove-cruft is in good progress
12:16:04 <coolsvap> i think by next meeting i will have upto 100% done
12:16:12 <tonyb> coolsvap: great!
12:16:28 <coolsvap> i have updated the https://etherpad.openstack.org/p/requirements-cruft for details of the packages
12:16:55 <coolsvap> which are removed
12:17:12 <tonyb> coolsvap: thanks.
12:17:59 <coolsvap> i am still new to requirements, reviews are most appreciated
12:19:11 <tonyb> coolsvap: +1
12:19:15 <coreycb> coolsvap, I took a pass on several from an ubuntu perspective, hopefully that is useful
12:20:10 <coolsvap> coreycb, yeah
12:21:50 <tonyb> anything else for the uber todo list?
12:22:09 <coolsvap> nothing more from my side
12:23:22 <tonyb> open discussion?
12:24:23 * tonyb started writing a script to "correct" the pip package names.
12:24:46 <coolsvap> tonyb, that is very useful
12:24:56 <tonyb> It's a little tricky as the Requirements class rewrites the specificatons which makes the diff bigger
12:25:16 <tonyb> also I'm not 100% certain we want to do it but it's a fun little script
12:26:10 <coolsvap> tonyb, yeah i think it should be useful considering some package conflicts i have seen in current remove-cruft reviews
12:27:21 <tonyb> coolsvap: my worry is that this will break horribly if it merges
12:27:42 <dirk> Tonyb I actually started that ages ago but ran out of time
12:27:49 <coolsvap> tonyb, once you have some thing ready lets put it on review
12:28:02 <coolsvap> lets test it locally for a month or so as a dry run
12:28:04 <tonyb> coolsvap: will poxix_ipc suddenly cause the bot to fail?
12:28:05 <coolsvap> and improve
12:28:27 <tonyb> Sure
12:29:05 <coolsvap> tonyb, i did not get context for the poxix_ipc question earlier
12:29:08 <dirk> https://review.openstack.org/#/c/207629/
12:29:19 <tonyb> coolsvap: It was poorly worded
12:29:21 <dirk> Ah, toabctl actually started that
12:29:33 <dirk> So, yes, it will cause an issue with the bot
12:29:42 <dirk> Didn't.het around fixing that yet
12:30:21 <coolsvap> dirk, i will take a grab at it some time in this week
12:31:00 <dirk> Cool, be happy to review it
12:31:07 <tonyb> Ahh yeah that thing.
12:31:23 <dirk> So far something else was always more urgent to do :-/
12:31:41 <tonyb> :/
12:32:38 <tonyb> Anyone else?
12:33:08 <coolsvap> nothing else from my side
12:33:25 <tonyb> dirk, coreycb ?
12:33:37 <dirk> Nothing from me today
12:33:38 <coreycb> tonyb, nothing from me, thanks
12:34:01 <tonyb> okay I'll end the meeting then
12:34:06 <tonyb> Thanks everyone
12:34:20 <tonyb> #endmeeting