12:00:44 <coolsvap> #startmeeting requirements
12:00:45 <openstack> Meeting started Wed Jun  8 12:00:44 2016 UTC and is due to finish in 60 minutes.  The chair is coolsvap. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:48 <openstack> The meeting name has been set to 'requirements'
12:01:02 <dims> o/
12:01:03 <coolsvap> #topic rollcall
12:01:08 <coolsvap> o/
12:01:53 <IgorYozhikov> o/
12:02:26 <coreycb> o/
12:02:37 <dirk> o/
12:03:03 <coolsvap> #topic Any controversies in the Queue?
12:03:22 <coolsvap> The review queue is good this week
12:03:23 <number80> o/
12:03:37 <coolsvap> anyone has anything to bring up?
12:04:35 <dims> coolsvap : yes, how to deal with new-release topic reviews - https://review.openstack.org/#/q/project:openstack/requirements+branch:master+topic:new-release
12:05:25 <dirk> good one
12:05:32 <dirk> I think we talked about that a few days ago, right?
12:05:36 <dims> coolsvap : my proposal is to not merge them immediately as-is. They should be merged AFTER we get confirmation from sniff tests
12:05:41 <toabctl> hi
12:05:42 <dims> so everyone cool with that?
12:05:55 <coolsvap> dims, i am fine with it
12:06:06 <dirk> dims: yes
12:06:15 <coolsvap> and i think thats what we agreed upon when we last discussed
12:06:21 <dirk> dims: only thing I'd love to have is something reporting back whether sniff tests were successful or not
12:06:37 <dims> dirk : /me too
12:06:37 <number80> wfm
12:06:44 <coolsvap> dirk, good point
12:07:04 <dims> dirk : looking at sniff tests output is a bit subjective
12:07:09 <coolsvap> dims, can we work on a poc to add the sniff tests as experimental gate?
12:07:57 <dims> coolsvap : yes, that's a possible option
12:08:01 <coolsvap> that way we can see the feasibility for checking the results
12:08:10 <coolsvap> and option to increase or modify the sniff tests
12:08:12 <dirk> dims: is it somehow possible to just include the jobs that we care about directly on the requirements repo ?
12:08:21 <dirk> so that we don't have to do those sniff prs ?
12:08:43 <dirk> I am not sure I understand why we have the sniff prs in the other repos rather than having them always run as e.g. experimental gate for changes on the requirements repo itself
12:08:54 <dirk> there are not that many prs per day so the overhead of always running them should be acceptable
12:10:05 <dims> dirk : i won't have time to drive it. but i highly encourage alternatives
12:10:58 <dims> will involve talking to infra and folks like sdague and mtreinish and others who know all this stuff inside out
12:11:53 <coolsvap> lets do this
12:12:00 <dims> example : i setup jobs for running oslo.* from master against different py27/34 jobs from other projects periodically - https://etherpad.openstack.org/p/dims-periodic-jobs
12:13:31 <dims> i have another one i'd like to share
12:13:54 <dims> http://logs.openstack.org/17/324817/4/check/gate-requirements-tox-py27-with-upper-constraints/9cf40f4/console.html#_2016-06-06_20_24_09_499
12:14:08 <dims> i have this in progress https://review.openstack.org/#/c/325658/ for fixing that
12:14:27 <dims> so please review that
12:15:09 <coolsvap> dims, sure thanks for the info
12:15:13 * dirk is amazed at that PR and has no idea what it does
12:16:07 * coolsvap thinks its related to gate-requirements-tox-py27-with-upper-constraints failure
12:16:08 <coolsvap> ;)
12:16:19 <dims> dirk : pip install of pykerberos fails, so we need to apt/rpm install some things so the headers etc are present when we try a pip install
12:16:52 <dims> the files/syntax is magic from infra, i just looked at one of the things they did and follow the same pattern
12:17:39 <coolsvap> i am not sure if we should add an action item for this?
12:18:15 <dims> nah, just so you know what to do next time :)
12:18:36 <coolsvap> dims, alright lets see the feasibility of the gate job for sniff tests
12:18:46 <dirk> dims: right, I get the problem, I would have just not been able to figure out how to fix that myself
12:19:09 <dims> dirk : y, lot of grepping involved
12:19:21 <coolsvap> reiterate in next meetings
12:19:57 <coolsvap> #topic Tasks from Etherpad
12:19:59 <coolsvap> #link https://etherpad.openstack.org/p/requirements-tasks
12:21:07 <coolsvap> I have done most of the cleanup-cruft for packages not consumed by projects
12:21:30 <dirk> hooray
12:21:39 <coolsvap> related to it i have one suggestion
12:21:50 <coolsvap> we need to update it a bit https://github.com/openstack/requirements/blob/master/README.rst#for-new-requirements
12:22:17 <coolsvap> like we need to ask which project will consume new added package
12:23:14 <dims> coolsvap : +1 to file review for that
12:23:33 <coolsvap> dims, thanks will add this review today
12:24:21 <dims> for the cruft work, we need to bump up to next level
12:24:26 <dims> for example http://markmail.org/message/lqmx2g3no7z3r6o4
12:24:36 <dims> we need to get rid of httplib2 from projects
12:25:11 <dims> so we need to find usages, ping people, do what it takes, it's a bit evangelization, bit outreach etc
12:25:53 <coolsvap> dims, ack lets do this
12:26:27 <dirk> dims: yeah, but isn't that mostly about creating a feature blueprint /s pec for the relevant project so that they tackle it on their own?
12:26:41 <dirk> some things like removing discover is easy but others like getting rid of httplib / httplib2 is a lot of work
12:26:47 <dims> dirk : sure, we need to maintain info and follow up
12:27:26 <dirk> yeah, basically we need to have a master blueprint that we push over a release cycle to deprecate and remove use of a certain library
12:28:27 <dims> y, we need to make a list of libraries we are going to chase cleanup for
12:28:44 <dims> probably maintain an etherpad for this?
12:29:00 <coolsvap> yes
12:29:06 <coolsvap> we can use the existing etherpad
12:29:48 <dims> sure
12:30:20 <dims> Another one, there's a new kid in the block - pycryptodome (https://pypi.python.org/pypi/pycryptodome) which is a fork of pycrypto
12:30:53 <dims> some projects we use are trying to switch to it like pysaml2
12:31:16 <dims> and we ran into issues with Nova for example - https://review.openstack.org/#/c/279909/
12:31:52 <dims> so even though pycryptodome is not in g-c/u-c right now. it will start leaking in and take over i think
12:32:05 <coolsvap> lets add these to the etherpad at the top, most of the existing cruft tasks outlined are done
12:32:17 <dims> i did some experiments a while ago - https://review.openstack.org/#/q/pycryptodome
12:33:35 <dims> the idea here is to figure out how to transition projects from one to another and tolerate if either one of them is installed in the changeover time period
12:35:07 <coolsvap> dims, yes
12:36:24 <coolsvap> #action take remove-cruft to next level and add packages that need replacement or removal to the etherpad with some plan of action
12:36:40 <coreycb> coolsvap, is this the etherpad you referred to? https://etherpad.openstack.org/p/requirements-cruft
12:36:47 <coolsvap> coreycb, yes
12:36:51 <coolsvap> #link https://etherpad.openstack.org/p/requirements-cruft
12:36:55 <coreycb> coolsvap, ok
12:37:07 <coolsvap> anything else on this topic?
12:37:30 <dims> one last tip from me is to talk to folks like dhellmann and haypo (Victor Stinner, working on python3 https://wiki.openstack.org/wiki/Python3) about things that we will end up consuming sooner or later
12:39:00 <coolsvap> dims, noted
12:39:16 <dims> if you see dependencies status on the wiki page, you will get an idea of things that are likely to change soon-ish
12:39:52 <dims> oh, standardization of the ldap libraries, we need to track keystone team's progress and talk to them periodically
12:40:07 <dims> that's all i had :)
12:40:23 <coreycb> dims, I just added ldap to the etherpad
12:40:41 <coreycb> well, it was there but I added a note about using just one. if that's what you meant.
12:41:28 <dims> right, we need to ping on or before milestone 2 for newton so we know if we'll end up with 2 libs and push towards just one
12:42:16 <coreycb> dims, ok
12:42:44 <coolsvap> moving on
12:42:46 <coolsvap> #topic Open Discussion
12:44:25 <coolsvap> seems like we dont have topics for open discussion :)
12:44:27 <dims> fyi, i'll ping existing cores in a week to come up with new members.
12:44:46 <dims> so i can stop being the sole +2 ...
12:45:07 <dims> i am hoping all of you had a good chance to learn what's needed to be done here
12:45:26 <coolsvap> dims, yes i think this is something we should adapt going ahead +2*2 +W
12:45:59 <dims> coolsvap : yes, once we have the new folks joining, we should switch back to regular voting habits
12:46:21 <dims> except for the ones we document as needing a single +2
12:47:39 <coolsvap> sure
12:48:30 <coolsvap> any last comments from anyone?
12:49:05 <dims> coolsvap : ask for volunteers for next 2 meetings?
12:49:24 <coolsvap> any volunteers for next two meetings?
12:50:47 <coolsvap> dirk, coreycb ^^
12:50:47 <dims> looks like folks have wandered away :) let's wrap this up. thanks for running the meeting
12:51:10 <coreycb> coolsvap, sure
12:51:11 <coolsvap> dims, yeah will you be able to run the next meeting or you want me to?
12:51:24 <coolsvap> look we found one :)
12:51:33 <coolsvap> coreycb, will you be able to run the next meeting?
12:51:53 <coreycb> coolsvap, yes I can, mind sending me info for doing so?
12:52:03 <coolsvap> coreycb, sure will let you know
12:52:09 <coreycb> coolsvap, thanks
12:52:47 <coolsvap> ending today's meeting
12:53:09 <coolsvap> thanks folks for the time :) see you in #openstack-requirements
12:53:14 <coolsvap> #endmeeting