12:02:22 <coolsvap> #startmeeting requirements
12:02:23 <openstack> Meeting started Wed Jul  6 12:02:22 2016 UTC and is due to finish in 60 minutes.  The chair is coolsvap. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:02:27 <openstack> The meeting name has been set to 'requirements'
12:02:36 <coolsvap> #topic rollcall
12:02:40 <prometheanfire> ah
12:02:44 <number80> o/
12:02:47 <coreycb`> o/
12:02:48 <prometheanfire> o/
12:03:27 <coolsvap> poeple we have a spam attack in #openstack-meeting so we have started meeting here
12:03:36 <coolsvap> I am not sure if it will be recorded or not
12:03:44 <number80> coolsvap: it will be
12:03:45 <coolsvap> if not i will send the log to mailing list
12:04:14 <coolsvap> alright lets see number80
12:04:16 <coolsvap> #topic Any controversies in the Queue?
12:04:26 <coolsvap> I think we have a lot to discuss here today
12:04:53 <coolsvap> #link https://review.openstack.org/335455/
12:04:54 <prometheanfire> the bump of oslo-concurrency in liberty for a sec bug
12:05:06 <coolsvap> prometheanfire, alright lets go ahead
12:05:17 <coolsvap> i was putting some reviews in master
12:05:18 <prometheanfire> coolsvap: you linked first :P
12:05:30 <coolsvap> i will come back to it again
12:05:32 <coolsvap> stable first
12:05:58 <prometheanfire> #link https://review.openstack.org/337277
12:05:58 <coolsvap> prometheanfire, can you provide a link?
12:06:22 <coreycb`> I have to agree with tonyb on that one, I'm -1 until we know it's the last resort
12:06:36 <number80> -1 too
12:06:46 <prometheanfire> the problem is that raising the version of olso-conc there will also make us raise the version of other things (oslo utils being the first)
12:07:35 <prometheanfire> my +1 was only from the perspective of a distro person, from a reqs perspective it's not fun
12:07:51 <number80> I think we need to define and set a policy for security-related bumps
12:08:00 <number80> yeah, as a downstream, I already did the update
12:08:14 <prometheanfire> ya, I target upper-constraints already
12:08:30 <number80> but I can imagine other people trying to be more conservative and backport security patches
12:08:33 <coreycb`> same here, as much as possible we target u-c
12:09:10 <coreycb`> it seems like there should be a way to backport to 2.3.1
12:09:55 <prometheanfire> ya, it's fair to try and really push for that
12:10:08 <number80> *nods*
12:11:08 <coolsvap> coreycb`, can you add a review comment with your view?
12:11:23 <coreycb`> coolsvap, yes I already did
12:11:38 <prometheanfire> ya, I should add another comment as well, clarifying my views
12:11:51 <coolsvap> coreycb`, missed it sorry thanks
12:12:02 <coolsvap> prometheanfire, yes please
12:12:15 <coreycb`> apevec said it's not possible because stable/liberty was at 2.6.0, but I don't think that's a good enough argument
12:12:37 <coreycb`> it's just a tag in git
12:13:11 <number80> well, we also have to accomodate stablemaint constraints in this case
12:13:24 <prometheanfire> true
12:14:00 <number80> maybe they'd be ok to push it as a hotfix release?
12:14:26 <prometheanfire> it'd be nice
12:15:26 <coreycb`> ok rookie question, can you fill me in on where to view stablemaint constraints?
12:16:10 <prometheanfire> http://docs.openstack.org/project-team-guide/stable-branches.html
12:16:13 <prometheanfire> #link http://docs.openstack.org/project-team-guide/stable-branches.html
12:16:14 <coolsvap> we need someone to check for update related to hotfix or something to work with, dhellmann dims?
12:16:56 <coreycb`> ah you're talking about support phases
12:18:11 <number80> we can ask apevec, he's part of stablemaint too
12:18:54 <coolsvap> number80, can you update team and review related to your discussion with apavec?
12:21:33 <coolsvap> alright
12:21:35 <coolsvap> i think we need to sync with tonyb about next steps or any of the stable cores regarding next steps
12:21:51 <coolsvap> #action sync up with tonyb about next steps or any of the stable cores regarding next steps
12:22:21 <coolsvap> moving on
12:23:14 <coolsvap> we have to decide upon policy to allow requirements with similar functionality but with different attributes like performance
12:23:39 <coolsvap> we have couple of reviews related to it in the queue
12:24:02 <coolsvap> #link https://review.openstack.org/337683
12:24:53 <coolsvap> am I disconnected?
12:25:09 <prometheanfire> ya, similliarlly we just merged another json lib
12:25:12 <prometheanfire> coolsvap: no :P
12:25:24 <prometheanfire> the new json lib is cython and quicker as well
12:26:03 <coolsvap> prometheanfire, thanks for the ack I think we need to decide on policy for it
12:26:19 <number80> coolsvap: ack
12:26:39 <coolsvap> I think if the library has promising attributes over the previous one with better support on distros
12:26:52 <coolsvap> we should be more accommodating on adding these
12:26:53 <number80> well, I'd like more concrete arguments than "it's faster"
12:27:05 <number80> not against it, just allow flexibility to distro
12:27:41 <number80> for instance hiredis can be an optional deps as redis-py will use its parser when installed and benefit from perf bumps
12:27:45 <coolsvap> number80, agreed but most will come with that attribute (being faster than previous one)
12:27:47 <prometheanfire> tracking it in UC would help as a packager, we basically do so for the entire python dep tree
12:27:58 <number80> proposal: having an optional-requirements
12:28:11 <number80> we can these in optional-requirements
12:28:26 <prometheanfire> for anything 'plugin' related?
12:28:30 <number80> stuff that are not required for runtime but could provide additional nice feeature
12:28:52 <number80> prometheanfire: depends on plugin definition :)
12:29:13 <coolsvap> number80, agree but we need some mechanism to manage that across projects
12:29:13 <prometheanfire> might work, but would need to verry strictly define what optional means
12:29:21 <number80> Yes
12:29:24 <prometheanfire> which projects get to define what's optional
12:30:05 <prometheanfire> I would think the project that submitted this would think it's not optional
12:30:41 <coolsvap> number80, can you draft something which we can discuss
12:30:44 <coolsvap> #link https://etherpad.openstack.org/p/optional-requirements-draft
12:30:50 <number80> coolsvap: will do
12:30:54 <coolsvap> just created a etherpad for the same
12:30:59 <coolsvap> number80, thanks
12:31:21 <prometheanfire> action for it?
12:31:22 <coolsvap> #action number80 to draft optional-requirements to discuss in next meeting
12:31:23 <number80> but for immediate purpose, if the guys offers concrete data that hiredis is necessary for their workflow, I'm not against adding it
12:31:27 <number80> thanks
12:32:26 <coolsvap> anything else in the queue?
12:32:32 <prometheanfire> ya, I'm ok with it, generally
12:32:48 <prometheanfire> nothing else controversial I think
12:32:54 <number80> *nods*
12:33:12 <coolsvap> moving on
12:33:13 <coolsvap> #topic Additional Gating - Updates
12:33:55 <coolsvap> prometheanfire, any updates related to it?
12:34:50 <prometheanfire> not at the moment
12:35:19 <coolsvap> prometheanfire, np I just added it to recurring meeting topic
12:35:45 <coolsvap> I was about to say no update is just as valid as any other update
12:36:06 <prometheanfire> that's fine, real life has been busy for the last month and will be for the next couple weeks
12:36:40 <prometheanfire> I have a recouring reminder that I need to get more details on it, so it won't be forgotten though
12:37:00 <coolsvap> prometheanfire, np it was action item for you and tonyb and I think review https://review.openstack.org/#/c/333650/ in good shape
12:37:05 <coolsvap> #link https://review.openstack.org/#/c/333650/
12:37:19 <coolsvap> moving on
12:37:25 <coolsvap> #topic Tasks from Etherpad
12:37:26 <prometheanfire> sure
12:37:48 <coolsvap> anyone has any updates related to tasks from etherpad
12:37:56 <coolsvap> we already covered the gating part
12:38:28 <coolsvap> #link https://etherpad.openstack.org/p/requirements-tasks
12:40:54 <coolsvap> I think we can move on the topic with no updates this week.
12:41:02 <coolsvap> #topic Volunteer for next 2 meetings
12:41:07 <coolsvap> #info prometheanfire is running the meeting on 13 July
12:41:14 <coolsvap> Any volunteer for July 20 meeting?
12:41:45 <coreycb`> coolsvap, I can take that one
12:42:14 <coolsvap> coreycb`, thanks
12:42:47 <coolsvap> #info coreycb  is running the meeting on 20 July
12:43:01 <coolsvap> #topic Open Discussion
12:45:03 <coolsvap> I think we call the meeting here
12:45:14 <prometheanfire> sgtm
12:45:15 <coolsvap> prometheanfire, number80 coreycb` ^^
12:45:26 <coolsvap> alright
12:45:45 <coreycb`> coolsvap, I don't have anything else
12:45:50 <coolsvap> #endmeeting