11:59:39 <prometheanfire> #startmeeting requirements
11:59:40 <openstack> Meeting started Wed Aug 24 11:59:39 2016 UTC and is due to finish in 60 minutes.  The chair is prometheanfire. Information about MeetBot at http://wiki.debian.org/MeetBot.
11:59:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
11:59:43 <openstack> The meeting name has been set to 'requirements'
11:59:47 <prometheanfire> #topic rollcall
11:59:56 <toabctl> hi
12:00:05 <dirk> o/
12:00:24 <tonyb> o/
12:00:26 <number80> o/
12:00:36 <prometheanfire> sigmavirus: you too
12:00:45 <sigmavirus> o/
12:00:53 <prometheanfire> there you go :D
12:01:57 <prometheanfire> ok, more people than normal
12:02:07 <prometheanfire> #topic controversies in the Queue?
12:03:01 <tonyb> prometheanfire: we need to be careful with osc 3.0.1
12:03:09 <prometheanfire> gate's slow, openstacksdk needs a bump but we are waiting on upstream for a new release
12:03:19 <tonyb> but with the gate as wedged as it is we're kinda stuck
12:03:21 <prometheanfire> ya, osc too
12:03:36 <tonyb> we can't get the u-c changes in befoer the bot triggers :(
12:04:15 <prometheanfire> ya
12:04:58 <prometheanfire> anything specific about osc?
12:05:18 <tonyb> just that it's a really big chnage and has the potrntial to break a lot
12:05:36 <tonyb> puppet are working with RDO to verify that side is cool
12:05:42 <prometheanfire> ah
12:05:54 <tonyb> once the ACK we just need buy in from shade
12:06:16 <sigmavirus> shade uses osc?
12:06:18 <prometheanfire> k
12:06:22 <sigmavirus> nevermind, not important
12:06:39 <prometheanfire> next?
12:06:44 <tonyb> +1
12:06:57 <prometheanfire> #topic Requirements freeze R-5 (Aug 29 - Sept 02)
12:07:17 <prometheanfire> so, how does this work, with gate slow and all
12:07:31 <tonyb> prometheanfire: badly :(
12:07:44 <sigmavirus> you prioritize against the slow gate
12:08:33 <sigmavirus> work with changeset authors to figure out what needs to get in before the freeze, some things won't be as high a priority as others and so you make the hard decision and work the important ones through the gate
12:08:34 <prometheanfire> what I mean is, hard or soft cutoff?
12:08:36 <tonyb> sigmavirus: sure
12:09:16 <prometheanfire> all changes submitted before/during that time frame can be merged
12:10:04 <prometheanfire> and should we make an announce to the list (though it's on the schedule
12:10:08 <tonyb> Perhaps all by 29th anything later are we can't make a promise
12:10:23 <prometheanfire> ya
12:10:25 <tonyb> prometheanfire: Yeah we do need an email to the list as well
12:10:26 <dirk> +1
12:10:46 <prometheanfire> who wants to do that?
12:10:54 * tonyb will
12:11:16 <number80> *nods*
12:11:28 <prometheanfire> #action tonyb email the list about the Requirements freeze R-5 (Aug 29 - Sept 02), Perhaps all by 29th anything later are we can't make a promise
12:11:35 <prometheanfire> next?
12:11:48 <tonyb> +1
12:12:06 <prometheanfire> #topic Barcelona Design Summit
12:12:12 <prometheanfire> who's going?
12:12:15 * prometheanfire is not
12:12:28 * tonyb will be there
12:12:31 <sigmavirus> not I
12:13:34 <prometheanfire> ya, don't think many are going
12:13:43 <tonyb> phooey
12:13:56 * prometheanfire wanted to go, but can't :(
12:14:08 <prometheanfire> space requirements?
12:14:13 <number80> o/
12:14:21 <prometheanfire> number80: you going?
12:14:26 <tonyb> prometheanfire: what rooms do we need (if any)
12:14:27 <number80> prometheanfire: yes
12:14:53 <prometheanfire> tonyb: I think a quick status update meeting would be nice
12:15:04 <tonyb> I was thinking 1 fishbowl and maybe a meetup but that seems like overkill based on who'll be there
12:15:05 <prometheanfire> beyond that, not sure if any are needed
12:15:11 <prometheanfire> ya
12:15:28 <dirk> A work Session is always good
12:15:38 <dirk> Main issue with Barcelona is space though
12:15:53 <number80> I agree we need at least one session
12:16:02 <dirk> (space/slots/time)
12:16:36 <tonyb> dirk: We can ask.
12:16:57 <prometheanfire> ok, next?
12:17:05 <dirk> I think it was just about submitting your wishes
12:17:05 <tonyb> DO we really think we'll get value out of a meetup?  We could just have lunch/dinner/beer
12:17:26 <dirk> Yeah, I think either a fishbowl or a work session has more vakue
12:17:28 <prometheanfire> I think an informal thing would be nice
12:17:35 <prometheanfire> dirk++
12:17:39 <tonyb> Will we actually work on anything as a team?
12:17:42 <dirk> +1 for informal meetup
12:18:18 <tonyb> okay I'll request a fishbowl
12:18:33 <prometheanfire> k
12:18:35 <dirk> tonyb: knowledge transfer is always good
12:18:58 <dirk> I know that I can ask lots of questions to fill up the slot if wanted ;-)
12:19:00 <tonyb> dirk: yeah.
12:19:09 <tonyb> dirk: :)
12:19:13 <prometheanfire> who want's to make sure we have a fishbowl?
12:19:29 <tonyb> prometheanfire: I will
12:19:42 <tonyb> prometheanfire: I have an email to reply to from ttx
12:19:44 <prometheanfire> #action tonyb make sure we have a fishbowl at the conf
12:19:51 <prometheanfire> next?
12:19:54 <tonyb> +1
12:20:06 <prometheanfire> #topic mascot
12:20:11 <prometheanfire> #link https://etherpad.openstack.org/p/requirements-team-mascot
12:20:23 <prometheanfire> our options were picked
12:20:49 <tonyb> Well scorpion was/is available but I'm not sure that's the image we want
12:20:50 <prometheanfire> waterfall would be funny, given it's dev connotations
12:20:56 <tonyb> "the sting in the tail"
12:21:32 <tonyb> So I was thinking we could just mark up the options and go with that.
12:22:11 <tonyb> You can pick more than one option but only vote once for a given option
12:22:39 <tonyb> I'm not sure any of the options really screams "requirements" to me
12:23:13 <prometheanfire> something that's dependant upon for the community
12:23:20 <prometheanfire> so, earth, or a field of grass
12:23:22 <prometheanfire> or something
12:23:54 <dirk> Riverbed perhaps?
12:23:59 <prometheanfire> http://famouswonders.com/wp-content/uploads/2009/03/serengeti-landscape.jpg
12:24:17 <prometheanfire> dirk: do you want another quantum, because that's how you get another quantum :P
12:24:53 <dirk> prometheanfire: ;-)
12:25:02 <tonyb> prometheanfire: interesting idea
12:25:55 <prometheanfire> added to list
12:26:02 <tonyb> cool
12:26:27 <tonyb> give it say 24 hours and then we'll get back to Heidi
12:26:33 <prometheanfire> k
12:28:09 <prometheanfire> next?
12:28:12 <tonyb> +1
12:28:28 <prometheanfire> #topic Tasks from Etherpad
12:28:39 <prometheanfire> #link https://etherpad.openstack.org/p/requirements-tasks
12:29:22 <prometheanfire> I've been working with other project trying to get 20 solved
12:29:26 <tonyb> prometheanfire: Thanks again for checking up on the bot failures
12:29:35 <prometheanfire> tony has helped :D
12:30:04 <prometheanfire> anyone else working on anything from the list?
12:30:41 <tonyb> I'm workign on 18 but only slowly
12:31:07 <tonyb> and 2
12:32:01 <prometheanfire> k, it'd be nice to have 2 done before the summit :P
12:32:06 <prometheanfire> next?
12:32:13 <dirk> +1
12:32:26 <tonyb> +1
12:32:39 <prometheanfire> #topic Volunteer for next 2 meetings
12:32:44 <prometheanfire> Aug 31 - coolsvap
12:33:01 <prometheanfire> Sep 14 - ???
12:33:26 <tonyb> prometheanfire: what happend to Sept 7th?
12:33:43 <tonyb> :D
12:33:48 <prometheanfire> oh, missed that
12:33:53 <sigmavirus> tonyb: september 7th is not on my calendar
12:33:55 <prometheanfire> Sep 07 - ???
12:34:05 <prometheanfire> sigmavirus: you volunteering?
12:34:11 <prometheanfire> way to be seen sir
12:34:25 <sigmavirus> No I'm not. I generally don't make it to these any longer
12:34:53 <tonyb> any takers?
12:34:57 <prometheanfire> I can do either the 7th or 14th
12:35:02 <prometheanfire> but would rather not take both
12:35:22 <tonyb> prometheanfire: ok you take one and put me down for t'other
12:35:42 <prometheanfire> ok, I'd rather take the 14th if possible
12:35:56 <tonyb> prometheanfire: works for me
12:35:59 <prometheanfire> k
12:36:40 <prometheanfire> #action tonyb run the sept 7 meeting
12:36:49 <prometheanfire> #action prometheanfire run the sept 14 meeting
12:36:59 <prometheanfire> #topic optional-requirements
12:37:04 <prometheanfire> #link https://etherpad.openstack.org/p/optional-requirements-draft
12:37:08 <prometheanfire> number80: ?
12:37:49 <number80> yes
12:38:08 <number80> first, I'd like to hear what is blocking us, it's not clear for me
12:38:37 <number80> If there's nothing against it, I may just push a review and ask feedback on the list
12:38:58 <prometheanfire> how it'd integrate with other projects
12:39:15 <tonyb> number80: I'm not sure I understand the point.  Doesn't it just complicate all out tooling?
12:40:02 <dirk> How is optional req different from global requirements except that it allows duplication?
12:40:08 <number80> tonyb: the idea is to track libraries that are not essential for runtime but provides additional goodies (performance boost, etc.)
12:40:16 <prometheanfire> how is the behavior of it's use differ
12:40:29 <prometheanfire> would we just check against both files when updating?
12:40:37 <number80> dirk: that could be a way to summarize it, the goal is to relax rules when we can
12:40:38 <dirk> Is this just that we know which requirements are more central to meet than others?
12:40:41 <prometheanfire> can we just comment gr/uc instead?
12:41:08 <number80> dirk: yes, and it would encourage people to use abstraction layers e.g anyjson
12:41:09 <sigmavirus> number80: which rules need be relaxed?
12:41:19 <number80> sigmavirus: no feature duplication
12:41:30 <tonyb> Yeah I'd rather do it in g-r either in seperate section or with a local comment
12:42:00 <tonyb> but fundamentally we still ned to ensure co-installability so we still need to do the same work
12:42:03 <number80> IMHO, what we want is not to require dozen of libraries doing the same thing to run an openstack cloud
12:42:22 <number80> tonyb: that's a good compromise (the section proposal)
12:42:51 <tonyb> number80: right 1 or 2 with *very good* reasons but not dozens
12:43:09 <prometheanfire> +1 the section idea
12:43:17 <dirk> number80: I'm not sure that's easy to achieve though
12:43:42 <dirk> Like e.g. pymysql vs pgsql
12:43:43 <number80> tonyb: yep, the goal is that additional goodies should remain non-essential but still tracked and tested
12:43:55 <dirk> Which one is core which one is optional?
12:44:46 <number80> dirk: I think this falls under the backend category and when we should favor any of them
12:44:53 <tonyb> dirk: the first is "core" the additional ones would become extra
12:45:10 <tonyb> dirk: we'd only allow a duplicate library if it had a *really good* reason
12:45:18 <tonyb> my $0.02
12:45:27 <number80> but we could enforce that a specific mysql python driver must be supported
12:45:47 <prometheanfire> somehow, not sure how
12:45:52 <number80> and allow another one if it brings performance improvement for instance
12:45:58 <prometheanfire> gating only on one set would help maybe
12:46:09 <dirk> To be honest I prefer one more library over one that exists but that has 200 dependencies
12:46:59 <number80> dirk: that could fall under the "very good reasons" to accept it
12:47:04 <tonyb> One of the things we shoudl do is facilite movement from $old to $new if we create that situation
12:47:17 <dirk> I understand the reason that we want to keep things 'small' and 'manageable' bit that's a complex thing, not just in/out imho
12:48:07 <dirk> Right, I see value in documentation $old->$new
12:48:25 <dirk> E.g. add a deprecated-by  comment to g-r deps?
12:48:46 <number80> +1
12:48:58 <prometheanfire> are we removing the old?
12:49:01 <tonyb> dirk: we need to do more than document
12:49:25 <tonyb> dirk: that's how we end up with libraries that are stuck on 2year old releases
12:49:48 <number80> I think this could be a cross-project session topic: how to get rid of requirements crufts
12:49:54 <tonyb> if we don't facilitate the move then we're making life hard for everyone
12:49:57 <dirk> tonyb: yeah, we also need to push by calling out deadlines
12:50:18 <dirk> tonyb: +1
12:50:27 <tonyb> dirk: and what do we do if $projects don't move?
12:50:28 <prometheanfire> so, less optional, more better?
12:50:45 <tonyb> prometheanfire: Yeah
12:51:03 <tonyb> prometheanfire: well "better for soem people"
12:51:09 <dirk> tonyb: 'it depends' :-)
12:51:14 <prometheanfire> well, for the ones we already added, they are truely optinal
12:51:23 <prometheanfire> they are try wrapped import statements
12:51:29 <tonyb> prometheanfire: for example *json some uses may not care about speed and prefer pure python
12:51:32 <prometheanfire> so they will get used when we add them
12:51:55 <prometheanfire> as for getting people to switch fully...
12:52:14 <prometheanfire> ya, that'll be fun :P
12:54:10 <tonyb> ok so we're going to add comments/ move thing to seperate section in g-r
12:54:24 <tonyb> but not add an additional file for tracking these things
12:54:27 <prometheanfire> who wants to submit that?
12:54:33 <tonyb> number80: ?
12:54:59 <tonyb> we should still be very selective about adding funcational duplicates
12:55:07 <prometheanfire> very
12:55:27 <number80> tonyb: I'll do it
12:56:21 <prometheanfire> #action number80 to submit review moving existing optional-reqs packages to their own section in gr
12:56:26 <prometheanfire> not sure about uc
12:56:41 <tonyb> ther *must* be only one uc
12:56:41 <prometheanfire> ok
12:56:50 <prometheanfire> only one, yes
12:56:54 <prometheanfire> but in it's own section
12:57:03 <prometheanfire> #topic open floor
12:57:24 <tonyb> no need for a seperate section in uc
12:57:35 * dirk needs to leave, cya
12:57:37 <tonyb> it's machine generated
12:57:42 <prometheanfire> true
12:57:55 <prometheanfire> so, that it?
12:58:22 * tonyb is done
12:58:33 <prometheanfire> #endmeeting