10:03:16 <tonyb> #startmeeting requirements
10:03:16 <openstack> Meeting started Wed Dec  7 10:03:16 2016 UTC and is due to finish in 60 minutes.  The chair is tonyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:03:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:03:20 <openstack> The meeting name has been set to 'requirements'
10:03:28 <tonyb> #topic roll call
10:03:38 <dirk> o/
10:03:52 <tonyb> sigmavirus, number80, coolsvap, toabctl
10:04:03 <coolsvap> o/
10:04:12 <tonyb> we have an appology from prometheanfire
10:04:26 <toabctl> hi
10:05:16 <tonyb> Hi, coolsvap toabctl
10:05:20 <tonyb> #topic Any controversies in the Queue?
10:05:43 <tonyb> I think it's pretty clean really
10:06:23 <tonyb> there's a high number of reviews with negative votes from jenkins but I don't see anything problematic in there
10:07:27 <tonyb> https://review.openstack.org/365837 is a little questionable so it'd be good to see feedback on that
10:07:46 <tonyb> anyone else?
10:09:11 * coolsvap is bit behind on the current status
10:09:34 <tonyb> coolsvap: that's fair ... I hope you're getting better
10:09:40 <dirk> tonyb: yeah, I couldn't make up my mind on this yet
10:09:52 <coolsvap> i will put things on reviews if find anything controversial
10:09:57 <dirk> it certainly overlaps with other uses, I didn't want to take a side there as I'm not unbiased
10:09:58 <tonyb> dirk: fair enough
10:10:20 <dirk> the only other thing is the posix-ipx removal I guess
10:10:31 <dirk> I think its blocked on one review, if that doesn't move soon I'd vote for stop caring
10:10:50 <tonyb> dirk: the thing that clinched it for me was if we -1 it then oslo_messaging will end up requireing monasca-statsd which IMO doesn't seem right
10:11:04 <tonyb> dirk: Yeah that's blocked on the blazar stuff
10:11:26 <tonyb> #link https://review.openstack.org/#/q/status:open+project:openstack/blazar+branch:master+topic:feature/goal-remove-incubated-oslo-code
10:11:34 <tonyb> ^^^ that's the "blazar stuff"
10:11:39 <dirk> tonyb: yeah.. monitoring services it the next hype it seems. way too many things
10:12:33 <dirk> its not yet visible in the queue but it looks like we'r eprogressing slowly on the docker-py uncap.
10:12:45 <dirk> haven't looked at where we're stuck today yet though
10:12:57 <tonyb> dirk: cool.  IIRC that's blocked by a change in the releases repo
10:13:25 <tonyb> dirk: Hmm actually that seems to have gone through
10:14:20 <dirk> tonyb: no, we still have the conflict over tripleo-common
10:14:37 <dirk> https://review.openstack.org/#/c/406443/
10:14:43 <dirk> ah, I see tonyb  commented on that. I missed that
10:14:48 * dirk will fix
10:15:37 <tonyb> dirk: cool.
10:16:34 <tonyb> dirk: I shoudl have just fixed it, sorry
10:17:01 <dirk> no worries, I have not yet completely fixed my gerrit email filtering setup.. some mails go to nowhere right now
10:17:42 <tonyb> dirk: Ahh okay.
10:18:04 <tonyb> dirk: sometimes I wish it'd be nice if mine went to /dev/null ;P
10:18:17 <tonyb> #topic Requirements priorities for Ocata
10:18:24 <tonyb> #link https://etherpad.openstack.org/p/requirements-track-constraints-usage
10:18:43 <tonyb> dirk: I see you've done a few more awesome!  I'll review them.
10:19:03 <tonyb> I wonder if it's worth automating them
10:19:25 <dirk> I started looking at that but there are so many differences in the projects..
10:19:37 <dirk> I wonder, do we always want to use tools/tox_install.sh ?
10:19:57 <dirk> or only where its needed? it seems some projects just use pip -c ${magic git url} -U {opts}
10:20:17 <dirk> directly. I guess tahts okay as long as they don't run into a conflict, right?
10:21:11 <tonyb> dirk: if $project is listed in upper-constratints.txt then they have to use tools/tox_install.sh
10:21:39 <tonyb> so nova can just use the -c {URL} but python-novaclient can't
10:22:08 <dirk> I see
10:22:16 <dirk> that makes sense. we should have a check for that
10:22:41 <tonyb> dirk: so *if* grep -i $(python setup.py --name) /path/to/upperconstratints.txt is emapty then it's a quick one liner
10:22:45 <dirk> probably something for validate-constraints ?
10:23:13 <tonyb> otherwise we need the other oneliner + tools/tox_install.sh
10:23:59 <tonyb> we'll hit problems with some of the neutron-stadium projects and horizon plugins butI have a cunning plan for them also
10:24:17 <tonyb> dirk: I don't follow?  validate-constratints?
10:24:49 <dirk> tonyb: well, whenever we merge reviews that extend upper-constraints we need to check that they use the proper way of restricting upper-constraints on that particular project imho
10:25:01 <dirk> extend upper-constraints.txt in global requirements repo..
10:25:38 <dirk> since in theory additional upper-constraints might be pulled in by version updates somewhere that depend on new stuff..
10:26:12 <tonyb> dirk: I understand now. Yeah we shoudl probably do that with a tool rather than manual checking
10:28:03 <dirk> tonyb: lets put it on the task list? I can't commit to the action item right now
10:28:12 <tonyb> dirk: Sure.
10:28:27 <tonyb> the focus needs to be getting u-c supprt up
10:28:47 <tonyb> then we can do more of the divergent requirements work that's actually interesting
10:29:59 <tonyb> Anything else for priorities?
10:30:00 <dirk> do we have a blueprint or bug for this? I haven't hit it but I guess at some point someone will ask for it
10:30:37 <dirk> (the uc-handling-unification part I mean, to be referenced in the reviews against all the projects)
10:30:38 <tonyb> dirk: No we don't but I shoudl create one so we have a common place to answer questions
10:30:53 <tonyb> dirk: I shoudl also email os-dev about what we're doing
10:32:06 <tonyb> #action tonyb to create a blueprint and email os-dev to explain the divergent requirements work and how that applies to u-c
10:32:09 <dirk> well, I guess a launchpad id against all the projects that are affected (or that get reviews) is a good first start to unify communication
10:33:20 <tonyb> dirk: I'm unlikey to create that thing, but a blueprint and a std. gerrit topic + an email will go a long way to doing the same thing
10:35:12 <dirk> tonyb: wfm
10:35:19 <tonyb> dirk: cool
10:35:26 <tonyb> #topic Open Discussion
10:35:51 <tonyb> anything?
10:37:48 <tonyb> Looks like we're close to wrapping up
10:38:28 <tonyb> I'd just like to say thank you to all the reviewers who are working on this.  I'd not fun but it is important
10:38:56 <tonyb> I'd also like to say I'm always open to feedback on what I can do better as PTL
10:40:20 <tonyb> and encourage people to think about PTL spot for Pike.  I'm happy to run but if y'all want a change that's also cool
10:40:40 <dirk> ugh, there are 2 more months for that :)
10:41:47 <tonyb> dirk: sure but if we start thinking now it wont sneak up on us
10:42:19 <dirk> we should think about the PTG as well
10:42:26 * dirk will be there
10:43:02 <tonyb> dirk: Yeah I'll be there too.  We have some "space" during the 2 horizontal days but I don't know what that means
10:45:09 <tonyb> okay if there isn't anything else ...
10:45:40 <tonyb> #endmeeting