10:00:01 <tonyb> #startmeeting requirements
10:00:02 <openstack> Meeting started Wed Jan 4 10:00:01 2017 UTC and is due to finish in 60 minutes. The chair is tonyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:00:05 <openstack> The meeting name has been set to 'requirements'
10:00:10 <tonyb> #topic rollcall
10:00:19 <prometheanfire> ok then
10:00:33 <tonyb> sigmavirus, number80, dirk, coolsvap, toabctl y'all around?
10:00:50 <tonyb> prometheanfire: morning
10:03:16 <dirk> o/
10:03:27 <tonyb> prometheanfire: looks like it could be more a chat than a meeting ;P
10:03:47 <tonyb> Hi dirk
10:04:03 <prometheanfire> :D
10:04:46 <tonyb> #topic Any controversies in the Queue?
10:05:15 <tonyb> anything?
10:05:25 <prometheanfire> not too sure, nothing really stands out
10:06:13 <tonyb> A few awkward constraints updates but nothing terrible
10:06:35 <prometheanfire> ya
10:06:39 <tonyb> Lots of red in the Verified column :(
10:07:43 <tonyb> #topic Requirements priorities for Ocata
10:07:49 <toabctl> hi
10:07:51 <tonyb> #link https://etherpad.openstack.org/p/requirements-track-constraints-usage
10:08:21 <tonyb> I meant to generate stats on how close to compleetion we are
10:09:03 <tonyb> 45 open reviews
10:09:18 <tonyb> not too bad I think we started with 124
10:09:50 <tonyb> There are a few that are a little messy but only 3 actually failing jenkins
10:09:51 <prometheanfire> with the holidays and all
10:10:28 <tonyb> Yeah dirk has done a good job with the support reviews
10:10:48 <tonyb> We may *just* make it this cycle so we can do the "fun" stuff in pike
10:11:25 <jokke_> :P
10:12:08 <tonyb> jokke_: hey long time no see
10:12:22 <prometheanfire> :D
10:13:04 <tonyb> I think the hardest one will be os-vif which needs to be able to develop on windows
10:13:30 <tonyb> hard only because I have 0 experience settinh up a development environment there
10:14:45 <prometheanfire> haven't touched windows in years :|
10:15:14 <jokke_> hi tonyb \o
10:15:17 <tonyb> we (OpenStack) don't have good docs on setting up a development environment
10:15:21 <jokke_> just lurking on the background :D
10:15:31 <tonyb> I'll tackle it but much later
10:15:40 <tonyb> it wont block us
10:15:44 <tonyb> jokke_: :)
10:16:24 <tonyb> So the next question is .... how much coverage is good enough to move on with the fun work and let the straglers catchup?
10:16:40 <tonyb> 80% 90% 99.999%?
10:16:45 <tonyb> thoughts?
10:16:56 <prometheanfire> can't we just give it 110%?
10:17:09 <tonyb> prometheanfire: LOL
10:17:20 <prometheanfire> though honestly, 80-90 is good to start
10:17:48 <jokke_> tonyb: I'd love to say majority, but I have feeling that majority does not agree :P
10:18:18 <tonyb> jokke_: well 51% is a majority ;P
10:18:25 <jokke_> tonyb: indeed
10:18:56 * tonyb goes to generate some stats ... talk amongst yourselfs ...
10:19:05 <prometheanfire> eh
10:19:08 <prometheanfire> I'm too tired
10:19:26 <jokke_> Rough holidays? Happy to be back work resting? :D
10:19:27 <prometheanfire> though, I do have musl based openstack images if you want to look :D
10:19:59 * jokke_ goes to google what is musl
10:20:09 <prometheanfire> lol
10:20:13 <prometheanfire> alt libc
10:20:26 <prometheanfire> http://gentoo.osuosl.org/experimental/amd64/openstack/gentoo-openstack-amd64-hardened-musl-20170103.qcow2
10:20:33 <jokke_> yah :D
10:20:33 <prometheanfire> I'm working on a smaller image now
10:21:17 <jokke_> so how good coverage that has nowadays and how much smaller footprint?
10:22:33 <prometheanfire> it is quite a bit smaller
10:22:53 <prometheanfire> same system, diferent libc, 27M musl on boot, 48M glibc on boot
10:23:06 <tonyb> jokke_: there are 254 projects, and we have 154 of them with merged constraints support (probably slightly more now)
10:23:28 <tonyb> jokke_: which is ~60%
10:23:39 <jokke_> tonyb: that's majority \\o \o/ o// o/7 :P
10:23:42 <tonyb> with open reviews on the others
10:23:44 <prometheanfire> tonyb: is that what you meant by coverage?
10:24:17 <tonyb> prometheanfire: a tox.ini that will use constratints when creating all appropriate venvs
10:24:24 <jokke_> tonyb: then you send e-mail to mailing list that you start doing fun stuff after 2 weeks, who is not onboard by that, feel free to merge or work around :)
10:24:43 <tonyb> :)
10:24:56 <prometheanfire> tonyb: I'd say 80% :D
10:26:06 <jokke_> tonyb: the problem with the community is that there's always significant portion who does not care until they have to. Give them a reason and that number bounces ;)
10:26:14 <tonyb> well the numbers for now are in and we're are 83% so perhaps we're good to go?
10:26:36 <tonyb> it's late to land anythign now but we can get rolling on the groundwork
10:27:00 <prometheanfire> sgtm
10:27:22 <tonyb> dirk: you've been quiet ... what do you think?
10:27:38 * dirk is in real life conversation needs to read backlog
10:28:29 <tonyb> dirk: okay ... focus on the IRL you can come back with thoughts here later
10:30:40 <tonyb> I'm going to skip right to Open discussion as we can cover anything from requirements-tasks there
10:30:48 <tonyb> #topic Open Discussion
10:30:57 <tonyb> #link https://etherpad.openstack.org/p/requirements-tasks
10:31:48 <tonyb> So the PTG ... do we have anything to talk about or shoudl we float around the other rooms during the Monday and Tuesday?
10:32:10 <prometheanfire> float around?
10:32:18 <tonyb> I s'pose we could have a half day sprint on some of the divergent requirments stuff
10:32:19 <prometheanfire> oh, ptg
10:32:25 <tonyb> prometheanfire: Yeah
10:32:46 <prometheanfire> I think we should sync up and work on that, ya
10:33:15 <prometheanfire> input from other groups would be nice there
10:33:21 <jokke_> is there space reserved for requirements?
10:33:46 <tonyb> jokke_: I think so ... during the horizontal days
10:34:02 <tonyb> but it might be shared with release management
10:34:16 <tonyb> I guess we'll know more RSN
10:34:30 <jokke_> tonyb: in that case I think it would be at least fair to make slot when people knows that there is someone in that space for syncs not initiated by req
10:34:46 <tonyb> prometheanfire: Yeah I shoudl setup a "at this time we'll be taling about $x" please be there
10:35:00 <tonyb> and do a better job of inviting key projects
10:35:16 <prometheanfire> yarp
10:35:40 <tonyb> jokke_: I think I agree
10:36:30 <jokke_> printing sing on the table "We'll be here Tuesday between 1400 and beer a clock. Beer a clock depends how much attendance after 1400" :P
10:37:31 <tonyb> :)
10:37:43 <prometheanfire> :D
10:38:03 <jokke_> as I would assume if the horizontals have anything specific scheduled that would be early and the Tue afternoon would be more of catching up time
10:39:02 <tonyb> jokke_: quite possibly
10:40:01 <tonyb> #action tonyb to find out whats going on with the PTG and setup a couple of timeslots for key discussions
10:40:53 <tonyb> Do we have anything else for open discussion?
10:41:19 <prometheanfire> non
10:41:38 <prometheanfire> I'll be at fosdem if anyone wants to say hi
10:42:22 <jokke_> prometheanfire: I'll be there too!
10:42:53 <prometheanfire> with evrard?
10:42:55 <jokke_> prometheanfire: we definitely need to catch up around some lunch triple :P
10:43:14 <prometheanfire> could be breakfast :P
10:43:22 <jokke_> it could
10:43:38 * jokke_ loves the relaxed feeling in FOSDEM
10:43:53 <prometheanfire> yarp
10:44:02 <jokke_> I'll be there from Fri till Mon
10:44:23 <prometheanfire> same, but leave sun night to the netherlands
10:44:24 <jokke_> not gonna do the same mistake as last time ... Flew in Sat morning and out Sun evening
10:44:31 <prometheanfire> ouch
10:45:32 <jokke_> tonyb: are you gonna be around?
10:45:48 <tonyb> jokke_: sadly no :(
10:46:01 <tonyb> I'm at home until the PTG
10:46:10 <prometheanfire> ya, he's too good for us
10:46:15 <tonyb> Well Australia at least if not at home ;P
10:46:39 <tonyb> prometheanfire: Or I just want to see my family ;P
10:46:55 <tonyb> Anyway I think we're done with the meeting
10:46:59 <jokke_> Australia is quite big ... you definitely can escape from home there
10:47:00 <prometheanfire> like I said
10:47:00 <tonyb> #endmeeting