07:00:11 <prometheanfire> #startmeeting requirements
07:00:12 <openstack> Meeting started Wed Jan 10 07:00:11 2018 UTC and is due to finish in 60 minutes.  The chair is prometheanfire. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:16 <openstack> The meeting name has been set to 'requirements'
07:00:21 <prometheanfire> #topic Roll-call
07:00:30 <prometheanfire> tonyb, prometheanfire, number80, dirk, coolsvap, toabctl, smcginnis
07:00:33 <prometheanfire> ping
07:00:35 <prometheanfire> o/
07:00:43 <coolsvap> o/
07:02:24 <dirk> o/
07:03:00 <prometheanfire> #topic Any controversies in the Queue?
07:03:19 <prometheanfire> I don't see anything
07:03:57 <coolsvap> oslo u-c patches failing
07:04:08 <coolsvap> I dont see anything except that
07:04:19 <prometheanfire> hmm, that is true
07:04:34 <prometheanfire> they do seem to be failing more often, I send an email to the list when I wake up
07:05:09 <prometheanfire> networkx is going to be a pain
07:05:27 <prometheanfire> I'm also trying to get eventlet to do a release so we can uncap that
07:05:56 <prometheanfire> networkx is a pain because pypowervm caps it too, and they are technically external to openstack, so less control
07:06:40 <prometheanfire> anything else?
07:08:16 <prometheanfire> k, moving on
07:08:19 <prometheanfire> #topic bugs
07:08:26 <prometheanfire> #link https://bugs.launchpad.net/openstack-requirements
07:09:07 <prometheanfire> #link https://bugs.launchpad.net/openstack-requirements/+bug/1741848 is a possible cryptography bug
07:09:09 <openstack> Launchpad bug 1741848 in OpenStack Global Requirements "Zuul check 'openstack-tox-py27' is failing with cryptography version" [Undecided,New]
07:10:15 <prometheanfire> but it's for cinders driver branches, not sure about it, but needs investigating
07:10:39 <prometheanfire> #link https://bugs.launchpad.net/openstack-requirements/+bug/1730673
07:10:40 <openstack> Launchpad bug 1730673 in OpenStack Global Requirements "check-requirements job is not running on stable/pike project branches" [Undecided,New]
07:10:59 <prometheanfire> that one may need some more investigating as we should be enforcing check-requirements
07:11:19 <dirk> urgh, thats bad
07:11:27 <prometheanfire> ya
07:11:39 <prometheanfire> reported two months ago...
07:11:51 * prometheanfire let the bug queue get too long
07:12:26 <prometheanfire> I'm kinda wondering if that was while some of the zuul breakage was happening
07:12:47 <dirk> do we have a more recent example?
07:13:01 <prometheanfire> no, I just made a task to see if it was still happening to that project
07:13:09 <prometheanfire> if it is, we need a systemic fix
07:13:09 <dirk> ok
07:13:43 <prometheanfire> unless others want to take the task (because I'm sleeping after this, and tomorrow is d&d day :P)
07:14:20 <prometheanfire> the other bugs are more long term things, but should get working on it
07:14:56 <prometheanfire> now that zuul is more stable we should look at the publish job, it'll help us come freeze time (maybe, projects need updates to consume iirc).
07:15:01 <prometheanfire> that's a simpler one too
07:15:12 <dirk> I don't want to promise looking into it any time soon, but I'll keep it in mind in case I have nothing else to do :)
07:15:27 <dirk> I actually want to refresh my patches against requirements to get them finally merged
07:15:28 <prometheanfire> #link https://bugs.launchpad.net/openstack-requirements/+bug/1719006
07:15:30 <openstack> Launchpad bug 1719006 in OpenStack Global Requirements "publish per branch constraints files to tarballs.o.o" [Undecided,New] - Assigned to Tony Breeds (o-tony)
07:15:33 <prometheanfire> for those wondering about publish
07:15:54 <prometheanfire> dirk: ya, that one is still waiting on a dependant patch :|
07:17:19 <dirk> yeah, hacking seems to be disfunctional
07:17:27 <dirk> it takes months to merge something there
07:17:34 <dirk> we can remove the dependency actually
07:17:44 <dirk> as I'm not removing pep8 anymore (even though I think we should)
07:17:49 <prometheanfire> gentoo is mad at me about it
07:17:57 <prometheanfire> I think we should too
07:18:07 <dirk> this patch is only adding pycodestyle
07:18:21 <prometheanfire> hacking locks deps to certian versions, which is stupid
07:18:25 <dirk> #action dirk split pycodestyle into add+remove patches, so that we can merge the add patchset already
07:18:40 <dirk> yeah, this is what my patch does :)
07:18:58 <prometheanfire> wfm
07:19:22 <prometheanfire> ok, anything else or next?
07:19:29 <dirk> what is d&d day?
07:19:33 <dirk> next
07:20:21 <prometheanfire> dungeons and dragons of course :P
07:20:27 <prometheanfire> #topic PTG
07:20:38 <prometheanfire> so, I'm going, have hotel and flight booked
07:20:51 <prometheanfire> airbnb is cheaper that hotels it seems
07:22:27 <prometheanfire> anyone else confirmed going?
07:22:37 <coolsvap> I am not confirmed yet
07:22:44 <coolsvap> will let you know if it changes
07:22:46 <prometheanfire> next couple meetings I'll probably start bringing up agenda and make an etherpad
07:23:19 <prometheanfire> k, well, moving on then
07:23:27 <prometheanfire> #topic Open Discussion
07:23:40 <prometheanfire> will be open for a min or two
07:24:53 <prometheanfire> dirk: nice to see that bug is fixed, that was quick :D
07:25:16 <dirk> prometheanfire: well, I just resolved it according to the last comment..
07:25:25 <dirk> prometheanfire: I'll go, I still have to book stuff though
07:25:31 <prometheanfire> kk
07:25:35 <prometheanfire> #endmeeting