07:04:09 <tonyb> #startmeeting requirements
07:04:10 <openstack> Meeting started Wed Mar  7 07:04:09 2018 UTC and is due to finish in 60 minutes.  The chair is tonyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:04:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:04:13 <openstack> The meeting name has been set to 'requirements'
07:04:50 <dirk> o/
07:04:55 <tonyb> The queue .... https://review.openstack.org/#/q/status:open+project:openstack/requirements
07:05:05 <tonyb> has anyone looked at it in the last 48 hours?
07:05:29 <coolsvap> o/
07:05:41 * coolsvap looking at it now
07:06:12 <dirk> a bit yeah, I don't think there is anything controversial atm
07:06:27 <dirk> actually it seems people are still on PTG-travel or other post activitie
07:06:46 <tonyb> The good news is tripleo has branched, so we just need to verify that kolla and OSA have and then we can really-really thaw
07:06:47 <dirk> the interesting thing is the switch to py36 testing (add bionic support)
07:07:00 <dirk> tripleo was the last project
07:07:07 <dirk> and we already started merging uc over the weekend
07:07:22 <tonyb> dirk: Yeah, we have easy access to wheel builders now and can add similat for tox-py36 when we're ready
07:07:35 <tonyb> Oh cool
07:08:55 * tonyb will fix up constraints generation and add py36 tomorrow if y'all don't beat me to it
07:09:43 <dirk> #action tonyb  fix up constraints generation and add py36 tomorrow
07:09:50 <dirk> happy to defer it to you :-)
07:09:55 * dirk is pretty busy today
07:10:02 <tonyb> ;P
07:10:21 <dirk> I might look at adding tumbleweed testing somewhere, but I don't see a *lot* of value in there
07:10:42 <pfire> internet is down
07:10:55 <coolsvap> pfire: o/
07:11:03 <tonyb> dirk: Havign new stuff would be good but it would mostly be a duplicate job
07:11:05 <dirk> or asking it differently: would it make sense to run a devstack-integration on more than ubuntu on constraints changes? I don't see a good reason atm
07:11:59 <tonyb> dirk: if we were using distro packages then it make a lot of sense but as we're just pulling most stuff from pypi we don't gain a lot IMO
07:12:37 <dirk> tonyb: agreed
07:13:45 <tonyb> #topic ptg
07:13:56 <dirk> one thing I haven't been following - does anyone want to look at getting rid of outdated/unused deps?
07:13:57 <tonyb> Anything we need to follow up on from the PTG
07:14:55 <pfire> talked to Doug earlier today
07:15:07 <tonyb> pfire: Yeah I read it
07:15:16 <dirk> yeah, there was some proposal from doug, I haven't fully read the backlog yet
07:15:25 <pfire> I think we are on close to the same page...
07:15:26 <tonyb> I think we're going to struggle to get everyon in the same discussion :(
07:15:41 <pfire> ya
07:16:00 <pfire> if you can talk to him don't wait for me
07:16:17 <tonyb> pfire: I'm not 100% certain I agree with that, and dhellmann's proposal will make the lower-constraints work harder
07:16:40 <tonyb> I get thet dhellmann isn't signing up for oding that which is fine but we still want to do it
07:16:54 <dirk> maybe all that we need to agree on is the first step, as thats the one we've been not doing so far
07:17:00 <pfire> by decoupling the carrot and stick?
07:17:10 <tonyb> ?
07:17:32 <pfire> carrot, per project reqs
07:17:43 <pfire> stick lc testing
07:17:47 <tonyb> I still don't follow
07:18:10 <pfire> we can talk later, when I'm not on the phone
07:18:46 <tonyb> okay
07:19:24 <tonyb> Anthing else from the PTG?
07:19:49 <dirk> was there any discussion on the pycrypto thing?
07:20:03 <dirk> or is the transition to cryptography settled?
07:20:39 <pfire> just to remind them more often, offering to help when needed
07:21:01 <tonyb> dirk: No I think we need to push for that to be an 'S' goal
07:21:07 <pfire> also pycrypyodome is the emergency fallback, kinda
07:21:21 <pfire> why s?
07:22:30 <tonyb> pfire: becaus the goals for R are settled already aren't they?
07:22:53 <dirk> earlier would be better though
07:22:58 <dirk> it started to hurt about last cycle
07:23:15 <dirk> I don't think its that big of a mess to be an official goal
07:23:32 <pfire> yes, though I started bugging people about it before the ptg
07:23:37 <tonyb> dirk: Sure, we can work on it without a goal and it can be done ad-hoc but if it's still an issue in 4 months we shoudl push for a goal to get the work complete
07:23:40 <dirk> but I guess dependency-cleanliness is not a priority anymore with containerization
07:24:44 <pfire> tony: cross project goal or reqs goal?
07:24:57 <tonyb> pfire: community wide goal
07:25:16 <tonyb> I agree it's apoor candidate but it's the only tool we have so ....
07:25:25 <pfire> ok, didn't know that was needed
07:25:26 <dirk> tonyb: wfm. Or maybe draft a generic goal of reducing overlapping dependencies
07:25:29 <pfire> ya
07:25:46 <tonyb> We could perhaps aim for a couple of items on our problem list
07:25:52 <tonyb> Sure
07:25:52 <pfire> it does also fall under that overlap
07:26:15 <tonyb> I just think we've been asking for 2 years now so we need to try somethign else
07:26:44 <pfire> I agree, cross project seems like a good idea
07:26:49 <dirk> I tried to look at deps that haven't released a new version for 2+ years
07:27:05 <dirk> As those might not be a good dependency
07:27:26 <dirk> That gives quite a list of candidate
07:27:36 <tonyb> dirk: Wow that's a big chunk of work. ;P
07:28:03 <dirk> Well, we don't need to eliminate all of them
07:28:14 <dirk> But the problematic ones
07:28:15 <pfire> for now I think we should limit our focus, but that's good for next cycle
07:28:35 <dirk> A crypto library without updates sounds smelly
07:29:01 <tonyb> sure
07:30:20 <tonyb> okay aything else?
07:31:17 <tonyb> #topic open discussion
07:31:27 <tonyb> coolsvap: which city are you in again?
07:31:43 <pfire> ok, gonna leave for now then
07:31:56 <pfire> cell phone and all
07:32:02 <tonyb> pfire: okay
07:32:49 <dirk> tonyb: the other obvious candidate for dropping is tempest-lib
07:33:16 <coolsvap> tonyb: Pune India
07:33:21 <dirk> ah we moved on already, sorry
07:33:22 <tonyb> dirk: Yeah I guess if tempest is the right thin to use there we shoudl do that
07:33:54 <dirk> well, any change to tempest-lib is -2'ed so its unmaintainable per excellence :-) but still there seems to be things depending on it
07:34:04 <tonyb> dirk: no biggie the topic is very fluid
07:34:22 <tonyb> dirk: Okay I'll reach out to thr QA team for help on that one
07:34:49 <tonyb> .... So meeting times, its the bi-annual veryone moves clock thing over the next few weeks
07:35:27 <tonyb> when that's done this meeing looks like: https://www.worldtimebuddy.com/?qm=1&lid=2147714,12,6,1259229&h=2147714&date=2018-4-4&sln=17.5-18
07:35:34 <openstackgerrit> Dirk Mueller proposed openstack/requirements master: Drop tempest-lib from g-r  https://review.openstack.org/550375
07:35:51 <tonyb> which is a bit silly for prometheanfire, dhellman and dims
07:36:09 <tonyb> so we shoudl probably look at what times are do able for us as a group
07:36:14 <dirk> yeah, its getting late for prometheanfire
07:36:39 <tonyb> ... Or give up and switch to alternatine meetins and rely on in channel comms to keep us in sync
07:37:04 <tonyb> thoughts?
07:37:05 <dirk> tonyb: the question is if you want to do a meeting at 11pm+ :-)
07:37:18 <tonyb> dirk: I do not ;P
07:38:07 <tonyb> https://www.worldtimebuddy.com/?qm=1&lid=2147714,12,6,1259229&h=2147714&date=2018-4-4&sln=21.5-22.5 isn't too bad
07:38:30 <tonyb> but I don't think prometheafire is a early riser
07:38:34 <dirk> 630 am might be tough for pfire
07:38:56 <tonyb> anyway start thinking and and we can disccuss it in channel or on the mailing list
07:39:10 * tonyb really dislikes moving meetings every 6 months
07:39:19 <dirk> so I think we used to have the slot at noon
07:39:42 <dirk> e.g. 8pm sydney 5am central
07:40:06 <dirk> but at this point its mostly prometheanfirew who needs to decide when he wants to be awake :-)
07:40:28 <tonyb> Yup
07:40:46 <dirk> the alternative is something like 6am european
07:41:12 <dirk> which is however still 11pm central - so probably not good for dims etc
07:41:45 <tonyb> Yeah.
07:41:55 <tonyb> It's a massive pain :(
07:42:26 <dirk> tonyb: so 9pm would be good for you?
07:42:34 <dirk> 6am central might be acceptable for some
07:42:40 <tonyb> Anyway I think we shoudl endmeeting as we're not going to decide now but we have a starting point for conversation
07:42:49 <dirk> agreed
07:42:54 <tonyb> dirk: good? no, but I can do it ;P
07:43:37 <tonyb> Thanks everyone
07:43:40 <tonyb> #endmeeting