#edge-computing-group: review_of_dublin_edge_notes

Meeting started by csatari at 14:02:17 UTC (full logs).

Meeting summary

  1. Roll Call (csatari, 14:02:38)
    1. Gergely Csatari (csatari, 14:02:48)
    2. Eric Sarault (esarault, 14:03:04)
    3. David Paterson (dpaterson, 14:03:29)

  2. Action items (csatari, 14:04:28)
    1. https://etherpad.openstack.org/p/Dublin-edge-notes-wiki (csatari, 14:05:03)
    2. No progress (csatari, 14:05:36)

  3. Review of 5.3.2.10 Flavors source side (csatari, 14:06:51)
    1. https://wiki.openstack.org/w/index.php?title=OpenStack_Edge_Discussions_Dublin_PTG#Flavors_source_side (csatari, 14:07:07)

  4. Review of 5.3.2.11 Flavors receiver side (csatari, 14:08:47)
    1. https://wiki.openstack.org/w/index.php?title=OpenStack_Edge_Discussions_Dublin_PTG#Flavors_receiver_side (csatari, 14:09:01)

  5. Review of 5.3.2.12 Projects source side (csatari, 14:10:24)
    1. https://wiki.openstack.org/w/index.php?title=OpenStack_Edge_Discussions_Dublin_PTG#Projects_source_side (csatari, 14:10:36)
    2. ACTION: (5.3.2.12) Change Quotas to Projects. (csatari, 14:11:36)
    3. ACTION: (5.3.2.12) Check if the data in a project can be inconsistent during the synchronisation (e.g.: if there are uuid-s there which are valid only olcally) (csatari, 14:15:51)
    4. https://wiki.openstack.org/wiki/Keystone_edge_architectures#Several_keystone_instances_with_federation_and_API_synchronsation (dpaterson, 14:18:36)
    5. ACTION: Add Requirements for the "2.1 Several keystone instances with federation and API synchronsation" option from https://wiki.openstack.org/wiki/Keystone_edge_architectures#Several_keystone_instances_with_federation_and_API_synchronsation (csatari, 14:26:21)
    6. ACTION: Add an alternative to the Keystone alternatives wiki for Keystone with distributed LDAP backend. (csatari, 14:38:13)
    7. ACTION: dpaterson to check what support there is, if it's auth only or if Projects/ACL/RBAC are part of ldap schema or does that data still have to live in relational database (csatari, 14:38:54)
    8. ACTION: Start a mail discussion about the Keystone with distributed LDAP backend alternative (csatari, 14:39:34)
    9. https://www.researchgate.net/publication/4284466_Enhancing_Edge_Computing_with_Database_Replication (dpaterson, 14:43:08)

  6. Review of 5.3.2.13 Projects receiver side (csatari, 14:45:46)
    1. https://wiki.openstack.org/w/index.php?title=OpenStack_Edge_Discussions_Dublin_PTG#Projects_receiver_side (csatari, 14:46:02)

  7. Review of 5.3.2.14 Quotas source side (csatari, 14:49:21)
    1. https://wiki.openstack.org/w/index.php?title=OpenStack_Edge_Discussions_Dublin_PTG#Quotas_source_side (csatari, 14:49:45)

  8. Wrapup (csatari, 14:53:08)
    1. Next Thursday we will have the Keystone testing meeting in the same time as this meeting, so we will skip the review. (csatari, 14:53:46)
    2. Next meeting is 26.07.2018 16 CET (csatari, 14:54:13)
    3. We will contiue from 3.2.15 Quotas receiver side (csatari, 14:54:44)
    4. I try to organize a meeting to discuss about https://wiki.openstack.org/wiki/Image_handling_in_edge_environment but that will be in a different timeslot than this one as we are parallel to the Glance meeing and I would like to invite Glance experts. (csatari, 14:56:00)


Meeting ended at 14:56:26 UTC (full logs).

Action items

  1. (5.3.2.12) Change Quotas to Projects.
  2. (5.3.2.12) Check if the data in a project can be inconsistent during the synchronisation (e.g.: if there are uuid-s there which are valid only olcally)
  3. Add Requirements for the "2.1 Several keystone instances with federation and API synchronsation" option from https://wiki.openstack.org/wiki/Keystone_edge_architectures#Several_keystone_instances_with_federation_and_API_synchronsation
  4. Add an alternative to the Keystone alternatives wiki for Keystone with distributed LDAP backend.
  5. dpaterson to check what support there is, if it's auth only or if Projects/ACL/RBAC are part of ldap schema or does that data still have to live in relational database
  6. Start a mail discussion about the Keystone with distributed LDAP backend alternative


Action items, by person

  1. dpaterson
    1. dpaterson to check what support there is, if it's auth only or if Projects/ACL/RBAC are part of ldap schema or does that data still have to live in relational database
  2. openstack
    1. Add Requirements for the "2.1 Several keystone instances with federation and API synchronsation" option from https://wiki.openstack.org/wiki/Keystone_edge_architectures#Several_keystone_instances_with_federation_and_API_synchronsation
  3. UNASSIGNED
    1. (5.3.2.12) Change Quotas to Projects.
    2. (5.3.2.12) Check if the data in a project can be inconsistent during the synchronisation (e.g.: if there are uuid-s there which are valid only olcally)
    3. Add an alternative to the Keystone alternatives wiki for Keystone with distributed LDAP backend.
    4. Start a mail discussion about the Keystone with distributed LDAP backend alternative


People present (lines said)

  1. csatari (72)
  2. dpaterson (25)
  3. openstack (3)
  4. esarault (3)


Generated by MeetBot 0.1.4.