13:04:36 <dirk> #startmeeting rpm_packaging
13:04:36 <openstack> Meeting started Thu Mar 24 13:04:36 2016 UTC and is due to finish in 60 minutes. The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:04:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:04:40 <openstack> The meeting name has been set to 'rpm_packaging'
13:05:31 <number80> hello
13:05:35 <toabctl> hi
13:05:49 <dirk> hey everyone
13:05:55 <dirk> please update agenda at https://etherpad.openstack.org/p/openstack-rpm-packaging
13:06:35 <IgorYozhikov> o/
13:08:10 <dirk> #topic stable branch
13:08:26 <mivanov> hi
13:08:48 <dirk> I'd like to request a creation of a stable branch for rpm-packaging so that we can continue updating to master and to stable/mitaka independently
13:08:53 <dirk> does anyone have concerns with that?
13:09:43 <IgorYozhikov> dirk, fine
13:09:51 <toabctl> +1
13:10:06 <number80> +1
13:10:19 <IgorYozhikov> only 1 question
13:10:52 <IgorYozhikov> if nothing changed - cherry-picking master -> stable/mitaka or how?
13:11:20 <IgorYozhikov> I'm about new uploads
13:11:42 <IgorYozhikov> 1st patchset goes to master
13:12:07 <IgorYozhikov> and if there are no diff, cherry-pick back to stable
13:12:23 <IgorYozhikov> thoughts?
13:12:40 <dirk> yep, would work for me
13:12:46 <dirk> assuming that the change makes sense for mitaka
13:12:50 <number80> yes, master should be first
13:12:55 <dirk> #agreed create a stable/mitaka branch for rpm-packaging
13:13:06 <dirk> #topic possible design session topics - CIs, how to react, which artifacts could be produced(IgorYozhikov)
13:13:36 <IgorYozhikov> yes, want to clarify possible topics
13:14:34 <IgorYozhikov> I'm suggesting to discuss how developers should react on CI results
13:14:36 <dirk> so the main issue I know of is that we didn't get any rooms allocated
13:14:58 <IgorYozhikov> dirk, could we do that or it's late
13:16:25 <IgorYozhikov> if it's not late - let me know, i'll try to help with somehow
13:17:00 <number80> well, we can somehow work it out, even by going to a coffee place
13:18:09 <IgorYozhikov> number80, I know, but it could be interesting for more wider audience
13:18:46 <number80> IgorYozhikov: we can always manage to be inserted in the official schedule if we have a defined place
13:19:31 <dirk> IgorYozhikov: I can try to get an answer, but the basic problem
13:19:40 <dirk> was that I missed the deadline
13:19:47 <IgorYozhikov> number80, does it means that all rooms already booked?
13:20:14 <dirk> IgorYozhikov: yes. there are many more projects in the big tent and fewer rooms
13:20:21 <dirk> so we hav eless availability than before
13:21:01 <number80> ack
13:21:06 <IgorYozhikov> dirk, i c. It would be great, because we could discuss not only one particular topic
13:22:14 <dirk> IgorYozhikov: yep
13:22:19 <dirk> so I'll try to get an answer
13:22:33 <IgorYozhikov> dirk, thanx again
13:22:35 <dirk> we just need a room that says "rpm packaging" work group, right?
13:22:49 <IgorYozhikov> looks fine
13:22:50 <dirk> and we can bring up topics then for the slot?
13:22:53 <number80> yes
13:23:02 <dirk> ok,
13:23:11 <dirk> #agreed try to add a slot to the agenda even without a room available
13:23:51 <IgorYozhikov> so, i'll try to prepare material from my side and share it with you
13:24:14 <dirk> great
13:24:21 <dirk> #topic futher steps according to http://toabctl.de/openstack/rpm-packaging-status.html update "needs upgrade" 1st?(
13:24:50 <IgorYozhikov> here I want to figure out what will be more useful to do next
13:25:20 <IgorYozhikov> update & merge pending CRs | update what is marked as required 4 update
13:26:10 <IgorYozhikov> i mean "needs upgrade" from toabctl list
13:27:19 <dirk> yep, that should be done as well
13:27:20 <IgorYozhikov> I prefer - update outdated
13:27:39 <IgorYozhikov> and after that proceed with py*clients
13:28:01 <toabctl> IgorYozhikov: +1
13:28:14 <toabctl> and we should remove all the versions we currently have in the .spec.j2 files.
13:28:37 <IgorYozhikov> toabctl, as here - https://review.openstack.org/#/c/270826/ ?
13:29:29 <IgorYozhikov> omg, I pushed request before save file :(
13:29:30 <toabctl> IgorYozhikov: hm. there are still versions. I guess from test-requirements because we currently only allow a single requirements file?
13:30:57 <IgorYozhikov> fixes
13:31:11 <IgorYozhikov> on the way
13:31:40 <IgorYozhikov> https://review.openstack.org/#/c/270826/16/openstack/oslo.db/oslo.db.spec.j2
13:31:42 <IgorYozhikov> updated
13:31:50 <IgorYozhikov> sorry for that
13:32:55 <IgorYozhikov> toabctl, I suggest to leave known versions which are differs from requirements file. your opinion?
13:33:24 <IgorYozhikov> I mean if version in setup.* is higher then in requirements
13:33:59 <toabctl> IgorYozhikov: I would then just bump the version in the requirements .
13:34:21 <toabctl> but we should check why there are different pbr versions. at least I don't know why that's the case...
13:35:58 <IgorYozhikov> may be after stable/mitaka will cut for global-requirements - versions will be equal, just guessing
13:36:17 <dirk> yeah
13:36:28 <dirk> ok, so we create a stable/mitaka branch and can keep version handling in global-requirements
13:36:59 <IgorYozhikov> anyway, we agreed on updating 1st what is already requires updates
13:38:26 <dirk> yep
13:38:44 <dirk> #agreed submit updates for the outdated packages
13:38:48 <dirk> ok, anything else?
13:39:17 <IgorYozhikov> may be last concern - how to deal with pbr 1.6 vs 1.8
13:40:04 <IgorYozhikov> leave it as is and just build 1.8 which will be used
13:40:16 <toabctl> +1
13:40:40 <IgorYozhikov> ok, so, i'll drop all the rest version record from my CR
13:41:22 <IgorYozhikov> done
13:42:52 <IgorYozhikov> I'm out of topics for today. Just want to share with you about progress with our CI. 1st steps made inside our "sand-box" and we've got today "green" jenkins jobs.
13:43:06 <dirk> IgorYozhikov: you're testing what?
13:43:16 <dirk> mirantis packags on rhel/centos ?
13:43:23 <IgorYozhikov> spec.j2
13:43:49 <IgorYozhikov> we use centos base layer for packages
13:44:05 <dirk> ok
13:45:32 <toabctl> so are we done?
13:45:47 <IgorYozhikov> toabctl, looks so
13:46:06 <IgorYozhikov> any1 else have something to discuss?
13:46:26 <dirk> number80: any update on your testing integration?
13:47:38 <dirk> well, I guess we can continue in openstack-rpm-packaging
13:47:47 <dirk> next week same time! enjoy the long weekend!
13:47:49 <dirk> #endmeeting