13:00:07 <dirk> #startmeeting rpm_packaging
13:00:08 <openstack> Meeting started Thu Mar 31 13:00:07 2016 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:11 <toabctl> hi
13:00:12 <openstack> The meeting name has been set to 'rpm_packaging'
13:00:49 <dirk> #topic agenda
13:01:01 <dirk> everyone, please update https://etherpad.openstack.org/p/openstack-rpm-packaging
13:05:18 <IgorYozhikov> o/
13:05:30 <dirk> can we start, anything still left?
13:05:51 <dirk> #topic pypi tarballs or sdisted from git tarball as source
13:05:59 <dirk> IgorYozhikov: care to explain?
13:06:08 <IgorYozhikov> yes
13:07:08 <IgorYozhikov> want to clarify is there any concerns about tarball source and how to  "cook" them.
13:07:56 <IgorYozhikov> or this is in responsibility of package maintainer
13:08:25 <IgorYozhikov> at present moment in our templates Source: pointing to pypi tarball
13:08:49 <dirk> yep
13:08:58 <dirk> which should be fine for things that are "released", right?
13:09:11 <dirk> is there a particular package you have in mind where this is a problem?
13:09:21 <dirk> or is it just for the "package from git" case?
13:09:28 <dirk> we could point to tarballs.openstack.org
13:10:05 <IgorYozhikov> dirk, packages built from git code instead of pypi prebuilt tarballs
13:11:38 <IgorYozhikov> with pypi we already have "cooked" tarball
13:11:53 <dirk> ah, ok
13:11:57 <IgorYozhikov> in case of git - tarball should be created from particular tag
13:12:17 <IgorYozhikov> and only after that passed into rpmuild | mock  |etc
13:12:18 <dirk> so are you tracking daily commits to the git branches?
13:12:27 <dirk> or are you creating the tarball yourself from a git tag and sdist it?
13:12:38 <IgorYozhikov> dirk, 2nd
13:12:52 <IgorYozhikov> own "kitchen"
13:13:27 <IgorYozhikov> building sdit-ed tarballs
13:13:40 <IgorYozhikov> sdist-ed
13:13:59 <dirk> and why do you prefer that over pypi?
13:14:14 <dirk> I mean, if its a requirement we need to add a renderspec variable for it and abstract it away :)
13:14:34 <dirk> generally I think pypi is preferable because its the canonical source for python packages
13:15:04 <toabctl> yes. and also upstream uses the tarballs from pypi
13:15:37 <IgorYozhikov> dirk, understood | clarified.
13:16:32 <IgorYozhikov> next topic?
13:17:37 <dirk> not sure what we agreed on
13:17:45 <dirk> do we need to create a renderspec filter ?
13:17:52 <dirk> or will you just switch to pypi ?
13:18:33 <IgorYozhikov> dirk, pypi looks fine and in case of necessity
13:19:06 <dirk> ok, thanks
13:19:16 <dirk> #agreed upstream spec files will link pypi tarballs
13:19:17 <IgorYozhikov> we can switch to another source - like locally prebuilt tarball
13:19:45 <dirk> #topic design summit session
13:20:33 <toabctl> r
13:20:36 <IgorYozhikov> dirk, what news - room, schedule ?
13:20:39 <dirk> just to give out the update, we have 1/2 fishbowl session
13:20:45 <dirk> shared with the deb-packaging project
13:20:55 <dirk> on thursday 11:50
13:21:03 <IgorYozhikov> so zigo will be there, right?
13:21:08 <dirk> and a single work room slot on thursday 2:20
13:21:17 <dirk> I guess/hope so
13:21:27 <dirk> PTL is Monty ,so at least he'll likely be there :)
13:21:40 <dirk> I haven't reached out to him yet regarding topic/slot
13:21:53 <dirk> do we have things we want to discuss in the fishbowl slot ?
13:22:07 <dirk> I'd send it as a topic RFQ then to monty to figure out what we're gonna do about it
13:22:24 <dirk> overall I think the decision from TC to do a shared fishbowl with deb and rpm makes a lot of sense
13:23:35 <IgorYozhikov> We could discuss approach which is already used om rpm-side and propose it to deb
13:23:57 <IgorYozhikov> templates + auto-fill will make life easier
13:24:19 <number80> o/
13:24:52 <dirk> yep, shared of experiences is probably good topic
13:25:01 <dirk> also common gating plans is probably an item to sync on
13:25:09 <dirk> gating/check gates
13:25:19 <IgorYozhikov> And as far as I know deb project working on CI on infra side
13:25:41 <dirk> yeah
13:25:47 <IgorYozhikov> our ci  engineers participated in review and meetings helping zigo
13:26:20 <jruzicka> o/
13:26:56 <IgorYozhikov> dirk, i really very hope that our ci will be ready before summit and we could also collect some results/data and discuss it too
13:27:12 <dirk> nice
13:27:16 <dirk> yep, would be great
13:27:22 <IgorYozhikov> working on it
13:27:35 <dirk> we have mixed experiences with the external zuul setup (its not very stable) still looking into fixing those issues..
13:27:51 <IgorYozhikov> I can,as promised, collect some data/proposal about CI stuff
13:27:57 <IgorYozhikov> and share it
13:28:13 <dirk> yep, anything else, any questions?
13:28:14 <IgorYozhikov> I have approve for summit btrip
13:28:55 <IgorYozhikov> and believe that can try to drive one-two topics :)
13:29:12 <number80> I should be there, and will also draft our plan for CI for RPM packaging
13:30:11 <IgorYozhikov> dirk, think that all these more | less enough for fishbowl
13:30:19 <dirk> yep
13:30:22 <IgorYozhikov> worksession:
13:30:28 <number80> I'll see if I can invite openstack infra folks to help us
13:30:38 <dirk> for the work session I guess we don't necessarily need a topic list
13:30:38 <number80> (or answer our questions)
13:30:39 <dirk> yet
13:30:50 <dirk> for the fishbowl I need to fill in the slot description
13:32:46 <dirk> next topic?
13:33:17 <dirk> #topic openstack salt packages
13:33:39 <dirk> jasondotstar: ping?
13:34:09 <toabctl> dirk: I already pinged him in #openstack-rpm-packaging without response...
13:34:28 <dirk> jasondotstar recently joined #openstack-rpm-packaging and was interested in getting/contributing openstack-salt rpm packages
13:34:37 <IgorYozhikov> salt? salt | saltstack
13:34:42 <number80> yes
13:35:50 <dirk> he wanted to invite people over for the rpm packaging meeting but apparently we miscommunicated on the time slot..
13:35:56 <dirk> anyway, I guess we can postpone the topic
13:35:59 <IgorYozhikov> dirk, salt* -> rpm-packaging/openstack/* right?
13:36:29 <dirk> IgorYozhikov: I think it was about packaging the git repo git.openstack.org/openstack/openstack-salt/
13:36:37 <dirk> I haven#t looked at what that would require yet
13:36:53 <dirk> would have been my first question. reportedly there are deb packages but people raised interest in having rpm packages as well
13:37:00 <IgorYozhikov> u i c
13:37:27 <dirk> in case anyone has spec files or wants to write some, contributions are welcome :)
13:38:10 <IgorYozhikov> will update old stuff tomorrow, a lot of work during these days :)
13:38:26 <dirk> any last topic?
13:38:48 <dirk> othwise I'd end the meeting. I have to rush over to something else but will do a round of reviews later tonight
13:39:31 <IgorYozhikov> dirk, i'm fine with finish earlier
13:40:09 <toabctl> nothing from my side.
13:40:22 <dirk> #endmeeting