12:59:37 <dirk> #startmeeting rpm_packaging
12:59:38 <openstack> Meeting started Thu Apr 14 12:59:37 2016 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:59:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:59:41 <openstack> The meeting name has been set to 'rpm_packaging'
12:59:53 <mivanov> hi dirk, IgorYozhikov
13:00:13 <dirk> everyone, please add your agenda items to https://etherpad.openstack.org/p/openstack-rpm-packaging
13:00:17 <dirk> hey mivanov, IgorYozhikov !
13:01:24 <jruzicka> o/
13:02:20 <IgorYozhikov> o/
13:02:40 <IgorYozhikov> already add some topics to agenda
13:07:44 <dirk> sorry
13:07:51 <dirk> someone dragged me off the computer!!
13:07:54 <dirk> darn
13:07:55 <dirk> lets start
13:08:04 <dirk> #topic Using all DB backends within project template as runt-time dependencies (IgorYozhikov)
13:08:21 <dirk> IgorYozhikov: Interesting one, I saw the discussion in the PR..
13:08:37 <IgorYozhikov> yep, I raised this question earlier with toabctl
13:09:43 <IgorYozhikov> So, should we add these python | other bindings as run-time deps
13:10:26 <IgorYozhikov> adding them lead to increasing a chain of dependent packages
13:10:58 <dirk> yeah
13:11:12 <dirk> but on the other side I don't want to require all different databases that exist
13:11:33 <dirk> either we have to conditionalize it somehow or choose the default
13:11:45 <dirk> or not choose any and let the user select one
13:11:54 <dirk> toabctl is on sickleave today btw
13:11:57 <IgorYozhikov> or, if i remembered right, toabctl suggest to add some-kind of sub-package for this purpose
13:12:53 <IgorYozhikov> only with that bindings
13:13:57 <IgorYozhikov> for example we have python-oslo-db and could add a sub package like python-oslo-db-bindings
13:14:27 <dirk> yeah
13:14:47 <IgorYozhikov> naming could be discussed :)
13:15:49 <IgorYozhikov> number80, r u around, your thoughts about ^^^^
13:16:25 <dirk> IgorYozhikov: I am fien with the idea, I don't have an own opinion right now as I haven't researched this in detail
13:17:44 <IgorYozhikov> dirk,may be move this topic to the next meeting with a higher quorum?
13:17:46 <dirk> IgorYozhikov: can we postpone the topic? toabctl  is not here, I don't have an opinion.. or do you have a concrete suggestion?
13:18:34 <IgorYozhikov> dirk, agree, we need more voices
13:18:58 <IgorYozhikov> to get a conclusion
13:19:42 <dirk> #agreed postpone the topic
13:19:46 <dirk> #agreed postpone the topic
13:19:59 <dirk> #topic AIs review  (IgorYozhikov)
13:20:04 <dirk> ah, thanks Igor.
13:20:31 <IgorYozhikov> https://wiki.openstack.org/wiki/ThirdPartySystems/Fuel_Packaging_CI
13:20:36 <IgorYozhikov> https://wiki.openstack.org/wiki/Rpm-packaging
13:20:43 <IgorYozhikov> https://wiki.openstack.org/wiki/Rpm-packaging/ReviewGuidelines
13:20:58 <IgorYozhikov> think that not missed anything
13:21:42 <IgorYozhikov> stable/mitaka has been cut
13:21:56 <IgorYozhikov> everything looks fine
13:22:01 <dirk> yep, thansk for that
13:22:07 <dirk> last meetings action items are done
13:22:49 <dirk> we have a few open from previou meetings though
13:24:31 <IgorYozhikov> https://etherpad.openstack.org/p/spec.j2.formatts
13:24:45 <IgorYozhikov> this is one about formatting
13:25:09 <IgorYozhikov> I proposed 2 variants
13:25:10 <dirk> ah, nice, thats the one I just looked up
13:25:48 <dirk> main change is different indentation level?
13:25:53 <dirk> whats your preference?
13:25:54 <IgorYozhikov> to be honest - I like this one http://paste.openstack.org/show/491703/
13:26:30 <dirk> so its one space vs two spaces after BuildRequires: ?
13:26:34 <IgorYozhikov> 2 \n separate logical parts in template like pre,build,instal, etc
13:27:43 <dirk> ok
13:28:04 <dirk> no strong opinion either way for me. so the different indentation isn't an issue?
13:28:33 <number80> nope
13:28:35 <number80> o/
13:28:56 <IgorYozhikov> no, just looking better when code blocks separated with 2 \n
13:30:06 <dirk> #agreed two \n for separating rpm sections like %prep, %build, %install
13:30:25 <dirk> want to update the review guidelines?
13:30:35 <IgorYozhikov> yes, will do
13:31:13 <IgorYozhikov> hang ai on me :)
13:32:38 <dirk> #ai IgorYozhikov  update review guidelines for section separation
13:32:48 <dirk> next topic ?
13:33:05 <IgorYozhikov> #action IgorYozhikov  update review guidelines for section separation
13:33:35 <IgorYozhikov> yes, if we finished with AIs
13:33:45 <dirk> anything still open?
13:33:46 * dirk looks
13:34:36 <number80> will there be a meeting next week?
13:35:12 <IgorYozhikov> number80, why not?
13:35:33 <number80> some people may be on their way to Austin
13:35:48 <IgorYozhikov> i c'
13:36:28 <dirk> I don't find any other open action items in the minutes
13:36:35 <dirk> ok to move on?
13:36:40 <number80> sure
13:36:49 <IgorYozhikov> go
13:36:51 <dirk> #topicAdd bareon RPM temlate to master (https://github.com/openstack/bareon)  (IgorYozhikov)
13:36:54 <dirk> #topic Add bareon RPM temlate to master (https://github.com/openstack/bareon)  (IgorYozhikov)
13:37:37 <IgorYozhikov> I had been asking about adding RPM 4 bareon project
13:38:08 <IgorYozhikov> I asked bareon leads to set a tag
13:38:15 <number80> ah formerly known as fuel-agent
13:38:16 <IgorYozhikov> to be used within build
13:38:20 <IgorYozhikov> yes
13:38:33 <IgorYozhikov> https://pypi.python.org/pypi/Bareon
13:39:01 <IgorYozhikov> so, if there are no objections or something else - I could make it
13:39:06 <dirk> which dependencies does it have? is it realistic to be added right now?
13:39:06 <number80> IgorYozhikov: none
13:39:31 <number80> (in principle, anything under the openstack namespace is welcome)
13:39:50 <IgorYozhikov> https://github.com/openstack/bareon/blob/master/requirements.txt
13:39:59 <IgorYozhikov> dirk, it looks very common
13:41:00 <dirk> IgorYozhikov: yeap. just add it then
13:41:06 <IgorYozhikov> ok
13:41:21 <dirk> #agreed barean can be added
13:41:25 <dirk> grrr
13:41:28 <dirk> #agreed bareon can be added
13:41:43 <dirk> #topic Pending reviews?
13:41:45 <IgorYozhikov> #action IgorYozhikov  will add bareon RPM template to master
13:42:13 <IgorYozhikov> https://review.openstack.org/#/q/project:openstack/rpm-packaging
13:42:30 <IgorYozhikov> we have here PRs with passed tests
13:43:27 <IgorYozhikov> https://review.openstack.org/#/c/305012/
13:43:44 <dirk> obviously fine by me :)
13:45:16 <IgorYozhikov> https://review.openstack.org/#/c/270826/
13:45:41 <dirk> good by me
13:45:42 <IgorYozhikov> number80, could you please look & merge if necessary
13:45:51 <number80> IgorYozhikov: ack
13:46:17 <IgorYozhikov> dirk, please look into https://review.openstack.org/#/c/303450/
13:46:34 <IgorYozhikov> all comments were addressed :)
13:46:35 <dirk> this should be an easy one: https://review.openstack.org/#/c/304309/
13:46:39 <number80> FYI, I'm working on our gating (I have a non-voting one running home)
13:47:33 <dirk> number80: nice. can it report back already?
13:47:45 <dirk> it would be good to see the results
13:48:08 <number80> well, it runs builds artifacts publishing is broken (hence breaking many builds)
13:48:47 <number80> so having a gate that -1 most reviews is not useful yet
13:49:01 <number80> but we'll have one running during Newton cycle
13:49:39 <IgorYozhikov> dirk, what is the point to set stable/mitaka as default review branch
13:49:40 <IgorYozhikov> ?
13:49:47 <IgorYozhikov> instead of master
13:50:17 <dirk> number80: ok
13:51:25 <dirk> IgorYozhikov: well, so that when you run "git review" on a change in stable/mitaka, it gets published under stable/mitaka by default
13:51:35 <dirk> otherwise you'd proposa a patch against master by default, which probably doesn't make sense
13:52:59 <number80> depends, we're bounded to do more work in the master branch
13:53:10 <IgorYozhikov> depends on goals, if you want to populate repo with mitaka related projects - makes sense
13:53:57 <dirk> jsut to clarify, there are two branches
13:54:03 <dirk> this PR is for the stable branch
13:54:10 <dirk> master branch defaults to master branch as before
13:54:16 <IgorYozhikov> dirk, o i c
13:54:30 <IgorYozhikov> sorry missed that
13:54:41 <IgorYozhikov> mine +2
13:55:39 <IgorYozhikov> number80 ?
13:55:48 <dirk> can we continue in #openstack-rpm-packaging?
13:55:57 <number80> +2
13:56:00 <number80> yes
13:56:04 <IgorYozhikov> sure
13:59:42 <dirk> #endmeeting