13:01:41 <dirk> #startmeeting rpm_packaging
13:01:42 <openstack> Meeting started Thu May 12 13:01:41 2016 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:46 <openstack> The meeting name has been set to 'rpm_packaging'
13:01:53 <toabctl> hi
13:02:01 <dirk> hey
13:02:06 <IgorYozhikov> hi there :)
13:02:16 <dirk> please add your agenda items to https://etherpad.openstack.org/p/openstack-rpm-packaging
13:02:18 <dirk> #link https://etherpad.openstack.org/p/openstack-rpm-packaging
13:02:53 <mivanov> hi folks
13:03:10 <dirk> mivanov: wb
13:05:07 <dirk> number80: ping?
13:07:23 <dirk> #topic AIs from Summit - should we start working on infra based builder & publisher scripts?(IgorYozhikov)
13:07:40 <IgorYozhikov> yes, just want to clarify further steps
13:07:56 <dirk> makes sense
13:08:08 <IgorYozhikov> are we going to start work on this?
13:08:23 <dirk> my personal goal was to look into  it after packaging-deb has solved it mostly
13:08:44 <dirk> paul berranger volunteered to help us in getting the same steps done after they have the workflow working for packaging-deb
13:08:46 <IgorYozhikov> as I remember - 1st prerequisite is image made by DIB
13:08:50 <dirk> I haven't seen an update on this
13:08:55 <dirk> is it already done?
13:09:38 <IgorYozhikov> As I know zigo is still working on jobs
13:09:46 <dirk> have any pointers?
13:09:58 <IgorYozhikov> 1 moment
13:10:06 <dirk> IgorYozhikov: well for suse we could potentially have this running on a ubuntu vm so the DIB image is not a mandatory requirement
13:10:48 <IgorYozhikov> dirk, sounds good
13:11:35 <IgorYozhikov> https://review.openstack.org/#/c/311190/
13:11:47 <dirk> if the whole publishing workflow as explained by mordred  in the work session works then we can indeed start working on moving our building upstream
13:12:42 <IgorYozhikov> and I believe this one https://review.openstack.org/#/c/307742/
13:13:24 <dirk> ok
13:13:36 <dirk> any questions about it?
13:14:42 <dirk> IgorYozhikov: do you want to work on this ?
13:15:20 <IgorYozhikov> dirk, I think that I can try to work on this with zigo because he has some exp here
13:16:10 <dirk> sounds good
13:16:41 <dirk> we don't have the package building job yet, so publishing is I guess the step after that
13:16:59 <dirk> first step for me would be to have a job that can actually build a package (with proper repos available and proper result)
13:17:11 <dirk> thats the part I guess we can work on while deb-packaging figures out the rest of the details
13:17:21 <IgorYozhikov> agree
13:17:40 <IgorYozhikov> builder 1st
13:18:03 <dirk> I guess we should invite paul maybe and understand how we can work on this (maybe start an etherpad)
13:18:12 <dirk> at least I"m pretty lost on this
13:19:09 <IgorYozhikov> good point
13:19:42 <dirk> wanna take the action item?
13:19:49 <IgorYozhikov> create etherpad with steps and fill it up with clarifications
13:19:54 <IgorYozhikov> ok
13:20:39 <IgorYozhikov> I'll take it AI
13:20:58 <IgorYozhikov> s/it/this/
13:21:01 <dirk> #action IgorYozhikov   create etherpad with steps and fill it up with clarifications for building rpm packages as part of PR testing
13:21:13 <dirk> #topic  Spec-Cleaner - install path
13:22:14 <IgorYozhikov> is it possible to use default sitelib?
13:22:25 <IgorYozhikov> without patching?
13:22:35 <IgorYozhikov> https://github.com/openSUSE/spec-cleaner/blob/master/setup.py#L35
13:23:06 <dirk> IgorYozhikov: this is how we build it https://build.opensuse.org/package/view_file/openSUSE:Tools/spec-cleaner/spec-cleaner.spec?expand=1
13:23:38 <dirk> IgorYozhikov: uuhh, that doesn't look good indeed
13:23:45 <dirk> IgorYozhikov: I suggest to send a PR :)
13:24:11 <IgorYozhikov> dirk, I'm asking because of 12:16:42 error: could not create '/usr/lib/obs': Permission denied
13:24:28 <IgorYozhikov> https://packaging-ci.fuel-infra.org/job/master-rpm-packaging-build/128/console
13:24:50 <dirk> IgorYozhikov: yeah, do you see the super fancy sed statement in the spec file ? :-(
13:24:53 <dirk> thats how to fix it..
13:25:03 <IgorYozhikov> yes, I saw
13:25:27 <dirk> toabctl: wanna help IgorYozhikov on cleaning this spec file up?
13:26:22 <IgorYozhikov> in our case spec-cleaner installed as python requirement
13:26:49 <dirk> IgorYozhikov: lets take it as an action item to clean this up..
13:27:00 <toabctl> hm. need to check what's wrong. but PRs upstream are usually reviewed quickly.
13:27:43 <dirk> toabctl: will you have some time for that until next week?
13:27:44 <IgorYozhikov> I can package spec-cleaner in our downstream while waiting for fix
13:27:49 <dirk> ok
13:28:03 <IgorYozhikov> with proper path & so on....
13:28:20 <dirk> ok to move on?
13:28:39 <IgorYozhikov> yep
13:29:03 <dirk> #topic  Update http://www.toabctl.de/openstack/rpm-packaging-status.html to newton
13:29:35 <dirk> if I understand things correctly, we're still tracking mitaka there because we do not have the merging of master with newton implemented in the tool
13:29:47 <dirk> just wanted to point out that doug was doing a lot of initial releases lately for newton
13:29:57 <dirk> so we could have a useful release section already now imho
13:30:14 <dirk> toabctl: can we create a separate page for tracking newton?
13:30:53 <toabctl> dirk: sure
13:31:05 <IgorYozhikov> dirk, for master branch we already use G-R from master
13:31:26 <IgorYozhikov> so packages built from latest commits has newton code
13:31:29 <toabctl> I'll try todo that until next week (but I'm a couple of days off next week)
13:31:38 <dirk> toabctl: thanks!
13:31:51 <dirk> #action toabctl create status page for newton release tracking
13:32:06 <dirk> IgorYozhikov: right.. master git should track newton.. I was merely missing the status page
13:32:18 <dirk> any last topics?
13:32:20 <IgorYozhikov> dirk, got it
13:33:06 <IgorYozhikov> dirk, can we just try to predict amount of projects done in a month?
13:33:28 <IgorYozhikov> all oslo 4 example?
13:33:49 <dirk> main thing right now is lacking review
13:33:50 <IgorYozhikov> and how often do review to speed up
13:33:51 <dirk> s
13:34:03 <dirk> I saw that the python*client proposal become buildable meanwhile
13:34:09 <dirk> so we should try to get them merged
13:34:28 <toabctl> I would like to have the spec-cleaner stuff merged first. to get a clean state for the new specs.
13:34:38 <dirk> toabctl: what is it stalled on right now?
13:34:39 <IgorYozhikov> toabctl, agree
13:34:49 <dirk> I saw that things are failing but I didn't look into the failure
13:35:16 <toabctl> dirk: diffutils needs to be installed on the hosts. I already added a other-requirements.txt file for bindep but without success. I'm currently looking into that.
13:35:31 <IgorYozhikov> so, fix 4 spec-cleaner and rebuild py*clients in master
13:35:42 <dirk> toabctl: ping aj or ask on #infra.. this can probably be fixed somehow..
13:36:00 <dirk> toabctl: thanks
13:36:07 <dirk> let me know if its something that I can help with :)
13:37:07 <dirk> can we end the meeting? next week same time same place?
13:37:19 <IgorYozhikov> I'm fine
13:37:32 <dirk> ok thanks all ttyl
13:37:35 <dirk> #endmeeting