13:00:10 <toabctl> #startmeeting rpm_packaging
13:00:11 <openstack> Meeting started Thu Jun  2 13:00:10 2016 UTC and is due to finish in 60 minutes.  The chair is toabctl. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:15 <openstack> The meeting name has been set to 'rpm_packaging'
13:00:44 <dirk> o/
13:00:48 <toabctl> hi. dirk is FTO so I try to lead the meeting today
13:00:52 <toabctl> oh. here he is :)
13:01:04 <dirk> But listening only :-)
13:01:08 <toabctl> please add your agenda points to https://etherpad.openstack.org/p/openstack-rpm-packaging
13:03:59 <toabctl> hm. looks like nobody is here today...
13:04:07 <IgorYozhikov> щ.
13:04:11 <IgorYozhikov> o/
13:04:55 <toabctl> ok. let's start
13:05:03 <toabctl> #topic pypi urls. use pypi.io
13:05:49 <dirk> Is it going to stay there?
13:05:49 <toabctl> using pypi.python.org for downloading files is a bit more complicated now because you have to update the Source url in the spec whenever you update a spec to a new version
13:05:57 <dirk> It says it is preproduction
13:06:01 <toabctl> #link https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
13:06:18 <toabctl> ^^ this is the full discussion about the topic
13:06:42 <toabctl> suggestion is to use pypi.io which is pypi "2.0"
13:07:17 <IgorYozhikov> toabctl, does that mean that previous path syntax should work?
13:07:18 <toabctl> both systems use the same data (so uploading to pypi.python.org is the same as using pypi.io)
13:07:24 <toabctl> IgorYozhikov, yes
13:07:48 <IgorYozhikov> sounds good, links will be shorter
13:07:58 <dirk> +1
13:07:59 <toabctl> and updates of specs easier
13:08:07 <IgorYozhikov> yey
13:08:24 <toabctl> #agreed use pypi.io for Source urls
13:08:52 <toabctl> let's switch order and do reviews at the end
13:08:58 <toabctl> #topic renderspec extending with deb support template
13:09:03 <toabctl> IgorYozhikov, your turn
13:09:13 <IgorYozhikov> yes
13:09:41 <IgorYozhikov> I have an idea about using same approach for DEB as we already use for RPM
13:10:02 <IgorYozhikov> We made working POC based on renderspec
13:10:20 <IgorYozhikov> but it use dh-python instead of pymod2pkg
13:10:54 <IgorYozhikov> difficulty here - dh-python can't be installed from pypi
13:11:12 <IgorYozhikov> only from source code repo or from package
13:11:44 <toabctl> hm. afaik is dh-python something different than pymod2pkg
13:11:50 <dirk> Do you need that dependency just for package name generation ?
13:11:59 <dirk> Or is this more?
13:12:12 <toabctl> and does zigo know about that? :)
13:12:18 <dirk> I am not very familiar with how that works
13:12:46 <IgorYozhikov> dirk, yes we decide to use dh-python because of native deb name resolution
13:12:49 <IgorYozhikov> zigo knew
13:13:36 <toabctl> IgorYozhikov, how is the name resolution done with dh-python? do you already have a patch to review for renderspec?
13:13:36 <IgorYozhikov> he asked to add auto-fill up from requirements.txt file from particular project
13:14:13 <IgorYozhikov> toabctl, I posted link in etherpad to our git repo
13:14:24 <toabctl> ah. cool
13:14:25 <IgorYozhikov> at 1ts we need to polish the code
13:14:38 <IgorYozhikov> before get it back to upstream
13:14:45 <toabctl> hm. I get a "not found" for https://review.fuel-infra.org/gitweb?p=packaging/renderspec-deb.git;a=tree;h=refs/heads/master;hb=refs/heads/master
13:15:42 <dirk> IgorYozhikov: sounds great, happy to review that after we got the 1.0.0 release out
13:16:06 * dirk still walking through that
13:16:09 <toabctl> I'm also fine with adding support for deb if it's useful for you
13:16:16 <IgorYozhikov> toabctl, I'll update gerrit ACL to let you view code, sorry
13:16:56 <toabctl> hm. so renderspec is no longer the right name if we add deb support :)
13:17:39 <toabctl> IgorYozhikov, imo it would be best to get a changeset where we can discuss it and see how it works.
13:17:46 <IgorYozhikov> sure
13:17:58 <IgorYozhikov> we just want to get it working 1st
13:18:06 <toabctl> sure
13:18:12 <IgorYozhikov> and as the 2nd step - return back
13:18:50 <IgorYozhikov> as for me renderspec sounds fine due package specification :)
13:19:08 <toabctl> true :)
13:19:26 <toabctl> anything else about renderspec deb support?
13:19:34 <IgorYozhikov> nope.
13:19:39 <toabctl> #topic reviews
13:19:47 <toabctl> #link https://review.openstack.org/#/q/(project:openstack/rpm-packaging+OR+openstack/renderspec+OR+openstack/pymod2pkg)+AND+is:open
13:20:03 <toabctl> there are plenty of changes ready for review now.
13:20:16 <IgorYozhikov> I didn't upload anythin since last meeting, we are very close to HCF in MOS, sorry :(
13:20:25 <toabctl> np. I did it :)
13:20:41 <toabctl> I also started to create new spec files
13:21:55 <toabctl> IgorYozhikov, if you find some minutes it would be nice to review thoses where dirk already give his +2 . I think theses could be merged quickly
13:22:34 <IgorYozhikov> toabctl, already looking for oslo.utils
13:23:11 <toabctl> thx
13:23:35 <toabctl> about the client packages - I think all of them are reviewed but they need more work
13:24:12 <toabctl> mivanov, do you plan to address the comments soon? or should somebody else fix it?
13:25:21 <mivanov> I will update them, but hcf in mos is coming
13:25:23 <dirk> toabctl: I'll review the others later
13:26:00 <IgorYozhikov> https://review.openstack.org/#/c/324220/1 +2.1
13:26:06 <dirk> number80 said he'd be able to help with reviews
13:26:35 <number80> o/
13:26:59 <number80> I'll be taking some reviews today and tomorrow morning
13:27:07 <toabctl> great
13:28:41 <toabctl> IgorYozhikov, there are some reviews where your CI fails. i.e. https://review.openstack.org/#/c/324222/
13:29:39 <toabctl> ah.it's about No Package found for python-oslo-utils >= 3.11.0
13:29:52 <IgorYozhikov> toabctl, it depends on  https://review.openstack.org/#/c/324220/
13:30:20 <IgorYozhikov> after merge our ci will publish new package
13:30:33 <toabctl> IgorYozhikov, I see. we are not filling the versions for the BuildRequires. that's why it's passing for suse
13:30:41 <IgorYozhikov> I'll go though the change of green review today
13:30:53 <toabctl> ok
13:30:58 <toabctl> anything else about reviews?
13:31:11 <IgorYozhikov> yes, we are filling all versions using G-R
13:31:25 <toabctl> IgorYozhikov, global-requirements from where?
13:31:43 <IgorYozhikov> master
13:31:49 <toabctl> so not from https://github.com/openstack/rpm-packaging/blob/master/global-requirements.txt ?
13:31:55 <IgorYozhikov> you can see it in artifacts of JJobs
13:32:14 <toabctl> ok. so you are using the ones from the requirements.txt repository
13:32:28 <toabctl> eh, requirements repository (without txt)
13:33:09 <dirk> IgorYozhikov: that can potentially cause bootstrap issues
13:33:23 <dirk> I still have the requirements sync on todo
13:33:30 <IgorYozhikov> dirk, how?
13:33:33 <dirk> Hopefully will get to it before next werk
13:33:36 <dirk> Week
13:34:57 <IgorYozhikov> toabctl, is it normal - https://review.openstack.org/#/c/324220/ still not merged?
13:36:24 <toabctl> IgorYozhikov, hm. I guess yes. It needs some time
13:37:02 <IgorYozhikov> good, will wait and retrigger all red jobs today
13:37:24 <toabctl> #topic open discussion
13:37:27 <toabctl> anything else?
13:38:38 <IgorYozhikov> may be i missed somth, when we are going to release 1.0.0?
13:38:52 <toabctl> IgorYozhikov, for renderspec?
13:38:54 <IgorYozhikov> yes
13:39:16 <toabctl> IgorYozhikov, there are still 2 open reviews. iirc dirk wants to have them in
13:39:25 <IgorYozhikov> ok
13:39:32 <toabctl> so reviews welcome :)
13:40:56 <IgorYozhikov> https://review.openstack.org/#/c/311565/1 +2.1 yaml safe load :)
13:41:29 <toabctl> IgorYozhikov, looking at http://status.openstack.org/zuul/ and filtering for rpm - then you see the gating job which is afaik responsible for merging
13:42:09 <dirk> IgorYozhikov: I didn't want the safe.load yet
13:42:12 <IgorYozhikov> toabctl, thanx
13:42:29 <dirk> I was mostly blocked on preparing the release Jenkins jobs
13:42:45 <dirk> Which is now almost done since today
13:42:57 <IgorYozhikov> o i c
13:43:50 <IgorYozhikov> anything else?
13:43:56 <toabctl> nope
13:44:00 <toabctl> #endmeeting