13:00:17 <dirk> #startmeeting rpm_packaging
13:00:18 <openstack> Meeting started Thu Jun 9 13:00:17 2016 UTC and is due to finish in 60 minutes. The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:22 <openstack> The meeting name has been set to 'rpm_packaging'
13:00:27 <toabctl> hi
13:00:56 <dirk> everyone, please add your agenda items to
13:00:57 <dirk> #link https://etherpad.openstack.org/p/openstack-rpm-packaging
13:02:39 <IgorYozhikov> o/
13:06:35 <dirk> #topic consume renderspec & pymod2pkg from pypi in CI jobs
13:07:38 <IgorYozhikov> yes, I started asking about it already.
13:07:47 <dirk> IgorYozhikov: I'd say yes, we should consume the versions listed in the *txt files
13:07:55 <dirk> e.g. to make it similar like running locally tox -e
13:07:57 <IgorYozhikov> so just to be sure that we are using the same versions in CI
13:08:30 <IgorYozhikov> and results of jobs are more || less the same according to used renderspec version
13:08:40 <dirk> yep
13:08:54 <dirk> I'm obviously pro the topic. any concerns?
13:08:57 <dirk> from anyone?
13:09:22 <IgorYozhikov> since that do we need make pymod2pkg release too?
13:09:45 <IgorYozhikov> which will contain all latest commits?
13:10:27 <IgorYozhikov> after that we could just use pip install renderspec instead of checking out code from git
13:11:19 <IgorYozhikov> number80, toabctl - your opinion
13:11:20 <dirk> IgorYozhikov: we released the tip of tree of pymod2pkg and renderspec as of yesterday as 0.4.0 and 1.0.0, respectively
13:11:33 <IgorYozhikov> dirk, cool
13:11:57 <IgorYozhikov> since that I can update packages for them in our downstream - yey
13:12:54 <toabctl> +1 for using the released versions.
13:13:04 <toabctl> that's also what we do in the SUSE CI
13:13:50 <dirk> IgorYozhikov: as I suggested we could just package the spec files for those packages in the rpm-packaging project :-)
13:15:53 <IgorYozhikov> dirk are you speaking about creating spec.j2 for renderspec & pymod2pkg?
13:16:17 <toabctl> make sense, dirk :)
13:17:07 <dirk> IgorYozhikov: yep
13:17:23 <IgorYozhikov> dirk, I can do that if there are no objections
13:17:49 <dirk> #agreed CIs should use the relesased versions of renderspec/pymod2pkg that the requirements.txt file depends on
13:17:54 <dirk> IgorYozhikov: fine by me
13:19:09 <IgorYozhikov> great, let's proceed?
13:19:11 <dirk> #topic python version for renderspec 2 or 3, functionallity extension - auto populate from project requirements + blacklist support
13:19:49 <dirk> I am not sure I understand the topic
13:19:55 <dirk> IgorYozhikov, would you explain
13:19:55 <dirk> ?
13:19:56 <IgorYozhikov> we almost done with renderspec "deb"
13:20:38 <IgorYozhikov> and I want to discuss some features we already add and want to add in nearest future
13:21:18 <IgorYozhikov> zigo asked about auto-population of requirements from project requirements.tx file
13:21:35 <IgorYozhikov> let me show you how it works - http://paste.openstack.org/show/509202/
13:22:29 <IgorYozhikov> also i asked our devops to provide access to our git repository, toabctl already checked it
13:22:40 <IgorYozhikov> and you could read the code
13:22:59 <IgorYozhikov> And I have a couple of questions here
13:23:50 <IgorYozhikov> 1: as we discussed a week ago about bringing back code with debian style support to initial repository
13:24:21 <IgorYozhikov> dh-python needs py3
13:24:39 <IgorYozhikov> with py2 renderspec fails with encoding error
13:24:49 <IgorYozhikov> SyntaxError: Non-ASCII character '\xc2' in file /usr/share/dh-python/dhpython/__init__.py
13:26:35 <IgorYozhikov> 2: question is about your thought/opinion about functionality we already made
13:27:44 <dirk> I haven't looked at it, toabctl ?
13:27:54 <IgorYozhikov> 3: blacklist file - list of pymodules that will be cut of from auto-population
13:28:32 <number80> debian style?
13:28:55 <toabctl> IgorYozhikov, m. I don't get the questions. about qeustion 1) - what's the question? to use renderspec with python3?
13:29:08 <IgorYozhikov> yes
13:29:46 <number80> having renderspec compatible w/ python3 is definitively a goal
13:30:08 <number80> but it should be running on both python2/3 for now
13:31:01 <toabctl> IgorYozhikov, as number80 said, afaik it is already working with py3. so just call it with python3
13:32:18 <dirk> IgorYozhikov: we have a review open to add python 3 testing for renderspec changes
13:32:33 <dirk> so just use it with python3 if thats what you need?
13:32:59 <IgorYozhikov> toabctl, just clarifying - if I || my colleagues will commit back renderspec with deb support it should be fine. because for debian it works fine only with py3
13:34:06 <IgorYozhikov> due limitation of dh-python
13:35:46 <toabctl> IgorYozhikov, py3 support should work and as dirk said, there will be a job to test with py3, too
13:35:48 <number80> IgorYozhikov: just a question, do you mean that renderspec would also generate debian packages?
13:36:29 <IgorYozhikov> number80, the goal here - add something like --spec-style debian - and yes
13:36:35 <toabctl> IgorYozhikov, regarding question 2) - I haven't looked into it in detail yet. tbh I would like to see a changeset on review.openstack.org to look into it. so others can comment on it, too
13:37:08 <IgorYozhikov> toabctl, sure, will do that on next week
13:37:12 <number80> IgorYozhikov: I don't mind, personally
13:37:17 <toabctl> number80, do you have an opinion about the debian support? we discussed that last week
13:37:19 <toabctl> ah.ok
13:37:31 <dirk> IgorYozhikov: just split it in sensible hunks, and we'll handle it as reviews
13:37:43 <number80> toabctl: if renderspec can generate debian packages, I don't mind but it has to be properly done
13:37:43 <dirk> I'm happy to make it more useable for others
13:37:44 <IgorYozhikov> dirk, I'll try
13:38:13 <toabctl> ok
13:38:27 <number80> for repo, I need more details because I'm not sure what I'd be signing for :0
13:39:20 <toabctl> IgorYozhikov, and I don't understand question 3) - what is auto-population?
13:39:43 <IgorYozhikov> number80, I can show you how it works, if any1 interested I can arrange a video call :)
13:39:55 <IgorYozhikov> toabctl, http://paste.openstack.org/show/509202/
13:40:02 <IgorYozhikov> {{ req2pkgs() | indent(9) }}
13:40:05 <IgorYozhikov> function
13:40:22 <number80> IgorYozhikov: I'll ping you later about it, I'm multitasking again
13:40:31 <IgorYozhikov> which is populating requirements from project reqs txt file
13:41:02 <toabctl> where does the requirements file come from?
13:41:31 <IgorYozhikov> I use this command renderspec-deb --requirements global-requirements.txt --project-requirements ../oslo.db/requirements.txt -o - examples/oslo.db.control.j2
13:41:45 <IgorYozhikov> from source code project
13:42:20 <toabctl> IgorYozhikov, what's the difference between --requirements and --project-requirements ?
13:42:42 <toabctl> you can already use --requirements multiple times.
13:42:47 <IgorYozhikov> --requirements works as usual
13:43:25 <IgorYozhikov> --project-requirements is used for auto-population
13:44:01 <toabctl> so we no longer maintain the list of Requires but use this autopopulation thingy?
13:44:51 <dirk> IgorYozhikov: but thats an independent feature .. (auto population)
13:44:54 <IgorYozhikov> we could maintain both in case of necessity
13:44:58 <dirk> we could decide for or against that for rpm packages
13:45:00 <dirk> as well
13:45:07 <dirk> currently I was leaning towards not having auto population
13:45:13 <toabctl> me, too
13:45:15 <dirk> to give a chance of opinionating the packaging
13:45:35 <toabctl> and just using requirements.txt from a project is not enough. there may be requirements in setup.cfg and other files
13:45:40 <IgorYozhikov> dirk, agree, and that is why I'm asking
13:45:45 <dirk> but thats maybe a wrong approach if you think about the goal of having a genuine openstack packaging of openstack
13:46:17 <toabctl> getting requirements from a repo/sdist could be a own project imo
13:46:42 <dirk> IgorYozhikov: is the project-requirements thing a requirement for zigo/the deb packaging folks?
13:46:54 <IgorYozhikov> dirk, yep
13:47:00 <IgorYozhikov> zigo asked about it
13:47:04 * number80 is found of autopopulation too
13:47:07 <number80> *not
13:47:31 <number80> it could be an option for debian support of renderspec though
13:47:52 <IgorYozhikov> yes, I can enable this only in case of style - debian
13:48:08 <IgorYozhikov> thanks number80 for suggestion
13:49:23 <toabctl> IgorYozhikov, has zigo already code to get requirements from a sdist ?
13:49:42 <zigo> We don't use sdist binaries.
13:49:47 <zigo> Just plain git...
13:50:17 <toabctl> zigo, hey
13:50:26 <toabctl> zigo, so same question - just replace sdist with git :)
13:50:47 <IgorYozhikov> toabctl, dirk are you fine if this function will available only with spec-style debian?
13:51:19 <zigo> toabctl: I used to, but since the requirements.txt are full of != and python-version<3.3 stuff, what I wrote is broken...
13:51:43 <toabctl> zigo, there is the packaging module which handles the requirements markers .
13:51:59 <zigo> toabctl: Using Python code?
13:52:04 <toabctl> zigo, yes
13:52:06 <zigo> My stuff was in plain shell ... :P
13:52:14 <toabctl> heh
13:52:47 <zigo> ISO shell, only for the true hackers (tm)
13:52:48 <zigo> :)
13:53:07 <zigo> More seriously: I was too lazy to write things correctly in Python.
13:53:18 <zigo> It's good someone else has enough time to write it properly.
13:53:36 <dirk> IgorYozhikov: well.. I would prefer to try to unify the approaches of requirements handling
13:54:00 <dirk> in the long run it would be better I think. but if we can't agree then I'm not objecting to adding an option for satisfying conflicting needs
13:54:23 <dirk> but still trying first to come to the same approach would be preferable
13:54:39 <IgorYozhikov> dirk, ok, I'll try to propose PRs
13:54:59 <IgorYozhikov> next topic?
13:56:07 <number80> yes
13:56:57 <dirk> #topic reviews
13:57:10 <dirk> since we're about to run out of time, can we do that topic in the rpm-packaging channel?
13:57:16 <toabctl> #link https://review.openstack.org/#/q/(project:openstack/rpm-packaging+OR+openstack/renderspec+OR+openstack/pymod2pkg)+AND+is:open
13:57:22 <IgorYozhikov> yes
13:57:25 <toabctl> ah.sure
13:57:31 <zigo> Guys, could you please review these 2: https://review.openstack.org/#/c/278360/1 https://review.openstack.org/#/c/274077/6
13:57:41 <number80> ack
13:57:42 <IgorYozhikov> I already spent some time this week doing this
13:57:46 <zigo> These are adding a --sysconfdir option in PBR.
13:57:54 <dirk> IgorYozhikov: main open things are rebasings of the python*client spec templates.. are you guys going to do that?
13:58:00 <dirk> ok, lets end the meeting here and move over
13:58:02 <dirk> thanks!
13:58:04 <dirk> #endmeeting