13:02:26 <dirk> #startmeeting rpm_packaging
13:02:27 <openstack> Meeting started Thu Jul  7 13:02:26 2016 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:30 <openstack> The meeting name has been set to 'rpm_packaging'
13:02:36 * dirk hates copy&paste
13:02:38 <number80> dirk: #meetingname to fix meeting title :)
13:02:52 <number80> (and chair few more people so they could use meetbot commands)
13:03:03 <toabctl> hey
13:03:14 <jruzicka> o/
13:03:40 <dirk> I can do that
13:03:47 <dirk> #addchair number80 toabctl
13:03:58 <dirk> #addchair number80 toabctl  IgorYozhikov
13:04:04 <dirk> hmm, maybe not
13:04:08 <dirk> I'll read the documentation
13:04:20 <dirk> #addchair number80
13:04:25 <jpena> dir, use #chair
13:04:31 <jpena> dirk :o)
13:05:08 <number80> I'll update the etherpad to add a meeting script
13:05:36 <dirk> everyone, please update https://etherpad.openstack.org/p/openstack-rpm-packaging for agenda items that you want to discuss
13:07:22 <dirk> #chair number80
13:07:23 <openstack> Current chairs: dirk number80
13:07:30 <dirk> #chair toabctl
13:07:30 <openstack> Current chairs: dirk number80 toabctl
13:07:37 <dirk> jpena: thanks
13:07:40 <dirk> that seems to work
13:07:43 <number80> astsmtl: could you add a topic about Fuel CI gate status?
13:07:45 <dirk> #topic please update agenda
13:07:55 <astsmtl> Yes.
13:08:03 <number80> thank you sir
13:08:11 <toabctl> astsmtl, wrong date
13:08:32 <toabctl> astsmtl, ah. no. I'm wrong. pardon
13:08:35 <dirk> toabctl: no, you're wrong :)
13:08:39 <astsmtl> :)
13:09:21 <toabctl> confusing that there are things from the future already :)
13:10:11 <toabctl> let's start?
13:10:43 <number80> yes
13:10:46 * dirk had a network outage
13:10:53 <number80> np
13:10:53 <dirk> #topic Barcelona summit sessions
13:11:14 <number80> since this summer vacations period, let's start preparing what we want to achieve there
13:12:18 <number80> my wishlist would be: fishbowl to determine our goals for ocata (and possibly a common one with deb packaging folks) + work session
13:12:50 <number80> work session could be focused on common gating
13:13:06 <number80> like more sanity checks and improved tooling
13:13:18 <number80> what do you think?
13:13:23 <toabctl> sounds good
13:13:39 <toabctl> I also thought about to submit a talk about our current status and the future goals
13:14:40 <number80> looks good
13:14:56 <dirk> number80: what do you mean by "common gating" ?
13:15:20 <dirk> toabctl: yeah, might be a good idea. although we're still a lot behind the newton goals :/
13:16:11 <toabctl> dirk, yes
13:16:12 <number80> dirk: well, 3rd-party gating would be platform-focused, common-gating on quality (e.g rpmlint, testing if we remove/rename packages, etc.)
13:16:53 <dirk> number80: ah, well, I thought common-gating would be the upstream-build packaging
13:16:54 <number80> and also defining a common set of basic testing for 3rd-party gating: installation, showing provides/requires in logs etc...
13:16:58 <dirk> binary packaging
13:17:04 <dirk> which was the goal for newton
13:17:05 <number80> dirk: we're not yet there
13:17:15 <dirk> true
13:17:47 <number80> if we harmonize our gating, then, it will mitigate that and we could move forward faster
13:18:02 <dirk> anyway, I think we agree on fishbowl (probably together with deb packaging again) +1 work session
13:18:06 <dirk> do we want more than 1 work session?
13:18:17 <dirk> we could do two and have one joint one for the deb packaging?
13:18:28 <number80> works for me
13:19:04 <toabctl> +1
13:19:22 <number80> if we want to save that in summary logs =>   #agreed one fishbowl (w/ deb packaging folks) + 1 work session
13:19:23 <dirk> #agreed ask for one fishbowl (possibly joint with packaging-deb) and two work sessions
13:19:29 <number80> excellent
13:19:39 <number80> zigo: ^
13:19:42 <dirk> afaik there hasn't been a roundcall for the design summit planning yet
13:20:05 <number80> dirk: yes, but as soon as it comes out, we'd be ready to do that
13:20:32 <dirk> number80: yep, thanks for thinking about this early
13:20:59 <dirk> do we want to put the common package building thing on the agenda for next week?
13:21:36 <toabctl> sure. we can postpone it if we want
13:21:42 <dirk> ok, just added it
13:21:46 <dirk> #topic RDO based gate
13:21:51 <number80> Yes
13:21:58 <number80> jpena: ^
13:22:20 <jpena> we're making good progress here, the reviews during this week helped a lot -> http://209.132.178.209/repos/status_report.html
13:22:45 <jpena> right now, we have 2 packages waiting for a new pymod2pkg release
13:22:55 <jpena> python-keystoneclient will be fixed in the next round
13:23:06 <jpena> and just oslo.cache and bareon would need some action on our side.
13:23:09 <number80> toabctl: btw, toabctl since you merged the latest review, we're good for a release from my PoV
13:23:28 <jpena> number80: about oslo.cache, we need a newer pytz somewhere, that's where it is failing atm
13:23:47 <number80> jpena: well, my fault then :)
13:23:55 <toabctl> dirk, I think you know where to commit to get a new pymod2pkg release, right?
13:23:57 <jpena> it doesn't fail in RDO because we rm test-requirements.txt in the spec
13:23:57 <number80> i'll fix it today
13:24:33 <dirk> is the fix for pymod2pkg already in git?
13:24:38 <dirk> I can get a new release created
13:24:48 <number80> dirk, toabctl: if it's openstack standard release process, then, I can try (wants to learn how to do it)
13:25:03 <toabctl> number80, go ahead!
13:25:14 <number80> Thanks, I'll ping Dirk if I have any issue
13:25:33 <toabctl> number80, maybe you can add me as reviewer so I know how it works
13:25:35 <number80> #action number80 sends review for pymod2pkg release
13:25:39 <number80> toabctl: sure
13:25:52 <dirk> number80: just send a review against openstack/releases file deliverables/_independent/pymod2pkg.yaml
13:26:02 <dirk> number80: add a new release entry there with a new version+hash
13:26:07 <number80> dirk: ack
13:26:09 <dirk> e.g. 0.4.1 or 0.5.0
13:26:13 <dirk> not sure which version number we want to pick
13:26:40 <number80> dirk: could be a 0.5.0 since there's additional feature (RegexRule)
13:26:53 <number80> definitions-only releases should be patch versions
13:26:54 <dirk> works for me
13:27:06 <number80> #agreed release pymod2pkg 0.5.0
13:28:24 <dirk> number80: just to understand this correctly, this is delorean (aka using the daily git snapshot with our spec teamplates)?
13:28:28 <dirk> s,daily,current,
13:28:37 <jpena> dirk: yes
13:28:51 <dirk> so you're not trying to build the release that is mentioned in the .spec.j2 Version / source: line
13:28:52 <dirk> ?
13:28:58 <number80> dirk: yes, but it will use tags in a future update of dlrn
13:29:07 <number80> (jpena is working on that)
13:29:15 <dirk> or is there also a build bot that builds the version we've packaged ?
13:29:29 <dirk> e.g. fetching the tarball from the Source0 line and building that one?
13:29:39 <number80> I guess we'll have both modes in the ned
13:29:57 <number80> building packaged version + trying to build stable branches HEAD
13:30:04 <dirk> would be great to have that 2nd mode added as a 3rd party gate
13:30:21 <number80> Yup
13:30:36 <dirk> ok, thanks for the update and all the work on this. anything else on that topic?
13:30:43 * number80 is good
13:30:53 <dirk> #topic RPM Packaging mascot
13:30:54 <jpena> nothing to add
13:31:27 <dirk> so, summary in two sentences
13:31:56 <dirk> OpenStack foundation would like to promote Big Tent projects like ours better and would like to hire a designer to create a perfectly looking logo for the project
13:32:32 <dirk> Packaging-rpm is one of those projects they want to work with. they would like to get our input on providing an idea for a mascot by July 27th
13:32:47 <dirk> this will be announced in a bigger round somewhen next week or the week after
13:32:56 <dirk> any idea what we should be picking?
13:33:00 <number80> I have few ideas
13:33:11 <dirk> the mascot can be anything from the natural world—an animal, fish, plant, or natural feature such as a mountain or waterfal
13:33:24 <dirk> it should not be something that is used by another company or project already under the big tent
13:33:30 <number80> http://i.makeagif.com/media/10-09-2014/UOywGe.gif
13:33:44 <dirk> lol
13:33:47 <toabctl> hehe
13:34:25 <number80> well, I guess we won't be running out of ideas :)
13:34:56 <toabctl> dirk, do you collect the ideas? should be create an etherpad?
13:35:24 <astsmtl> https://s-media-cache-ak0.pinimg.com/236x/f5/5c/b8/f55cb8e59d98a9ddad7df0f1b98e8631.jpg
13:35:49 <toabctl> :)
13:36:57 <dirk> toabctl: etherpad is probably a good idea
13:37:06 <dirk> should we just use a section in the current one or create a new one?
13:37:19 <astsmtl> On serious note, it probably can be OpenStack logo sticking out of the box?
13:37:34 <dirk> yeah, I was thinking about a bottled openstack logo
13:37:47 <dirk> or something like that
13:37:47 <astsmtl> Or more spicifically, RPM box
13:37:56 <number80> ativelkov: kittens :>
13:37:58 <toabctl> dirk, new etherpad imo. https://etherpad.openstack.org/p/openstack-rpm-packaging-logo-ideas
13:38:01 <dirk> I don't know if that complies to the openstack logo trademark guidelines though :)
13:38:12 <jruzicka> kitten in a box? :D
13:38:15 <dirk> #link https://etherpad.openstack.org/p/openstack-rpm-packaging-logo-ideas
13:38:23 <number80> well, we can ask RPM project
13:38:30 <dirk> #action all please submit logo ideas to https://etherpad.openstack.org/p/openstack-rpm-packaging-logo-ideas
13:39:24 <dirk> I add this to the agenda for next week
13:39:35 <dirk> #topic  Fuel CI gate status
13:40:05 <astsmtl> Well, I can't say much atm.
13:40:23 <astsmtl> Except that you say it's broken, and I promised to fix it. :)
13:40:48 <astsmtl> I'm not the author of this CI, but I can debug and submit fixes.
13:40:51 <toabctl> astsmtl, I haven't looked into the logs. maybe it's the same problem for all changesets
13:41:22 <jpena> astsmtl: I've looked at some failures, and all of them have the same error
13:41:24 <jpena> "Error: No Package found for python-oslo-utils >= 3.14.0"
13:41:36 <astsmtl> Should be easy to fix then.
13:41:38 <jpena> So it looks like the CI does not have the latest oslo.utils package
13:42:31 <astsmtl> #action astsmtl fix Fuel CI
13:42:45 <toabctl> astsmtl, thx!
13:43:48 <toabctl> next topic?
13:44:18 <dirk> #topic ipproute vs iproute2 ? how to handle non-python Requires/BuildRequires
13:44:31 <dirk> #link https://review.openstack.org/#/c/323158/7/openstack/oslo.rootwrap/oslo.rootwrap.spec.j2
13:44:51 <toabctl> number80, if I understand your comment there correctly, you mean that iproute2 (the name) is suse specific?
13:45:41 <number80> toabctl: yes, we just update iproute to latest
13:45:44 <toabctl> in general I wonder how we want to handle theses different names depending on the used distro. do we want to use macros or create a method in renderspec which can handle it?
13:45:57 <dirk> toabctl: yeah, our iproute2 is called iproute everywhere else
13:46:11 <toabctl> dirk, because the upstream name is iproute2 :)
13:46:31 <number80> toabctl: I don't mind here using a %distro specific conditionals until we figure out a better way
13:46:41 <dirk> toabctl: so I think in this case we can just add an %else blocka nd move on
13:47:00 <dirk> when it gets complicated and repetitive (e.g. iproute2 in 200 spec files) we should add a substitution to renderspec that deals with it
13:47:17 <dirk> imho lets revisit this if its a more-than-once issue
13:47:23 <toabctl> ok
13:47:40 <toabctl> #agreed use macros to handle iproute vs iproute2 package name
13:47:44 <dirk> any concerns about that?
13:47:53 <toabctl> ups. agreed to early?
13:48:35 <dirk> doesn't look like
13:48:36 <dirk> ok
13:48:46 <dirk> #topic update of our *-requirements.txt files
13:49:03 <dirk> I guess the short answer is: still on my todo.. somewhere
13:49:07 <toabctl> ok
13:49:23 <toabctl> we could update it manually for now I guess
13:49:39 <toabctl> next topic then.
13:49:42 <toabctl> running out of time.
13:51:02 <astsmtl> dirk
13:51:21 <dirk> #topic packages reviews (https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open )
13:52:28 <number80> dirk: a minor nitpick for oslo.versioned, could you fix it?
13:52:33 <number80> otherwise, it's +2 for me
13:52:44 <number80> https://review.openstack.org/#/c/331548/
13:53:01 <toabctl> number80, this needs a lint fix: https://review.openstack.org/#/c/333197/
13:53:12 <dirk> number80: yep, will do after the meeting
13:53:13 <toabctl> dirk, this one a rebase : https://review.openstack.org/#/c/333831/
13:53:27 <number80> toabctl: yes, it's the next one on my list :)
13:53:36 <number80> Is Mikhail Ivanov here?
13:53:48 <toabctl> I updated the cinder and glance client packages from Mikhail
13:54:19 <number80> Yes, I'd like him to focus on some reviews, he was not very responsive
13:54:28 <astsmtl> I can invite him or pass any info.
13:54:37 <toabctl> yeah. for the clients there was no progress for 2 month
13:54:47 <dirk> toabctl: done :)
13:54:54 <toabctl> but I think they are now ready to be merged (when the fuel CI passes)
13:55:15 <number80> astsmtl: well, I prefer newcomers to focus on small numbers of reviews and work to get them approved
13:55:34 <astsmtl> Misha is going to join us.
13:55:40 <number80> hi mivanov
13:55:45 <mivanov> hi
13:55:52 <dirk> hey mivanov
13:55:54 <toabctl> hey
13:56:05 <mivanov> hi folks
13:56:07 <number80> as I was saying, I'd like you to focus on one/two reviews to get them approved
13:56:50 <mivanov> are you talking about my patches?
13:56:58 <number80> Yes
13:57:06 <toabctl> mivanov, about the patches from https://review.openstack.org/#/q/(project:openstack/rpm-packaging+OR+openstack/renderspec+OR+openstack/pymod2pkg)+AND+is:open
13:57:48 <mivanov> okay, I've update this review asap
13:58:00 <number80> thank you
13:58:16 <toabctl> thx
13:58:56 <mivanov> no problem, folks. thank you for reminding :)
13:59:55 <toabctl> ok.  I guess we have to move to #openstack-rpm-packaging
14:00:06 <dirk> yeah
14:00:08 <astsmtl> #action mivanov update CRs, strive to merge.
14:00:11 <dirk> lets continue with reviews there
14:00:17 <dirk> thanks!
14:00:18 <dirk> #endmeeting