13:01:04 <number80> #startmeeting rpm_packaging
13:01:05 <openstack> Meeting started Thu Aug 25 13:01:04 2016 UTC and is due to finish in 60 minutes.  The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:09 <openstack> The meeting name has been set to 'rpm_packaging'
13:01:13 <number80> #topic roll call
13:01:15 <number80> o/
13:01:17 <jpena> o/
13:01:35 <toabctl> hi
13:01:43 <number80> #chair IgorYozhikov jpena toabctl jruzicka
13:01:44 <openstack> Current chairs: IgorYozhikov jpena jruzicka number80 toabctl
13:01:49 <number80> agenda is here
13:01:52 <number80> https://etherpad.openstack.org/p/openstack-rpm-packaging
13:02:29 <jruzicka> o/
13:02:30 <number80> let's start
13:02:42 <number80> #topic python3/renderspec
13:03:17 <number80> IgorYozhikov: ?
13:03:49 <IgorYozhikov> number80, I wrote my thoughts and want to discuss them
13:04:13 <IgorYozhikov> https://etherpad.openstack.org/p/openstack-rpm-packaging-python3-renderspec
13:04:57 <IgorYozhikov> We can discuss topics from etherpad 1 by 1
13:05:05 <jruzicka> yeah please go on
13:05:13 <jruzicka> I don't have enough context to just answer inline
13:05:51 <number80> Having done a fair amount of python3 packaging, I think this is something that could be fully automated
13:06:10 <number80> the only blocker is that we have no good rpm spec file parser
13:06:31 <IgorYozhikov> jruzicka, dirk 2 weeks ago informed us about possibility of py3 usage in openstack starting from O release
13:06:56 <jruzicka> number80, what for?
13:07:38 <jruzicka> rdopkg has some codez to modify .spec, spec-cleaner also parses it
13:07:40 <number80> jruzicka: you need to be able to manipulate concepts like subpackages and stuff
13:07:49 <number80> no parser does that
13:07:51 <jruzicka> oh, so a real parser
13:07:55 <number80> yes
13:07:57 <jruzicka> not a piece of hacked crap
13:08:17 <toabctl> number80, we could go the other way and regenerate the spec always from a template. then you don't need a parser
13:08:22 <number80> if you look AIO packages, it basically duplicating subpackages
13:09:09 <number80> toabctl: we'd still need that, we have this requirement of one source == one package
13:09:18 <number80> *source package
13:09:43 <jruzicka> I'm quite unsure howto proceed here
13:09:47 <number80> it ensures that you don't package different versions of same sources
13:09:59 <jruzicka> toabctl wants to implement {{ requires }} macro to generate all
13:10:12 <jruzicka> and handle irregularities with override configs
13:10:21 <number80> that would work for me
13:10:35 <toabctl> that's my current pain point when I need to update packages...
13:10:38 <jruzicka> problem is howto distribute deps between subpackages
13:10:50 <IgorYozhikov> jruzicka, this requires macro - what will it do?
13:10:59 <toabctl> jruzicka, with a config file (could be a global one and then, if needed, one per spec)
13:11:03 <jruzicka> and howto corretly override projects that don't follow conventions and all the special cases
13:11:32 <toabctl> jruzicka, the good thing in openstack is that there are not so much special cases. if we get 90% automated we did a huge step forward imo
13:11:36 <jruzicka> IgorYozhikov, basically generate {Build,}Requires from tarball
13:11:51 <IgorYozhikov> from req and test-reqs?
13:11:52 <number80> I think it works fine for oslo libs and clients
13:12:04 <jruzicka> toabctl, agreed but I still think supporting mixed approach between full automation and what we have now
13:12:06 <number80> but services will not work with that macros due to splitting
13:12:22 <toabctl> yep.
13:12:35 <toabctl> but if we can first automate oslo + clients that would be imo reat
13:12:41 <number80> but well, it doesn't hurt having such macro and use it when it makes sense
13:12:43 <toabctl> jruzicka, btw I started this morning https://github.com/toabctl/metaextract
13:12:50 <IgorYozhikov> jruzicka, toabctl if you remember I showed you auto-generation from reqs files
13:13:11 <IgorYozhikov> a couple of months ago
13:13:15 <jruzicka> number80, yeah I'm all for that, just not sure that we want to have only that macro and oboslete current way
13:13:35 <jruzicka> IOW I'd rather have the extra metadata about special cases directly in the .spec.j2
13:13:48 <jruzicka> as opposed to some magical config for the {{ requires }} macro(s)
13:13:49 <IgorYozhikov> and we use py3 in our version of renderspec-deb
13:14:02 <toabctl> jruzicka, fine for me
13:14:18 <toabctl> IgorYozhikov, you mean renderspec runs on py3 or it creates py2 specs?
13:14:44 <jruzicka> IgorYozhikov, wait you have a tool to convert the .spec to .deb? :D
13:14:48 <toabctl> IgorYozhikov, not all projects use req-files. some use setup.cfg to define requirements and extras_require
13:15:00 <IgorYozhikov> toabctl, yep runs on py3
13:15:18 <IgorYozhikov> and created deb/controls for both py2 and py3
13:15:26 <toabctl> IgorYozhikov, I think renderspec is able to run with py3, too. and if not it should be easy to fix it.
13:15:29 <toabctl> ah.ok
13:15:54 <jruzicka> is it somewhere public?
13:16:05 <IgorYozhikov> toabctl I believe has access
13:16:11 <IgorYozhikov> let me check
13:16:28 <IgorYozhikov> https://review.fuel-infra.org/gitweb?p=packaging%2Frenderspec-deb.git;a=summary
13:16:37 <IgorYozhikov> jruzicka, ^^^^^
13:17:03 <jruzicka> Not Found
13:17:05 <jruzicka> for me
13:17:07 <IgorYozhikov> yep
13:17:17 <IgorYozhikov> you need login 1st
13:17:21 <jruzicka> anyway, I'm just glad to know such thing exists
13:17:24 <toabctl> anyway - should we go back to the etherpad points?
13:17:27 <number80> yes
13:17:28 <jruzicka> let's continue
13:17:50 <number80> #topic mock hardcoded options for tmpfs
13:17:52 <number80> IgorYozhikov: ?
13:17:55 <IgorYozhikov> ye
13:18:31 <IgorYozhikov> I found that hard coded self.optArgs = ['-o', 'nr_inodes=0'] doesn't work on u16.04
13:18:46 <IgorYozhikov> mount -t tmpfs -o mode=0755 -o nr_inodes=0 -o size=1g mock_chroot_tmpfs /mnt/
13:18:46 <IgorYozhikov> mount: wrong fs type, bad option, bad superblock on mock_chroot_tmpfs,
13:18:46 <IgorYozhikov> missing codepage or helper program, or other error
13:19:09 <IgorYozhikov> this is not critical but very annoying
13:19:38 <IgorYozhikov> code here https://git.fedorahosted.org/cgit/mock.git/commit/?h=mock-1.2.14&id=de710c5b7d3a4e563c372a796f5305fa9cf17241
13:20:02 <number80> IgorYozhikov: I think you can submit a patch to msuchy to allow mock usage on other distros
13:20:21 <number80> not sure this is relevant to that meeting but we can discuss this
13:20:40 <IgorYozhikov> ok
13:21:12 <number80> let's move to the next topic
13:21:34 <IgorYozhikov> yes
13:21:39 <number80> #topic reviews: pymod2pkg
13:21:45 <number80> https://review.openstack.org/#/q/project:openstack/pymod2pkg+status:open
13:21:56 <jruzicka> (None)
13:22:05 <number80> we cleaned up the queue, toabctl has submitted a new release
13:22:06 <toabctl> has anybody requested a new release?
13:22:12 <toabctl> I didn't
13:22:27 <number80> toabctl: ok, I'll take care of that then
13:22:33 <toabctl> number80, ok. thx
13:22:40 <number80> #action number80 request a new pymod2pkg release
13:23:01 <number80> #topic reviews: renderspec
13:23:03 <number80> https://review.openstack.org/#/q/project:openstack/renderspec+status:open
13:23:14 <number80> any comments?
13:23:36 <IgorYozhikov> https://review.openstack.org/#/c/357733/
13:23:42 <jruzicka> first one still needs discussion :)
13:23:44 <IgorYozhikov> looking
13:24:25 <IgorYozhikov> https://github.com/openstack/rpm-packaging/blob/master/openstack/python-neutronclient/python-neutronclient.spec.j2
13:24:39 <number80> yeah, just giving a change to allow people to push for specific stalled reviews
13:24:42 <number80> IgorYozhikov: ?
13:25:11 <number80> (spec reviews are next, I left it explicitly at the end, since it's biggest chunk)
13:25:19 <IgorYozhikov> v 5.0.0
13:25:20 <IgorYozhikov> Error: No Package found for python-neutronclient >= 5.1.0
13:25:45 <jruzicka> number80, nothing to discuss in renderspec, go on
13:25:49 <IgorYozhikov> number80, we need to update used as dependencies py*clients 1st
13:26:04 <number80> #topic reviews: specs
13:26:15 <number80> https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open
13:26:22 <toabctl> I would abandon both renderspec review tbh
13:26:40 <jruzicka> toabctl, me too :)
13:27:06 <jruzicka> but we can leave them a little longer, wait for dirk... dunno
13:27:18 <number80> toabctl: we need to have a timeout policy for reviews
13:27:24 <toabctl> yeah
13:27:31 <toabctl> for both - dirk and timeout
13:27:43 <toabctl> let's discuss the spec reviews
13:27:48 <number80> yep
13:28:02 <IgorYozhikov> toabctl, as I remember it there are no any movements for 2 weeks - core can merge with 1 +2
13:28:08 <toabctl> IgorYozhikov, what's the problem with neutronclient other then a spec.j2 update is needed?
13:28:20 <toabctl> IgorYozhikov, for which review?
13:28:35 <number80> yes, I agree that we just need to update neutronclient
13:29:00 <toabctl> there are plenty of updates needed - see http://toabctl.de/openstack/rpm-packaging-status-newton.html
13:29:21 <toabctl> IgorYozhikov, so which one has no progress that you want to merge?
13:30:01 <IgorYozhikov> toabctl, not now - I'm about policy, we discussed it more them half year ago
13:30:14 <IgorYozhikov> s/them/than/
13:30:41 <toabctl> IgorYozhikov, yeah. I'm still fine with that policy. but in my experience we usually response in 2 weeks at least on irc.
13:31:35 <IgorYozhikov> ok, getting back to updates. about py*clients, please do not be swift with update of openstackclient
13:31:54 <IgorYozhikov> I faced issue - https://bugs.launchpad.net/python-openstackclient/+bug/1615988
13:31:54 <openstack> Launchpad bug 1615988 in python-openstackclient "[osclient v3.x.x]Default auth type is not detected in case when os-token and os-url is used " [High,In progress] - Assigned to Dean Troyer (dtroyer)
13:32:19 <toabctl> IgorYozhikov, please add these kind of comments to the corresponding review. that's much easier :-)
13:32:22 <IgorYozhikov> 2.6.0 - latest working one
13:32:46 <toabctl> IgorYozhikov, btw we don't even have openstackclient in git iirc
13:33:02 <IgorYozhikov> toabctl, i c
13:33:11 <toabctl> it's https://review.openstack.org/#/c/357733/
13:33:28 <number80> IgorYozhikov: I added a -W until we update neutronclient
13:33:46 <IgorYozhikov> number80, I saw, thanks
13:34:13 <toabctl> I think we can merge https://review.openstack.org/#/c/279477/
13:34:13 <number80> ok, any specific review, you want to mention?
13:34:26 <IgorYozhikov> https://review.openstack.org/#/c/358816/
13:34:37 <IgorYozhikov> dirk made comment about sphinx
13:35:06 <IgorYozhikov> does it means that we need to propose a patch to cliff directly?
13:35:57 <IgorYozhikov> and it is also mentioned here  https://github.com/openstack/requirements/blob/master/global-requirements.txt#L351
13:36:09 <IgorYozhikov> sphinx>=1.2.1,!=1.3b1,<1.3  # BSD
13:36:34 * toabctl wonders what's special about cliff here...hm
13:37:16 <jruzicka> toabctl bugs :)
13:37:20 <jruzicka> special bugs I mean
13:37:27 <IgorYozhikov> or I missed something
13:37:33 <jruzicka> especially in 1.3b1
13:37:35 <toabctl> jruzicka, :)
13:37:35 <jruzicka> :D
13:38:38 <jruzicka> I'd see a history of that line and how it got there
13:39:31 <toabctl> jruzicka, I think the problem was pbr and the doc build feature. i tried to fix that month ago but the patch was not accepted iirc
13:39:38 <number80> I don't get why we need to patch cliff
13:40:01 <toabctl> number80, I think we should try to get rid of the < 1.3.
13:40:21 <toabctl> in the SUSE CI I think we use a newer version of sphinx. I wonder why that works with other packages...
13:40:22 <number80> toabctl: yes, but should happen in global-requirements
13:40:28 <toabctl> number80, yes
13:40:57 <toabctl> oh. pbr supports now sphinx 1.4
13:41:01 <toabctl> https://review.openstack.org/#/c/229951/
13:41:02 <number80> toabctl: for now, can't we just fix our copy of requirements?
13:41:29 <toabctl> number80, hm. that should work I guess
13:42:54 <IgorYozhikov> number80, you r now about - https://github.com/openstack/rpm-packaging/blob/master/global-requirements.txt right?
13:43:34 <number80> IgorYozhikov: yes, I think we should temporarily override it (with a comment)
13:44:12 <IgorYozhikov> number80, looks like it should work
13:44:14 <number80> toabctl: please add me as a reviewer for the g-r review, we should hurry to have this change accepted in newton
13:44:28 <toabctl> number80, the sphinx thing?
13:44:38 <number80> yes, we'll be freezing things soon
13:44:49 <toabctl> number80, yeah.
13:44:55 <IgorYozhikov> yey
13:46:04 <number80> #action toabctl to override sphinx upper bound in rpm packaging g-r copy :)
13:46:14 <number80> let's move on as everyone agreed on that
13:46:25 <toabctl> well - IgorYozhikov - could you just add this to your changeset for cliff to see if that works?
13:46:26 <number80> any other specific review to peek on?
13:48:04 <IgorYozhikov> toabctl, what exactly do you want to be add?
13:48:26 <toabctl> IgorYozhikov, remove the <1.3 from Sphinx in out global-requirements.txt copy.
13:49:04 <IgorYozhikov> oh, ok, will propose PR soon
13:49:05 <number80> I'd prefer a separate changeset as it's easier to grep it in git log
13:49:19 <number80> but that personal pref
13:49:20 <toabctl> number80, ok
13:49:38 <toabctl> then the cliff one can depend on the requirements one
13:49:40 <toabctl> fine for me
13:49:49 <IgorYozhikov> number80, I can do it for test and remove after without merge
13:50:02 <toabctl> IgorYozhikov, we can add a DependsOn: line
13:50:03 <number80> toabctl: yes, we should use more special keywords!
13:50:28 <IgorYozhikov> ok
13:51:34 <number80> next?
13:51:50 <IgorYozhikov> https://review.openstack.org/#/c/343335/
13:52:45 <IgorYozhikov> looks like hanging too much time :0
13:52:57 <number80> dirk has arguments, so I'm fine with keeping the discussion open
13:53:12 <toabctl> iirc we had that last week and wanted to wait for dirk. not sure
13:53:42 <number80> let's revisit this next week, and if no strong opposition, we can merge it
13:53:49 <IgorYozhikov> so let's wait 4 dirk with this
13:53:51 <IgorYozhikov> ok
13:53:53 <number80> yes
13:54:09 <jruzicka> funny, problems with cliff are now discussed independently on two channels I am on :)
13:56:23 <IgorYozhikov> we have 4 min to go, anything else?
13:56:26 <number80> I suggest that we close the meeting as we're reaching the hour
13:56:57 <toabctl> yes
13:56:59 <number80> anyway, we're all on #openstack-rpm-packaging if we need to discuss specific item
13:57:08 <number80> thank you gentlemen for attending
13:57:15 <number80> #endmeeting